MacBook Pro Mid 2012 (9,2) via Opencore auf BigSur updaten

  • Hoffen wir mal, das die zukünftigen updates einfach durchlaufen.

    Ich denke wir sind auf einen guten Weg :thumbup:


    schmalen

    Eine Frage noch an dich:

    Auf was für einen mac hast du jetzt installiert?

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • schabulske iMac late 2012

  • so...hat ein wenig gedauert da ich verschiedene Ansätze verfolgt habe. Resultat ist...immer noch kein Bild auf dem MBP 2012 15´´mit HD4000 und GT650M. Die Framebuffer Fraktion nach Dortania durchgearbeitet. Es wird nicht den Hauch einer Grafikkarte angezeigt im Apfel.

    DSSDT wurde erstellt unter Catalina Original.

    Weg Parameter durch probiert und dabei jedesmal neugestartet.

    Was immer funktioniert ist Wlan Bluetooth.

    Über Bildschirmfreigabe...kann ich dem Geschehen folgen.

    Grafikkarten sind aber im System vorhanden. Beide funktionieren unter Catalina.Es liegt also kein Defekt vor. verschiedene SMBios Versionen bis jetzt zum ImacPro1,1 läuft es aber ohne Bild.

    Jetzt bin ich ratlos oder fantasielos. Halt Coronalike...

    Die EFI aktuell läuft auf MacBookPro9,1

  • Erdenwind Inc.


    Hattest du schon das Bootargument "agdpmod=pikera" probiert?


    Habe mal vorhin mit dem OC Legacy Patcher eine EFI für ein MBP 9,1 erstellt und gerade mal schnell verglichen mit deiner EFI.

    Die haben das Bootargument bei sich auf jeden Fall drin.

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • Ja hatte ich auch. Keine Wirkung. Da ich das BootArgument ja bei meinem Hack nutze wegen der RX5700xt kenne ich diese Möglichkeiten durchaus. Auch die Framebuffer hatte ich schon alle durch die in Frage kämen. Nichts. Doch gestern Abend wollte ich gerade mal aufgeben da fand ich dann eine Efi ohne viel drin und probierte die aus. Tada… Bild war da und MBP 9,1 drin. Grafik und alles andere. Sehr seltsam? Jo ich beobachte das mal weiter bezüglich Updates nächste Woche. Aber echt komisch. Ihr habt welches smbios drin? MBP 9,2/9,0?

  • sehr sehr cool was da bei Euch abgeht.


    Danke lieber Erdenwind Inc. und schabulske


    Ich werde heute mein 13 Zoll 2012 mal wieder auf OPEN Core umbauen.

    Sollte ja kein großes Problem sein....


    Aber ich hab es so verstanden, dass es ganz wichtig ist den Open Core Legacy Patcher von Catalina aus zu machen... installiere es gerade auf einer externen...


    Geb euch dann Bescheid.


    Würde Euch gerne auch bei dem 15 Zoll 2012er unterstützen. Habe nämlich in der weiteren Familie 2 Stück am laufen.

    Leider werden sie aber täglich gebraucht. (Homeoffice)


    Viel. schnapp ich mir ein Teil.......





    PS ich überlege mir auch, für meinen MacPro2012 5.1 solch eine EFI von Open Core Legacy Patcher bauen zu lassen..

    Er läuft ja auf BIG SUR bereits mit OPEN Core. Aber am Original SMBIOS. Leider funktioniert zB. am iMac Pro die CPU Steuerung nicht gut. Bekomme nur die halbe Leistung raus.

    Übrigens auch wenn ich mein MBP mit meiner selbst gebastelten EFI laufen lass. Bekomm ich genau nur die Halbe CPU Leistung raus...


    Bin mal gespannt was der Open Core Legacy Patcher mir da ausspuckt....

  • Da kannst du dir das Powermanagemet zu generieren mit ssdtPRGen. Das sollte Wunder bewirken.

  • Erdenwind Inc. Funktioniert bei dir alles einwandfrei? Gibt es keine Nachteile?

  • Aber ich hab es so verstanden, dass es ganz wichtig ist den Open Core Legacy Patcher von Catalina aus zu machen... installiere es gerade auf einer externen...


    Nein ich glaube es spielt keine Rolle solange dein BigSur noch original ist. Also ich meine es darf noch nicht durch den Micropatcher oder Patched Sur installiert worden sein. Es muss noch ganz jungfräulich sein.


    Aber ich glaube auch das es am besten ist einmal von vorne anzufangen und dann alles original und vernünftig zu haben


    Desweiteren um es noch mal klar auszudrücken.:

    Der OC Legacy Patcher verändert nichts an der BigSur Installation. Er patched keine Dateien.Das einzige was er macht ist euch eine OC EFI zu erstellen die für euer original Gerät passt.

    Somit bootet Ihr OpenCore und OpenCore dann das System. Also ein Hackintosh auf original Hardware.


    Eine meiner Meinung nach perfekte Lösung.

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • Nur Kurze Frage...


    Bin grad beim MBP 13 Zoll dabei...


    war schon mal in der Recovery.... WLAN funktioniert...


    Bin aber gerade mit der generierten EFI und einer Externe SSD Catalina 10.15.7 hochgefahren...... da geht leider kein WLAN...


    werde aber von dort aus Big Sur drüberbügel...



    Passt des?

  • Ich habe leider nicht ausprobiert Catalina damit hochzufahren. Hatte mir ja direkt einen Stick erstellt und dann direkt in die Recovery gebootet und dann sofort über mein bestehendes Catalina drübergebügelt.


    Ich hatte Catalina nicht auf einer Externen SSD sondern auf meiner internen SSD

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • Ist auch nicht dafür da um Catalina vom Original zu booten. Total sinnfrei😁

  • Hi Leute,


    1.)


    Also das MacBook 2012 13 Zoll funktioniert jetzt super. WLAN da....alles Super

    Auch die CPU Leistung ist jetzt so, wie sie soll...... wahrscheinlich wegen der CPU Friend KEXT.

    Alles super


    Hab nur ein wenig Angst, wenn sich das BOOK viel. irgendwann ein Firmware update herunterzieht! BERECHTIGT?


    2.)


    Hab mir via

    OpenCore-Legacy-Patcher

    https://github.com/dortania/Opencore-Legacy-Patcher


    auch eine EFI für MacPro 2012 erstellen lassen.


    Hatte da ja schon OC und betrieb das Teil mit dem Original SMBios...

    weil auch die CPU Steuerung nicht passte (halbe Leistung).


    Die Updates machte ich immer am Hacki....

    war ja leicht... Lade des MacPro auf...ssd raus...extern am Hacki und los geht.....


    Habe mit der erstellen EFI gestartet.... als SMBios schlug er MacPro7.1 vor....


    Update wurde angezeigt..... und lies sich auch installieren.

    Endete am ab dem 2 Boot im nirgendwo....


    Konnte die Installation auch mit dem Hacki nicht mehr retten...

    Auch das Drüberinstallieren mit dem Hacki half nicht....


    ...nur mehr formatieren half........


    Hat wer damit Erfahrungen?



    3. Erdenwind Inc.


    Wie schaut es denn mit dem MBP 2012 15 Zoll aus?

    Bist du da irgendwie weiter gekommen ? Bild usw?


    Schönen Sonntag wünsche ich Euch

  • Das freut mich zu hören. Anfangs auch mit dem Legacy Catcher mit 9,1 MBP SMBios. Aber kein Bild. Jetzt mit ner einfachen EFI mit WLAN Kext und nichts gross drin. Alle Funktionen. Updatefähigkeit muss ich prüfen am Dienstag.

  • Ok,


    dh du betreibst das MacBook mit dem Original SMBios damit du das Bild hast.


    Glaub aber nicht, dass dir dann die Updates angeboten werden.


    Hatte beim MacPro auch immer eine Update EFI und eine WORK EFI.

    (Bei Original EFI wird auch der Fullinstaller nicht genommen...Button ist angegraut)


    Vielleicht gibts aber eine KEXT oder ein Boot Arg welches die Prüfung umgeht?


    EDIT:


    Erdenwind Inc.


    Hast du auch schon das 11,1 BIOS probiert.


    Ich kann mich glaub ich erinnern, dass ich auch einmal das 11,2 BIOS erwischt habe und ich dann kein Bild hatte... Bin mir aber nicht ganz sicher

  • Nur zur Info:

    Systemupdate auf 11.2.3 ist ohne Probleme durchgelaufen auf dem MBP 9,2

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • Bei mir auch ohne Probleme durchgelaufen .... dank euch


    Lieber schabulske

    Mit welchem SMBios betreibst du den 9,2?


    Kurze andere frage:


    Was muss ich in OC einstellen damit er von geklonten externen Festplatten durch bootet ?


    Danke

  • DerTschnig


    Ich betreibe den 9,2 mit meinem Original SMBios. Der Open Core Legacy Patcher fragt ja ab ob man sein original SMBios nehmen will oder nicht.


    Das habe ich dementsprechend mit Ja beantwortet. Die Daten dafür sind aber grundlegend anders in der Config.Plist eingepflegt worden als ich es normalerweise mache beim Hackintosh. Ist schon interessant wie die das verwirklicht haben.



    Zu der Sache mit der externen Festplatte:

    Die sollte doch ganz normal im Bootpicker auftauchen sofern sie angeschlossen ist. Müsste man dann normalerweise doch auswählen können und sollte dann normal booten? :think:

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ BigSur 11.2.3 (20D91) / OpenCore 0.68 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2


    Lenovo Thinkpad X220 / Core I5 2520M / Intel HD3000 / 8GB Ram / WIFI Dell DW 1510 / Bios Mod / 120 GB SSD / High Sierra 10.3.6 (17G14042)/ OpenCore 0.62


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / Big Sur 11.2.3 (20D91) via Opencore 0.68


  • In open core muss EnableJumpstart und JumpstartHotPlug aktiv sein, dass er von EXTERNE Festplatte bootet....


    In meinem Fall war das Problem aber, dass mein Externe Festplatte kaputt geworden ist.



    Lieber Erdenwind Inc.


    Darf ich mir deine config.plist vom 15 Zoll MBP mal anschauen.?

    Des wär sehr nett.




    Mei MBP 13 Zoll läuft mit dem 11,1 SMBios super..


    Hab nur a bissl Angst wegen den Firmware updates.....

  • Sorry hat bisschen gedauert. hier hast du mal meine EFI! Wie gesagt für die 15" Zoll mit GT 650M und HD4000er Grafik. So läuft die Kiste. Updates konnte ich nicht probieren da keine vorhanden diese Woche.

    Files

    • EFI.zip

      (3.89 MB, downloaded 14 times, last: )