OpenCore 0.6.6 auf HP ProDesk 600 G3 mini

  • Hallo zusammen,


    hoffentlich passt das von der Einsortierung und den Infos, falls nicht, weist mich bitte zurecht.


    Ich habe mir zum Hacki basteln nen HP ProDesk 600 G3 mini (Skylake) organisiert. Da ich aktuell in der Windows Welt zuhause bin habe ich mit der Internet Stick Methode mein Glück versucht. macOS Internet Recovery Stick: Installation ohne Mac oder VM


    leider ohne Erfolg, der Rechner bootet der Balken unter dem Apfel füllt sich(dauert ca, 15 Minuten) aber bleibt dann so stehen.


    Also dachte ich mir probieren wir es doch mal mit OpenCore und habe mich mit der Anleitung hier OpenCore: Desktop-EFI erstellen unter macOS / Windows bzw. dem Dortania Guide https://dortania.github.io/OpenCore-Install-Guide/ durchgehangelt. Die SSDT's hatte ich erst erstellt, aber als nach dem Boot der Installer bei diesem Problem hing Catalina 10.15.3: Hängt beim Start zur Installation , habe ich die defaults aus dem Dortania Guide rein gepackt.


    Jetzt schlägt der Boot an der selben stelle fehl, nur produziert nicht mehr apfs_module_start:1689: ....... sondern apfs_module_start:2436

    Zu diesem Fehler finde ich aber leider keine weiteren Informationen. Würde mich über Antworte freuen.



    Files

    • EFI.zip

      (2.39 MB, downloaded 16 times, last: )
  • teste das mal bitte und :welcome2:

  • al6042 magst du hier mal darüber schauen was mann hier machen kann ;)

  • Das macht aus meiner Sicht erst dann Sinn, wenn die tatsächlichen verbauten Details des ProDesk 600 G3 hier zu sehen sind.

    Immerhin gibt es viele verschiedene Möglichkeiten, wie man aus folgendem Link sehen kann --> https://support.hp.com/de-de/document/c05369797


    der_twister

    Bitte trage diese Infos entweder in deiner Signatur oder in deinem Profil, im Bereich "Über mich" ein.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • al6042

    Habe die passenden Sachen eingetragen, im Prinzip ist es ja nur der Prozessor, Core i5 6500T. Der ganze optionale Kram ist nicht eingebaut.


    Oder welche Information fehlt dir?

  • Das passt schon...


    Ich habe das Teil mal im Sanity Checker geprüft und mit der config.plist meines H170N-Wifi verglichen.

    Letzteres natürlich nur in Bezug auf Einstellungen der config.plist, welche auch unter 0.6.6 vorhanden sind, da ich dort noch 0.6.3 nutze.


    Daraus polterte dann folgende config.plist, die du bitte mal testen kannst.

    Sollte diese funktionieren, lösen wir auch auf, was sich daran geändert hat.


    BTW:
    Die DeviceProperties können wir erst korrigieren, wenn wir die genaue PciRoot-Bezeichnung für den Conexant CX20632 Codec kennen.

    Laut Supported Codecs Liste für den AppleALC sollte das später entweder layout-id 23 (Hex 17) oder 28 (Hex 1C) werden.

    Files

    • config.plist

      (29.36 kB, downloaded 12 times, last: )

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Auch die plist bringt exakt dieselbe Meldung.


    zu der ALC Meldung, dachte ich mein Bedarf an Sound in der Setup Routine ist jetzt soooo groß, im Gegensatz zu APFS.

  • Ich empfehle mal den Austausch der SSDT-EC-USBX-DESKTOP.aml mit der beiliegenden SSDT-EC.aml.

    Files

    • SSDT-EC.aml

      (124 Byte, downloaded 5 times, last: )

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Leider auch keinen Erfolg, selbe Meldung.


    Bin gerade noch mal durch die Anleitung durch. Und da fiel mir noch eine Diskrepanz auf, die vllt. in die Richtug gehen könnte das wollte ich jetzt als nächstes tauschen. In Opencore wird OpenHFSPlus.efi mitgeliefert, im Text wird von HFSPlus.efi geredet. ich habe mich in dem Fall an den Text gehalten und HFSPlus dort rein geworfen.

    Das werde ich jetzt mal probieren


    EdIt:

    OpenHFSPls.efi ist jetzt nicht so die Tolle Idee

  • Benutze diese HFSPlus.efi solange immer bis der Guide was andres empfehlen würde.


    Ich habe da ein Rename H_EC to EC (USB Power) unter ACPI/Patch eingebaut.

  • Sry hat ein bisschen gedauert, bis ich es ausprobieren konnte.

    Leider ist der Effekt immer noch der selbe.

    Code
    1. apfs_module_start:2436: load: com.apple.filesystems.apfs, v1677.81.1, 2021/01/24


    Ich versuche noch dahinter zu steigen was dort wann passiert. Und wenn ich das richtig verstehe dann werden dort doch kexts geladen, oder was passiert da genau?

    Ist es dann so das der SATA Controller im ACPI "angekündigt wird" und dann später die kext dazu geladen wird, was fehlschlägt? Oder könnte es sein das die Kext zum Controller falsch ist.

    Hat es mit SATA überhaupt was zu tun und liegt ggf. am nicht lesen können von USB ?

    Fragen über Fragen..........

  • der_twister


    Teste es mal min der OpenCore 0.6.7 Version

  • Ist getestet, ausser das die Debug Version vor dem Selector nen bisschen gesprächiger ist sehe ich leider keine Veränderung.

  • der_twister


    In der EFI Partition wo die OpenCore EFI hingeschoben hast müsste eine log drin sein lade die mal hier hoch :)

  • Kannst du ein Bild machen wo er hängenbleibt , für mich sieht es so aus wenn er direkt nacht denn Booten hängt :rolleyes:

  • Das Foto vom 28.2. ist das was rauskommt. Vom Bootvorgang habe ich nen Video gemacht was zu groß für die Anhänge ist, wer den Link haben will dem schicke ich gerne ne PM

  • Hat noch irgend jemand nen Ansatz was ich mal ausprobieren könnt, oder welche Logfiles ich ziehen könnte ?