nativer MacPro3,1 OpenCore 0.6.5, Soundprobleme unter Mojave, Catalina und Big Sur

  • hallo zusammen,


    vielleicht klingt das ein wenig komisch: es geht hier in erster linie nicht um einen wirklich "klassischen hackintosh", wohl mehr in die richtung, macOS auf unsupported Mac, vielleicht könnt ihr mir trotzdem helfen?


    ich habe eine passende config.plist für meinen MacPro3,1 gebastelt. sie erlaubt mir jedes pre-el capitan macOS zu installieren.

    unter sierra und high sierra funktioniert auch alles bestens, ab mojave ist natürlich eine metal fähige grafikkarte mehr als empfehlenswert.

    bei einer big sur installation muss zusätzlich das interne BT2.0 modul entfernt werden, was nicht weiter schlimm ist.

    viel schlimmer ist es, es wird kein audio ausgabe gerät gefunden.

    ich habe es mit dem bootarg: ALCID=11, 12 und 15 versucht, als auch mit dem reinen laden des AppleALC kextes.
    Lilu und WEG sind mit "betaall" bzw. "beta" eingebunden.

    leider wird nach wie vor der ALC885 sound chip im 3,1er nicht angesprochen, eine externe soundkarte per USB wird einwandfrei erkannt.

    könnte mich jemand auf die richtige spur bringen? danke im voraus!

    RealMac : MacPro1,1 - 6,1



  • ich hab mir mal erlaubt, deinen beitrag in das passende unterforum zu verschieben... es geht ja, wenn ich dich richtig verstehe um einen originalen apple mac pro?

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • uups, sorry...danke! ( dachte es wäre im POST install gut aufgehoben )

    RealMac : MacPro1,1 - 6,1



  • Henninges


    Du hast selbst geschrieben, bis HighSierra geht Audio noch, was daran liegt, dass sich die AppleHDA danach geändert hat.

    In der AppleALC gibt's kein Audio für MacPro3,1. Lösche die AppleALC und den Inject ALCID=... etc. in Deinem OC EFI (bringt nix) und installiere ab Mojave die originale AppleHDA aus HighSierra nach S/L/E und Du hast wieder nativ Audio auf dem MacPro3,1.

    Für den Install und KextCache-Neuaufbau kannst Du z.B. Hackintool verwenden.


    Insgesamt bist Du evtl. ohnehin den falschen Weg gegangen, denn mittels der Dosdude-Patcher läuft ein MacPro3,1 völlig nativ, ohne extra Bootloader, wie OC.

    Internetsuche "dosdude sierra", "dosdude highsierra", "dosdude mojave", "dosdude catalina".

    Bei mir läuft selbst BigSur auf dem MacPro3,1 noch ohne fremden Bootloader, aber dies ist eine andere Hausnummer.


    Ok, Du bist den Weg mit OpenCore gegangen, aber dennoch kommst Du nicht um den Tausch der AppleHDA herum, ab Mojave.

    Viel Erfolg!

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • Insgesamt bist Du evtl. ohnehin den falschen Weg gegangen,

    Wenn mich meine Erinnerung nicht täuscht,ist der Einsatz von OC beim MP3.1 nicht angeraten.

    Gruß

    LOM



  • LuckyOldMan

    Ist so nicht ganz richtig. OC funktioniert natürlich auch beim MacPro3,1 und ist dann wohl zwingend, wenn man keine Metal-Grafik mit Apple-Bios drin hat, da man so ja nicht ins Apple-Bootmenü kommt.

    In dem Fall wird es nativ schwer.

    Daher hatte ich lange, bis nach HighSierra, die HD5770 drin für's BootMenü auf einem Monitor und die GT710 auf dem Hauptmonitor Cinema 30 Zoll. Nach dem Boot brachte die HD5770 natürlich kein Bild mehr.

    Inzwischen habe ich auf eine kleine Karte mit AppleBios gewechselt (NVIDIA Quadro K600 1GB) und arbeite damit an zwei Cinema's völlig nativ.

    Wenn jemand eine modernere Grafik einsetzt, wie RX580 oder sowas ohne Apple-Bios, dann kommt er auf den realMac's an OpenCore nicht vorbei.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • wenn man keine Metal-Grafik mit Apple-Bios drin hat, da man so ja nicht ins Apple-Bootmenü kommt.

    Um einen Bootscreen plus Metal-Fähigkeit zu bekommen, gibt es PC-GraKas wie die GTX680 2GB, die man einfach mit dem Apple-Bootrom flashen kann. Dafür brauche ich kein OC - meine echten Macs bleiben OC-freie Zonen. Es reicht schon der Einfluß auf PC-MBs bestimmter Sorte - weiß ich, ob die Firmware nicht zerschossen wird?! Als Briefbeschwerer sind mir die Käsereiben zu kostbar & zu schwer.

    Gruß

    LOM



  • Insgesamt stimmt dat ja alles, was Du schreibst, aber auch die GTX680 2GB bringt keine H264-, bzw. HEVC-Unterstützung.

    Mir persönlich wäre dies auf einem realMac 3,1 bis 5,1 völlig egal, aber wie ich hier oft lesen musste, anderen Usern ist dies total wichtig.

    Also, was soll ich dazu sagen?

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • was soll ich dazu sagen?

    Nix! :D

    Gruß

    LOM



  • erstmal danke für eure antworten MacPeet + LuckyOldMan .
    dosdude patcher sind mir selbstverständlich bekannt, mir geht es jedoch um die big sur installation.
    diese lässt sich "vanilla" von el capitan als auch von einem dosdude gepatchten catalina aus starten und läuft normal durch.
    ich habe jetzt den high sierra applehda.kext mit dem "hackintool" in S/L/E als auch in L/E installiert und den KK neu aufgebaut.

    nach dem reboot meldet big sur jedoch weiterhin den installierten applehda.kext in version 283.15 statt 281.52...

    RealMac : MacPro1,1 - 6,1



  • Mir ist schon klar, warum Du wegen BigSur nun OpenCore verwendest, aber dies macht die Sache absolut nicht leichter.

    Du bekommst die AppleHDA nicht getauscht, da Deine Systemplatte versiegelt ist (Seal).

    Du bekommst Fremd-Kext's nur ins System mit dieser Snapshot-Methode, bei der ich Dir aber nicht helfen kann, da ich diese nie versucht habe und auch keinen realMac mit Fremdbootloader bestücke, bzw. bestückt habe und werde.

    Diese wird im BigSur-Thread auf macrumors beschrieben.

    Ich bin halt einen anderen Weg gegangen, welchen ich auch dort beschrieben habe, auf den unzähligen Seiten des Threads.

    Ich installiere die Platte BigSur vom MacPro3,1 auf einem Fremdrechner (supported) mit der DoNotSeal-Option (wird auch dort beschrieben).

    Damit bleibt mein System beschreibbar und via Terminal-Befehle impfe ich die alte AppleHDA ins System.

    In meinem Fall hat der MacPro3,1 dann auch Audio, wie gewohnt.

    Fazit: Für Deine OpenCore-Lösung habe ich auch keine Lösung, wie Du die alte AppleHDA ins System bekommst.

    Der Tausch dieser AppleHDA ist ab Mojave aber zwingend. Die Dosdude-Postinstaller für Mojave und Catalina haben diesen Patch, bzw. Kexttausch ja auch drin, allerdings war bis Catalina das System auch nicht versiegelt.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • vielen dank für deine hilfe MacPeet, ich versuche es später mal mit der snapshot methode.

    edit:

    frage mich jedoch warum das ganze mit einem alten mojave kext für die von mir verwendete WiFi karte funktioniert

    RealMac : MacPro1,1 - 6,1



    Edited once, last by Henninges ().

  • Kann ich Dir auch nicht genau sagen. Mein WLAN geht nativ, auch mit BigSur, da ich die real Apple ...CD drin habe auf PCIe-Adapter.

    Die Frage ist ja auch, ist Dein Mojave Kext im OpenCore oder im System getauscht?


    Dies ist die AppleHDA, welche seit Mojave getauscht werden muss:


    AppleHDA.kext.zip


    Wie gesagt, ich installiere für den MacPro3,1 die BigSur-SSD immer via Fremdrechner und FullInstaller auf meinem Lenovo.

    Hierbei unterbreche ich den ersten Neustart vom Installer und boote ins Catalina vom Lenovo selbst. Hier bearbeite ich diese ...Update.plist im Installer-Paket auf DoNotSeal.

    Dann boote ich neu und lasse den Install durchlaufen mit allen Phasen bis zum Anmeldefenster nach Install. Hier schalte ich den Lenovo mittel Powerknopf einfach aus.

    Dann schiebe ich die SSD wieder in den MacPro. Dort boote ich aber erst Catalina.

    Von dort aus kopiere/ersetze ich die alte AppleHDA im BigSur-System S/L/E, was ja prima geht, da meine SSD notSeal ist.

    Ferner lösche ich in /System/Library/UserEventPlugins/ das telemetrie.plugin, welches ja den MacPro3,1 erst ohne SSE4.2 die Möglichkeit gibt.

    Ferner lösche ich auch alle relevanten Netzwerk.plist's in /Library/Preferences/SystemConfiguration/, da der Lenovo bei dem FremdInstall ja eine ganz andere Hardware hat.


    Dann boote ich mit dem Pro ins BigSur und habe erst einmal kein Audio.

    Dann Terminal öffnen und nacheinander folgendes:


    sudo -s

    sudo mount -uw / (Dein SIP muss entsprechend gestellt sein im Nvram)

    killall Finder

    cd /System/Library/Extensions/

    sudo chmod -R 755 AppleHDA.kext

    sudo chown -R root:wheel AppleHDA.kext

    sudo touch /System/Library/Extensions && sudo kextcache -u /

    kmutil install --update-all

    kcditto

    exit


    Dann Neustart ins BigSur und ich habe Audio, wie immer, inkl. Airplay zum HomePod-Mini. Bin gerade mit dem MacPro3,1 in BigSur und so sieht es hier aus:




    Allerdings werden Dir diese Hinweise nicht wirklich helfen, solange Deine Systemplatte Seal ist und Du den alten AppleHDA.kext gar nicht dort überschrieben kannst.


    Du guten Zeiten mit DosDude-Patcher bis Catalina sind nun mal vorbei, wo alles noch einfach war. Natürlich ist der MacPro3,1 von 2008 und wir haben inzwischen 2021 und eigentlich war bei El Capitan Ende mit dem MacPro3,1, aber dennoch muss man mal ganz klar sagen, dass er bis dato läuft. Ich habe keinerlei Unterschiede zwischen Mojave, Catalina oder BigSur im Betrieb. Unterschiede beim Booten gibt es im Sekundenbereich, wobei BigSur noch schneller bootet.

    Das muss ein anderer Rechner von 2008 erst einmal nachmachen, denke ich.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

    Edited once, last by MacPeet ().

  • vielen dank für deine einschätzung und die mehr als ausführliche antwort MacPeet.

    der hintergrund der ganzen geschichte ist folgender: ich möchte gerne ein OC paket, ähnlich wie das von martin lo, für den 3,1er schnüren.
    viele benutzen seine konfiguration und wundern sich, keine OTA updates damit zu bekommen. die meisten interessiert es eben nicht das es für einen 4,1/5,1 geschneidert wurde.
    die lösung dafür war im grunde einfach und liegt in der verwendeten SSDT datei. dortania hat da ja ein wunderbares tutorial und wenn man sich bewusst geworden ist: eine harpertown xeon cpu ist im grunde nur ein aufgebohrter penryn, nutzt man eben die entsprechende datei.
    das man damit im grunde jeden nativen mac "impfen" und durch das board-id spoofing auch jedes macOS installieren kann, macht es fast zu einer dosdude alternative.
    mehr als einen passenden full installer braucht es dann nicht mehr...

    das paket ist zu 98% soweit fertig und könnte verteilt werden, wenn, ja wenn da nicht die doofe sachen mit dem ton und bluetooth wären.

    ich habe noch etwas beobachten können: natürlich sind der 4,1/5,1 und der 3,1, in sachen hardware, grundsätzlich verschieden.
    die soundcodecs in beiden sind jedoch identisch, RTL ALC855. wohingegen auf einem 4,1/5,1 überhaupt keine notwendigen änderungen vorgenommen werden müssen, scheint es dieses problem nur auf dem 3,1 zu geben.

    gleiches gilt für grafikkarten.
    während eine von mir, mit apple efi gop geimpfte hd7870, auf dem 4,1/5,1 ein wunderbares bild von bootscreen, über verbose output und desktop zaubert, hört die ausgabe auf einem 3,1 plötzlich auf und man denkt die karte hätte sich verabschiedet.
    ein weiterer vbios patch lässt die karte dann aber irgendwie in einen "fallback" modus fallen sobald ein desktop gerendert werden soll und das bild erscheint auch wieder auf dem 3,1. auch wenn ich dafür das mDP kabel abziehen und wieder einstecken muss.

    es sind also grundsätzlich verschiedene welten in der man sich bewegt, man kann nicht "einfach so" aus einem MAC einen HACK zaubern.

    schönes WE euch beiden und nochmals danke für eure antworten!

    RealMac : MacPro1,1 - 6,1



  • Ich denke, dass die 4,1/5,1 den Micropatcher nutzen können, wo Audio bereits gefixt wird. Beim 3,1 geht der nicht.

    AMD-Grafikkarten brauchen auf dem 3,1 auch den SSE4.2 Patch für die Grafik. Erinnere Dich an PostInstaller Dosdude Catalina, dort ist der ja auch drin.


    Ich denke, Du kannst sehr wohl bei Deiner OC-Methode bleiben, aber Du musst sicher DoNotSeal installieren, was ja auch nicht schlimm ist.

    Installiere BigSur doch nochmal neu und unterbreche den ersten Neustart, indem Du z.B. Catalina bootest.

    Dort gibt es dann auf de BigSur-Daten-Partition den Ordner macOS Installer.

    In diesem Ordner liegt dann eine UpdateOptions-plist, in der Du den Wert DoNotSeal auf true stellst.

    Dann Neustart und BigSur fertig installieren. Nun ist Deine System beschreibbar und Du kannst Deine Kexte für Audio und BT einbringen und im Terminal neu aufbauen, wie oben schon beschrieben.

    Mit einem dichten System kommst Du auf dem 3,1 nicht zum Endziel.

    Für den AMD SSE4.2 Patch müsste man im Dosdude Postinstaller mal schauen, welche Änderungen dort gesetzt werden und es ggf. für BigSur händisch übernehmen.


    Ach so, Nachtrag zum Audio:

    Die 4,1/5,1 haben zwar den gleichen AudioChip, verwenden aber intern sicher eine andere LayoutID in der AppleHDA.

    Damals hatte Apple in der AppleHDA einige LayoutIDs komplett entfernt, wegen Wegfall der Unterstützung dieser Geräte.

    Zu dem Zeitpunkt waren die 4,1/5,1 aber noch nativ unterstützt.

    Seit dem hatte die AppleHDA sich aber nicht mehr geändert, so dass diese vermutlich auch heute noch nativ Audio haben.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • Wenn das der gleiche Audio-Chip wie im 4.1/5.1 ist, dann sollte es doch mindestens unter Mojave gehen, denn der 4.1/5.1er unterstützt mit passender GPU auch Mojave, wenn es unter Mojave wirklich nicht geht, ist das ja mehr als merkwürdig:/

  • ich habe dazu oben einen Nachtrag geschrieben.

    Das beschriebene war damals auch der Grund, dass die AppleALC alle ID's intern auf ID7 umpatchen musste, damit die Fehlenden ID's aufgefangen werden.

    Das ist bis heute noch so.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • MacPeet : der unterschied zum 4,1/5,1 muss grösser sein, den ich ändere ja nichts an der konfiguration ( was an sich schon seltsam genug ist, den ich kann auf dem 4,1 auch die penryn ssdt nutzen... )
    einmal damit gestartet, läuft die installation von BS durch und am ende habe ich eine native soundausgabe, ohne ALC oder HDA geimpft zu haben.


    HackBook Pro : bis catalina ist das impfen problemlos möglich, durch die geSEALte installation von BS jedoch nicht mehr.

    RealMac : MacPro1,1 - 6,1



  • Was Audio betrifft wird es genauso sein, wie ich beschrieben habe. Der 4,1/5,1 verwenden eine interne ID, welche in der aktuellen nativen AppleHDA noch immer unterstützt ist.

    Für viele andere altere realMac's war es ja damals dann nötig, die AppleHDA von HighSierra .4 zu verwenden, wo die ID's noch drin waren.

    Ab .5 wurde die AppleHDA geändert und die ID's gelöscht.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.3 DP2

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.15.7 / 11.2

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7

    iPhone8 64GB: iOS 14.4  iPad Pro 9,7" WiFi 32GB: iPadOS 14.4

  • dann versuche ich mein glück mal mit catalina und der DoNotSeal geschichte...ich berichte. :)

    RealMac : MacPro1,1 - 6,1