! SOLVED ! ONLY-USB ! Kaby Lake - Open Core ( ASUSTeK M32CD4-K ) Big Sur !!! SOLVED !!!

  • Hey Leute, habe hier neuerdings so einen Glitch. Über Catalina geht alles, aber sobald Big SUR Installer starten will, wird das Bild so zerstreut. Hat einer von euch einen Tipp? Gefunden habe ich den Fehler schon Mal, nur leider ohne Lösung. Ich lass den Prozess mal laufen.


    Could not recover SATA HDD after 5 attempts


    was hat das zu bedeuten?


    !!! UPDATE !!!


    Hey liebe Hackintosh-Forum-Kollegen,


    nach sehr langer Zeit konnte ich endlich das Problem lösen. Es liegt an den fehlenden Treiber im Mairdboard, der die SATA CONTROLLER reguliert.


    (still waiting for root device)

    ( appleintellpssi2ccontroller-1 notificationpublishedhandler: getchannelnumber failed )


    Warum und wieso weiß ich noch nicht genau, aber mit BIOS AHCI off und SATA ADAPTER AUF SSD hat es funktioniert. Der Bootvorgang ins SET UP dauert nicht sehr lange, ca. 20 Minuten. Die Installation dauert an sich ca. 1 Stunde. Danach bootet Big Sur in ca. 31 Sekunden vollständig hoch. Das Betriebsystem ist sehr zuverlässig.


    Ich empfehle den Kauf von einem SSD-Sata-Adapter und einer neuen SSD Festplatte. Ihr benötigt einen 32GB USB Stick und ein bisschen Zeit.


    Das Ergebnis ist es wert.


    Im Anhang findet ihr auch die passende EFI für die ASUSTeK M32CD4-K Reihe.


    Um dieses Problem im Laden des Setups zu umgehen ist es notwendig im BIOS die Funktion "AHCI" zu deaktivieren. SATA am besten komplett deaktivieren. Wie ihr in meiner Signatur erkennen könnt ist mein Rechner nicht mehr der jüngste (2017). Aber Big Sur läuft performant den je. Erstellt euch einen OpenCore Stick mit EFI Partition und einen Big Sur Installer.


    Das Ergebnis wird euch umhauen! Einfach Genial!


    Danke an die vielen Forummitglieder die mir geholfen haben! Ohne euch wäre ich verzweifelt! Danke :)

  • Also wenn das Bild über die RX 560 (dein Profil) kommt und so aussieht wunderts mich.

    Habe auch ein Kabylake System und sowohl bei der RX 460 als auch 570 war sowohl Catalina als auch Big Sur kein Problem (WEG , keine gpu boot args wie pikera etc.).

    Jedoch nutze ich den Radeonboost.kext nicht, keine Ahnung ob du den nutzt (unter Catalina geht der :) ) und die evtl. bei Big Sur Probs macht.

    PS: Whatevergreen und Lilu aktuell (oder zumindest nicht zuz alt für Big Sur)?

    Wichtig für Hilfe wäre auch zu wissen ob dies dein erster Kontakt mit Big Sur ist oder das, mit gleicher Konfig schonmal ohne Glitch lief. Und auch evtl. vorhandene Device Properties für dGPU oder iGPU, falls du doch mit iGPU probs hast.

  • Ich nutze keinen Radeonboost.kext, auch mit den aktuellsten kext mit whatever green und Lilu kommt der Fehler.


    Ja ist der erste Kontakt mit Big Sur

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

  • Moin,

    du könntest mal deine EFI hier hochladen.

    Das Stop-Zeichen könnte auf falschen USB-Anschluß, den du für deinen Boot-Stick benutzt, hindeuten, oder benutzt du keinen Boot-Stick und hast von Catalina aus ein Update versucht? Welche Clover-Version benutzt du?


    Vlel Erfolg

  • Ich habe von Catalina versucht ein Update zu fahren. Ich denke auch an falschen SATA Zugang / Anschluss. Aber was würde über einen Bootstick anders laufen? Catalina startet mit der Opencore wie gewohnt.


    hab auch verschiedene Bootflags probiert, aber keiner will zu wirklich. Und Sound habe ich auch nicht mit Opencore.

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

  • Sound geht unter Catalina?

    Wahrscheinlich hast du einen Asus VivoPC, also Asus Komplettrechner, gell? MIch hatte die Mainboard Bezeichnung gewundert und gegoogelt....

    Anders als bei Mainbords schweigt sich ASUS (was ich bisher gefunden habe aus welche Chipsätze für Sound etc. verwendet werden.

    Hast du schon mal versucht nach einem Clover / OC für diesen ASUS PC zu googeln?

    Aus den evtl. aufgefundenen Clover / OC EFis könnte man die nötige LayoutID bzw. das bootarg alcid=LayouID für Audio - klar muss dazu auch AppleALC.kext (ein Lilu Sound plugin) vorhanden sein.




    Auch bin ich mir nicht sicher ob die BIOS Einstellungen dieses ASUS PCs schon gut für OS X passen.

  • Genau, ich habe so eine fertigen Rechner. Unter einem Clover Bootloader 5119 habe ich auch den Sound zum belaufen bekommen. Meinst du es macht Sinn einfach auf Clover zu wechseln? Kann ich einfach alle .AML Dateien und Config rüber kopieren, oder ist das schwerer? Bedarf es hier noch ein paar Änderungen?

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

  • Habt ihr schon mal über die EFI Shell eure Config.plist bearbeitet? fs0:)


    Hier kommt die .ZIP mit meine jetzigen funktionierenden OpenCore.

    Ich kenn die genaue Version leider nicht. Vermute aber 0.6.6.

    Ich habe das Tool genutzt: OC_Gen-X


    Hab jetzt Sound dank alcid=1


    Versuche die ganze Zeit über Update zu installieren,

    aber er bricht ständig ab.

    Woran kann dass nur liegen?


    could not recover SATA HDD after 5 attempts

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

    Edited 2 times, last by Hydrate ().

  • Versuch mal nen Cleaninstall aber Backup nicht vergessen.


    Update ist so ne Sache bei Big Sur...


    (ohne deine EFI gesehen zu haben...)

  • Es gibt mal wieder Updates. Derzeit habe ich drei SSD Festplatten installiert.

    Von einen auf den drei war der EFI Ordner. Diesen habe ich verschoben auf disk01 EFI.

    Siehe da, es lädt schon mal länger. Aber es wieder zu einer Fehlermeldung.

    Aber dieses Stop-Symbol (Siehe oben, erster Beitrag) ist verschwunden.


    Ich habe vorsichtshalber einen USB-Stick Installer erstellt. Dieser lädt viel länger und bleibt hängen bei "Device is locked". 10 Minuten später kam dann eine Meldung: Timeout.


    Ich werde gleich noch Fotos von den Fehlercodes hochladen.

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

  • Lad mal deine IOReg und ACPI aus Catalina generiert hier hoch bitte.

  • Hallo Kaneske, vielen Dank für deine schnellen Antworten.

    Auch nach Formatierung und Neu-Partitionierung, keine Chance.

    Habe mich nach längeren Durchlesen in diversen Foren dazu entschlossen zu warten:

    device is write locked, nach drei Timouts startet auch der Big Sur Installer von USB. "Kleines JUHU!"

    Aber es werden keine Festplatten erkannt, aber mit Catalina schon komisch oder?

    Dass kann tatsächlich nur an den Device Properties liegen. Hast du eine Idee? Viele Grüße aus BS ;)


    Im Anhang sind IO REG als Text und die Config.plist, plus Screenshot vom ProperTree

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

    Edited once, last by Hydrate ().

  • Bitte die IOReg nicht als Text sondern „Save“ und dann zippen. Danke...

  • So?

    Sorry hab sowas noch nie gemacht.

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr

    Edited once, last by Hydrate ().

  • Danke ich schau da mal rein wenn mein Kasten wieder rennt...

  • Wenn XhciPortLimit aktiviert ist, dann ist der UsbInjectAll nicht notwendig (weiß nicht, ob der aktiviert ist, kann ich am Handy nicht anschauen).

  • appleintellpssi2ccontroller-1 notificationpublishedhandler: getchannelnumber failed


    Jemand ne Idee warum gerade im Installer vom Big Sur diese Nachricht kommt?


    kleines Update:

    Der Installer bricht nach ca. 20 Minuten ab. Die Installation stammt von einem Update. Auch mit USB Installer keine Chance.

  • Danke ich schau da mal rein wenn mein Kasten wieder rennt..

    Hey Kaneske, hast du noch eine Idee?

    iPhone 12 Pro - 256G
    iPad Pro 12,9“ - 256GB

    ASUS Kaby Lake - 2017, 16GB RAM, 1TB SSD

    Music Producer / Audiosoftware / Workarounds und mehr