OpenCore Update

  • Hey,


    ich hab mal ne kleine Frage, ich beschäftige mich die letzte Zeit mal wieder etwas mehr mit meinem Hackintosh, gerade nach dem Umstieg auf OpenCore bin ich auch daran interessiert zu wissen wie alles funktioniert. Nun hab ich mir den Update Guide hier im Forum einmal angeschaut und den von dortania.


    Also habe ich meine aktuelle Config.plist von OpenCore 0.6.3 mit der sample.plist 0.6.5 verglichen. Dabei hab ich folgendes ausgespuckt bekommen.

    hackintosh-forum.de/attachment/166255/


    Wenn ich das nun richtig verstanden habe, soll ich die missing Values die in meiner config.plist fehlen ja hinzufügen. Das habe ich wie vorgeschlagen gemacht, indem ich mit PropperTree beide configs geöffnet habe nebeneinander und die Einträge von der sample.plist dann exakt an die selbe Stelle in meiner config.plist rübergezogen habe. Erstmal: Es funktioniert alles, es bootet, ohne Probleme. Jetzt bekomme ich aber vor der Auswahl was ich booten möchte folgendes angezeigt:


    hackintosh-forum.de/attachment/166256/


    Jetzt stehen quasi genau die Dinge da, die ich von der sample.plist in meine config.plist übertragen habe. Habe ich da was falsch gemacht? Würde mich freuen, wenn mich da jemand aufklären kann :)


    Vielen Dank schonmal für die Antworten.



    EDIT: fixed, war dumm, hatte nur meine Config geupdated und die kext, aber noch nicht die anderen Dateien. :)


    Edit2: Ich hab keine Ahnung warum der Thread nach dem Editieren auf einmal doppelt vorhanden ist. Sorry.

  • Hallo,

    du könntest mal deine EFI hier hochladen. Vielleicht findet ja jemand den Fehler.


    Viel Glück

  • Nochmal eine kleine Frage, ich hab nun alles geupdated, bekomme aber im Log immer folgendes zu sehen, kann man da noch was verbessern? Es läuft alles und ich kann normal booten, wenn ich einige Dinge aus der Log google sind die meistens in Verbindung mit Leuten die gar nicht erst booten können.

    Ist das normal, was in der Log steht? Oder kann ich da noch was machen?

  • Also ich sehe da im Log keine Fehlermeldungen?!

    Was meinst du soll da im Log auf Probleme hinweisen?

  • Dinge wie folgendes:


    00:326 00:012 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-signature 7C436110-AB2A-4BBB-A880-FE41995C9F82

    00:339 00:012 AAPL: #[EB|WL] 0 0 0x01 0x01 23 0x0E

    00:352 00:012 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-image-key 7C436110-AB2A-4BBB-A880-FE41995C9F82

    00:364 00:012 AAPL: #[EB|WL] 0 0 0x01 0x01 24 0x0E

    00:377 00:012 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-image 7C436110-AB2A-4BBB-A880-FE41995C9F82

    00:389 00:012 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-signature 7C436110-AB2A-4BBB-A880-FE41995C9F82

    00:402 00:012 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-image-key 7C436110-AB2A-4BBB-A880-FE41995C9F82

    00:415 00:013 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-image 7C436110-AB2A-4BBB-A880-FE41995C9F82


    Dachte das Err steht für Error.

  • 5T33Z0 Ja, das habe ich schon gefunden, aber ich bin ja nirgendwo Stuck. Wie gesagt, ich komme ganz normal in macOS rein, alles funktioniert. Für mich ist nur dieser Text der in der Log steht neu, der kommt jetzt vor dem was ich sonst gesehen habe beim booten. Wollte nur wissen, ob ich das dann jetzt getrost ignorieren kann, wenn ja, kann ich das umgehen, dass das vorher durchgerattert wird? Und wenn nein, wie fixe ich das?

    Ich wiederhole nochmal: alles funktioniert, bin nicht stuck, daher verwundert mich das.


    Edit: Ich werde halt aus dem Log absolut nicht schlau, egal was ich google, meistens finde ich was mit Leuten die Stuck sind, aber ich bin nicht Stuck. Warum rasselt bei mir denn der komplett selbe Text durch? Ist das alles ganz normal? Hab das erst seitdem ich OpenCore geupdated habe.

  • Die Screenshots aus dem Ausgangspost haben damit gar nichts mehr zu tun. Geht nur um die Log, ob da alles okay ist.


    Edit: Niemand eine Antwort? :(

    Edited once, last by Dnl ().

  • Es gibt ja einige Anleitungen und auch Tools wie die Sample.plst mit der config.plst vergleichen werden.


    Deinem ersten Betrag nach vermute ich, dass Du auch so ein Vergleichstool benutzt. Ich habe es immer vorgezogen, die beiden Dateien mit einem Plst-Editor gemeinsam zu öffnen und dann alle Einträge Punkt für Punkt miteinander zu vergleichen. Das dauert u. U. zwar länger, hat aber den Vorteil, dass man sich recht bald in seiner config gut auskennt und weiß, wo alles steht.


    Der Nachteil ist, man muss sehr genau schauen, a) welche Einträge weggefallen sind (die lösche ich einfach), b) wo welche hinzugekommen sind (die ziehe ich einfach aus der Sample.plst in die config.plst) und c) wo sich vielleicht die Variablen-Typen bestehender Werte geändert haben (die passe ich dann an). Immer wenn ich etwas gefunden habe, gehe ich die OpenCore-Anleitung und schaue, was es mit der Änderung auf sich hat. Die in jedem Download mitgelieferte PDF-Datei gibt aber meist auch schon Auskunft.


    Die Nachteile überwiegen aus meiner Sicht die Vorteile nicht.


    Zur Kontrolle schickst Du Deine Config hier durch


    https://opencore.slowgeek.com


    und lässt Dir eventuelle Fehler anzeigen.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Ja, der Sanity Checker zeigt mir keine Fehler an. Also da ist alles gut, es geht mir gerade nur darum, warum er das hier ausspuckt. Gerade die Dinger mit ERR (steht das überhaupt für Error)?


    Edit: Kann mir wirklich niemand sagen, ob mit der Log unten alles okay ist? Es läuft alles durch und alles funktioniert. Würd nur gern die Log verstehen. :)