Grafikfehler Sapphire RX 5500 XT unter Last

  • Hallo liebes Forum, ich habe folgendes Probelm mit der Grafik. Wenn ich mit z.B. Premiere oder Aftereffects Material abspiele bekomme ich über beide Bildschirme weisse bzw schwarze Linien.


    Modellname: iMac

    Modell-Identifizierung: iMac20,2

    Prozessortyp: 10-Core Intel Core i9 (10850K)

    Prozessorgeschwindigkeit: 3,6 GHz

    Anzahl der Prozessoren: 1

    Gesamtanzahl der Kerne: 10

    L2-Cache (pro Kern): 256 KB

    L3-Cache: 20 MB

    Hyper-Threading Technologie: Aktiviert

    Speicher: 32 GB

    Boot-ROM-Version: 1554.50.3.0.0


    Hat da Jemand eine Idee? Sonst läuft das System sehr gut.


    Besten Dank im Vorraus


    Bernhard

  • Ohne jetzt in deine config.plist geschaut zu haben, würde ich es mal mit dem smbios Imac pro 1.1 versuchen.

    1.

    Mainboard Gigabyte Z490 Gaming X

    i5-10400

    GPU Palit GT 710

    16 GB Arbeitsspeicher

    WIFI-Bluetooth Dell1830 mit Adapter MZHOU PCI-E M.2/NGFF

    MACOS Catalina 10.15.6

    Bootloader: Opencore 0.6.2


    2.
    Dell Optiplex 3060 mff

    I3 8100t

    8GB Arbeitsspeicher

    1TB Samsung 970 NVME M.2

    256GB Samsung 860 (Windows 10pro)

    WLAN-Bluetooth BCM94360NG
    Big SUR 11.1

    Bootloader: Opencore 0.6.4

  • Also ich habe das mit dem Imac Pro 1,1 gemacht, irgendwie, scheint es besser zu sein aber es ist nicht weg. Somit nehme ich an, dass dein Tipp die Richtige Richtung ist.

    Grafiktreiber Bug. Damit haben die iMacs mit Navi Grafik auch zu kämpfen. Bekommt Apple nicht gefixt.

    D.h. es macht dann wohl keinen Sinn da weiter zu forschen? Die Sapphire RX 5500 XT ist ja nun nicht mehr die neuste Karte.


    Gibt es noch weiter Möglichkeiten?

  • Hast du auch die iGPU im Bios abgeschaltet und den Eintrag aus der config gelöscht, dann noch ein schnellen NVRAM reset.

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • "0300C89B Used when the Desktop iGPU is only used for computing tasks and doesn't drive a display"

    ist schon eingetragen gewesen, NVRAM Reset hat leider nichts weiter gebracht. Im Bios ist sie auch raus.

  • Ein iMacPro1,1 hat keine iGPU, daher im Bios deaktivieren bei deinem System und in der config löschen den Eintrag.

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • Schon mal ein Test mit Big Sur gemacht auf einem anderen Container?

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • APFS bietet die Möglichkeit Container zu erstellen, was so viel ist wie eine andere Partition, kurz gesagt bleibt dein vorhandenes System unangetastet und du kannst Big Sur auf eine andere Partition testen, ohne dein derzeitiges macOS zu verändern, vorausgesetzt ist das deine SSD noch 20GB locker Platz hat.

    Sollte alles funktionieren, weißt du woran es liegt und du kannst den Test Container einfach löschen.


    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • Big Sur in einen Catalina APFS Container zu installieren ist eine ganz schlechte Idee. APFS von Big Sur und das von Catalina sind zueinander nicht kompatibel. Außerdem mischst du Begrifflichkeiten durcheinander. Was du meinst ist ein APFS Volume. Der Container ist das was die Volumen enthält. Und nein, ein Volume entspricht nicht einer Partition. Eine Partition unterteilt eine Festplatte in separate Bereiche. Zwei APFS Volumen steht der gesamte Platz auf der Festplatte zur Verfügung.

    LG Chris


    Meine Hardware:

  • Ein Container an sich hat nichts mit dem Installierten macos zu tun, daher kannst du in einem Container auch mehrere Volumen erstellen die unabhängig von einander wirken.

    Ich habe unter Mojave ein Container erstellt, seit dem nur die Volumen Catalina und Big Sur dazu gefügt, da ich noch Tools habe die nicht mit den beiden anderen macOS Versionen laufen.

    Vielleicht habe ich mich falsch ausgedrückt, meinte eher er soll ein Test Volumen erstellen in dem selben Container.

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • Ok, soweit scheint mir das zun klar... Also wenn ein Big Sur Test, dann nur auf einer weiteren SSD.


    Komischerweise habe ich z.B. wenn ich einen Cinebenchtest mache oder mit Geekbench keine Streifen/Linien auf dem Monitor, und da wird ja dann mit Last gearbetet, nehme ich an. Allerdings taucht der Fehler auch auf wenn z.b. im Browser auf wetransfer ein "bildfüllender" Foto/Grafik wechsel ist. Also es liegt wohl nicht nur an Adobe will ich damit sagen.

  • Ein Container an sich hat nichts mit dem Installierten macos zu tun, daher kannst du in einem Container auch mehrere Volumen erstellen die unabhängig von einander wirken.

    In der Regel ist das der Fall, ja. Aber nicht bei Big Sur.

    Ich habe unter Mojave ein Container erstellt, seit dem nur die Volumen Catalina und Big Sur dazu gefügt, da ich noch Tools habe die nicht mit den beiden anderen macOS Versionen laufen.

    Und genau das ist gefährlich. Mit Big Sur gab es Änderungen an APFS welche zu Inkompatibilitäten zwischen den Systemen sorgen. Genau damit habe ich mir meine Catalina Installation gekillt als ich die Public Beta von Big Sur erstmals in einem APFS Volume installieren wollte. Apple selbst warnt auch ausdrücklich davor Big Sur in einen APFS Container von Catalina zu installieren. Es wundert mich, dass es bei dir angeblich funktioniert.


    Edit: Natürlich kann es sein, dass Apple die beiden Systeme mittlerweile kompatibel gemacht hat. Habe dazu aber nie etwas explizites in den Release Notes gelesen. Wäre da also lieber sehr vorsichtig mit.

    LG Chris


    Meine Hardware:

  • Vielleicht kann es daran liegen das ich für macOS noch SATA SSD benutze, bis jetzt klappt es, da ich eh 70% noch Catalina benutze und erst richtig auf Big Sur wechsle, wenn mindestens die 11.3 Version verfügbar ist.


    Nachtrag:


    Ich habe mal nachgeforscht und das erklärt auch jetzt das Problem was ich habe mit den Updates, das keine mehr angezeigt werden, Abhilfe schafft da Big Sur in eine neue Partition (Container) zu erstellen, was dann auch funktioniert.

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

    Edited once, last by Bob-Schmu ().

  • Korrekt, separate Partition ist kein Problem. Allerdings kann man dann auch gleich ne externe nehmen bevor man auf der produktiven Platte herumpfuscht. ;)

    LG Chris


    Meine Hardware:

  • Bob-Schmu, CMMChris


    Ich habe auch in einem Container zwei Volumes für Catalina und Big Sur. Hatte ebenfalls das Problem, dass mir unter Big Sur keine Updates mehr angeboten wurden. Der Fehler lag daran, dass Snapshot Sealed: broken bei der Terminal Ausgabe diskutil apfs list des Big Sur Volumes stand. Zu diesem Zeitpunkt war SIP in der config.plist deaktiviert und nach der Aktivierung von SIP (in der config.plist) konnte ich nicht mehr Big Sur booten, Catalina funktionierte aber einwandfrei. Deaktivierte ich SIP konnte ich wieder Big Sur starten. Deshalb fiel mir der Fehler erst auf. Als ich dann mit einem USB Stick Big Sur über das bestehende Volume drüber installierte, war das wieder behoben. Ich glaube, der Grund das mein Snapshot Sealed auf broken stand, war, dass ich die Big Sur Systempartition zuvor auf Lesen und Schreiben (mit Kext Updater) gesetzt hatte. Obwohl ich in der Systempartition nichts geändert habe, dürfte dadurch das Problem entstanden sein (reine Vermutung!!!). Seitdem funktioniert alles wieder wie es soll. SIP kann verändert werden und Updates werden mir auch angeboten. Es handelt sich dabei um eine SATA SSD. Ich werde es noch weiter beobachten und mich ansonsten von Catalina verabschieden.