OpenCore zum verzweifeln :-/

  • Hallo zusammen und ein gutes Neues noch,


    ich sitze schon seit 2 Tagen am Open Core Bootloader 0.6.5 und ich bekomm es einfach nicht hin. Open Core startet nach Catalina Auswahl bleibt er irgendwie hängen und ich weiß nicht was es ist bei BIG SUR bekomm ich KP. Warum auch immer. Lt. https://opencore.slowgeek.com scheinen die Einstellungen völlig in Ordnung zusein aber ich bleibe immer an einer Stelle stehen danach passiert nix mehr.

    Liegt es vllt an der iGPU???

    Kann mir jemand von Euch BITTE helfen??


    Vielen Dank schonmal und einen schönen Sonntag

    Files

    • OC.zip

      (8.13 MB, downloaded 12 times, last: )

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • Ja genau um dieses. Mit dem Clover Bootloader funtzt es auch als iMac. Von daher glaub ich nicht das es daran liegt. Die Anleitung kenn ich schon und bin sie auch so durchgegangen

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • Versuch mal mit diesem Config.plist zu starten.

    Hab dein Config genommen und nur den IGPU angepasst.

    Teste mit deinem EFI aber mit diesem Config mal.


    Gruss Coban

    Files

    • config.plist

      (36.25 kB, downloaded 12 times, last: )

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Ich hab jetzt ein schwarzes Display 🤔

    Aber scheinbar muss es daran liegen

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • Fauli Erstmal dem Guide für Laptops folgen, nicht dem für Desktops, wie bereits erwähnt. Ansonsten:

    • .dsl source code Dateien gehören nicht in die EFI, sondern nur .aml
    • IvyBridge CPUs unterstützen das X86 Platform Plugin seit OSX 10.12 nicht mehr und es lässt sich daher auch nicht via SSDT-PLUG aktivieren. Stattdessen SSDT-PM mit ssdtPRGen erzeugen und einbinden, damit das CPU Power Management funktioniert. Steht auch so im Guide – egal ob Desktop oder Laptop.
    • SSDT-EC wird nur benötigt, falls der Embedded Controller in der System DSDT nicht definiert ist. Dazu die System DSDT dumpen (mit SSDT-Time unter WIndows). Darin dann suchen nach "PNP0C09". Falls vorhanden, brauchst Du keine SSDT-EC. Ansonsten von SSDT-Time generieren lassen (die Laptop Variante in diesem Fall).
    • SSDT-IMEI benötigt man nur bei Serie 6 Mainboards.
    • Damit SSDT-PNLF funktioniert, das für die Steuerung der Hintergrundbeleuchtung benötigt wird, muss man wissen, wie die Grafikkarte in der DSDT heißt und den Pfad "External (_SB_.PCI0.GFX0, DeviceObj)" in der SSDT unter Umständen anpassen. Bei mir heißt sie z.B. IGPU: External (_SB_.PCI0.IGPU, DeviceObj)
      Guide: https://dortania.github.io/Get…tml#finding-the-acpi-path
    • Falls versehentlich der Desktop Guide verwendet wurde, passt der Framebuffer Patch für die Interne Grafikkate noch nicht. Unter Device Properties den aus dem Dortania Guide einbauen.
    • Falls das Notebook über eine extra Grafikkarte (diskrete GPU) verfügt, diese im BIOS deaktivierren. Falls das nicht geht Boot-arg -wegnoegpu verwenden.
    • Das SMBIOS muss natürlich auch angepasst werden: MacBookPro10,1 für Catalina und MacBookPro11,1 für Big Sur
    • Kexts: entweder BrcmFirmwareData.kext in EFI, ODER BrcmFirmwareRepo.kext in System > Library > Extensions installieren. Sieht auch ansonsten ein wenig überladen aus. 2 AHCI port Kexte zB.

    Viel Erfolg

  • Wenn Du einen zweiten Mac hast, versuche über das Netzwerk per Screen Sharing drauf zu kommen, dann kannst Du ja nachschauen, was angezeigt wird und welcher Framebuffer erkannt wurde.


    Wenn CAPS LOCK geht, bedeutet das, dass der Rechner ganz normal läuft, nur das Display ist schwarz. Wenn kein Licht angeht, höngt der Rechner irgendwo.

    GA-Z97X-UD7 TH / 4790K / GTX750Ti / LG 34UM95-P
    GA-Z97N-WiFi / 4790K / GTX750Ti
    HP ProBook 650 G1 / Clover

  • Also wenn ich dein Config so angucke...

    Ich wollte zuerst mal da aufräumen aber bemerke gerade das du kein WhatEverGreen lädst im Config.plist.

    So kann es nicht starten :-)

    Nimm den Config.plist den ich hingestellt habe, ergänze Whatevergreen und versuche es nochmals :-)

    Bis dann räume ich mal dein EFI bissl auf, dann hast du ein gutes Basis zum verfeinern.


    Gruss Coban


    EDIT: So, kannst mal mit diesem EFI hier als Basis arbeiten, vergleiche mit deinem EFI im ersten Posting, die sachen die ich rausgeworfen hab brauchst du nicht.

    Wenn es startet kannst du stück für stück Feintuning betreiben.

    Edit2: hab den SMBIOS auch angepasst beim v2.


    EDIT3: Nach einem zufälligen Test festgestellt das die Config defekt ist.

    Mit V3 korrigiert.

    Files

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

    Edited 2 times, last by cobanramo ().

  • 5T33Z0 vielen Dank für deine Info‘s

    Bzgl .dsl und .aml Dateien, es ist doch egal welche drin sind Hauptsache es stehen nur die aml Dateien in der Config. So denk ich.

    Aber der Tipp mit dem SMBIOS probiere ich später auch mal. Ist das ein Ivy Chipsatz?


    cobanramo dir auch recht herzlich Dank, ich teste es später und gebe dann Bescheid ob es geklappt hat. 🙂🙃🙂

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • Fauli Ja, stimmt. Aber falls Du mal einen Snapshot der Config mit ProperTree erstellen solltest, werden die .dsdl eingebunden. Von daher .dsl am besten rauslöschen. Der Bootloader kann eh nichts mit anfangen.


    Bzgl. Chipsatz: Hackintool installieren und unter PCI gucken, was da steht. Da steht auch der genaue Chipsatz drin. Wenn in der Spalte "Device Name" 7 Series drinsteht, brauchst Du auch keine SSDT-IMEI.

  • 5T33Z0 das probiere ich mal aus, mit ProperTree, bin ich gespannt.

    Also im Hackintool steht es sei eine 7er Serie dass heißt raus damit, ok.

    Noch eine kleine Frage bzgl Audio🤓

    Es ist ein AlC269 muss ich jede ID durchgehen bis ich den richtigen gefunden oder gibt es einen Trick?

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • Fauli Für Audio benötigst Du sehr wahrscheinlich noch eine SSDT-HPET, damit Audio funktioniert. Kannst Du mit SSDT-Time generieren. Bei meinem Lenovo Laptop ist auch ne ALC 269 verbaut und da funktionieren Layout ID 28 und 29. Aber das muss nichts heißen.


    Die Batterieanzeige wird wahrscheinlich nicht funktionieren. Da muss man viel umbenenen und so, bis sie funktioniert oder eine gepatchte DSDT verwenden, was man unter OpenCore vermeiden sollte. Damit kenne ich mich auch nicht aus. Meine Erfahrung ist jedoch, dass meine Laptop mit SSDTs statt gepatchter DSDT smoother läuft. Aber einige Dinge habe ich bisher nicht hinbekommen – seit November ;) Also schon mal auf viel Frust vorbereiten.

  • 5T33Z0

    Das hatte ich als Vorlage drin (Plug), ist aber deaktiviert in dem EFI.

    Da ich den Laptop nicht genau kenne hab ich mal vorläufig die IMEI eingebaut.


    Fauli

    für den Audio kannst du gerne mal so Testen falls das ein ALC269VD sein sollte.

    Mit ID 99 hab gute/bessere Ergebnisse bei meinem Ivy erzielen können.


    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Für Clover gibt es einen Guide für diesen Laptop bei den Tomaten.

    Der ist etwas veraltet aber zeigt auch das alles geht.

    Als Smbios eigentlich MacBook Pro 9.2

  • Smbios eigentlich MacBook Pro 9.2

    würde bis Catalina funktionieren, mit MacBookPro11,1 kann man auch BigSur installieren.

    funktioniert bei mir tadellos.


    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • cobanramo hab jetzt deine config und OC Ordner eingefügt aber es kommt nur dieses bild. Habe auch mal die Whatevergreen ausgetauscht aber ohne Erfolg

    Sony Vaio

    Intel(R) Core(TM) i7 CPU 3610QM @ 2.30GHz

    16.00 GB

    HDD 500GB

    Intel HD 4000

    macOS Catalina Version 10.15.7 (Build 19H2)

    Broadcom BCM43225

  • "Whatevergreen info.plst is missing" - Da stimmt der Eintrag unter Kernel/Add für die Whatevergreen.kext nicht.


    Lade mal die config.plst hoch.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Hab Nachhinein bemerkt das die Config defekt ist.

    Hab es mit einem V3 korrigiert.

    guck mein vorherigen posting nochmals an.

    Die Whatevetgreen ist eingetragen aber da stimmt was nicht.


    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Ja für Big Sur nötig. Bei MacBook Pro 11.1 müsste man eventuell die CPU Einstellungen anpassen sonst rennt der ohne Ende da das smbios eine andere CPU voraussetzt.


    Hab für Sidecar auch MacBook Pro 15.1. Doch ohne Anpassung rennt die CPU immer bei 1,2 ghz im idle.


    Die Broadcom Karte muss auch ersetzt werden für macOS