Weder Sidecar noch DRM mit SMBIOS iMac 20,2 I9 10850k und Gigabyte Vision G Big Sur

  • 5T33Z0 Vielen Dank erstmal für den bisherigen Support.


    Ich habe heute mal mein OC aktualisiert und dabei deine Config als Leitfaden benutzt.


    Mir ist aufgefallen das nach dem Update der PowerBereich/Energiesparen eher nach Notebook aussieht oder? Oder habe ich was falsch gemacht?


    LG

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Muss denn X86PlatformShim vorhanden sein? Wenn ich das in IORegistryExplorer checke wird es nicht angezeigt wie hier beschrieben: https://dortania.github.io/Ope…nabling-x86platformplugin


    oder wird das durch die CPU Friend ersetzt?

    Beim i9 10th Gen wird die CPU als PR00 gelistet, nicht als CP00.


    Wenn Du ins Terminal sysctl machdep.xcpm.mode eingibst, so wird als Ergebnis entweder "1" oder "0" ausgegeben. Bei mir steht 1, also 86PlatformPlugin ist aktiv dank SSDT-PLUG.aml.


    Energy Saving Kram habe ich mir nicht angesehen. Power Nap gibt es bei mir nicht als Option.

    Edited 3 times, last by 5T33Z0 ().

  • Blackninja_1985  bluebyte


    Ich habe mir das CPU Power Management nochmal genauer angesehen. Es gibt tatsächlich ein Problem damit. Danke für den Hinweis, Ninja. Es stellt sich wie folgt dar:


    1. Wenn man mit CPUFriendFriend sein Power Management anpasst und dann eine Kombination aus SSDT-PLUG, CPUFriend und CPUFriendDataProvider.kext verwendet, spuckt IORegistryExplorer folgendes für die CPU (Object PR00) aus:



    Ergo: Alles gut, CPU Power Management funktioniert, wie es soll.


    2. Wenn Man stattdessen aber ssdt-data.aml (was ja im Grunde SSDT-PLUG plus cf-freq data ist) samt CPUFriend.kext verwendet, fehlt der Eintrag für's X86Plugin und sieht so aus wie hier: Missing XCPM


    Von daher: Wenn das CPU Power Management angepasst wird, dann ausschließlich SSDT-PLUG, CPUFriend und CPUFriendDataprovider.kext verwenden.

  • Bei mir steht da das ich eine USV habe und habe deine config 5T33Z0 damals auch genommen ...

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • "Damals" ist gut… Die config wurde mehrmals aktualisiert seit "damals" und es sind SSDTS dazugekommen.

  • Die SSDT habe ich von hier auch schon ersetzt...


    Aber trotzdem seltsam das er mir eine USV anzeigt und deswegen klappt das update auch nicht :(


    Weil er mir ständig sagt, das ich die Stromversogung dran machen soll ...

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • Nachdem ich SSDT-PLUG manuell gefixt habe (s.o.) ist PowerNap nun verfügbar

    Dein Code (mit der Abfrage ob überhaupt ein Prozi drin ist und wenn ja, dann eine weitere Methode einsetzen) …



    … kann deutlich reduziert werden:


    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • trotzdem seltsam das er mir eine USV anzeigt

    Vielleicht ein unpassendes SMBIOS gewählt? Oder in der "config.plist" von Clover bei SMBIOS "Mobile" angehakt? Oder bei ACPI "Smart UPS" angewählt?

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Vielleicht ein unpassendes SMBIOS gewählt? Oder in der "config.plist" von Clover bei SMBIOS "Mobile" angehakt? Oder bei ACPI "Smart UPS" angewählt?

    Hab die alte config von 5T33Z0 drin... ich werde die mal aktualisieren.


    Benutze OC und da finde ich in ACPI keine Smart UPS ...

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • Die SSDT habe ich von hier auch schon ersetzt...


    Aber trotzdem seltsam das er mir eine USV anzeigt und deswegen klappt das update auch nicht :(


    Weil er mir ständig sagt, das ich die Stromversogung dran machen soll ...

    Wo wird das denn angezeigt überhaupt? Ich glaube ich habe so was schon mal gelesen und es es lag dann am AIO oder an ner Wasserpumpe oder irgendnem LED Controller Gedöhns.

  • Wo wird das denn angezeigt überhaupt? Ich glaube ich habe so was schon mal gelesen und es es lag dann am AIO oder an ner Wasserpumpe oder irgendnem LED Controller Gedöhns.

    Ja ich glaube auch... Da war was... Habe ja ne Corsair H150i Elite verbaut und Corsair Commander Pro usw usw

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • apfelnico Wenn ich deinen korrigierten Code verwende, funktioniert das Plugin nicht mehr. Ich lasse es jetzt so.

  • Aber das muss man doch irgendwie Patchen können :(


    Ich bekomm auch sonst keine updates rein...


    EDIT: Hab den alten Thread gefunden, aber es gibt dort auch keine richtige Lösung :(


    Alter Thread

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • Benutze OC und da finde ich in ACPI keine Smart UPS ...

    Ok. Dann aktualisiere mal bitte deine Daten. Bei dir steht "Bootloader: Clover", daher bin ich davon ausgegangen. "Corsair Commander Pro" – da bist du auf der richtigen Spur.


    5T33Z0

    Jupp, mein Fehler. So wäre es richtig, ist ähnlich auch im originalen Mac drin:



    Wohl auch nicht kürzer. :)

    Du kannst es aber gern testen.

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

    Edited once, last by apfelnico ().

  • Ok. Dann aktualisiere mal bitte deine Daten. Bei dir steht "Bootloader: Clover", daher bin ich davon ausgegangen. "Corsair Commander Pro" – da bist du auf der richtigen Spur.

    Hab es geändert. Habe die selbe Hardware wie 5T33Z0 ... Hab auch gerade alles noch mal aktualisiert ...


    Bei OC gibt es ja leider nicht die Einstellung wie bei Clover wegen Mobile oder Smart UPS ...


    Mit freundlichen Grüßen

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini

  • Bei OC gibt es ja leider nicht die Einstellung wie bei Clover wegen Mobile oder Smart UPS

    Ist auch nicht wichtig. Je nach SMBIOS und tatsächlich vorhandener und eingebundener Hardware bei Laptops (Akku- oder Netzteilbetrieb), wird das schon korrekt benutzt. Diese vielen extra Hacks von Clover sind ja Teil des Problems, dass da keiner durchsteigt … :)


    Dein Problem ist tatsächlich Corsairs "Commander Pro". Wie dazu eine Lösung aussieht, weiß ich leider nicht. Keine Ahnung, ob "nichtbenutzen" eine Option ist.

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Ich benutze sie ja auch nicht unter Mac, unter windows nur halt ...


    Jetzt hab ich mir überlegt ob ich die nicht irgendwie blocken kann... Geht das?


    Als ich damals die USB Ports konfiguriert habe... Aber ich meine das meine BT Karte auch dran angeschlossen ist, daher ist es wichtig... Oder ich muss mir so ein intern USB Splitter kaufen und dann den Commander wirklich aus der USB liste raus schmeissen :(


    5T33Z0 : Gibt es einen Grund warum du die EnergyDriver.kext raus genommen hast bei deinem aktuellem update=?


    Mit freundlichen Grüßen

    HackMac:

    Intel Core i9 10850K/Gigabyte Z490-Vision G/Corsair Vengeance LED 32GB DDR4@3200MHz

    Radeon RX 580 8GB / WD Black SN750 1TB SSD @ OC 0.6.6 BigSur / Crucial P2 1TB @ WIN10 Pro


    MacBook Pro 15 Early 2011
    Core i7/16GB Ram/Crucial MX500 480GB


    Apple Devices:
    iPad Air 2, Iphone 5 & 12 Pro Max, Watch Series 5, Apple TV 2, Apple iPod Nano, HomePod Mini