Weder Sidecar noch DRM mit SMBIOS iMac 20,2 I9 10850k und Gigabyte Vision G Big Sur

  • Hallo zusammen,


    ich habe mir gerade einen neuen Hacke zusammen gebaut und mich dabei für die EFI an verschiedenen anderen Systemen aus dem Forum hier orientiert.


    Ich habe aber das Problem das ich weder DRM noch Sidecar nicht zum Laufen bekomme.


    Ich habe das Gefühl also ob die eingetragenen AAPL ig-platform-id nicht richtig übernommen wird.


    Ich habe schon folgende ausprobiert: 0300C89B sowie 0300923E und 07009B3E


    neben der IGPU ist noch eine Vega 64 im System verbaut. und die IGPU soll headless laufen.


    Den Fehler konnte ich beheben: Im Bios war die IGPU auf auto statt auf nable gestellt.


    Hat noch jemand eine Idee das zumindest das eine oder andere funktioniert? Also entweder DRM oder Sidecar?


    Anbei noch meine EFI



    und Dank vorab.

    Files

    • EFI.zip

      (9.15 MB, downloaded 14 times, last: )

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

    Edited once, last by Blackninja_1985: Fortschritt :-) ().

  • DRM funktioniert nur mit deaktiver IGPU, dann geht Sidecar nicht und umgekehrt

    Also entweder Sidecar oder DRM

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • Nightflyer


    Das ist immer noch?

    LG

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Wüsste nicht dass es sich geändert hat

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • Gilt das denn auch für die TV app?


    auf meinem alten System ging die immer noch ;)

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Die TV App hab ich nie benutzt

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • Ggf sonst noch jemand?

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Blackninja_1985 Komische SSDTs hast Du da drin teilweise. Wo stammen die her? Haste die einfach 1:1 aus dem Vision D Build von Schmockloard übernommen?


    In BASIS-SSDT (zum Glück deaktiviert) stehen Sachen drin, die teilweise unnötig sind oder von anderen SSDTS übernommen werden. PMCR ist für Z390. DTPG braucht man nur, wenn man gepatchte DSDTs verwendet, wenn ich es richtig verstanden habe:

    Quote

    DTGP method must be present at the DSDT in order to inject custom parameters to some devices. Without this method the modified DSDTs would not work well.

    But in Dortania they prefer independent SSDTs, each for a specific function. And all these SSDTs already have the DTGP method incorporated. For this reason, it is currently not necessary to use SSDT-DTGP and information about it is not easily found.


    https://www.reddit.com/r/hacki…e_knows_what_ssdtdtgp_is/

    Von daher überflüssig in OpenCore.


    Und Disable CNVW (Kommentar in Config: "Disables the CNVi Slot where the onboard m.2 Intel Wifi 6 card sits") ist auch überflüssig, da das Board gar kein on-board WLAN hat.


    Kannst ja mal meine EFI angucken:


    Z490 Vision G


    DRM funktioniert. Allerdings nutze ich weder eine AMD GPU noch Sidecar, von daher kann ich dazu nichts sagen, außer das, was meine Vorredner bereits angemerkt haben: entweder DRM mit iMacPro1,1 oder Sidecar mit iMac20,2.

  • Ja sicher, bei mir auch. Aber kein Sidecar... dazu brauchst du iMac19,1 aber dann leider kein DRM mehr [floet]

    Grüße, MacDream

  • Erstmal vielen Dank für die Antworten. Die Basis-SSDT stammt von einem anderen Board. Daher auch deaktiviert. Entferne ich aber direkt hast recht. Die CNVi Sache ist mir durch gegangen. Auch hier vielen Dank für den Hinweis 5T33Z0 Ich schaue mir deine EFI gleich mal an

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • 5T33Z0 ich habe mir deine config angesehen und glaube alles verbessert an meiner Config. Auch das Intel power gadget läuft gut. Vielen Dank dafür.


    Btw.: hast du für unsere Combi Vision G mit 10850k einen overclocking Guide gefunden? Bzw kannst du mir sagen was ich da ändern muss um ein bisschen mehr Leistung zu bekommen?

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Alles klar. Trotzdem vielen Dank für alles bisher

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Blackninja_1985 den 10850K brauchst du nicht zu übertakten die 100MHz die du mehr raus bekommst, fressen ordentlich Leistung und bringen keine Punkte.

    Was hast du für eine Kühlung?

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • Bob-Schmu gekühlt wir mit Wasser :-) 360 Radiator von Alphacool mit entsprechendem Zubehör. Also keine AIO


    Ich denke es sollte schon was bringen wenn man den Boots auf alle Kerne ausweiten kann...oder?

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Nimm doch einfach mal das PL2 raus und mach ein Prime95 test, automatisch bosten die ganzen Kerne auf 5.0GHz.

    Für Dauerbelastung den Multiplikator auf 50 Stellen und die Volt zahl anpassen, mehr brauchst du eigentlich nicht.



    Um auf 5.2GHz zu kommen wenn es deine CPU hergibt, musst du schon 1.4V anlegen um einen stabilen Takt zu bekommen, den Mehrverbrauch ist für die 5% mehr Gewinn nicht in Relation zu setzen.


    https://www.techpowerup.com/re…el-core-i9-10850k/20.html

    iMac20,1


    CPU: Intel Core i7-10700

    GPU: RTX 3090 + Gigayte RX 560

    MB: Gigabyte Z490 Vision G

    RAM: 64GB

    OS: Big Sur / Windows 10

    Bootloader: OpenCore 0.6.x

  • 5T33Z0 funktioniert bei dir Power Nap?


    Bei mir habe ich den Punkt unter Energie sparen nicht verfügbar


    LG

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x

  • Nope. Aber da es ich den Rechner als Wrkstation nutze und es kein Notebook ist, benötige ich AppNap auch nicht. Die einen sagen, ErP aktivieren hilft, die anderen sagen, SSDT-PLUG muss vorhanden sein. Habe Platform Power Management aktiviert und deaktiviert, ebenso ErP – keine Änderung. Von daher werde ich mich auch nicht weiter damit beschäftigen, ob und wie man es fixt.

  • Muss denn X86PlatformShim vorhanden sein? Wenn ich das in IORegistryExplorer checke wird es nicht angezeigt wie hier beschrieben: https://dortania.github.io/Ope…nabling-x86platformplugin


    oder wird das durch die CPU Friend ersetzt?

    LG

    René


    Gigabyte Z490 Vision G| i9 10850l | 32GB | Vega64 8GB | NVMe 1TB | macOS 11.1| Open Core 0.6.x