Hackbook für Sohnemann - Dell E5470

  • Mahlzeit! Bin gestern Abend leider nicht mehr sehr weit gekommen. Beim Cryptostick kam nach dem Vorbereite und Booten ein Textmenü ("Continue", "Select Language", "Boot Manager", "Device Manager", "Boot Maintenance Manager"), ich vermute, dass ist ein Clover Menü?! Also hab ich den Stick noch einmal komplett platt gemacht:


    Disk Utility -> Löschen -> "MyVolume", "Mac OS Extended (journaled)", "GUID-Partitionstabelle"

    sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume

    Clover_r5128.pkg ->

    Den Inhalt Deines EFI Paketes nach "EFI" in der EFI-Partition kopiert.


    Das müsste es dann doch eigentlich gewesen sein, oder fehlt noch etwas?


    Edit: Danke für's Daumendrücken und die Unterstützung! Mal schauen, was zuerst passiert: Dass ich MacOS installiert bekommen oder Dein Dell-Läppi wieder bei Dir ist. ;)

  • Das müsste es dann doch eigentlich gewesen sein

    naja, eigentlich war das sogar zuviel. wenn du die install....app auf den stick geschrieben hast (anymacos, tinu, terminal...) dann reicht es aus, einfach die EFI zu mounten, und den efi-ordner dort hineinzukopieren. clover muss nur dann "richtig installiert" werden, wenn es sich um einen rechner handelt, der noch kein uefi kann.



    Mal schauen, was zuerst passiert:

    bis dienstag abend hast du zeit um den wettlauf zu gewinnen 8o

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Okay, hab ich also zu viel gemacht - aber war's schädlich? Der EFI Ordner samt Deinem Inhalt ist ja da:


    Denn Wettlauf würde ich ja gerne annehmen, aber im Moment sieht's nach nem ziemlich holprigen Start für mich aus...


    Edit:

    Okay, zumeist sitzt das Porblem ja vor dem Rechner... :D Ich hatte wohl bei den manuellen Bootoptionen die falsche Auswahl getroffen, nachdem ich den Dell einfach habe starten lassen (ohne Boot-Auswahl) hat er Clover gestartet und dort auch die Installation. Der oben genannte Fehler tritt aber trotzdem auf. Und ein Blick auf den Cryptostick zeigt: der ist ja auch USB3.0... Sollte es daran liegen? Gibt's ne Kext für USB3.0 Unterstützung? Im Clover Configurator sehe ich unter Installierte Treiber -> Drivers BIOS 64 Bit -> XhceDxe "USB 3.0 Driver" nicht installiert. Muss das installiert werden?

  • biosdrivers sind für uefi-geräte komplett uninteressant.

    du könntest noch (ist jetzt nicht überlebensnotwendig...) den ordner CLOVER/ACPI/origin ausleeren, das sind noch dateien von meinem klapptopf. und im ordner BOOT stecken 2 dateien mit der endung .bak. kann auch weg.


    was aber sein könnte: verschieb mal die datei "USBE5470i3.kext" von other nach off.

    und auch hier könnte der fehler vorm rechner sitzen.... wir werden sehen....

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Wessen Rechner auch immer das war, vor dem der Fehler saß... 8o


    Nach dem Verschieben der USBE5470i3.kext und dem Löschhen der.bak Dateien (die werden's nicht gewesen sein) ist die Installation gestartet.:top:


    Man soll den Abend ja nicht vom Tag, oder so... aber nun sieht's gut aus! Melde mich bei den nächsten Schwierigkeiten (was je nach Zeit, die mir die Familie lässt sehr schnell gehen oder auch noch etwas dauern kann. :D

  • prima. dann scheinen sich unsere geräte bei den usbs ein wenig zu unterscheiden. das gucken wir uns an, wenn die installation durchgelaufen ist.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • So, ich kämpfe mich Stück für Stück voran. Natürlich war die ursprüngliche Windows Installation auf einer SSD mit MBR - will der Mac OS Installer scheinbar nicht... Also Win 10 ISO runter geladen, auf den anderen Stick kopiert, "alte" Windows Installation platt gemacht und neu Installiert, diesmal mit GUID. Soweit so gut. Auf der SSD sind noch ca. 170 GB fpr Mac OS, was erst mal locker reichen sollte. Der Installer erwartet aber eine Mac OS Extended. Ist ja nicht so, dass er die selbst im freien Platz der SSD erstellen könnte. Das Festplattendienstprogramm ist auch nicht in der Lage, eine weitere Partition anzulegen. :| Also muss echt das Windows Festplatten Dingsbums dran, um im noch leeren Speicherbereich eine ExFAT Partition anzulegen. Beim Versuch, diese dann wiederum im Mac Festplattendienstprogramm zu löschen und mit Mac OS Extended zu formatieren, bricht das mit der Fehlermeldung ab "MediaKit meldet: Gerät hat für den gewünschten Vorgang nicht genügend Speicher.: (-5344)". Hä?! Muss man hier eigentlich nen Fünfer löhnen, wenn man sagt, dass man sich verApplet vorkommt? ;) Selbst löschen geht nicht mit gleicher Fehlermeldung?! Hmmm, ich dachte, ich könnte den Wettlauf noch gewinnen...

  • mach das doch mal andersrum. wenn du im macosinstallerscreen bist, schmeiss das festplattendienstprogramm an, achte darauf, dass unter darstellung "alle geräte einblenden" ausgewählt ist.



    jetzt löschst du die ganze platte (windows wird jetzt einfach mal geschlachtet...), wählst beim neu machen "apfs" ohne schnickschnack wie verschlüsselt oder case-sensitiv aus. danach gehst du auf partitionieren, bestehst darauf, dass partitioniert wird, nicht nur ein neuer container gebastelt, teilst die partition, und wählst als format macos journaled extended für die 2. partition aus.

    dann installierst du macos in die apfs-partition. mach alles fertig, pass gut auf den installerstick mit der efi-partition auf ;-) und schmeiss jetzt die windosen installation an. windows wird die 2. partition formatieren wollen, darf es, und es wird sich auch in der efi-partition verewigen. den "microsoft-ordner" brauchst du, die dateien im ordner "BOOT" sollten danach gegen die vom clover ersetzt werden (mach dringend ein backupp der windosenbootdateien!!!!!!), und im bios muss man den windosenbootmanager nach hinten schieben (nicht löschen, der hat das mit der wiederauferstehung ziemlich gut drauf ;-) )

    dann kommt noch der ordner "clover" in den efi-ordner, und eigentlich sollte die dualbootwelt des hackbooks dann in ordnung sein.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Klingt nach nem Plan! :danke:


    Edit: Der Plan war gut! MacOS installiert, Windows installiert, Boot-Reihenfolge geändert (Stick vor Windows). Reicht erst mal für heute.


    Das Hackbook kann noch kein WLAN und war bisher auch noch nicht ans LAN angeschlossen (das kommt morgen). Die Tastatureinstellungen sind noch gewöhnungsbedürftig, insbesondere die Fn-Tasten passen noch nicht und scheinen die Funktionen gelegentlich zu wechseln oder vergessen.


    EFI ist noch nicht angepasst, auch das kommt dann vielleicht morgen. Für heute bin ich zufrieden :)


    Merci!


    Edit2: Moin! Ich frage mich gerade, ob bzw. wann ich die Seriennummer nochmal ändern sollte. Sollte das vor dem ersten Kontakt des Hackbooks mit dem Internet passieren oder ist das egal?


    Ich mach mal nen dritten Edit auf.


    itisme Du hattest vorgeschlagen, die interne WLAN Karte über itlwm.kext einzubinden. Ich habe den Kext heruntergeladen (sind eigentlich bei allen die GitHub Downloads so unerträglich lahm oder nur bei Telekomikern?) und den Kext mal mutig einfach nur in den other Ordner unter EFI/clover/kexts abgelegt und das Hackbook neu gestartet. Siehe da: Bluetooth ist da und eine zweite Ethernet-Schnittstelle. Ich habe jetzt herausgefunden, dass da so normal ist und man z.B. über HeliPort das WLAN konfigurieren kann (bzw. muss, wenn man nicht in irgendwelchen Plists herumfuhrwerken will).

    Was hab ich sonst noch festgestellt? Ton geht, Webcam geht, Uhrzeit geht NICHT, wenn man das Laptop mal zugeklappt hat.


    grt kann ich eigentlich bedenkenlos das Netzwerk eunschalten, ohne die Seriennummer geändert zunhaben? Oder viel bessere Frage: wo ändere ich die? Im Clover-Configurator? Wird die dann automatisch in der config.plist geändert?

  • die seriennummer ist nur dann wirklich interessant, wenn du dich mit deiner appleid anmeldest. ich hab sie geprüft, sie wäre eigentlich in ordnung, und könnte so genutzt werden.

    aber da man ja nun nicht weiss, wer sich den efi-ordner noch alles so runterlädt, und sich nicht um die seriennummer schert, sage ich immer dazu, dass man sich doch bitte um eine eigene seriennummer kümmern möge. nicht, dass dann plötzlich etliche "macbooks" mit identischer seriennummer im store angemeldet werden....

    online gehen kannst du jetzt ohne weiteres, solltest du sogar, um zu testen ob lan funktioniert.


    die seriennummer änderst du mit dem cloverconfigurator:



    bei grün mehrfach auf "neu generieren" klicken, bis die zeichenfolge gefällt (oder so...). dann "überprüfen des gehäuses", dort landest du auf einer webseite, captcha eintippen, und wenn dann rauskommt, dass es sich NICHT um eine gültige seriennummer handelt, ist alles gut.


    jetzt trägst du die zeichenfolge "boardserialnumber" (gelber kasten) unter MLB im reiter "rt variables" (auch gelber kasten) ein:



    speichern, freuen, fertig.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Hmm, okay. Und da soll sich auch was tun, wenn man auf Neu generieren klickt, nehme ich mal an. Weil bei mir ändert sich da nix. Wenn ich nebendran bei SmUUID klicke auf neu generieren klicke, dann scho, aber nicht bei der Seriennummer, um die es ja geht. Steck da irgend ein System bei den Seriennummern dahinter? Vermutlich schon. Sonst würde ich einfach irgendeine Seriennummer ausprobieren. Ich denke, das wird nicht funktionieren, oder?



    Edit: Okay, man muss erst mal auf das unscheinbare Pfeil-hoch-runter Element rechts klicken und dann das Modell noch einmal Mac auswählen, also hier Macbook Pro 13,1. Auch wenn das in der config.plist eigentlich schon steht. Ist wohl ein kleiner Bug im Clover Configurator. Aber so hat's dann geklappt.


    Edit2: So, doch noch ein Grund zum Freuen: LAN funktioniert, WLAN mit HeliPort auch, das hier schreibe ich jetz schon vom Hackbook. :) Also gleich mal die Systemkonfiguration hier aktualisieren, EFI Ordner nochmals sichern, dann ist Feierabend für heute...


    Edit3:

    So, da ich keine neue Antwort senden kann, erfärt auch dieser Eintrag noch ein Edit :)


    Heute Themen Bluetooth und WLAN-Karte:

    • Ich sehe zwar eine Bluetooth Netzwerkschnittstelle, aber Bluetooth Verbindungen im klassischen Sinne (Headset, Maus o.ä.) sind über den itlwm.kext aktuell bei mir nicht möglich. itisme Weißt Du, was da ggf. noch zu tun wäre?
    • WLAN Karte hatte ich mitgenommen, dass die 1820A zwar günstig und verfügbar ist, aber nicht die komplette Funktionsvielfalt unterstützt. Insofern käme die Broadcom BCM94352Z DW1560 infrage (https://www.ebay.de/itm/Broadc…FI-WLAN-Card/272204993348). Bei meiner Recherche bin ich dann noch auf Karten mit dem Broadcom Chipsatz BCM94360NG gestoßen, die in der Bucht häufig mit "better than BCM94352Z" beworben wird (https://www.ebay.de/itm/Plug-p…4352Z-DW1560/392946654003). Hier im Forum hat auch schon jemand geschrieben, dass die out of the box ohne Kexte usw. funktioniert. Hat jemand Erfahrungen mit der Karte? Preislich und bzw. Verfügbarkeit/Lieferzeiten ist die ja verleichbar und soll wirkliche den kompletten Apple Funktionsumfang unterstützen. Hat jemand Erfahrungen? Diesen Beitrag hatte ich schon gefunden: OOB BCM94360NG NGFF Broadcom Karte

    Edited 3 times, last by Kandamir: Nachfrage zu Bluetooth und WLAN-Karte ().

  • Bluetooth Verbindungen im klassischen Sinne (Headset, Maus o.ä.) sind über den itlwm.kext aktuell bei mir nicht möglich.

    Da muss die IntelBluetoothFirmware.kext zusätzlich installiert sein, dann sollte das eig. klappen.


    dass die 1820A zwar günstig und verfügbar ist, aber nicht die komplette Funktionsvielfalt unterstützt

    Wie kommst Du da drauf?

    Kleiner Geheimtipp zu "das" und "dass" ;) Kannst Du das umgangssprachliche "des" einsetzen? => "das" :) (sonst immer "dass").

  • Ich meine, das so gelesen zu haben. Oder anders: Ich meine, Aussagen gelesen zu haben, dass User nicht die ganze Funktionsvielfalt nutzen und deswegen keine Aussage treffen konnten. Müsste mich im Zweifelsfalls raussuchen, aber ich will mich darauf nicht versteifen. Manche Dinge kommen bei mir eher nicht in Frage (entsperren mit Apple Watch ist mangels Apple Watch beispielsweise nicht relevant), aber ich investiere lieber ein paar Euro mehr, wenn ich weiß, dass ich perspektivisch damit keine bzw. weniger Probleme haben werde, als wenn ich mir die Euros gespart hätte. Ich habe definitiv auch gelesen "ich hätte besser mal nicht gegeizt und gleich die DW1560 gekauft" (sinngemäß). Wenn die 1820A den gleichen Funktionsumfang ermöglicht und ebenso stabil läuft - wegen mir... ;)


    IntelBluetoothFirmware.kext werde ich nachher raussuchen und ausprobieren, Danke! :)

  • ich könnte den Wettlauf noch gewinnen...

    was du wenn ich das richtig sehe, ja auch geschafft hast. mein dellchen ist erst seit einer stunde wieder zu hause, und du hattest (spätestens) vor 4 stunden schon das finetuning bzgl. der wlankarte angeworfen. dass eine intel-wlankarte eventuell etwas sehr holperig unterwegs ist, inkl. ihres integrierten BT ist normal, und zählt nicht.


    also: herzlichen glückwunsch zum gewonnenen wettlauf ;-) :feuerwerk::party::feuerwerk:


    ich hatte mir die tage eine DW1560 geleistet, und ich könnte sie morgen mal gegen die DW1820A tauschen, und von den unterschieden berichten. bisher bin ich mit der 1820A voll zufrieden, allerdings nutze ich die ganzen apple-raffitücken mangels gerätschaften auch nicht. leider kann meine alte fritzbox kein 5ghz, so dass ich nicht wirklich realistisch gucken kann, ob wlan evtl. fixer ist mit der DW1560 - bei der dichte von 2.4 ghz-netzwerken und den unendlich vielen bt-devices, die hier herumfunken, ist ein aussagekräftiger test einfach mal nicht machbar. ich warte ja schon seit ewigkeiten, dass mal eine frischere fritzbox vom himmel fällt, aber bisher vergebens... ;-)

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Das mit dem IntelBluetoothFirmware.kext hat bei mir leider nicht geklappt. Herunter geladen und in den others Ordner gelegt, neu gestartet. Immer noch keine Bluetooth Unterstützung. Im ZIP lag auch noch eine Injector kext bei, die hab ich dann auch noch da abgelegt - ohne Verbesserung.


    grt :danke2: für‘s Feuerwerk, die Glückwünsche und ganz besonders für die gute Unterstützung! Der Anfang war schwer und Dein An-die-Hand-nehmen extrem hilfreich!


    Bin gespannt, was Du zur DW1560 sagst, allerdings ist meine Fritte scheinbar deutlich moderner und 5GHz sollte bei mir schon gut laufen. In F‘hain ist die WLAN-Dichte deutlich höher (offtopic: freifunkst Du eigentlich?), als bei mir draußen im Speckgürtel. Aber ich hab hier alleine so viele 2,4GHz WLAN Geräte aktiv, dass ich froh bin, wenn ich 5GHz nutzen kann.


    BT ist mir dahingehend wichtig, dass Sohnemann erstens mit BT Headset unterwegs ist und das auch für‘s Homeschooling nutzen soll und zweitens auch ein Taschenäpfelchen sein Eigen nennt und da die Interaktion mit dem Hackbook klappen soll. Weil das gibt sonst Mecker, da hab ich keine Lust drauf. Wobei ich gerade am überlegen bin, ob ich den kleinen Hackintosh nicht selbst behalten soll. :D Ach nee, ich nehm dann doch das gute teure MBP, das war ja nicht nur teuer, sondern hat auch des geilere Display. ;) Nur die Klapperatur nervt mich mit ihren Tastenprellern, da hat sich der Tim verkocht...

  • ich warte ja schon seit ewigkeiten, dass mal eine frischere fritzbox vom himmel fällt, aber bisher vergebens...

    Das wär doch gelacht, wenn wir das nicht hinkriegen würden, oder?

    Kleiner Geheimtipp zu "das" und "dass" ;) Kannst Du das umgangssprachliche "des" einsetzen? => "das" :) (sonst immer "dass").

  • :D Die Fritte fiele dann aber nicht vom Himmel, sondern dem Paketdienst aus dem Transporter und grt vor die Wohnungstür. ;) Trotzdem coole Aktion! :thumbup:

  • Na dann, Thema erledigt! Mega von Dir! :klatschen::):):)


    Ups ... man muss auch richtig lesen: "fiele" ... Ok, bleibt unerledigt! :P

    Kleiner Geheimtipp zu "das" und "dass" ;) Kannst Du das umgangssprachliche "des" einsetzen? => "das" :) (sonst immer "dass").

  • ich warte ja schon seit ewigkeiten, dass mal eine frischere fritzbox vom himmel fällt

    und das warten hatte tatsächlich eben ein ende.... ich konnte grade noch den kopf einziehen, da purzelte eine 7490 herunter...

    mehr hier: KLIKK

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus