(Brauche Hilfe) HP "Hackbook" Folio1040 G3 kein Touchpad, keine Tastatur und keine Batterie Anzeige

  • Die DSDT.aml kannst so direkt nicht bearbeiten, sie muss zunächst in ihre Quelldatei "zerlegt" werden. Dafür gibt es ein Tool. Ich weiß gar nicht ob, das noch funktionier, ist schon wieder eine Weile her, dass ich das gemacht habe. - Aber wir können es ja mal versuchen. Die aml.Datei wird dann zu einer DSL.Datei. Die kann man dann mit MaciASL ändern und anschließend wieder zur aml.Datei compilieren.


    Entpackt die iasi.zip am besten in Deinen Programme-Ordner. Kopiere Deine DSDT.aml unverändert in einem Ordner, den Du per Terminal schnell erreichen kannst. Dann im Terminal folgendes eingeben:


    cd "Dein Ordner"
    iasl -da -dl * .aml


    nun werden alle aml.Dateien in ihre Quelldateien zerlegt und sollten dann dsl.Dateien sein.


    Diese Datei kannst Du dann mit dem MaciASL verändern.In MaciASL findest Du unter Preferences und dann Sources bereits Quellen mit teils vorgefertigten Patches (Batterie, aber auch andere Dinge), Ich bin immer so vorgegangen, dass ich immer nur eine Sache verändert habe und dann ausprobiert, was es bringt. So kannst Du immer wieder zurück und musst nicht ganz von vorn anfangen.


    Ich glaube für Dein HP ganz konkret ist in den Vorlagen kein Batterie-Patch dabei, also würde ich ein ähnliches probieren.


    Wenn keine Vorlage funktioniert, bleibt uns nur die Handarbeit. Ich habe schon mal flüchtig reingeschaut. Du hast natürlich zahlreiche 16bit Blöcke, die müssen aufgeteilt werden und dann noch die B1B2 Methode. Ich komme aber jetzt nicht dazu. Dass müsste ich mal in Ruhe machen.

    Files

    • iasl.zip

      (431.21 kB, downloaded 8 times, last: )

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Danke dafür, ich werde mal testen wie weit ich komme und dir dann berichten.


    Ich finde es voll cool, mal wieder was neues zu lernen.


    Vielen Dank und Gute Nacht,


    KantarOSX:andiearbeit::danke2::danke2::danke2:

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

  • Guten Morgen @ all, jetzt hab ich mich mal paar Tage mit der DSDT befasst aber irgendwie blicke ich da noch nicht richtig durch. Die Fehler habe ich soweit es geht beseitigt, aber ein Fehler bekomme ich nicht weg. Ein bearbeiten der DSDT wegen der Batterieanzeige und den 8bit geschichte habe ich noch nicht verstanden, ich hab die Anleitung gelesen und mir das mal angeschaut, aber ich komme da nicht weiter.


    Wenn ich heute Abend zuhause bin hänge ich die DSDT nochmal an vielleicht kann da mal jemand schauen.





    RenStad Vielen Dank nochmal für deine Hilfe bis jetzt vielleicht hast du ja auch nochmal einen Tip für mich der mir das verständlich macht wo ich in meiner DSDT schauen muss.


    Gruß,

    Kantar

    Files

    • DSDT.dsl.zip

      (93.37 kB, downloaded 8 times, last: )

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

    Edited 3 times, last by KantarOSX: DSTD angefügt ().

  • ich hatte mit Deiner DSDT am Wochenende mal angefangen, bin aber noch nicht dazu gekommen, etwas fertig zu machen. Ich komme frühestens wieder am WE dazu. Wenn ich was habe, stell ich es hier rein.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • super vielen vielen Dank.:danke::danke::danke::danke::danke::danke:

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

  • So, anliegend einmal zwei Versuche:


    1. DSDT.aml

    2. SSDT-1040G3.aml


    Die DSDT.aml ist Deine Vorlage mit einigen Patches zurück. Kann die Datei natürlich nicht testen, sonst hätte ich jede Änderung einzeln eingebaut und getestet. Probiere mal, ob sich etwas zum Positiven verändert, insbesondere ob Du nun eine Batterie-Anzeige hast und berichte, was sich getan hat.


    Vorher kannst Du aber auch versuchen, nur die SSDT-1040G3.aml einzubinden. Die ist mir aus meinen früheren Experimenten mit meinem Probook noch in die Hände gefallen.

    Files

    • AML.zip

      (53.42 kB, downloaded 11 times, last: )

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Erstmal vielen Dankfür deine Hilfe, ich werde es gleich testen und dann berichten ob sich was getan hat. Muss ich noch irgendwas beachten, oder einfach die aml in den Ordner und in der Config einfügen.


    Gruß,

    KantarOSX

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

  • Genaus so, einfügen und einbinden.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Also mit der SSDT-1040G3.aml keine Veränderung.

    Mit der DSDT.aml passiert es das der Laptop-Monitor nicht mehr funktioniert, er wird beim starten einfach Dunkel das wars. Ich habe einen Externen Monitor über HDMI angeschlossen, dieser liefert ein Bild.


    Leider keine Verbesserung mit der Batterieanzeige.


    Ich hab nochmal meine EFI angehängt vielleicht hab ich ja irgendeinen Fehler den ich nicht sehe.


    Gruß,

    KantarOSX

    Files

    • EFI.zip

      (22.79 MB, downloaded 14 times, last: )

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

    Edited once, last by KantarOSX ().

  • Schade, das mit dem Display hätte man heilen können, hier fehlen noch Eintragungen unter DevicePropperties aber wenn die Batterieanzeige immer noch nichts macht, muss man weitersuchen.


    Mir ist allerdings erst jetzt aufgefallen, dass wir ein wichtiges Detail wohl schon eine ganze Weile übersehen haben, Du hast die ACPIBatteryManager.kext in Deiner config.plst nicht eingebunden. Nun bin ich zurückgegangen. In #17 war die Kext noch in der config enthalten, in Deiner Version aus #26 schon nicht mehr. Warum hast Du den Eintrag entfernt? Mir ist dies leider gar nicht aufgefallen.


    Das bedeutet, Du musst praktisch noch einmal die Hinweise min. ab #25 zurückgehen.


    Nach Einbindung der ACPIBatteryManager.kext in Deiner config dann jeweils die verschiedenen aml.Dateien nochmals prüfen:


    Prüfe min.:

    1. Die SSDT-BATT.aml aus #25

    2. Die SSDT-1040G3.aml aus #46

    3. Die DSDT.aml aus #46 (wobei hier ja das Display-Problem angegangen werden muss, ist aber erstmal egal - jetzt geht es zunächst mal um die Batterie-Anzeige)

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Hallo RenStad, wie konnte das denn passieren? Ohwei ich werde schon alt ;-)


    Ich korrigiere es und versuche die 3 Varianten erneut.


    EDIT: 1 Versuch voller Erfolg!!!!! Ich habe die DSDT.aml von dir genommen und den ACPIBatteryManager.kext in die Config.plist eingetragen und schon gibt es eine Batterieanzeige, JUHU!!!!!


    Jetzt bleibt noch das Problem mit dem Schwarzen Laptop Bildschirm. Und es wäre super nett von dir wenn du mir das irgendwie ( keine Ahnung wie ) beipringen könntest mit dem DSDT patchen, dann könnte ich in Zukunft auch dem einen oder anderen Helfen.


    Aber im Moment bin ich nur Happy das es funktioniert. log mich jetzt mal auf dem Laptop ein und lade von dort mal ein Bild hoch.


    So hier mal paar Screenshots:


    Hier ohne Netzteil:


    Hier mit Netzteil:


    Und komischerweise geht grade auch der Bildschirm, werde noch ein paar mal booten um das zu verifizieren.


    EDIT2: Also das war wohl Zufall, hab jetzt 5 mal gebootet und nur 1 mal kam Bild am Laptop Monitor.


    Gruß,

    KantarOSX

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

    Edited 3 times, last by KantarOSX ().

  • Na super, dann war die Mühe nicht umsonst. Dann fehlt nur noch Dein "Daumen nach oben".


    Aber ich kenne das auch, man probiert und probiert und verliert irgendwann den Überblick. Ich finde es gut, dass Du die Info-Zeile in der Config übernommen hast. Das ist bei den vielen Tests auch eine kleine Stütze.


    Zur Grafik:

    In Deiner Config hast Du nur die Plattform-ID unter DeviceProperties eingetragen. Ohne jetzt recherchiert zu haben, meine ich, dass du da auch mal andere ID-Werte testen solltest. Google mal nach Deiner CPU. Es kann ausreichend sein, nur die Plattform-ID einzutragen, bei Laptops aber werden meist noch andere Angaben (Device-ID, Framebuffer-Werte usw. - auch die Steuerung der HDMI-Ausgabe kann hier eingestellt werden).


    Versuche mal die Werte aus der anliegenden plst.Datei zum Test zu übernehmen.


    Und wichtig - immer wieder zwischendurch ein NVRAM-Reset machen.

    Files

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Hallo RenStad, ja man macht soviel und da geht sowas mal unter, aber ich muss mir auch einfach angewöhnen es langsamer zu machen und 1-2 mal zu Kontrollieren.


    Heute komme ich nicht mehr dazu, morgen werde ich das Notebook mal mit auf Arbeit nehmen und bisschen Zeit investieren ( während den unwichtigen Telkos ).


    Melde mich dann sobald ich was geändert habe, es gibt sogar noch einen POST Fehler den das Notebook bei einem Neustart macht. Ich hab gedacht das wäre eine BIOS Einstellung, aber da lag ich wohl Falsch, hast du sowas auch schonmal gehabt?


    Ich lade morgen mal ein Video Hoch und vielleicht kannst du oder jemand aus dem Forum was dazu sagen, ich kann mir das nicht erklären.


    Gruß und nochmals vielen Dank für die ganze Mühe,


    KantarOSX:danke::danke::danke:

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s:

  • Hallo KantarOSX,
    Ich verfolge diesen Thread schon ein bisschen, da ich den gleichen Laptop wie KantarOSX besitze und mich gerade mit dem DSDT Patching bzgl. Batterie beschäftige. RenStad hat da schon sehr gute Arbeit mit der DSDT geleistet. Danke an dieser Stelle für die Infos. Werde versuchen die DSDT selbst zu patchen.

    KantarOSX, Du meinst mit Deinem "POST Fehler" bestimmt einen CMOS Fehler, der bei jedem Neustart des Laptops angezeigt wird.
    Hier schreibt macOS Daten in den NVRAM des Laptops. Leider in Bereiche, die macOS besser nicht beschreiben sollte, was sich dann in dem von Dir beschriebenen Phänomen äußert.
    An diesem Problem Arbeite ich parallel. Bisher konnte ich den betroffenen Bereich schon gut eingrenzen, leider aber noch nicht zu 100%, da ca. alle 5 Neustarts dieser Fehler erst wieder auftaucht. Was die Suche nach dem betroffenen Bereich erschwert.


    Sobald ich den richtigen Bereich heraus gefunden habe. Kann ich Dir den entsprechenden Eintrag für die config.plist gerne mitteilen.


    Beste Grüße

    LuckyStriker

  • Hallo LuckyStriker, erstmal vielen Dank dafür das du an dem Problem arbeitest. Ja RenStad hat einen super Job gemacht, alles andere läuft Wunderbar.


    Achso bevor ich es vergesse, das mit dem Video hat nicht geklappt und dann hatte ich keine Zeit mehr, ich versuche es nochmal sobald ich mehr Zeit habe.


    Gruß,


    KantarOSX

    Hackingtosh Projekte:

    Abgeschlossen:

    In Arbeit:

    Echte Mac`s: