Clover Big Sur - Feintuning und OneDrive

  • Hallo liebe Community,


    ich habe mal mit Al6042 bei der letzten Hckcn meinen Hack mit Hilfe seines vorgefertigten Systems erfolgreich auf Catalina geupdated.


    Damit war ich bis vor kurzem auch sehr glücklich. Ich möchte jetzt aber eine Apple eigene App laden und kann das jetzt nicht mehr, weil die jetzt nicht mehr unterstützt wird.


    Also muss Big Sur her.


    Mit OC habe ich mich ca. 30 Minuten beschäftigt, dann beschlossen, dass ich das ein andermal angehen will und das Update ohne Bootloader Umstieg sicher schneller klappt. Habe ja eine funktionierende schlanke config ohne ssdt und dsdt etc.


    Ich habe mein SMBIOS auf 15.1 geändert und neue Seriennummern erstellt. Ging danach alles problemlos wie vorher auch.


    Schnell über Anymacos Big Sur geladen und Stick erstellt. Allerdings verweigerte mir das System nachdem die Daten von Big Sur kopiert wurden den Neustart und beendete mit einer Fehlermeldung. Also habe ich die neue SSD in ein externes Gehäuse und bin den gleichen Weg über das MacBookAir meiner Frau gegangen. Da lies sich dann problemlos Big Sur auf der Festplatte installieren. Also hier wieder angeschlossen und versucht über meinen Bootstick die SSD zu starten. Bekam dann leider folgenden Panic.


    Da ich in einem anderen Thread über Probleme alter Mainboards wie meinem GA-Z77-DS3H Rev. 1.0 gelesen habe, nahm ich ein Bios downgrade von 11a auf F9 vor. Alle relevanten Einstellungen für macOS habe ich vorgenommen.


    Ich glaube alle Änderungen die ab der Clover Version 5120 nötig sind gemacht zu haben. Habe mich da an den Guide von MacGrummel und 5T33Z0 gehalten.


    Habe jetzt mehrere Versuche durch mit verschiedenen Einstellungen und kann weiterhin Catalina aber nicht die externe Festplatte starten.


    Vielleicht kann mal jemand drüber schauen.


    Vielen Dank und schöne Grüße

    Martin

    Images

    Files

    • CLOVER.zip

      (6.8 MB, downloaded 43 times, last: )

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Mach mal beides hier auf 0.


  • Vielen Dank für die schnelle Hilfe! Habe das gemacht. Auch mal Testweise eine SSDT-EC eingefügt. Ich glaube aber das war alles nicht relevant oder zumindest nicht nur.


    Ich depp habe zuviele externe Geräte dran und mein Clover war daher etwas voll. Dabei habe ich die Preboot Partition der neuen SSD übersehen :facepalm: die hat sich anstandslos booten lassen.


    Oh man... melde mich nochmal falls es hier doch noch Probleme gibt.

    Images

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • schau mal hier.


    Außerdem muss Quirks richtig eingestellt werden. Das sieht m.E. etwas dünn bei Dir aus. Kann aber selbst nicht helfen. burzlbaum


    EDIT: Zu spät gesehen dass es schon läuft. Viel Glück weiterhin.

    Grüße

    Arkturus

  • Also über Preboot läuft alles prima. Über die normale Partition bekomme ich den Kernel Panic, das ist gewollt so glaube ich oder?


    Wenn ich den Preboot verwende, kann ich Onedrive nicht nutzen. Weil er mir den Speicherort verwehrt. (One-Drive kann am ausgewählten Speicherort nicht erstellt werden...)

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Clover funktioniert mit BigSur nur über das Preboot Volumen. Das ist bei OpenCore gleich nur da wird automatisch das Preboot Volumen gestartet und man hat gar keine andere Auswahl.


    OneDrive ist kein Problem unter BigSur. Du solltest die Schreibrechte vom dem Ordner prüfen welchen du mit OneDrive verwenden möchtest.

  • versuche mal die EFI aus dem Anhang. SMBIOS ist deins burzlbaum

    Files

    • EFI.zip

      (24.64 MB, downloaded 54 times, last: )

    Grüße

    Arkturus

  • Vielen Dank euch beiden. Das teste ich morgen. Bei meinem DSL Anbieter liegt eine Störung bis morgen vor. Da hat wohl jemand ein Kabel bei einer Baustelle durchtrennt :rolleyes:

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Danke für die EFI Arkturus

    Die ist deutlich voller als meine. Teils mit Kexten die ich wahrscheinlich nicht brauche. Habe es trotzdem mal versucht. Hing bei einem SSDT Fehler fest.


    Ich habe mittlerweile auch festgestellt, dass mein Sleep nicht geht (er wacht nicht mehr auf) und nicht jeder Boot erfolgreich ist. Da bleibt dann oft alles schwarz. Ein Neustart klappt dann und läuft auch durch.


    Alien

    Ich habe das Problem mit OneDrive noch nicht lösen können. Glaube auch, dass ich irgendwo ein Berechtigungsproblem habe. Hast du eine Lösung für mich wo ich nach was schauen könnte? Ich als User habe Lese und Schreibrechte in User/meinname/ und auch der übertragene Ordner OneDrive aus dem Time Machine Backup hat diese Berechtigungen. Habe den Ordner Testweise auch mal gelöscht. Auch da bekomme ich die Fehlermeldung von Onedrive.


    Quote

    Ihr OneDrive-Ordner kann am ausgewählten Speicherort nicht erstellt werden.

    Verwenden Sie einen anderen Speicherort. Stellen Sie sicher, dass sich der Speicherort nicht auf einem Wechseldatenträger oder einem Datenträger mit einem Format befindet, bei dem Groß-/Kleinschreibung beachtet wird.

    Ich benötige OneDrive für meine Arbeit. Das ist gerade etwas nervig vor allem da ich per Cryptomater mit verschlüsselten Containern arbeite und die gerade nicht synchronisieren kann.


    Habe auch schon versucht die Version aus dem Appstore zu verwenden sowie die von der Microsoft Seite. Beide wollen nicht.

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Öffne das Terminal und gib folgenden Befehlskette dort ein ohne Eingabebestätigung mit einem Leerzeichen am Ende.

    Code
    1. ls -l

    Dann Ziehe den Ordner welchen du für OneDrive verwenden möchtest in das Terminal.


    Es sollte dann da so was ähnliches wie hier stehen.


    Code
    1. ls -l /Users/"Benutzername"/OneDrive/

    Poste dann bitte das Ergebnis nach Eingabebestätigung.

  • Danke für die EFI Arkturus

    Die ist deutlich voller als meine. Teils mit Kexten die ich wahrscheinlich nicht brauche. Habe es trotzdem mal versucht. Hing bei einem SSDT Fehler fest.

    .....

    sorry, ich war unkonzentriert. Ich hatte eine EFI von meinem T430 genommen udn einfach Deine Config.plist reingetan, Quirks angepasst und nicht an die ACPI/Kexte gedacht.


    das geht natürlich gar nicht.


    Vielleicht schaust Du dir in der config.plist mal die Einstellung zu Quirks an und die drivers/UEFI. Ich habe bei Dir die OCQuirks.efi vermisst.

    Grüße

    Arkturus

  • Arkturus das erklärt natürlich die vielen Kexte :)

    Laut meiner Information braucht man OCQuirks.efi seit Clover v5125 nicht mehr. Ich schau mir deine Einstellungen in der config nochmal genauer an. Danke


    Alien

    wenn ich den OneDrive Ordner aus meinem User/Name/ Ordner reinschiebe kommt der Output den ich angehängt habe.


    Wenn ich meinen user/Name Ordner reinziehe kommt folgendes:


    drwx------@ 7 MeinNAME staff 224 27 Dez 21:15 OneDrive

    Images

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • burzlbaum

    Changed the title of the thread from “Clover Catalina zu Big Sur - Kernel Panic - Ivy Bridge” to “Clover Big Sur - Feintuning und OneDrive”.
  • Sieht eigentlich gut aus. Was für eine Version ist installiert? Siehst du im AppStore.



    Und was passiert wenn du den kompletten OneDrive Ordner im Finder löschst und nochmals neu anlegst?


    Versuche es mal mit dieser OneDrive Variante.

    https://answers.microsoft.com/…4f-47fe-afc3-10d4adf90e4c

  • Das hat auch nichts gebracht. Aber ich habe mir die Fehlermeldung nochmal genau angesehen. Da steht groß/Kleinschreibung...


    mich habe mal nachgesehen. Warum auch immer aber meine SSD war nicht als apfs sondern apfs groß/Kleinschreibung formatiert und das mag OneDrive und einige andere Apps wohl nicht.


    Nochmal Backup gemacht und werde eine neue Installation testen.

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Also jetzt geht alles prima auch sleep scheint zu funktionieren.


    habe aber doch noch ein Problem. Bekomme die Meldung, Meine Festplatte sei nicht kompatibel.


    habe über das Problem schon einige Male gelesen. Da ging es oft um Ausflüge zu irgendwelchen Beta Versionen und dann wieder zurück. Habe aber jetzt keine wirkliche Lösung für mich gefunden.

    Habt ihr dazu Ideen?

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • diese Meldung habe ich in den 3 Jahren Hackintosh noch nicht gesehen. Poste bitte mal einen Screenshot.

    Grüße

    Arkturus