Intel NUC als MacMini?

  • RenStad so, bin jetzt endlich dazu gekommen deine EFI zu testen. Kurzum, tut sich garnichts. "Failed to load configuration"


    Habe mir sonst alles mit ProperTree durchgeschaut und kann deine Beschreibung der Unterschiede gut nachvollziehen, sieht allgemein sehr schlank aus :thumbup:


    Wäre jetzt interessant zu wissen, ob die EFI so bei anderen läuft, die sie auch geladen haben.

    Intel NUC8i3BEH rennt...

    Edited once, last by RoboDackel ().

  • Ja, das hört sich nach einem NVRAM-Problem nach Systemwechsel an (andere OC-Version). Hast Du einen NVRamReset oder Systemreset gemacht? Vermutlich kommst Du mit dieser EFI noch nicht in den Picker.


    Nimm einen Stick mit einer früheren EFI, F10 Bootmenü aufrufen, im Picker von OC NVRAM-Reset (oder System-Reset) auswählen. Nach dem Neustart Gerät wieder ausschalten und danach mit meiner EFI booten. Dann wird es gehen.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

    Edited once, last by RenStad ().

  • Hatte resetet, aber die Fehlermeldung ist erst verschwunden, nachdem ich einmal im BIOS war, ohne irgendwas zu ändern (??)


    Er hat jetzt grade normal gebootet, WLAN geht aber nach wie vor nicht, nur Thunderbolt taucht jetzt zusätzlich auf.


    Übrigens meckert er jetzt wegen iCloud, dürfte wegen der Seriennummer sein, kann ich mir vorstellen :D

    Intel NUC8i3BEH rennt...

  • Dann wähle mal System-Reset, statt NVRAM-Reset.. Kann aber sein, dass Du danach im Bios das Boot-Laufwerk neu einstellen musst.


    Edit: "Meckert wegen iCloud" ??? Für solche Tests - wenn Du also eine andere Config bzw. eine andere EFI testest, das Gerät immer erst von der iCloud abmelden!!!!


    Mein Rat, schnell abmelden, icloud.com im Browser aufrufen, auf Verwalten klicken und prüfen, ob das Gerät wirklich verschwunden ist.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Hat sich nichts verändert. Was mich wundert, ist das alle Unterschiede deiner EFI sofort sichtbar sind (also Thunderbolt und diverse Kleinigkeiten) aber nur der WiFi Adapter konsequent nicht auftaucht. Sollte ich vielleicht mal eine ältere Version von der Kext ausprobieren?


    edit: iCloud war ganz normal eingerichtet, ist jetzt aber abgemeldet. Hab mich nur gewundert, dass da direkt eine Meldung kam.

    Intel NUC8i3BEH rennt...

  • Ich denke, dass ich meine Version der Kext drin gelassen habe, daran kann es nicht liegen.


    Wirklich alle Bios-Einstellungen überprüft? Ist die Anzeige im Systembericht immer noch so wie zuvor?

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Ja, es ist exakt die gleiche Angabe wie bei dem Screenshot von gestern Abend. Verglichen mit den Angaben bei MacBook fehlt da so ziemlich alles..

    Intel NUC8i3BEH rennt...

  • Hast Du mal versucht, mit dem Hackintool Deine PCI-Liste auszulesen? Versuche das mal. Exportiere diese und packe mal die erzeugte .plst--Datei hier rein.


    Kann sie mir aber dann erst morgen anschauen.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Mache ich, allerdings erst morgen, zeit schlafen zu gehen.


    Nochmal vielen Dank für dein und euer Engagement.:thumbup:


    Dass das System da grade so eigenartig rumzickt, lässt mich fast befürchten, dass hier so viel Mühe betrieben wird und ich am Ende nur einen sehr blöden Fehler gemacht habe, den ich nur grade echt nicht erkennen kann.

    Intel NUC8i3BEH rennt...

  • RoboDackel anbei meine EFI nochmal.


    Die ist definitiv OC 0.6.3, läuft bei mir mit Big Sur 11.1

    WLAN ist schon fertig in der config.plist konfiguriert.

    Musst nur noch unter PlatformInfo deine Seriennummer, MLB usw eintragen.


    Ich musste die EFI splitten, also bitte alle kext-Dateien aus den zwei Kexts.zip Archiven in den Ordner /EFI/OC/Kexts reinpacken

    Files

    • EFI.zip

      (702.13 kB, downloaded 20 times, last: )
    • kexts1.zip

      (10.78 MB, downloaded 21 times, last: )
    • kexts2.zip

      (14.24 MB, downloaded 20 times, last: )


    Support ausschließlich im Forum und NICHT per PN!

  • RenStad Liste ist angehängt


    Jono habe deine EFI jetzt am Laufen, WLAN wieder ohne Funktion. Was mich wundert, dass die Kext nicht angezeigt wird (siehe Bild).


    edit: habe jetzt noch mal ein BIOS update gemacht, auch keinerlei Veränderung.


    edit2: habe grade erst gesehen, das ich die Liste ja als .txt und nicht als .plist angehängt habe, ist jetzt behoben, sorry


    edit3: mittlerweile zeigt er mir zumindest mal wieder ein WLAN Icon in der Menüleiste an, und ich kann WLAN aktivieren und deaktivieren. Netzwerke findet er allerdings keine, auch der Eintrag im Systembericht ist unverändert. Hatte den Chip im BIOS mal aus und wieder eingeschaltet...

  • Txt-Datei war auch ok. Also Deine Liste stimmt mit meiner (bis auch die Thunderbolt-Dinge) überein. Ich gehe auch davon aus, dass die Intel-Karte die gleiche ist.


    Fassen wir zusammen: An der EFI kann es nicht liegen. Das haben wir jetzt ausgiebig getestet. Hackintool hat die Karte auch gefunden, dennoch wird die Kext nicht geladen. Vielleicht ein blöde Frage, können wir sicher sein, dass die Karte auch arbeitet, konntest sie mal unter Windows oder Linux testen?


    Was wird Dir unter Systembericht/Netzwerk alles angezeigt?


    Edit: gibt mal im Terminal:


    kextstat | grep -v com.apple


    ein. Der Befehl zeigt Dir alle geladenen Kexts, die nicht von Apple stammen.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Anbei die Screenshots von den Berichten:


    Die Kext für den Wifi Adapter taucht einfach nicht auf.


    edit: Wenn dann nur via Linux, gibt es da ein besonders empfehlenswertes für diesen Zweck? Windows habe ich nichts da, das habe ich vor 15 Jahren aufgegeben ;)

  • Bin ein wenig ratlos. Ich bin morgen wieder an meinem NUC und werde noch einmal ein paar Dinge vergleichen - melde mich dann wieder.


    Welche Linux Distributionen ist eigentlich gleich - ich hab mir ein Stick mit Linux-Mint erstellt. Du kannst Dir einen startfähigen Stick erstellen und nutzen, ohne dass Du etwas installieren musst.


    https://linuxmint-installation…cs.io/de/latest/burn.html

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Ich hab´s!


    Der Fehler lag, wie vermutet, in einer kleinen Unachtsamkeit beim Einbinden der Kext. Um das kurz zu veranschaulichen:

    AirportItlwm.kext oder:

    A i r p o r t I t l w m .kext wobei das große "i" und das kleine "L" im Editor identisch aussehen. Beim lesen im Troubleshooting kam mir so ein leiser Verdacht, dass es da verdächtige Ähnlichkeiten gibt...


    Kurzum, man möchte im Boden versinken. :cursing:


    Jono  RenStad Nehmt es mir bitte nicht all zu übel, dass ich euch seit drei Tagen damit beschäftige.

    Intel NUC8i3BEH rennt...

    Edited once, last by RoboDackel ().

  • Wahnsinn! Übel wird Dir hier nichts genommen. Bin auch nicht traurig, dass Du meine grauen Zellen bemüht hast. Soll wohl helfen fit zu bleiben. Da sieht man mal wieder, wie wichtig so ein kleiner Buchstabe sein kann.


    Dennoch wundert es mich, dass Du auch mit meiner EFI keinen Erfolg hattest, denn da muss der Eintrag ja korrekt sein. Vielleicht ein Tipp, ich kopiere einfach den Dateinamen, um in der Config den richtigen Eintrag zu erzeugen.


    Wie sieht jetzt Netzwerk im Systembericht aus? Wurde das WLAN auf en1 gesetzt?


    Und welcher Airdrop-Kanal wird Dir im Systembericht unter WLAN angezeigt?

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Das mit deiner EFI wundert mich, jetzt wo du es schreibst, allerdings auch. Ich habe zusätzlich auch in allen EFIs die WiFi Kext gegen eine frisch geladene ersetzt. Möglicherweise war auch das der Grund. :/


    WLAN steht auf en7


    Der Airdrop Kanal ist 149.

    Intel NUC8i3BEH rennt...

  • WLAN hat sich da wohl hinten angestellt. Habe irgendwo mal gelesen, dass es Probleme mit manchen Diensten geben kann, wenn Ethernet nicht auf en0 und WLAN auf en1 steht. Muss noch mal raussuchen, welche dies genau waren. Allerdings weiß ich noch, dass sich das korrigieren lässt. (Falls Du mal ein Problem feststellst).


    Diese "Reihenfolge" ist in der NetworkInterFaces.plist, die Du unter Library/Preferences/SystemConfiguration findest. Diese Datei (vorsichtshalber vorher sichern) kannst Du löschen und anschließend neu starten. Dann sollte die Reihenfolge passen.


    Airdrop-Kanal ist bei mir auch 149. Richtig wäre 44 für Deutschland. Es wird gesagt, dass Airdrop noch nicht funktioniert. Man sieht aber, sie sind nahe dran, denn ich finde mit meinem NUC bereits andere Geräte, nur die Übertragung hat noch nicht funktioniert und der NUC wird von den anderen Geräten nicht gefunden. Das kann aber am Kanal liegen. Ich denke, dass auch AirDrop bald funktionieren wird.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Das mit der Reihenfolge werde ich noch mal angehen, danke. Mal schauen, ob da vorher irgendwelche Probleme auftauchen.


    Die Sache mit dem Airdrop Kanal hattet ihr ja früher in diesem Thema schon mal angesprochen, denke auch, dass da nach und nach der volle Funktionsumfang kommen wird. Für diesen NUC ist das für mich nicht so wichtig, vielleicht für den nächsten der bald kommen wird..

    Intel NUC8i3BEH rennt...

  • Hallo zusammen,
    da das hier anscheinend die Expertenrunde für Intel NUC8-Systeme ist, stelle ich mein erstes Projekt hier mal vor. Ich vermute, ich kann einiges von Eurer Vorarbeit hier übernehmen.
    Mir ist ein Intel NUC 8 Pro Kit - NUC8v5PNK zugeflogen, dass ich gerne für meine ersten Gehversuche nutzen möchte. Mein erster Eindruck ist, dass es Euren NUC8-Systemen sehr ähnlich ist. Lediglich fällt auf, dass es 2 M2-Steckplätze hat - was in Sachen WLAN-Karte die Sache vereinfachen könnte.
    Mein Plan ist nun, mit OpenCore und Catalina anzufangen und sollte das funktionieren Big Sur anzugehen.
    Was mir an Hardware noch fehlt um loszulegen ist die M2-SSD und der Memory (war defekt...).

    Sollte das Ding irgendwann gut funktionieren, möchte ich es vorwiegend für Bildbearbeitung nutzen. Daher bin ich schon gespannt, ob Lightroom und Affinity Photo auf dem Teil ihren Dienst versehen werden.

    Schon mal vorab danke für alle Fragen, die ihr schon beantwortet habt :)