[Vorstellung] 265 Euro Hackintosh, erweiterungsfähig, klein, energiesparend und mit aktueller Hardware

  • Krass Deejay das wäre für mich keine Lösung ich bin mir sicher, auch meine Schwägerin die den Hack bekommen soll wird davon nicht so begeistert sein xD


    ein USB 3.0 Hub wird übrigens problemlos erkannt. Sobald ich aber da einen der anderen USB3 Sticks stecke läuft nichts. Und im Hackintool selbst wird mir auch nur angezeigt, dass etwas im HS und nicht im SS Port steckt. In wie fern das normal ist, weiß ich nicht.

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Zumindest die Mainboard USB sollten eigentlich schon funktionieren. Die Gehäuse USB und ggf. falls man eine WLAN/BT Karte hat der interne USB an dem die angeschlossen ist müssen mit dem Hackintool je nach Belegung und Gehäuse USB mit dem Hackintool konfiguriert werden.


    Ich habe nicht alle Port durchgetestet aber hatte bei der Installtion und mit meinen USB Sticks keine Probleme (EFI Stick war alt und USB2 aber der BigSur Stick war ein SanDisk USB3). Meine Tastatur Maus arbeiten auch (direkt am Board angeschlossen) und die Front USB vom Gehäuse auch.


    Aber, ich habe keine Erfahrung mit dem Hackingtool. Vielleicht kann das ja einer von euch rausfinden konfigurieren un ich verlinke es hier.



    PS: Das ist jetzt allerdings kein sauberes arbeiten sondern austesten. Ich habe mal Github nach EFis abgesucht für das Mainboard und eine USBKext gefunden bei dem der RepoOwner behauptet bzgl. USB würde alls (wobei ich hier von den Mainboard Anschlüssen ausgehe) funktionieren soll.


    Kann die jemand mal testen? Einfach in den EFI Folder kopieren sollte reichen, da Sie intern ja schon referenziert wird.

  • Bin dann gleich wieder zu Hause und werfe nochmal einen Blick drauf und teste das USB Kext File.


    Habe wie gesagt den USB vorne am Schalter am G5 Case auf dem Mainboard. Auf dem anderen steckt

    meine Wifi Karte. Die funzt auch einwandfrei mit Airdrop und allem drum und dran.


    Meine USB erscheinen leider auch alle im Hackintool als HS und nicht als SS! 😔


    Leider wird meine 2. SSD mit dem Ubuntu auch nicht mehr erkannt. Zwar im BIOS als SATA aber nicht

    als Startvolume und auch nicht im Bootstrap (wofür ich ne Anleitung verlinkt bekommen habe).

    Die fliegt heute Abend raus. Ehrlich gesagt reicht MacOS BS und Win10 Pro.


    Komisch ist auch das mein RAM nur mir 2133 erkannt wird, statt mit 2667 wie bei Jörg!


    Hoffe wir bekommen das alles und besonders das mit den USB Ports noch hin.

    Wäre schade, da das Board sonst einen klasse Eindruck macht.


    UPDATE:

    Kext bringt leider nichts. :-(

    Habe jetzt alle USB 3.0 Sticks und 2.0 Sticks angeschlossen. Alles noch beim Alten.

    Das Midi Keyboard (V49) steckt am ersten USB 2.0 Port und steht mit 12 Mbps im Tool.

    Auf dem anderen 2.0 USB steckt die MS WebCam.

    Die schnellen Sticks (Extreme & Patriot Memory) mit 480 Mbps. Der Dritte tauchte leider

    garnicht auf. Mein 256GB Patriot Memory macht nur 10-20 MB beim Schreiben und 35-40MB

    beim Lesen! Meine Kingston 16GB USB 2.0 sind der DataTraveler2.0 und der 2. nicht sichtbar!


    Habe jetzt nochmal spaßhalber meinen Adapter vom 19pin onBoard USB 3.2 auf zwei USB 3.0 A Ports

    angeschlossen und die USB Sticks, egal ob 2.0 oder 3.0 erscheinen auf den HS05 und dem HS06 Anschlüssen.


    Mein 3 Port USB 3.0 Hub mit RJ45 Gigabit LAN Port erscheint als "USB2.1Hub" auf HS01, HS02, HS03,

    HS04 (die USB3.0 Ports hinten am Mainboard) und aber auch so auf dem HS11 & HS12 (USB 2.0).

    Alles sehr dubios, aber so, definitiv nicht brauchbar. Leider!


    Wird das evtl. besser mit Catalina? Da kann ich auf den neuen Look verzichten, wenn dafür alles

    funktioniert. Bei DJ Software wird auch noch von Big Sur abgeraten.

    Images

    iHack 32": iMac 20,1 Retina 5K (2020) - Gigabyte B460M DS3H, Intel i3-10100, RAM G.Skill AEGIS DDR4-3000 32GB, PNY XLR8 CS3030 1TB M.2 PCIe NVMe, GC Titan Ridge 2.0 flashed - Mac OS Big Sur 11.2.1

    HackNano: MacMini (2018) - ASUS VivoMini PN61, Intel i5-8265U, RAM 32GB DDR 2400, Gigabyte M.2 PCIe NVMe 256GB, Crucial MX100 512GB SSD, Apple AirPort Extreme BCM43X - MacOS Catalina 10.15.7

    HackMini: MacMini 7,1 (2014) - Asus H81T, Intel i5-4570T, RAM 8 GB DDR3, Crucial BX500 240GB SSD, Apple iMac WiFi Bluetooth Card BCM94360CD - MacOS Big Sur 11.0.1 - zu verkaufen!

    Echte Äpfel: Mein erster ein LCII (Pizzakarton), mein letzter ein iMac 27", 5 St. MacBooks (aktuell ein MacBook Pro 13,3" 2020 M1 Touchbar Space Grau), iPads (zuletzt 6th Gen), iPhones (etliche, erstes
    iPhone aus USA mit AT&T SIM und Jailbreak, aktuell ein XS Max), Apple Watches (Series 3 und aktuell eine 5er mit LTE)! Geht nicht, gibt's nicht!

    Edited 6 times, last by Deejay: Update ().

  • Hast du dein SMBIOS schon auf imacpro umgestellt? Das könnte auch zu deinen Problemen führen.


    Siehe: Klick


    Die Ioreg Anweisung ausführen um zu sehen ob ein ACPI Rename notwendig ist.


    PS: Ich habe es gerade hier gecheckt und zumindest der ACPI Rename ist bei mir mit SMBIOS iMac20,x nicht notwendig.

  • Hast du dein SMBIOS schon auf imacpro umgestellt?

    Nein der steht noch auf iMac 5K 2020, da nur mit Intel 630 UHD Grafik und noch ohne Grafikkarte.


    Der Prozessor steht auch noch in der Systeminfo noch als: 3,6 GHz Unbekannt


    Habe jetzt nochmal alles zusammengefasst im Hackingtool auf die insgesamt 15 USB Port verfügbar und genutzt.

    Leider kann ich keine USBPorts.kext exportieren! Vielleicht sollte ich versuchen das vorhandene File umzuschreiben?

    Images

    iHack 32": iMac 20,1 Retina 5K (2020) - Gigabyte B460M DS3H, Intel i3-10100, RAM G.Skill AEGIS DDR4-3000 32GB, PNY XLR8 CS3030 1TB M.2 PCIe NVMe, GC Titan Ridge 2.0 flashed - Mac OS Big Sur 11.2.1

    HackNano: MacMini (2018) - ASUS VivoMini PN61, Intel i5-8265U, RAM 32GB DDR 2400, Gigabyte M.2 PCIe NVMe 256GB, Crucial MX100 512GB SSD, Apple AirPort Extreme BCM43X - MacOS Catalina 10.15.7

    HackMini: MacMini 7,1 (2014) - Asus H81T, Intel i5-4570T, RAM 8 GB DDR3, Crucial BX500 240GB SSD, Apple iMac WiFi Bluetooth Card BCM94360CD - MacOS Big Sur 11.0.1 - zu verkaufen!

    Echte Äpfel: Mein erster ein LCII (Pizzakarton), mein letzter ein iMac 27", 5 St. MacBooks (aktuell ein MacBook Pro 13,3" 2020 M1 Touchbar Space Grau), iPads (zuletzt 6th Gen), iPhones (etliche, erstes
    iPhone aus USA mit AT&T SIM und Jailbreak, aktuell ein XS Max), Apple Watches (Series 3 und aktuell eine 5er mit LTE)! Geht nicht, gibt's nicht!

  • Doch Du kannst speichern. //Edit: Unsinn

    Edited once, last by MPC561 ().

  • Ja hat geklappt! :-) Hatte das "USBPorts.kext" noch auf dem Desktop liegen

    und nicht gesehen, dass es exportiert wurde. :-)


    Jetzt habe ich das Setup so, wie oben auf dem Bild. 15 Geräte und sieht schon mal

    sehr schick und aufgeräumt aus. :-)


    Aber wie geschrieben, es gehen halt maximal "nur" 40MB/sek. beim Lesen vom USB.

    Habe jetzt 1,7GB in knapp 40 Sek. vom USB 3.0 Stick auf die Festplatte kopiert.

    Von der Festplatte auf den USB 3.0 Stick, hatte ich als Zeitangabe "1 TAG". =O

    iHack 32": iMac 20,1 Retina 5K (2020) - Gigabyte B460M DS3H, Intel i3-10100, RAM G.Skill AEGIS DDR4-3000 32GB, PNY XLR8 CS3030 1TB M.2 PCIe NVMe, GC Titan Ridge 2.0 flashed - Mac OS Big Sur 11.2.1

    HackNano: MacMini (2018) - ASUS VivoMini PN61, Intel i5-8265U, RAM 32GB DDR 2400, Gigabyte M.2 PCIe NVMe 256GB, Crucial MX100 512GB SSD, Apple AirPort Extreme BCM43X - MacOS Catalina 10.15.7

    HackMini: MacMini 7,1 (2014) - Asus H81T, Intel i5-4570T, RAM 8 GB DDR3, Crucial BX500 240GB SSD, Apple iMac WiFi Bluetooth Card BCM94360CD - MacOS Big Sur 11.0.1 - zu verkaufen!

    Echte Äpfel: Mein erster ein LCII (Pizzakarton), mein letzter ein iMac 27", 5 St. MacBooks (aktuell ein MacBook Pro 13,3" 2020 M1 Touchbar Space Grau), iPads (zuletzt 6th Gen), iPhones (etliche, erstes
    iPhone aus USA mit AT&T SIM und Jailbreak, aktuell ein XS Max), Apple Watches (Series 3 und aktuell eine 5er mit LTE)! Geht nicht, gibt's nicht!

  • //Edit: Ich hab das erste Problem. Äusserst peinlich.


    Ich habe eine Kext disabled gelassen. Die für den XHCI Controler...



    Das Bit bei Enabled von 0 auf 1 setzen bitte. Dann dürfte es besser werden...


    PS: Nachdem der XHCI Aktiv ist die Hackintool Anleitung ausführen um eine USBport.kext und eine xxxusb.aml erstellen. Dann gehen auch die USBPorts perfekt. Ich laden im Laufe des Tages eine Version 1.2 der EFI hoch mit einer von mir erstellten USBport.kext mit der die direkten Mainboardanschlüsse an der Rückseite gehen sollten


    PPS: Ich habe gerade 3,22GB in unter einer Minute geschrieben auf einen USB3 Stick.


    PPPS: Neue EFI Version 1.2 verfügbar im 1. Post des Threads

    Edited 4 times, last by MPC561 ().

  • PPS: Ich habe gerade 3,22GB in unter einer Minute geschrieben auf einen USB3 Stick.

    Yuuuup! Das war's wohl! :-) 1,79GB in 32 Sek. auf den USB geschoben und da schau her,

    endlich werden auch die USB 3.0 Sticks auch unter SS01-06 angezeigt mit 5 Gbps! ;-)


    :klatschen:

    iHack 32": iMac 20,1 Retina 5K (2020) - Gigabyte B460M DS3H, Intel i3-10100, RAM G.Skill AEGIS DDR4-3000 32GB, PNY XLR8 CS3030 1TB M.2 PCIe NVMe, GC Titan Ridge 2.0 flashed - Mac OS Big Sur 11.2.1

    HackNano: MacMini (2018) - ASUS VivoMini PN61, Intel i5-8265U, RAM 32GB DDR 2400, Gigabyte M.2 PCIe NVMe 256GB, Crucial MX100 512GB SSD, Apple AirPort Extreme BCM43X - MacOS Catalina 10.15.7

    HackMini: MacMini 7,1 (2014) - Asus H81T, Intel i5-4570T, RAM 8 GB DDR3, Crucial BX500 240GB SSD, Apple iMac WiFi Bluetooth Card BCM94360CD - MacOS Big Sur 11.0.1 - zu verkaufen!

    Echte Äpfel: Mein erster ein LCII (Pizzakarton), mein letzter ein iMac 27", 5 St. MacBooks (aktuell ein MacBook Pro 13,3" 2020 M1 Touchbar Space Grau), iPads (zuletzt 6th Gen), iPhones (etliche, erstes
    iPhone aus USA mit AT&T SIM und Jailbreak, aktuell ein XS Max), Apple Watches (Series 3 und aktuell eine 5er mit LTE)! Geht nicht, gibt's nicht!

  • Das üble dabei ist. In der EFI auf der SSD war der XCI Controler an. Auf meinem Boot Sicherheitsstick nicht. Die EFI von den Stick hatte ich aber hier im Thread abgelegt.


    Deswegen gings bei mir auch die ganze Zeit. Wie gesagt ein peinlicher Fehler meinerseits.

  • Alles gut! Passiert! Bei allem was man beachten muss, kann das schon mal passieren.

    Denke mir auch oft, ist das jetzt wirklich das letzte Backup oder noch ein altes!

    Soll ich noch eines machen, oder braucht es das doch nicht! :-) Alles easy!

    Images

    iHack 32": iMac 20,1 Retina 5K (2020) - Gigabyte B460M DS3H, Intel i3-10100, RAM G.Skill AEGIS DDR4-3000 32GB, PNY XLR8 CS3030 1TB M.2 PCIe NVMe, GC Titan Ridge 2.0 flashed - Mac OS Big Sur 11.2.1

    HackNano: MacMini (2018) - ASUS VivoMini PN61, Intel i5-8265U, RAM 32GB DDR 2400, Gigabyte M.2 PCIe NVMe 256GB, Crucial MX100 512GB SSD, Apple AirPort Extreme BCM43X - MacOS Catalina 10.15.7

    HackMini: MacMini 7,1 (2014) - Asus H81T, Intel i5-4570T, RAM 8 GB DDR3, Crucial BX500 240GB SSD, Apple iMac WiFi Bluetooth Card BCM94360CD - MacOS Big Sur 11.0.1 - zu verkaufen!

    Echte Äpfel: Mein erster ein LCII (Pizzakarton), mein letzter ein iMac 27", 5 St. MacBooks (aktuell ein MacBook Pro 13,3" 2020 M1 Touchbar Space Grau), iPads (zuletzt 6th Gen), iPhones (etliche, erstes
    iPhone aus USA mit AT&T SIM und Jailbreak, aktuell ein XS Max), Apple Watches (Series 3 und aktuell eine 5er mit LTE)! Geht nicht, gibt's nicht!

  • Läuft perfekt! Alle Ports inklusive Gehäuse werden ordentlich erkannt. Ein 2.0 Gehäuseport wird in Hackintool immer noch nicht angezeigt aber er funktioniert also egal :)


    Vielen Dank! Genau rechtzeitig. Morgen soll der PC verschenkt werden. Etwas gutes hat der Fehler auch, ich habe mich viel mehr mit Open Core auseinander gesetzt, als ich es wahrscheinlich ohne das Problem getan hätte ;)

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Sehr Geil der Post. Ich habe mich auch gewundert.

    Habe vom USB 2 Port BigSure installiert, Oben wo der alte Rund Stecker noch ist, sind die Beiden USB 2 Steckplätze. Beim erstem Bild (Das rote BigSurebild nach der Installation) War meine Tastatur und meine Maus nicht mehr zu benutzen. Habe alles in die Blauen unter der Netzwerkdose gesteckt. Alles wieder da. die USB 2 Pins auf dem Board sind auch tot. Nun schau ich mal nach, ob der XHCI auch auf 0 steht. melde mich.

  • Info: Update auf BigSur 11.2 ist bei mir sauber durchgelaufen.

  • Gibt es eigentlich einen Grund für OC 0.6.3 wenn 0.6.5 aktuell ist? Bei Clover war es bei einem Update ja oft nötig auch den Bootloder zu aktualisieren. Wie ist das bei OC geregelt? Kann man da gefahrlos bei 0.6.3 bleiben solange es läuft? Oder sollte man das sogar wenn man nickt mehrere Änderungen vornehmen will?

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Nein gibt es nicht. Man muss nur die Zeit haben umzustellen.


    Ich aktualisiere meine OC normal jeden 2. Release. Dann sind die Unterschiede nicht so stark und man kann recht einfach migrieren. Mein Main PC läuft schon auf 0.6.5. Hat 30 Minuten gekostet. Bei Gelegenheit aktualisiere ich auch diese hier.


    Wenn Du brav die Kexte aktualisierst solltest du mehrere Releases keine Probleme bekommen. Auf jeden Fall solltest Du aktualisieren vor einer neuen Mainrelease von OSX.

  • Version 1.3 der EFI, basierend auf OC 0.6.6 wurde im Startpost hinzugefügt.

  • Das bedeutet wahrscheinlich, dass die eigene usb-kext weiter verwendet werden kann, die config.plist muss aber wieder angepasst werden, da geht die eigene nicht mehr oder? Sorry ich bin auf dem Gebiet OC echt unerfahren.

    iMac 15,1 - Gigabyte GA-Z77-DS3H Rev. 1.0
    i5 3750K :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: macOS 11.1 @ Clover r5 & Windows 10 Pro
    MacBook Pro 15,4 - Terra Mobile 1550 :: 15,6" FullHD
    i5-8265U :: Intel UHD620 :: 8 GB RAM :: DW1560 :: macOS 10.15.5 @ Clover r5096

    MacBook Pro 8,1 - 13" Anfang 2011 :: MacBook Air 7,2 - 13" Anfang 2015


  • Du solltest den ganzen folder übernehmen. Wenn Du willst deine USBport.kext rein und die meine ersetzen (wobei Du meine erstmal testen solltest) und die config.plist muss angepasst werden in der PLATFORMINFO Sektion. Deine Seriennummer etc. übernehmen damit Apple glaubt es ist der gleiche Mac.

  • Kurzes Feedback zu dem 265 Euro Hackintosh.


    Habe es auch mal für mich gewagt und bin echt Mega Happy mit allem... rennt wie die Wutz.. Windows 10 ist parallel drauf ... habe die Konfig durch einen I5 ein wenig nach oben aufgewertet... dazu noch das kleine BeQuiet Gehäuse und das Teil läuft quasi ohne Geräusche... die 265 Euro sind aktuell aufgrund der Marktlage aus meiner Sicht nicht ganz zu packen.. aber wie gesagt ich bin froh das ich es getan habe... Danke für solche Beiträge :danke2:

    Wohnzimmer Hackintosh

    Gigabyte B460M DS3H, Intel i5-10400 , 16GB Ram
    interne UHD630
    500 GB SSD Samsung 850 Pro , Gigabyte Original Bios , OSX 11.2