Restart und Sleep funktioniert nicht

  • Nach Update von OpenCore 0.5.2 ( vom Thema: HowTo: Ryzentosh ) auf Open Core 0.6.3

    bekomme ich diese Fehlermeldung:


    ?thumbnail=1



    Wenn ich im ProperTree-master:

    Misc -- Boot -- ConsoleAttributes den Wert von 0 auf 2, kommt der gleiche Fehler.


    Misc -- Security -- Vault den Wert vom Secure zu Optional ändere kommt:


    OCABC: Incompatible OpenRuntime r2, require r11


    Was kann ich machen?

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Der Link zum Screenshot funktioniert leider nicht. Aber sieht so aus, als hättest Du beim Updaten vergessen, OpenRuntime.efi auch zu aktualisieren: "Incompatible OpenRuntime r2, require r11"-


    Hier ist der Guide zum Updaten von OpenCore. So alt wie Deine Config ist, da würde ich lieber frisch von 063 starten. Ist weniger Arbeit.

  • Danke für die Rückmeldung, die habe ich abgearbeitet, habe die config.plist komplett bearbeitet und in OCConfigCompare-master verglichen und alle werte mit ProperTree-master eingefügt.


    OpenRuntime.efi ist aus der OpenCore-0.6.3-RELEASE ersetzt wurden.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Hier EFI und screen:

    EFI.zip


    157418-dsc-0269-jpg

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Bei so einem Versionssprung würde ich OC neu runterladen und den EFI Ordner als Basis nehmen. Dann ACPI/Kexte rüber kopieren und die neue config.plist mit der alten abgleichen. Für die neuen Optionen am besten den Dortania Guide konsultieren.

  • Hier noch mal:


    https://www.hackintosh-forum.de/attachment/157419-efi-zip/


    *Update*


    Jetzt klappt nichts mehr.

    Ich habe den Stick leer gemacht, die OC Original 0.6.3 genommen.

    Alle Daten wie bei Dortania Guide und in euern Thema [GUIDE] OpenCore Update Workflow mit Kext Updater und OCConfigCompare

    bearbeitet.

    Dann die config.plist nach den Vorgaben von Dortania Guide für AMD bearbeitet https://dortania.github.io/Ope…MD/fx.html#starting-point

    und nun hab ich nur noch einen Schwarzen Bildschirm.

    Files

    • EFI.zip

      (2.47 MB, downloaded 32 times, last: )

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

    Edited 2 times, last by Gordon-1979: Nachtrag. ().

  • Ich traue solchen Tools nicht und mache das alles jeweils von Hand.


    Dein EFI sieht recht verkorkst aus:

    • Schmeiss mal alle ACPI Adds raus die du nicht brauchst
    • Drivers sollte alles raus ausser HfsPlus.efi, OpenRuntime.efi und allenfalls OpenCanopy.efi
      • VirtualSmc.efi ist schon lange in OC integriert und wird wohl das grösste Problem sein...

    Zum Rest kann ich nicht viel sagen da ich mich mit Intel Systemen nicht auskenne.

  • Ich habe doch AMD und kein Intel.

    Tool habe ich nur OCConfigCompare-master und ProperTree-master genommen.

    Bearbeitet unter Windows 10, auch mit AMD Hardware.


    Habe die Sachen raus gelöscht und nichts passiert. Schwarzer Bildschirm.


    *Update*

    Habe noch mal die EFI-Ordner überarbeite und die config.plist mit der alten config.plist verglichen und mit dortania geprüft.

    Jetzt habe ich das OC Boot Menü.

    Dann laufen die ganzen CMDs durch, dann steht nur noch [PCI Config Begin]

    Dann Black Screen.

    Hier mal die neue EFI und OC Log


    *Update 2*

    Fehler gefunden:

    Bei NVRAM - Add - 7C436110-AB2A-4BBB-A880-FE41995C9F82 unter boot-args

    steht laut https://dortania.github.io/Ope…l-Guide/AMD/fx.html#nvram

    -v keepsyms=1 debug=0x100 alcid=1

    aber laut alter config steht:

    -v nv_disable=1 keepsyms=1 npci=0x2000 debug=0x100 agdpmod=pikera


    habe die alte config eingefügt und auf Open Core 0.6.2 downgrade und PC startet mit Bootstick.

    Files

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

    Edited 2 times, last by Gordon-1979: Nachtrag Fehler gefunden. ().

  • Gordon-1979

    Changed the title of the thread from “Fehlermeldung nach Update OC 0.5.2 auf 0.6.3” to “Update OC 0.6.3 Kernel Err: LOG:EXITBS:START”.
  • Ich habe aber ein AMD FX Prozessor und kein Ryzen, für das Mac OS.

    Zählt da die Liste immer noch???


    *Update*

    Jetzt wird kein USB-Stick mehr von Mac OS angenommen.

    Maus und Tastatur gehen.


    *Update*

    Fehler gefunden

    die Kext XLNCUSBFix.kext , USBInjectAll.kext und GenericUSBXHCI.kext fehlten.

    So wie die Eintrage im config.plist unter Root - Kernel - Add eingetragen werden und Enabled auf True stellen.


    *Update*

    Update auf Big SUR landet im LOG:EXITBS:START und es geht ich weiter hoffe um Hilfe.

    Muss dabei OC 0.6.3 haben, denn ich habe 0.6.2 ???


    *Update*

    Nach neu Install von catalina, starte ich den App store und diese wird unerwartet beendet.

    Keine Anmeldung mit der Apple IP, wurde übersprungen, bei der Neu Install.

    EFI Hochgeladen.


    *Update*

    So MacOS nach dieser Anleitung HowTo: Ryzentosh erneut installiert und gleicher Fehler.

    ( Meldung: App Store wurde unerwartet beendet)


    Laut Fehlerbericht:

    Crashed Thread: 40 com.apple.audio.IOThread.client

    Exception Type: EXC_BAD_Instruction (SIGILL)

    Exception Notes: EXC_CORPSE_NOTIFY


    Termination Signal: Illegal instruction: 4

    Termination Reason: Namespace SIGNAL, Code 0x4

    Termination Process: exc Handler (513)


    Fehler gefunden. (40 com.apple.audio.IOThread.client)

    Der Fehler ist, es muss das richtige Sound Ausgabegerät ausgewählt werden, sonst Crasht der App Store.

    WTF


    *Update*


    Hier ein User mit Big Sur auf dem FX8350 , mit normalen Update durchgeführt.

    Hackintosh BigSur AMD FX (8350)

    Files

    • EFI.zip

      (2.59 MB, downloaded 29 times, last: )

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

    Edited 6 times, last by Gordon-1979: Fehler gefunden. ().

  • Gordon-1979

    Changed the title of the thread from “Update OC 0.6.3 Kernel Err: LOG:EXITBS:START” to “Restart und Sleep funktioniert nicht”.
  • Ich arbeite seite Tagen an:

    Das der MAC ein Restart durchführt.

    Herunterfahren geht.


    Mit dieser Anleitung bin ich noch nicht zurecht gekommen:

    https://dortania.github.io/Ope…ll/usb/misc/shutdown.html

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Gordon-1979 Um mal auf deinen ersten Post in diesem Thread zurück zu kommen. Zuvor hat wohl alles funktioniert, bis du auf OC 063 gewechselt bist.


    1. Warum wechselst du von 052 auf 063, und nicht auf 066?


    2. Bei so einem Versionssprung sollte man auch die OcBinaryData (Icons etc.) gleich mit erneuern.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Hi @karacho,

    der oberste ist nicht mehr aktuell.

    Bin aktuell aus OC 0.6.7 vom 20.2.2021

    Brauchst du die aktuelle EFI???


    *Update*

    USB-mapping durchgeführt mit hilfe der Anleitung:

    https://dortania.github.io/Ope…and-3rd-party-usb-mapping

    aber wie in der Anleitung:

    https://dortania.github.io/Ope…ll/usb/misc/shutdown.html

    gesuchten begriffe:


    To find the USB Controller that needs fixing, search for _PRW in your DSDT and see what Device is mentioned within it, generally this will be something like SB.PCI0.XHC.


    habe ich nichts gefunden. EFI hochgeladen.

    Files

    • EFI.zip

      (1.65 MB, downloaded 9 times, last: )

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

    Edited 2 times, last by Gordon-1979: Update ().

  • Hallo Gordon-1979,


    ich habe das Problem mit den App Store Crash ebenfalls.

    Beim googeln bin ich auf folgendes gestoßen:


    (https://github.com/AMD-OSX/bugtracker/issues/7)


    Trying to play audio crashes the thread with com.apple.audio.IOThread.client: Illegal instruction: 4

    Fixed by replacing /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib with a dylib from 10.13.


    Über den Finder komme ich nicht an das Verzeichnis, über das Terminal schon.

    Hast du schon einmal die "libvDSP.dylib " mit der aus 10.13 ersetzt?


    Deine Lösung mit dem Audioausgabegerät funktioniert nicht bei mir.


    LG Franziska1993

    Desktop macOS Betriebssysteme (siehe Spoiler):

  • Ja habe ich schon gemach, SIP muss komplett deaktiviert sein, dann kommst du daran.

    Leider gibt es keine Updates dann mehr.


    Teste mal ein anderes Audio Gerät, vielleicht klappt es dann.

    Oder Audio richtig einrichten.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Hallo Gordon-1979,


    habe ich gemacht, jetzt habe ich zwar Ton, aber dafür crashed App Store nicht.


    Wenn ich den App Store benutze, wechsel ich das Ausgabegerät und wenn ich fertig bin

    im App Store, wechsel ich zwecks Musik das Ausgabegerät.


    LG Franziska1993


    PS: Ich werde aber trotzdem mal die "libvDSP.dylib " austauschen, mal sehen, ob das so einfach klappt.


    Update Freitag, 22:54: Weder der App Store, noch QuickTime noch Youtube in Safari crashen, wenn die

    "libvDSP.dylib " ausgetauscht wurde.


    Da in Big Sur die "libvDSP.dylib " nicht ausgetauscht werden kann, ich beziehe mich auf folgende Aussage:


    Quote

    This fixes for me. Unfortunately this will not work on Big Sur, since Apple removed all dynamic link libraries from filesystem. Any one has any idea to patch this in Big Sur?

    bleibt die Frage nach einen anderen bzw. neuen Fix für die AMD FX CPU's.

    Desktop macOS Betriebssysteme (siehe Spoiler):

    Edited once, last by Franziska1993 ().

  • Ich empfehle es nicht, da du mit deaktivierter SIP und keine Updates leben musst.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Hallo Gordon-1979,


    > Ich empfehle es nicht, da du mit deaktivierter SIP und keine Updates leben musst.


    das ist für mich das geringste Problem, da Catalina auf der CatalinaSSD schon das maximale Update

    10.15.7 erhalten hat.


    Big Sur hat eine eigene SSD.


    Franziska1993

    Desktop macOS Betriebssysteme (siehe Spoiler):