Broadcom Bluetooth funktioniert plötzlich nicht mehr

  • Moin zusammen!


    Vor ein paar Tagen habe ich mein Hackbook gestartet und mich über das durchgestrichene Bluetooth Menubar-Icon gewundert. Seitdem funktioniert Bluetooth und somit AirDrop etc. nicht mehr.

    Es handelt sich um eine BCM94360CS2 die in einem M.2 Adapter steckt, welcher dann direkt mit dem Mainboard des Laptops verbunden ist. Die Karte ist nicht per weiterem (USB-) Kabel verbunden, sondern eben nur per Steckverbindung, Bluetooth hat bisher genau so funktioniert.

    WLAN funktioniert einwandfrei, ich gehe deswegen nicht von einem defekt der Karte aus. Gleiches Szenario ergibt sich unter Windows 10 und Ubuntu, alle 3 Betriebssysteme finden kein Bluetooth Modul, WLAN funktioniert jedoch.


    Ich bin etwas ratlos, hat jemand eine Idee?

    :help

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Ich würde an der Stelle mit einem Live-Linux die BT-Funktion erstmal grundsätzlich testen und mich damit über den tatsächlichen Zustand informieren.


    Sollte das, wie zu erwarten, problemlos funktionieren, kann es meiner Ansicht nach am USB-Gedöns im macOS liegen.

    Vielleicht reicht auch schon die Aktivierung der Funktion unter Linux, damit der BT-Anteil der Karte unter macOS wieder mitspielt.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • hast du die karte schon mal ausgebaut ? hatte das mal bei meiner Fenvi CD Karte , die hat gesponnen. ein komplettes stromlos machen per ausbau hat geholfen.


    KEIN SUPPORT PER PN!

    julian.png

  • Danke für die Antworten!


    al6042 Ich habe bisher die BL Funktionalität unter Ubuntu versucht zu testen und zu aktivieren, dort wird die Bluetooth Hardware ebenso nicht erkannt. Die Karte an sich inklusive WLAN wird erkannt. Meinst du ein zusätzlicher Test mit einer anderen Distro per Linux Live USB wäre nützlich?


    julian91 Nein, das wird meine letzte Hoffnung sein. Ich habe leider aktuell die ganzen dafür benötigten Torx Schraubenzieher nicht da, deswegen suche ich noch nach einer Software Lösung :)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Vielleicht gibt es auf dem Gerät eine FN-Tastenkombination, mit der man BT aus und einschalten kann, die Du "per Zufall" gedrückt hast? Mir ist das zumindest mal so passiert.

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 16 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, DW1560, macOS Mojave 10.14.6


    Hackmini 1: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.15.6


    Hackmini 2: Acer Revo Base, Intel Broadwell-U PCH-LP, Intel Core i3-5005U, Intel HD Graphics 5500, macOS Mojave 10.14.6

  • im Bios haste aber geschaut oder ?

    Konnte man ja bei lenovo extra deaktivieren ...


    KEIN SUPPORT PER PN!

    julian.png

  • Gute Frage...
    Ich bin mir nicht sicher, ob die Treiber für den BT-Anteil der Broadcom-Karten unter Linux nicht nachträglich installiert werden muss.

    Dazu gibt es weitere Infos unter https://wiki.ubuntuusers.de/WLAN/Karten/Broadcom/

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Vielleicht gibt es auf dem Gerät eine FN-Tastenkombination, mit der man BT aus und einschalten kann

    Gute Idee, leider finde ich keine entsprechende Kombi. Unter Windows ebenfalls alle Kombis durchprobiert, da war leider kein BL dabei. Vielleicht sollte ich mal einen Blick ins ACPI werfen, das könnte aber sehr kompliziert werden.

    im Bios haste aber geschaut oder ?

    Konnte man ja bei lenovo extra deaktivieren ...

    Im Normalen Bios ja, da kann ich nur Wireless Lan deaktivieren. Deaktivieren und wieder aktivieren inklusive diverser Neustarts brachte leider nichts. Ich werde mal versuchen in das erweitere Bios zu kommen, ist nur immer sehr schwer und sehr viel Glück dabei. Weißt du zufällig wie die Option im BIOS heißen muss?


    Zu beachten ist, dass ich die original Intel in ihrem M.2 Slot durch die BCM ersetzt habe. Ich weiß also nicht ob alle eigentlich für die Intel vorgesehene Optionen funktionieren/verfügbar sind.

    Ich bin mir nicht sicher, ob die Treiber für den BT-Anteil der Broadcom-Karten unter Linux nicht nachträglich installiert werden muss.

    Ich mir auch nicht, deswegen habe ich die gleiche Linux Installation mal mit meinem Standrechner der auch eine BCM94360CS2 besitzt gestartet und hier funktionierte Bluetooth ohne Mucken. Scheint also im Standardrepertoire vorhanden zu sein :/

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hm...

    dann würde ich julian91 's ersten Rat mal testen und die Karte ausbauen.
    Ggf. auch schauen, ob etwas im m.2-Slot zu sehen ist, dass u.U. den Kontakt für die Nutzung beeinflusst.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Vielleicht hat ja noch jemand eine Idee. Sonst werde ich mir wohl erstmal noch neue Torx besorgen müssen...


    Ich bin in der Zwischenzeit ins erweiterte BIOS gekommen und habe mit den Bluetooth Settings gespielt, und obwohl hier viel möglich ist kann ich leider keinerlei Erfolg vermelden. Wenn sich hier jemand auskennt, dann freue ich mich über Tipps.


    Wenn jemand noch eine andere Idee hat dann bitte immer her damit :)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hey,

    Ich habe tatsächlich auch ein ähnliches Problem. Ich habe das neueste OpenCore 0.63 installiert und nach dem Neustart ist Bluetooth nicht mehr aktiv, WLAN funktioniert jedoch ohne Probleme. Ich habe die "BCM94360CD" Bluetooth/WiFi Karte die ebenfalls per M.2 / PCI Erweiterung und USB am Mainboard hängt.


    Ich habe alle USB Ports gemappt und entsprechend mit einem kext 15 der Ports aktiviert. Der USB Port auf dem Mainboard an dem Bluetooth angeschlossen ist habe ich auch auf "internal" eingestellt. Hier sollte also das Problem nicht liegen.


    Ich werde mal unter Windows / Linux testen ob dort die Karte aktiv ist und eventuell die Karte mal ausbauen.


    Viele Grüße!

    Steffen

    CPU: i7 4790k - Board: GA-Z97X-UD3H (rev. 1.0) - Grafik: Xfx 5700 DD Ultra (mit 5700 XT Thicc II BIOS) - Sound: Sound Blaster Omni Surround 5.1 (USB) WLAN+BT: Broadcom BCM94360CD RAM: 2x8GB DDR3 - Dispay:LG 27GL850 über Display Port - Bootloader: OpenCore


  • steff89 Interessant, ich glaube die Brcm Karten machen das manchmal...


    Aber ich sehe da einen entscheidenden Vorteil bei dir, und zwar die USB Verbindung, die ich nicht habe. Wenn das BL Modul noch am USB Controller im IOReg erkannt wird, sollte es möglich sein es über DFU anzusprechen. In diesem Fall könntest du dfu-util benutzen um die Bluetooth Firmware neu zu flashen/laden.


    Meine Vermutung ist, dass sich bei uns beiden die BL Firmware aufgehängt hat. Das könnte zB durch einen Absturz und kein korrektes Entladen der Firmware passiert sein. Soweit ich weiß ist die Software non-persistant, sprich bei vollständigem Stromverlust kann von einem Betriebssystem die FW neu geladen werden, egal in welchem Zustand sie zuvor war. (Das erklärt auch, warum die Karte von The_Dave nach ein paar Monaten Schrank wieder funktionierte). Und genau hier ist halt (glaube ich) mein Problem, denn stromlos machen ist nicht bei Laptops ohne Ausbau und FW neu laden auch nicht, wenn ich nicht per DFU USB an die Karte komme. Einen anderen Weg kenne ich aktuell nicht.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hey,

    ich habe jetzt rausgefunden warum mein Bluetooth nicht mehr funktioniert: Als ich die PCI Karte ausgebaut habe, musste ich feststellen dass der Pin für Bluetooth auf der Karte abgebrochen war. Es ist somit schlicht ein Hardwaredefekt. Jetzt muss ich mich mal nach einer Alternative umsehen. Ich dachte eventuell an diese Karten:


    BCM94360CD Wireless Card -MQUPIN AC1750

    CPU: i7 4790k - Board: GA-Z97X-UD3H (rev. 1.0) - Grafik: Xfx 5700 DD Ultra (mit 5700 XT Thicc II BIOS) - Sound: Sound Blaster Omni Surround 5.1 (USB) WLAN+BT: Broadcom BCM94360CD RAM: 2x8GB DDR3 - Dispay:LG 27GL850 über Display Port - Bootloader: OpenCore