ASUS Rampage VI Extreme (original) with Radeon VII

  • I forgot to enable SmallTreeIntel8259x.kext in config for Intel X550T2.
    My Radeon VII´s is DownPower with Custompowerplay to 981mV & HBM 1100MHz in aml.

    7960X / X299 Sage-10G / 2x Radeon VII / OC 0.6.6

  • juantrix


    Congrats. With your Radeon VII SSDT my hack is now quite stable. I can say that as I'm running a duplicate finder since 5 hours on my principal repo (more than 2 TB data) w/o reboot and/or kernel panic. The only problem to solve is now the audio on DP. The related controls are missing along with the audio itself ...

  • juantrix I am also curious regarding your use of MacPro 7,1 vs iMacPro1,1 was there any reason you moved towards using MacPro 7,1?
    Also I noticed you have a thunderbolt aml, do you have any issues with hot plug working?

  • For me, there is no differences in smbios used. But remember, for x299 is recommended iMacPro.
    I have a TitanRidge AIC with v33 firmware flashed & personalized aml. No issues at the moment.

    7960X / X299 Sage-10G / 2x Radeon VII / OC 0.6.6

  • TitanRidge AIC? Not familiar with that one. Is it the same board as the ASUS ThunderboltEX 3? If you have nothing plugged into your Thunderbolt card, does it say "No drivers are loaded." in the System Information panel?

    As far as smbios, I am currently using iMacPro1,1, I was just curious why you were using MacPro7,1.


    I also have seen an issue where my 10Gbit ethernet ( Aquantia AQC107 ) on the ASUS Rampage VI Extreme seems to be recognized as you can see in the screenshot, but for some reason says that the ethernet cable is not plugged in. I don't have a solution so far, any ideas? I am using the following in my config.plist


    I saw you had a specific SSDT-X299-AQC107.aml file, though I wasn't sure why. I also noticed you had a different patch. I tried your patch, and the AQC107 stopped showing up entirely.



    XocKb7c.png

    IkDdxrF.png

  • Thunderbolt

    I have a gigabyte GC-Titan Ridge Card.... there are a lots of information in this forum thanks to DSM2 about flash it with a programmer, jumpers pins to force power... needed to appear in system info - hardware - Thunderbolt.

    If you have a no flashed card (modified firmware), you can obtain hotplug only with a correct aml for your card.

    Asus ThunderboltEX (Alpine ridge) (need to be configured in bios and connect to mobo).


    more info:

    ASUS-THUNDERBOLT-EX-3

    REMOVED by DSM2 - Tonystuff links are not welcome here...

    Thunderbolt SSDT with Custom DROM

    Personalized SSDT


    AQC107

    If you have problems with AQC107... Remember to update the firmware...

    A long time ago, used Aquantia Diag Tool Software to update the initial 1.50 firmware from windows.
    AQC firmware


    I used SSDT-X299-AQC107.aml in Clover...
    In Opencore, properties can be added directly in config.plist

    Patch it necesary.(kernel - Patch)


    Files

    7960X / X299 Sage-10G / 2x Radeon VII / OC 0.6.6

    Edited once, last by DSM2 ().

  • Thanks for the information juantrix , I will check out what that Thunderbolt config page gives me compared to my current .aml file.
    My Aquantia AQC107 is flashed to the latest firmware and that didn't help. I am going to check your latest patch, as it differs from the patch find and replace that I have seen talked about everywhere. I will let you know how this goes, thanks!


    juantrix I am curious, why did you move from the Rampage VI Extreme to the Sage-10G?

  • You nee a patch for the Aquantia:


    * com.apple.driver.AppleEthernetAquantiaAqtion

    * Find: 0F84C002 0000

    * Replace: 660F1F44 0000




  • You nee a patch for the Aquantia:


    * com.apple.driver.AppleEthernetAquantiaAqtion

    * Find: 0F84C002 0000

    * Replace: 660F1F44 0000

    When I use that patch, the 10Gb Ethernet disappears completely from the system information page. If I use the following patch it at least shows up, though it acts like I never have a cable plugged into it:


    * com.apple.driver.AppleEthernetAquantiaAqtion

    * Find: 6275696C 742D696E

    * Replace: 62626262 62626262


    Under Windows 10 the Aquantia 10g Ethernet built into my ASUS Rampage VI Extreme works great with no issues.


    I am noticing the following during bootup:


    AssetMacros: status, file:/AppleInternal/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleEthernetAquantiaAqtion/AppleEthernetAquantiaAqtion-89/AppleEthernetAquantiaAqtion/lf_axge.cpp, line: 5853, value: 0


    5kqD5ws.png

  • Code
    1. * com.apple.driver.AppleEthernetAquantiaAqtion
    2. * Find: 0F84C002 0000
    3. * Replace: 660F1F44 0000

    Some users appears with the same problem (disconnected).

    Did you play with windows? (check it work with drivers installed, then shutdown, power Off completly). Try boot OSx.

    7960X / X299 Sage-10G / 2x Radeon VII / OC 0.6.6

  • Yea I verified that the 10Gb Ethernet worked and received an IP under Windows 10. I am also running the current firmware for the built-in NIC. I then shutdown completely and powered down, and then booted up macOS Catalina. With my previous patch


    * com.apple.driver.AppleEthernetAquantiaAqtion

    * Find: 6275696C 742D696E

    * Replace: 62626262 62626262


    I would at least get the Aquantia to show up under system information, but it never picks up an IP and acts like the cable is not plugged in. Any other patch, like the one mentioned by Toskache wouldn't end up even showing my 10Gb NIC under System Information.

    I have been digging through other forums, insanelymac for instance, trying to find other users who have experienced a similar issue, but so far nothing has worked.

    There were some threads where people were having to use an older macOS build to flash the firmware on the NIC ( unsure but I think those were standalone cards ).


    I know people have gotten the 10Gb ethernet to work on the ASUS Rampage VI Extreme, I am just at a loss on how.