Clover Update schlug fehl, altes EFI lässt sich nicht booten. MacOS 10.15.3 auf 10.15.7

  • Hallo,


    ich bin seit Mai ein Hackintosh Benutzer und bin auch zufrieden mit macOS Catalina 10.5.3 (glaube ich) und Clover 5117 unterwegs gewesen. Nun wollte ich auf Catalina 10.5.7 updaten und vorher Clover aktualisieren. Das habe ich mit dem Wizard gemacht und vorher die EFI Partition gemountet und das EFI kopiert. Nach dem Neustart blieb der Bootloader nach Ablauf der automatischen Bootzeit hängen, eine weitere Auswahl war nicht mehr möglich. Die Shell kann ich auch nicht starten. Nun habe ich gelesen, dass es u.a. an den fehlenden Quirks liegen könnte. Ich habe einen alten USB Stick nach dieser Anleitung (Clover Bootstick mit Windows erstellen) vorbereitet und dort mein EFI reinkopiert. Bei der Bootauswahl in Clover kann ich es auswählen, aber ich habe nur einen dauerhaft blickenden Cursor. Was kann ich noch tun?


    Gruß

    Stephan

  • Welche EFI hast du auf den Stick kopiert? Die erneuerte oder die zuvor funktionierende? Im zweiten Fall, mach mal im clover Bootmenü einen nvram reset mit F11. Für Catalina Updates braucht es den neuen clover nicht.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Zunächt herzlich willkommen im Hackintosh-Forum.

    Nun wollte ich auf Catalina 10.5.7 updaten und vorher Clover aktualisieren.

    Es wird mir wohl ein Rätsel bleiben, woher dieses in meinen Augen fast schon zwanghafte Aktualisieren von funktionierenden Systemen kommt.

    Für ein Aktualisieren ist es immer noch früh genug, wenn nach dem Catalina-Update die noch recht aktuelle Clover-Version der Grund für einen Nichtstart ist. Zumal die 5117 noch nicht mit OC-Ingredienzen versehen ist.


    Ich nehme an, Du hast vor Beginn Deiner Aktivität keinen Backup-Stick Deines 5117-Clover erstellt, der Dir jetzt u. U. aus der Patsche helfen könnte. Oder doch?

    Gruß

    LOM



    Edited once, last by LuckyOldMan ().

  • Das habe ich mit dem Wizard gemacht und vorher die EFI Partition gemountet und das EFI kopiert.

    Ich verstehe das so, dass du vor dem Clover-Update deine alte EFI gesichert hast? Wenn das so ist, könnte es dein Rettungsring sein

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • Ich verstehe das so, dass du vor dem Clover-Update deine alte EFI gesichert hast?

    Woraus liest Du das? Nebenbei habe ich die Frage im umgekehrten Sinn gestellt (kein Backup-Stick), denn seine Schilderung beziehe ich mehr auf das Aktuliaiseren der EFI. Ich hoffe für den TE, ich habe unrecht.

    Gruß

    LOM



    Edited once, last by LuckyOldMan ().

  • Nun wollte ich auf Catalina 10.5.7 updaten und vorher Clover aktualisieren. Das habe ich mit dem Wizard gemacht und vorher die EFI Partition gemountet und das EFI kopiert. liest Du das?

    er hat geschrieben:

    Nun wollte ich auf Catalina 10.5.7 updaten und vorher Clover aktualisieren. Das habe ich mit dem Wizard gemacht und vorher die EFI Partition gemountet und das EFI kopiert."

    Das - vorher gemounted und das EFI kopiert - lässt mich das vermuten

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • Mal abwarten wie sich der TE dazu äussert

    Too Old To Rock 'n' Roll; Too Young To Die!

    Meine Systeme


  • bazza


    Hätte ich gerne, wenn der TE es mir bestätigt. ;)

    Gruß

    LOM



  • Alle Beiträge nach meiner Frage weiter oben sind doch OT und Spekulation Kinners. Wartet doch bitte erstmal bis er sich meldet.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Vielen Dank für die bisherigen zahlreichen Antworten.

    Welche EFI hast du auf den Stick kopiert? Die erneuerte oder die zuvor funktionierende? Im zweiten Fall, mach mal im clover Bootmenü einen nvram reset mit F11. Für Catalina Updates braucht es den neuen clover nicht.

    Ich hatte zuvor funktionierenden kopiert und diese Kopie dann auch hier im Forum hochgeladen.

    Dann hatte ich gedacht dies auch einen Stick zu kopieren und davon zu starten.

  • Kannst Du den Stick mit dem funktionierenden Clover denn in der Bootauswahl (F8 oder F11 je nach Mainboard) auswählen?

    Wenn ja, startet dann Clover und Du siehst eine Bootauswahl u.a. mit macOS Catalina?

  • Ich habe es eben nochmal probiert. Also wenn ich die Bootreihenfolge im UEFI des MB ändere, dann startet die alte Clover 5117 Konfig wieder. Super.

    Nun reicht es aus, diese wieder in die gemountete EFI Partition zu kopieren?

    Muss für ein Catalina Update Clover nicht auch aktualisiert werden? Würde 5117 denn ausreichen auch irgendwann mal auf Big Sur zu gehen?

  • Für ein Catalina-Update muß Du den Clover nicht zwingend aktualisieren, so alt ist der ja auch nicht.

    Für Big Sur rate ich zum Umstieg auf Opencore, das ist mit Clover kein Vergnügen.

  • ede-server

    Added the Label In Arbeit
  • ede-server

    Changed the title of the thread from “Clover Update schlug fehl, altes EFI lässt sich nicht booten.” to “Clover Update schlug fehl, altes EFI lässt sich nicht booten. MacOS 10.15.3 auf 10.15.7”.
  • Da bin ich wieder.
    Kann der Thread weiter verwendet werden oder ist ein neuer zu erstellen? Den Titel habe ich mal angepasst.


    Fortsetzung: Nach dem ich den Clover und Kexte unangetastet lies, habe ich einfach das Update über den Appstore auf 10.15.7 gewagt. Leider mit mäßigem Erfolg. Nach dem Neustart wurde der Installer in Clover erzeugt und lies sich starten, allerdings kam dann ein Black Screen. Ich hatte, nach dem keine Festplattenaktität mehr erkennbar war, einen Neustart gemacht, dann selbes Verhalten. Nach dem 3. Neustart war der Installer verschwunden und in Clover stand macos 10.15.7, allerdings läuft der Ladebalken nur zur Hälfte durch und dann geht der Monitor aus.

    Im Verbose Modus stoppt er nicht bei einem Fehler, muss ich da selber aufpassen um das zu pausieren? Geht das überhaupt? Was ich erkennen konnte, dass es anscheinend am GFX liegt, dass dort keine Firmware gefunden werden konnte.

    Über einen Installations Stick könnte ich ein Time Machine Backup zurückspielen, allerdings wird doch dann auch der EFI Ordner auf der Festplatte formatiert? Kann ich die Kexte denn manuell aktualisieren und mit einem Clover USB Stick starten?


    Gruß

    Stephan

  • Falls Du nicht online kommst, habe ich Dir ein Archiv mit den aktuellen Versionen deiner verwendeten Kexte zusammengestellt.

  • Hallo,


    danke g-force für die Kexte, damit konnte ich erstmal wieder booten. Allerdings habe ich nun 3 neue Probleme.

    1. Der Anmeldebildschirm wird schwarz, ziehe ich das HDMI Kabel raus und stecke es unmittelbar wieder rein, kommt wieder ein Bild.

    2. Ich habe kein BT.

    3. Ich habe kein WLAN.


    Derzeit verfolge ich das Ausschlussprinzip und teste gerade den Boot Stick mit einzelnen neuen Kexten. Bisher habe ich nur Lilu und Whatevergreen getauscht und keinen Erfolg gehabt. ISt dieses Vorgehen überhaupt okay oder vergeudete Zeit?

    Was kann man noch erledigen um o.g. Probleme zu beheben?

  • Wir sollten deinen "status quo" mal zusammenfassen, damit wir besser durchblicken.


    1.) Du hast jetzt auf Catalina 10.15.7 upgedatet.

    2.) Du hast aktuelle Kexte in die EFI aus Post #1 eingebaut und kannst damit 10.15.7 booten.

    3.) Die Clover-Version ist weiterhin die alte Version aus Post #1.

    4.) Du hast seit dem Update folgende Probleme (die es in 10.15.3 noch nicht gab):


    Quote

    1. Der Anmeldebildschirm wird schwarz, ziehe ich das HDMI Kabel raus und stecke es unmittelbar wieder rein, kommt wieder ein Bild.

    2. Ich habe kein BT.

    3. Ich habe kein WLAN.

    Ist das bis hier richtig zusammengefasst?

  • Das ist vollkommen richtig zusammengefasst.