Dual Boot Hackintosh / Z490M / i10500K / RX 5700 XT

  • Hallo ins Forum,


    seit einiger Zeit bin ich hier still am mitlesen. Nun hab ich mich entschlossen mal einen Beitrag zu verfassen, da ich einige offene Fragen durch diverse Aussagen habe.


    Am Montag kommen die Komponenten (Siehe Profil) für meinen ersten Hackintosh, hier erstelle ich allerdings schon im Vorfeld meinen Bootstick und die entsprechende EFI um bestens für die Installation vorbereitet zu sein. Zum erstellen bin ich dem Guide auf Youtube von SchmockLord gefolgt, vielen dank dafür! Allerdings ergeben sich jetzt die ersten Fragen.


    • Ich möchte meinen Hackintosh primär zur Musik Produktion und zur Video/After Effects Bearbeitung nutzen. Hier stellt sich die Frage, ob es sinnvoll ist, die Intel GPU zusammen mit der RX 5700 XT laufen zulassen. (Ich habe gehört, dass dadurch das Timeline scrolling besser laufen soll, wenn die Intel GPU aktiv ist) Stimmt das ?


    • Ich habe eben mitbekommen, dass 10.15.7 released wurde und damit anscheinend Bugs der RX 5700 XT gefixt wurden. Allerdings soll auch die GPU dadurch etwas langsamer geworden sein. Hat damit jemand Erfahrungen und zu welcher Catalina Version würdet Ihr mir raten ? (Ich möchte den Hackintosh eigentlich nicht mehr Updaten und das System so stabil wie möglich lassen. Auf meinem MacBook läuft seit Jahren auch noch Yosemite, da die meisten älteren Audiointerfaces nur bis dahin laufen)

    • Zu welcher SMBIOS Version würdet Ihr mir in diesem Fall raten ?


    • Das ganze soll als Dual Boot Rechner laufen, sprich eine SSD mit macOS und die zweite mit Windows. (Das wird hier ja auch oft geraten)

    Gibt es in dieser "Dual Boot" Konfiguration entsprechend etwas zu beachten, oder gewisse no-go's die man beachten sollte ?


    • Gibt es hier am Ende sogar einen User mit der identischen Konfiguration, der ein Stabiles System hat und mir ein paar Tipps zur EFI geben könnte ?


    e: So jetzt taucht das erste Problem auf.

    Wenn ich mir über GenSMBIOS Serials generieren lassen möchte, werde ich mit der Fehlermeldung: "MacSerial binary was not found and failed to download" abgespeist. Auch wenn ich zuvor über Menüpunkt 1. das Install/Update versuche zu laden.


    Hab die macserial Datei auch manuel aus dem 0.6.1. OC Ordner in den Script Ordner von GenSMBIOS kopiert, leider ohne Erfolg.


    Ich bedanke mich schon mal im Voraus und stark begeistert von der sehr hilfreichen Community hier.

    S ++

  • Ich habe auch den Guide von SchmockLord benutzt. CPU allerdings die 10900k und eine Radeon VII. Ich habe zuerst die config.plist an einem anderen Rechner bearbeitet und mit OPenCore Configurator die Serials generiert. Viele raten davon ab das Programm zu nutzen, für das erste Setup finde ich es aber ganz hilfreich. Ansonsten https://dortania.github.io/OpenCore-Install-Guide/ da steht auch wie man mit GenSMBIOS eine Serial erstellt. Bearbeitung kann man dann auch mit Xcode machen.

    Ich habe zuerst das iMac20 Profil versucht, lief, aber Grafikscores unter aller Kanone. Dann gewechselt auf iMacPro1,1, da waren die Scores ok (CPU und Grafik).

    Windows habe ich einfach nach macOS installiert mit angeklemmter macOS SSD auf einer separaten SSD, jetzt habe ich im OpenCore Bootmenu den Eintrag "Windows" und kann darüber starten.

    Die EFI von schmocklord habe ich nahezu 1:1 übernommen. SSDTs habe ich nicht hinzugefügt, da mir hier die Skills fehlen.

  • haemmerchen


    Das hier schon mal probiert?


    https://github.com/corpnewt/GenSMBIOS#to-install


    Und ganz wichtig: one line at a time

    My Youtube Channel: https://www.youtube.com/channel/UCnohQxGguJlqTeOsZUl3E4A


    Desktop: Gigabyte Z490 Vision-D | Intel i9-10900k@5.2Ghz bei 1.35V| AsRock Phantom Gaming Radeon VII | 64GB RAM TridentZ 36000Mhz | 1TB Samsung 960 EVO für macOS | 1TB Samsung 970 EVO für Windows 10 | 2TB Intel 660p als ExFat für Windows/Mac


    Laptop: MacBook Pro 16 Base Model

  • lukeslater

    also empfiehlst du das iMacPro 1,1 Profil zu nehmen ?


    SchmockLord

    Vielen dank, hat funktioniert.

    Welches Mac Profil würdest du mir den zu diesem Build empfehlen ?

    Vermutlich werde ich die Profile dann mal durchtesten müssen.

  • iMac20,1 als SMBios nehmen, iGPU im Bios aktivieren, GPU als Primäre Ausgabe verwenden und das




    in die config eintragen.

    iMac20,1


    CPU: Intel Core i7-10700 8C/16T

    GPU: MSI RTX 2070 + Gigayte RX 560 + Intel UHD 630

    MB: Gigabyte Z490M

    RAM: G.Skill RipJaws V 32GB Kit DDR4-3200

    OS: Catalina / Big Sur / Windows 10

    Bootloader: OpenCore 0.6.2

  • Kommt drauf an. Wenn du auf Sidecar verzichten kannst und lieber Amazon und Netflix in Safari können willst, iMacPro1,1.


    Wenn du Sidecar willst und auf Amazon und Netflix in Safari verzichten kannst, iMac20,1.


    Und dann je nachdem ob du die iGPU für Bildausgabe nutzen willst:

    - die Device Properties von Bob Schmu, wenn du die iGPU nur als Computing und nicht für Bildausgabe nutzen willst (geht mit iMacPro1,1 und iMacxx)

    - meine Device Properties, wenn du die iGPU für Bildausgabe nutzen willst (geht mW nach nur bei iMacxx)

    My Youtube Channel: https://www.youtube.com/channel/UCnohQxGguJlqTeOsZUl3E4A


    Desktop: Gigabyte Z490 Vision-D | Intel i9-10900k@5.2Ghz bei 1.35V| AsRock Phantom Gaming Radeon VII | 64GB RAM TridentZ 36000Mhz | 1TB Samsung 960 EVO für macOS | 1TB Samsung 970 EVO für Windows 10 | 2TB Intel 660p als ExFat für Windows/Mac


    Laptop: MacBook Pro 16 Base Model

  • Was erzählst du den Leuten, sowohl Prime als auch Netflix funktionieren mit iMac.



    Nur muss man auch wissen was man einstellen soll, steht schön alles beschrieben, sollte man als Power User wissen, wenn man schon Geld für Beratungen und Co nimmt.

    iMac20,1


    CPU: Intel Core i7-10700 8C/16T

    GPU: MSI RTX 2070 + Gigayte RX 560 + Intel UHD 630

    MB: Gigabyte Z490M

    RAM: G.Skill RipJaws V 32GB Kit DDR4-3200

    OS: Catalina / Big Sur / Windows 10

    Bootloader: OpenCore 0.6.2

  • Und warum musst du eigentlich in fast jedem 10th Gen Thema dein imac20,x loswerden ?


    Warum mit extra Bootarg arbeiten wenns nativ mitm imacpro1,1 laufen würde ?


    Siehste, da drehen wir uns im Kreis.


    KEIN SUPPORT PER PN!

    julian.png

  • Weil dein LGA1200 Frequenzvektoren hat und wenn dir egal ist wie dein CPU taktet, dann bleib einfach bei iMacPro1,1, nur wollen Leute die LGA1200 haben auch ihren CPU voll benutzen können und nicht das der Taktet wie ein V8 Motor der nur auf 4 Zylinder läuft.

    Wenn ich jetzt ein Intel 3000 CPU hätte und auf iMac15,1 stellen würde um weiter macOS zu nutzen, dann würde ich das in kauft nehmen, das dieser schlechter taktet, da hilft auch kein SSDT-CPU und auch kein CPUFriend.

    CPUFriend mit einem iMac2020 SMBios, läuft mehr schlecht als recht, wenn man damit unter iMacPro1,1 arbeitet.

    Anscheint hat hier mal jemand den witzigen Irrglaube gestreut das SMBios von der GPU abhängig ist, eher nicht.


    Denk mal drüber nach julian91.

    iMac20,1


    CPU: Intel Core i7-10700 8C/16T

    GPU: MSI RTX 2070 + Gigayte RX 560 + Intel UHD 630

    MB: Gigabyte Z490M

    RAM: G.Skill RipJaws V 32GB Kit DDR4-3200

    OS: Catalina / Big Sur / Windows 10

    Bootloader: OpenCore 0.6.2

    Edited 3 times, last by Bob-Schmu ().

  • haemmerchen Ich hatte zuerst das iMac20 SMBIOS probiert, darunter schlechte Scores für die Radeon VII bekommen mit Geekbench5. Mit dem iMacPro SMBIOS die zu erwartenden Scores. CPU Score bei beiden Setups unverändert. Sidecar geht bei iMacPro nicht, bzw geht bedingt, Seitenleiste ist auf dem iPad zu sehen, ich kann aber keine Fenster rüberschieben

  • @lukeslater Hast du bei dem iMac20 SMBios die iGPU im Bios aktiviert, die Connector framebuffer ID im der config eingetragen zusammen mit WEG+Lilu.kexte benutzt und agdpmod=pikera als Bootarg mit eingesetzt?

    iMac20,1


    CPU: Intel Core i7-10700 8C/16T

    GPU: MSI RTX 2070 + Gigayte RX 560 + Intel UHD 630

    MB: Gigabyte Z490M

    RAM: G.Skill RipJaws V 32GB Kit DDR4-3200

    OS: Catalina / Big Sur / Windows 10

    Bootloader: OpenCore 0.6.2

  • Erstmal vielen dank an alle.

    Der Rechner ist mittlerweile angekommen und baue Ihn gerade zusammen.


    Bin leider nach der Diskussion hier, etwas verwirrter als vorher, welches SMBIOS ich nun nutzen sollte.

    - Sidecar werde ich nicht benutzen

    - Netflix und Amazon Prime wären schon super!


    Primär ist es ein reines Arbeitsgerät, welches auch nur über Ethernet läuft, sprich Airplay und co werde ich nicht nutzen.


    Ich habe wieder zwei neue Fragen:

    - Hat jemand ne Idee, wieso mein Install Stick nicht als Partition im Hackintool auftaucht ? (Siehe Screenshot, unten in der Liste tauchen diese beiden Punkte auf, allerdings oben im Bereich nicht.)


    - Würde jetzt tatsächlich 10.5.7 installieren. Gibt hier noch geteilte Meinung bezüglich der Performance. Macht das Sinn ?


    - Gibt es eine Möglichkeit die macOS Version aus der Installdatei zu lesen ?

  • Bob-Schmu benutze nur noch die iMacPro config. Hatte die iGPU im Bios aktiviert


    haemmerchen dann nutze die iMacPro config. Wenn du einen anderen Rechner zum konfigurieren hast, erstelle einen USB Stick nach den üblichen Guides für 10.5.7. Ich habe dann direkt meine editierte EFI Partition auf den USB Stick kopiert und damit installiert. Ich habe ausser Seriennummern nix geändert von der config.plist von SchmockLord, bis auf die zusätzliche radeonboostkext, aber ich nutze auch ein Radeon VII. Nach Installation bootest du nochmal mit dem USB Stick und kopierst den EFI Ordner des USB Sticks auf deine SSD. Beim nächsten Boot habe ich einen NVRAM Reset gemacht, keine Ahnung ob das notwendig ist.

  • Natürlich nutze ich die permanent, warum soll ich wechseln, sonst hätte ich ja Nachteile.

    iMac20,1


    CPU: Intel Core i7-10700 8C/16T

    GPU: MSI RTX 2070 + Gigayte RX 560 + Intel UHD 630

    MB: Gigabyte Z490M

    RAM: G.Skill RipJaws V 32GB Kit DDR4-3200

    OS: Catalina / Big Sur / Windows 10

    Bootloader: OpenCore 0.6.2