Problem beim USB Mapping / USB Header für Fenvi Karte nicht erkannt

  • Ja, habe ich. Und auch beide USB 2.0 Header an der Unterseite meines Mainboards probiert. Habe wie hier im Thread auch beschrieben XhciPortlimit auf False gesetzt, brachte aber keine Änderung.

  • Es war die ganze Zeit auf true, habe es aber jetzt wieder auf true gesetzt und neugestartet.

    Hab auf den Nimbus 2000 geklickt (für die späteren Leser: der Besen) und dann auf den aktualisier button, das meinst du doch mit USB neu einlesen? Im Anhang siehst du das Ergebnis.


    EDIT: habe nun übrigens gemerkt, dass ich die ganze zeit nur einen USB 2.0 Stick benutzt habe. Habe nun einen USB 3.0 Stick besorgt und der wird an keinen Ports erkannt (ausser an meinen beiden USB 2.0 Ports hinten).


    EDIT2: unter Windows funktioniert Bluetooth (und Wlan) mit den entsprechenden Treibern. Die Karte funktioniert also, hatte nämlich bedenken, bezüglich dem dünnen Kabel.

  • riddy1907


    Der USB Port, an dem deine Fenvi hängt, muss auf Intern gesetzt sein.

    Physische USB3 Ports (bestehen aus einem HSxx und SSxx Teil und sind im Hackintool somit 2 Ports) müssen auf USB3 (HSxx und SSxx) gesetzt sein.

    Edited 2 times, last by LetsGo ().

  • Leider werden mir diese Ports gar nicht im Hackintool angezeigt, damit ich auf intern setzen könnte. Die Fenvi ist an einem internen USB 2.0 Header aber im Hackintool regt sich nichts.

  • Deaktiviere/Entferne mal den USBPorts.kext und setze XhciPortLimit wieder auf True.

    Neustart und Hackintool öffnen, darin den Besen und Aktualisieren drücken. Dann sollten eigentlich wieder alle USB Ports sichtbar sein.

    Nun kannst du einen neuen USBPorts.kext erstellen. Alternativ kannst du auch den Besen und danach die Spritze (Inject) drücken. Manchmal (z.B. bei meinem OEM Mainboard) erscheinen dadurch Ports die alleine mit dem XhciPortLimit=True nicht sichtbar sind.

  • Habe ich versucht, geht leider immer noch nicht. Ich habe den USBPorts.kext entfernt, in der config.plist deaktiviert und XhciPortLimit auf true gesetzt. Dann neugestartet, Besen und dann aktualisiert. Im Anhang seht ihr dann das Bild. Bei der Spritze tut sich nichts.


    Unter Windows funktioniert sowohl Wifi als auch BT, somit ist ein Defekt an Port/Karte auszuschließen.


    FUNKTIONIERT: Ich habe es endlich geschafft, BT funktioniert und damit auch Airplay, Airdrop und sogar Sidecar.

    Lösung: SMBIOS von 20,1 (was mir für Comet Lake empfohlen wurde laut Dortania Guide) auf 19,1 gestellt. Noch die 3 Seriennummern in plist.config angepasst und fertig. Bluetooth wurde sofort angezeigt.

  • riddy1907


    Schön, dass es funktioniert. Vergiss aber nicht bei den USB2 und USB3 Ports den Connectortyp wieder richtig zu setzen.

    Falls du vorher schonmal SMBIOS19,1 verwendet und damit die USBPort.kext erstellt hast, würde das auch der Grund sein warum die USB Ports nicht unter 20,1 erkannt werden. In der info.plist des USBPort.kext ist nämlich auch das verwendete SMBIOS eingebunden. Hast du die SSDT-RHUB unter iMac20,1 verwendet, diese wird nämlich für manche MSI Boards benötigt?


    P.S. Den Connectortyp kannst du auch direkt in der info.plist ändern.



    Kannst du nochmals ein Bild von deinen USB Ports (mit dem SMBIOS iMac19,1) vom Hackintool posten? Mich würde interessieren, ob unter Name noch immer ??? steht.

    Edited 2 times, last by LetsGo ().

  • Ich hatte nie SMBIOS 19,1. Ich habe den Macintosh vor weniger als 1 Monat aufgebaut und bin direkt auf 20,1 gegangen. Die USBPort.kext hatte ich ja immer mit dem Hackintool unter 20,1 gebaut, daher war es ja so nervenzerreissend, rauszufinden, wieso er diese Ports nicht anzeigt. Ich finde meine Ports immer noch "unsauber", aber bin einfach froh, dass ich meine Logitech MX Keys + Master endlich nutzen kann.

    Die SSDT-RHUB kommt mir bekannt vor, ich habe die EFI so oft mittlerweile angepasst, dass es gut sein kann. Aktuell und die letzten 2 Wochen hatte ich die SSDT-RHUB aber nicht.

  • riddy1907


    Ich hab das gerade auf einem B460m Board zum laufen gebracht mit SMBIOS iMac20,1 also muss es funktionieren. Ich habe da den gleichen XHCI controler mit der ID 0x0A3AF (sieht man oben rechts in deinem Hackintool Screenshot)


    Kann es sein das Du nicht die XHCI-unsuported.kext geladen hast? Die ist normal notwendig wenn die USBport.kext genutzt werden soll/muss. Ist die nicht geladen erkennt er nicht alle USB Ports und die USBport.kext Erstellung funktioniert nicht wirklich zufriedenstellend.

    Damit sollte dann auch das USBport.kext erstellen kein Problem sein und das bessere iMac20,1 SMBIOS kann genutzt werden.


    //Edit: Warum geht es jetzt mit dem anderen SMBIOS iMac19,1

    Wird die XHCIunsupported.kext nicht geladen nimmt der der Hackintosh vermutlich das USB Portmapping des originalen Macs das zum SMBIOS gehört. Da scheint das Mapping des 19,1 anders zu sein als das 20,1. Und dadurch hast du mit dem neuen SMBIOS vermutlich Glück weil da der Port im Mapping enthalten ist. Und deswegen sind die anderen Ports noch „unsauber“ wie du schreibst, trotz eigen generierter USBport.kext. Die wird schlicht und ergreifend nicht benutzt.

    Edited 3 times, last by MPC561 ().

  • so, hatte die letzten Tage viel zu tun, melde mich mal zurück:


    ich habe die XHCI-unsupported.kext drin, habe mal versucht diese Kext zu entfernen. Wenn ich XHCI-unsupported entferne habe ich ebenfalls kein BT, also auch nicht mit SMBIO 19,1. Natürlich wäre mein Wunsch zurück auf SMBIOS 20,1 und die USB Ports sauber mappen.


    Ich habe einen Screenshot meines Kext Ordners angefügt. Ich weiss, USBPorts.kext und USBInjectAll.kext sollte man nicht gleichzeitig nutzen. War aber froh, dass es nun funktioniert. Als nächstes sollte ich dann mal die USBInjectAll.kext entfernen und in Hackintool mappen, schätze ich mal?


    EDIT: habe eben die USBInjectAll.kext entfernt und auch den Eintrag in der config.plist entfernt und neugestartet. BT geht immer noch. Was sollte ich nun tun? Gehe ich auf SMBIOS 20,1 wird mein BT nicht funktionieren, da er den Port nicht findet. Wenn ich jetzt mit 19,1 die USB Ports mappe und damit eine neue USBPorts.kext erstelle, dann bin ich nur auf 19,1...


    EDIT2: Bin dabei die Ports neu zu mappen. Was ist eigtl der XX03 Port? Laut meiner Info hängt die Fenvi am HS11 Port.

  • Ich würde das Ganze mal ohne XHCI-unsupported.kext und mit SMBIOS 20,1 versuchen.Gegebenenfalls mal 20,2 probieren. Wird für für deine CPU zwar nicht empfohlen, aber die 19,1 ebenfalls nicht.


    Lade mal deine EFI hoch. Hast du zufällig die SSDT-RHUB in Verwendung? Manche MSI Boards benötigen diese!

  • Und nach dem USBport.kext erstellen wie LetsGo schreibt die Option xhciportlimit wieder auf true und statt injectall die xhci-unsuported.kext nutzen. So sollte es klappen.


    Und die EFI hochladen ist auch sinnvoll.

  • Wieso XhciPortLimit aktiviert lassen, wenn man die Port gemappt hat? MPC561

  • Ich würde das Ganze mal ohne XHCI-unsupported.kext und mit SMBIOS 20,1 versuchen.Gegebenenfalls mal 20,2 probieren. Wird für für deine CPU zwar nicht empfohlen, aber die 19,1 ebenfalls nicht.


    Lade mal deine EFI hoch. Hast du zufällig die SSDT-RHUB in Verwendung? Manche MSI Boards benötigen diese!

    Okay, dafür werde ich leider erst ab Dienstag Zeit habe. SSDT-RHUB habe ich nicht in Verwendung, hatte gelesen, dass ASUS Boards das brauchen. EFI ist nun im Anhang.

    Und nach dem USBport.kext erstellen wie LetsGo schreibt die Option xhciportlimit wieder auf true und statt injectall die xhci-unsuported.kext nutzen. So sollte es klappen.


    Und die EFI hochladen ist auch sinnvoll.

    Okay, sobald ich 20,1 wieder drauf habe, werde ich eine neue USBPort.kext erstellen, diesmal mit xhci-unsupported.kext. Muss ich irgendwas beachten beim SMBIOS ändern? Einfach neue Serials erstellen und in config.plist ergänzen, oder?

  • riddy1907


    Es wäre zumindest mal einen Versuch wert.



    Die Serials müsstest du eh noch vom ersten Versuch haben! Aber das Ganze sollte vorerst auch ohne Serials klappen.

  • Bin auf SMBIOS 20,1 und BT funktioniert!!!


    Was ich gemacht habe:

    -SSDT-RHUB hinzugefügt und in config.plist eingetragen

    -SMBIOS auf 20,1 (mit meinen alten Serials)

    -xhci-unsupported.kext ist drin

    -XHCIPortlimit auf false


    Was anders ist im vergleich zu vorher auf 20,1 ist die SSDT-RHUB und die xhci-unsupported.kext. Soweit ich mich erinnere, hatte ich diese kext nicht drin. Vielleicht lag es aber tatsächlich am SSDT-RHUB.