OSX Update auf "altem" Hackintsoh mit Clover

  • Hallo zusammen,

    bisher habe ich mir vor allen Versions-Updates geschäut. Denn jedes mal lief es nicht rund und ich hatte 1-2 Tage Arbeit an der Backe bis ich den Hacki wieder am laufen hatte.

    Das war maßgeblich zu Ozmosis-Zeiten. Ich habe dann den Cut gemacht und alles platt gemacht und mit Clover neu aufgesetzt. Seit dem läuft er mit OSX HighSierra.

    Jetzt möchte ich dann aber doch mal das Update auf Catalina machen.


    Was ist denn die richtige Vorgehensweise um das System nicht wieder komplett zu zerschießen und den Rest der Woche damit beschäftigt zu sein, die Grundinstallation zu machen. :-)

    Sofern man mit den "alten" Komponenten überhaupt ein Versionsupdate machen kann. Da ändert sich ja alles so schnell.


    Und wie bekomme ich den als neueren Mac ausgegeben? Einen 2018er zum Bsp. Ich habe hier ein neues Keyboard was grundsätzlich zwar funktioniert. Aber so richtig rund wohl nur mit neueren Macs läuft (War eine Kickstarterkampagne)


    Ich habe einfach auch mal die gesamte EFI als ZIP hier angehängt.

    Clover habe ich wohl noch in der Version 4844... zumindest spuckt das mal CloverConfigurator aus. :-)

    Files

    • EFI.zip

      (21.02 MB, downloaded 7 times, last: )

    Mainboard: Gigabyte Z77-D3H Rev. 1.1 F18 Grafik: HD4000 des i5 bzw. ASUS GeForce 750 TI
    CPU: i5 3570K @3,4GHz Disk: SSD 120GByte Samsung Evo
    RAM: 16GByte OS: HighSierra 10.13.6

  • Clover muss aktualisiert werden, die ordnerstruktur geändert werden, und die Kexte und Treiber müssen aktualisiert werden. Aber, es gibt für dieses Board auch schon einen Opencore. Mit dem sollte man auch big sur installieren können.

    Die GTX 750 TI muss ebenfalls ausgebaut werden.

    Und wie bekomme ich den als neueren Mac ausgegeben? Einen 2018er zum Bsp. Ich habe hier ein neues Keyboard was grundsätzlich zwar funktioniert. Aber so richtig rund wohl nur mit neueren Macs läuft (War eine Kickstarterkampagne)

    Anderes smbios.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • was willst du mit neuerem smbios? der rechner wird dadurch nicht neuer, und du handelst dir ärger ein, wenn das smbios nicht mit der hardware deines rechners zusammenpasst.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin GEHT WIEDER LOS!! nächster termin 19. oder 26.8.2020 19.00 (ankündigung kommt noch ;))

  • So, also am schlausten ist es wohl die SSD abzuhängen die Grafikkarte raus und mit einer unbenötigten Testplatte alles von vorne zu installieren. Und wenn es nicht geht oder ich nicht weiter komme, kann ich ja meine SSD mit HighSierra wieder rein tun und schauen wie ich weiter mache. :-)

    Mainboard: Gigabyte Z77-D3H Rev. 1.1 F18 Grafik: HD4000 des i5 bzw. ASUS GeForce 750 TI
    CPU: i5 3570K @3,4GHz Disk: SSD 120GByte Samsung Evo
    RAM: 16GByte OS: HighSierra 10.13.6

  • Ja, das klingt gut :)

    Catalina installer erstellen (der Stick muss mindestens 16gb groß sein). Dann (wenn möglich) einen zweiten Stick für opencore (oder clover) erstellen.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Die NVidia Karte läuft die eigentlich gar nicht mehr unter Catalina? Oder hat sich da was getan mit den Webdriver.... hatte das nur mal gelesen das es da "Puff" gab.

    Mainboard: Gigabyte Z77-D3H Rev. 1.1 F18 Grafik: HD4000 des i5 bzw. ASUS GeForce 750 TI
    CPU: i5 3570K @3,4GHz Disk: SSD 120GByte Samsung Evo
    RAM: 16GByte OS: HighSierra 10.13.6

  • wenn die karte webdriver bräuchte, ist sie nach highsierra raus. danach gibts keine webdriver mehr.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin GEHT WIEDER LOS!! nächster termin 19. oder 26.8.2020 19.00 (ankündigung kommt noch ;))

  • Die GTX 750 TI ist eine Maxwell, und für Die gibt es keine Web Driver mehr.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Aufgrund der erforderlichen Hardware-Änderung (deine GraKa läuft nicht mit Mojave/Catalina) würde ich bei High Sierra bleiben.

  • Die 50 - 60 Euro für eine gute gebrauchte RX560 ist nicht fehl investiert, die Z77 Board's und CPU's gebraucht sind auch günstig, da hat man noch ein paar Jahre Spaß mit macOS.

  • domonicb

    Brauchst du die Gpu Leistung, oder würde dir die iGPU reichen? Einen entsprechenden opencore Ordner gibt es im forum, und der apfel-baum hat das gleiche Board mit opencore. Den dann noch auf die neueste Master opencore aktualisieren, und auch alle Kexte aktualisieren. Dann solltest es schon laufen.

    Vllt. Benötigt die igpu noch ein paar Änderungen in der config. Macos Big sur (11.0 beta) sollte dann auch laufen. Für den install muss das smbios aktuell sein, danach kannst du auch ein nicht offiziell unterstütztes + den bootarg "-no_compat_check" verwenden :)

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • KOmmt drauf an. Ich habe hier noch einen alten VGA Monitor den ich als Zweitbildschirm nutze. Der Läuft mit der Nvidia Karte. Wäre blöd wenn der dann nicht mehr geht mit der iGPU. Aber das weiss ich nicht...ohne es zu testen. :-)


    OpenCore schaue ich mir mal an und lese mich mal ein bzw.habe den hier direkt gefunden.
    OpenCore Sammelthread (lauffähige Konfigurationen) Desktop

    Wenn ich die EFI nutze, sollte es ja prinzipiell klappen, oder nicht?


    Das mit dem SMBios check ich nicht. 🤷‍♂️

    Mainboard: Gigabyte Z77-D3H Rev. 1.1 F18 Grafik: HD4000 des i5 bzw. ASUS GeForce 750 TI
    CPU: i5 3570K @3,4GHz Disk: SSD 120GByte Samsung Evo
    RAM: 16GByte OS: HighSierra 10.13.6

  • VGA funktioniert unter macOS nicht...

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Hmmm mit der nVidia Karte gehts aber aktuell. Betreibe einen DVI und den alten Medionmit VGA Stecker an der Karte. Läuft einwandfrei. Oder meinst Du nur in bezug auf die iGPU?

    Mainboard: Gigabyte Z77-D3H Rev. 1.1 F18 Grafik: HD4000 des i5 bzw. ASUS GeForce 750 TI
    CPU: i5 3570K @3,4GHz Disk: SSD 120GByte Samsung Evo
    RAM: 16GByte OS: HighSierra 10.13.6

  • Nein, funktioniert eigentlich generell nicht... :/

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • VGA funktioniert unter macOS nicht...

    das stimmt so nicht. es gab zwar bei den originalen nie vga, aber nixdestotrotz kann man vga zum laufen kriegen. beim X/T..20 (HD3000) ging es mit framebufferpatch, dito in der nachfolgegeneration. T440s gibt ohne anpassung anstandslos signal per vga aus (HD4400), erkennt im laufenden betrieb alles, was angestöpselt wird, und kriegt (im gegensatz zur HD3000) auch mit, dass der vgamonitor wieder abgezogen wurde. auch der dell 5470 (HD520) kann vga, ebenfalls wie T440 oob.

    einen desktop mit igpu und vga hab ich leider nicht zur hand, aber ich denk, dass es dort auch machbar wär, vga per framebufferpatch an den start zu bekommen.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin GEHT WIEDER LOS!! nächster termin 19. oder 26.8.2020 19.00 (ankündigung kommt noch ;))

  • OK. Mein HP hat VGA, mal probieren :D

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!