Emulierter NVRam funktioniert nicht (Asus Z97 Pro Gamer)

  • Seit heute habe ich ein "neues" altes Z97 Asus Pro Gamer. Die OpenCore-Config konnte ich fast 1:1 von meinem gestorbenem Gigabyte Z97 übernehmen. Soweit läuft auch fast alles perfekt. Bis auf Sleep welches etwas rumzickt. Schlafen tut er ohne Probleme. Wenn ich ihn allerdings aufwecke ist eine Sekunde später alles eingefroren und ich muss den Resetknopf drücken. Darkwake 0,1,10 habe ich schon probiert aber kein Erfolg. dart=0 ist ebenfalls gesetzt. Evtl. muss im BIOS eine bestimmte Einstellung vorgenommen werden?


    Hier jedenfalls mal meine OC-Efi. Vllt. kann ja jemand mal einen Blick drauf werfen.


    EDIT:

    Mein Problem scheint sich erledigt zu haben. Auf dem Board war eine asbach BIOS Version. Habe die Aktuellste jetzt mal geflasht. Jetzt hab ich keinen Freeze mehr.

    Files

    • EFI.zip

      (3.56 MB, downloaded 17 times, last: )

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    Edited 2 times, last by Sascha_77 ().

  • Sascha_77

    Changed the title of the thread from “Freeze nach Wakeup” to “Freeze nach Wakeup (Asus Z97 Pro Gamer)”.
  • Hi Sascha_77


    Gratulation zum erfolgreichen Wechsel des Mainboards.


    Habe jetzt auch den langen Thread gefunden und gelesen. Vielleicht wäre die gebrauchte Mainboard Lösung auch etwas für mich.


    Mal schaun.


    LG Rolf

  • Danke. Bin echt happy. Hat sich LuckyOldMan ´s Befürchtung zum Glück nicht bewahrheitet. Das Board ist innem sehr guten Zustand.


    Hatte den Text kurz vor Deinem Post noch editiert ... jetzt freezed hier auch nix mehr.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • was ist mir in deiner config.plist aufgefallen, dass du für Sound layout id mit Nummer 7 nutzt und bootarg mit alcid 2, vielleicht liegt es daran, da gegenseitig arbeiten und bringen AppleALC zum Freeze, sonst werde ich nachschauen, ob du irgendwo im BIOS Overlocking aktiviert ist!!!

  • Ich nutze die ID=2. Diese 7 ist dieser "komische" Umrechnungswert. Aber wie ganz oben ergänzt ... der Freeze ist seit dem BIOS Update verschwunden. Kann nat. auch sein, dass ich jetzt bei der Neueinstellung des BIOS nach dem Flash eine Option diesmal nicht angewählt habe die vllt. zu den Freezes vorher geführt hat. In dem BIOS kann man ne Menge einstellen. So Umfangreich war das bei meinem Gigabyte nicht.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    Edited once, last by Sascha_77 ().

  • sry, dann habe ich was falsch gelesen oder darauf nicht konzentriert war :facepalm:

    Wenn du id=2 nutzt dann einfach statt 7 nun 2 und alcid kann weg von bootarg und du hast patch für externalicon, der ist nicht nötig, dafür gibt es ein Quirk unter Kernel

    Und statt EC0 zu EC umzubenennen lieber fakeEC als SSDT nehmen

  • Danke, habs jetzt mal so gemacht.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • Hat sich LuckyOldMan ´s Befürchtung zum Glück nicht bewahrheitet.


    In solchen Fällen liege ich gerne falsch. ;)


    Bei meinem "neuen" alten Asus Z87-A (aktuelles BIOS) habe ich nach dem Aufwecken auch Total-Freezer in Catalina (nicht in Mojave), gegen die ich derzeit noch mit der Notlösung "Bildschirmschoner" vorgehe. Bevor wieder auf OC gezeigt wird: war schon unter Clover so,

    Gruß

    LOM


  • Ein Problem habe ich jetzt aber dennoch. Natives NVRam scheint nicht zu funktionieren. Was ich im Netz so gefunden habe sagt, dass bei neueren BIOS Versionen der NVRam Zugriff abgeschaltet wurde. Bleibt mir jetzt nur die nvram.plist Methode oder?

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • Sascha_77

    Changed the title of the thread from “Freeze nach Wakeup (Asus Z97 Pro Gamer)” to “NVRam funktioniert nicht (Asus Z97 Pro Gamer)”.
  • Klappt leider damit nicht. Nach einem Neustart ist die hinterlegte Variable weg.


    EDIT:

    Auch das aktivieren der nvram.plist Methode geht nicht. Er schreibt zwar bei einem Neustart alles in diese plist rein aber beim Hochfahren ignoriert er das dann.



    "TestVar" taucht bei nvram -p nicht auf.


    Was auch seltsam ist, dass meine SystemPlatte im Picker als "Ohne Titel" bezeichnet wird. So hiess sie anfangs auch. Habe sie aber zu "Hackintosh" umbenannt. Aber warum auch immer zeigt er diesen Namen nicht an.


    EDIT:

    So wie es scheint ist das Problem gelöst. Verwende jetzt Clover. Damit merkt er sich jetzt wieder so Sachen wie das zuletzt gebootete Volume. Habe im Hardwarebereich alles hinterlegt. Inklusive eines gemoddeten Roms von den win-raid Jungs.

    Asus Z97 Pro Gamer

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    Edited once, last by Sascha_77 ().

  • Ich nutze die ID=2. Diese 7 ist dieser "komische" Umrechnungswert. Aber wie ganz oben ergänzt ... der Freeze ist seit dem BIOS Update verschwunden. Kann nat. auch sein, dass ich jetzt bei der Neueinstellung des BIOS nach dem Flash eine Option diesmal nicht angewählt habe die vllt. zu den Freezes vorher geführt hat. In dem BIOS kann man ne Menge einstellen. So Umfangreich war das bei meinem Gigabyte nicht.

    Nein, das ist kein Umrechnungswert. 0700000 bleibt auch alcid=7, 09000000 bleibt alcid=9 und erst > 9 wird umgerechnet. alcid=10 wird dann zu 0a000000, die 11= 0b0000 usw.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Nichts ist gelöst. :( Auch mit Clover gehts nicht. Ich verstehe es nicht. Versuche es nun wieder mit OC und bin nach dieser Anleitung (wie auch zuvor schonmal) wieder vorgegangen. nvram.plist wird angelegt. LogoutHook.command funktioniert auch, da er mir eine Testvariable korrekt in der nvram.plist hinterlegt beim Ausloggen. Allerdings holt er sich das nicht beim wieder hochfahren. Nur warum? Die plist wird scheinbar komplett ignoriert.


    Download-Fritz

    Kannst Du Dir das erklären?

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • Sascha_77

    Changed the title of the thread from “NVRam funktioniert nicht (Asus Z97 Pro Gamer)” to “Emulierter NVRam funktioniert nicht (Asus Z97 Pro Gamer)”.
  • Download-Fritz


    Ok hier das Log und die config.

    Files

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    Edited once, last by Sascha_77 ().

  • Sascha_77 Dein Scheme erlaubt die Vars nicht. Mit "TestVar" konnte ich nix finden und dachte an einen Bug, aber deine Log passt einfach nicht zur Beschreibung: "OC: Setting NVRAM 7C436110-AB2A-4BBB-A880-FE41995C9F82:Test is not permitted"

  • Download-Fritz

    Ok verstehe. Man muss die Variablen im Scheme mit angeben die man übernommen haben möchte.


    Aber jetzt unabhängig davon sollte er sich aber eigtl. merken welches Startvolume gewählt ist ohne weiteres Zutun am Scheme oder? Aber selbst das macht er nicht. Er springt im Picker jedesmal auf die Windowspartition. Egal was ich in macOS als Startvolume einstelle. Und bei Systemupdates muss man dann auch immer "Install macOS from......" solange händisch anwählen bis es nicht mehr da ist.


    EDIT:

    Habe jetzt mal probiert alles was mit Bootvolume zu tun haben könnte in das Schema zu setzen:


    Klappt aber auch nicht. Bei "efi-boot-device" ist der Eintrag falsch. Wobei es in der nvram.plist aber korrekt hinterlegt ist. Er wandelt die < und > alle um.

    Auf meinem T530 (native NVRam) sieht es z.b. so aus:

    Files

    • nvram.plist

      (2.66 kB, downloaded 7 times, last: )

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    Edited 14 times, last by Sascha_77 ().

  • keine dieser NVars wird von OC benutzt, den Müll überlassen wir schön Clover... /s wichtig sind Boot0080 und Boot0082 der UEFI-GUID, aber keine Ahnung, wie gut das funktioniert

  • Scheint zumindest mit 0.6.0 nicht wirklich zu funktionieren. Er setzt mir zwar Boot0080 in der nvram.plist wenn ich ein Startvolume auswähle



    ignoriert es aber beim Booten. Werde das mal in die Issues bei GitHub schreiben.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<