Lenovo Thinkpad T530 I5-3210M Mojave

  • Hey zusammen, ich nutze derzeit auf meinem ThinkPad T530 ElCapitan. Würde gerne Mojave auf einer externen HDD installieren und ausprobieren. Dazu habe ich bereits einen Installationsstick mit Mojave und Clover v2.5k r5070 drauf erstellt. Ich habe den Clover Ordner aus dem Thread hier genommen Install-Stick für diverse System-Varianten (High Sierra 10.13.6 und Mojave 10.14 (CLOVER-Ivy) und entsprechend das "-Ivy" aus dem Namen gelöscht.


    Mein ElCapitan läuft mit sehr veralteten CLOVER version und kexten, config.plist etc. Da bin ich mir nicht sicher inwiefern ich das für Mojave verwenden kann.


    Wenn ich den Installationsstock booten möchte, kommt dieser ERROR (siehe Screenshot)


    Könnte mir da bitte jemand helfen Mojave auf der externen HDD zu installieren? :) Ich habe den CLOVER, welchen ich bei der Mojave Installation verwende mal als ZIP hochgeladen


    IMG-2671.jpg

    IMG-2672.jpg

    Screen-Shot-2020-06-29-at-9-43-18-PM.png

    Files

    • CLOVER.zip

      (2.97 MB, downloaded 7 times, last: )

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Kannst mal die config testen

  • Danke für deine Rückmeldung 🙂 Habe gerade deine config.plist getestet, leider erfolglos:



    IMG-2677.png

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Ich hätte eine für HS, welche auf dem T520 läuft.

    Boardman, wenn Deine für einen T520/530 ist, lade sie doch bitte mal hoch.

    Gruß

    Günter

  • warum baust du dir nicht eine efi auf der basis der vorherigen: such dir aktuelle versionen der genutzten kexte, guck, was im ordner drivers64UEFI steckt, und gleich den neuen ordner clover/bios/uefi entsprechend an, übernimm die config.plist sowie evtl. vorhandene dsdt/ssdt, und guck, ob der rechner damit in gang kommt.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin FÄLLT bis auf weiteres AUS!!

  • Vielen Dank für eure Antworten 🙂


    Boardman der Grund warum ich gerne auf Mojave upgraden würde ist, weil es neue Versionen gibt von Apps, die nicht mehr auf ElCapitan laufen und ich dann mein iPhone XR mit macOS syncen kann + iCloud ist dann kompatibel mit iBooks etc. Und die nächste finale Version ist Mojave. Catalina ist erst in 10.15.5.


    grt ich war mir nicht sicher, ob die config.plist und DSDT etc. wegen dem neuen Filesystem (nach ElCapitan) funktioniert. Ich war auch verwundert was VirtualSMC etc. ist. Daher dachte ich wäre es vielleicht einfacher von 0 zu beginnen. Ich habe das jetzt mal so wie du beschrieben hast ausprobiert:


    Folgende Kexte, welche, in meinem alten ElCapitan Clover verwendet werden für Mojave_Clover auf neuste Version geupdated:


    RehabMan-FakeSMC-2018-0915 - FakeSMC.kext (updated) 15/09/2018

    AppleALC-1.5.0-RELEASE - AppleALC.kext (updated) 01/06/2020

    RehabMan-Battery-2018-1005 - ACPIBatteryManager.kext (updated) 05/10/2018

    Lilu-1.4.5-RELEASE - Lilu.kext (updated) 01/06/2020

    RehabMan-CodecCommander-2018-1003 - CodecCommander.kext (updated) 03/10/2018

    RehabMan-Voodoo-2018-1008 - VoodooPS2Controller.kext (updated) 08/10/2018

    RehabMan-IntelMausiEthernet-v2-2018-1031 - IntelMausiEthernet.kext (updated) 01/11/2018

    RehabMan-USBInjectAll-2018-1108 - USBInjectAll.kext (updated) 09/11/2018

    BrcmFirmwareRepo.kext (updated) 06/05/2018

    BrcmPatchRAM2.kext (updated) 06/05/2018


    Diese Kexte habe ich erstmal nicht geupdated, die hat mir Sascha_77 aufgrund meiner re-branded Atheros 9280 geschickt:

    AtherosWiFiInjector.kext

    FakePCIID_AR9280_as_Custom.kext

    FakePCIID.kext


    Hatte Sascha schon gefragt, ob es klappt mit der re-branded unter Mojave. Er sagte ich muss dann nur mit dem Kext-Updater unter "Werkzeuge" den AR928x Kext installieren. Ich nehme mal an das mache ich erst wenn Mojave läuft?


    Bezüglich drivers64UEFI und clover/bios/uefi sieht es bei mir so aus, also so wie es bei "CLOVER Mojave" gezeigt ist, verwende ich gerade:

    Picture-2.png

    Müsste ich da noch Anpassungen vornehmen? Es gäbe noch OsxApitoFixDrv oder OsxApitoFix3Drv, was im CloverConfigurator installieren ginge oder einen anderen Driver?


    Clover für Mojave Änderungen:

    Habe jetzt die alte config.plist und DSDT (von ElCapitan) verwendet. Die SSDT-EC.aml und SSDT-EC.dsl, welche vorher schon drin waren von dem Install-Stick Thread habe ich mal drin gelassen.


    Bevor ich Kext Updates gemacht habe sah es so aus:

    Picture-1.png


    Nach Kext Updates:

    Picture-3.png



    Das Problem was bei mir jetzt kommt, wenn ich es so wie beschrieben starten will, im CLOVER menu kann ich den Install nicht starten und es wird auch sonst nichts an Festplatten angezeigt:

    IMG-2678.jpg

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Bin nicht ganz sicher ob nötig, versuche mal noch den HFSplus zusätzlich einzubinden.

    Gruß

    Günter

  • canyonwalker habe ich mal ausprobiert was du gesagt hast, jetzt sehe ich zwar in Clover den Install stick, wenn ich ihn starte kommt auch der Apple ladescreen nur kurz nach dem Laden kommt dieser Error-Screen:


    Screen-Shot-2020-06-30-at-8-48-43-PM.png

    IMG-2688.jpg

    IMG-2693.jpg

    IMG-2689.jpg

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Wenn Du in den Bootargs -v einfügst, dann kann man etwas mehr sehen,)

    Gruß

    Günter

  • canyonwalker Alles klar habe ich gemacht, vielen lieben Dank für deine Hilfe :)


    IMG-2694.jpg

    IMG-2695.jpg


    Edit: hier ein Link um es besser lesen zu können:

    https://ibb.co/988pZtX

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Die vorletzte Zeile bezieht sich auf Kexte oder Patches die zum Wlan od BT gehören, bin mir gerade nicht ganz sicher. Versuche doch mal die 2 vorübergehend zu entfernen und den Atheros auch um zu sehen ob es daran liegt.


    Habe gerade gesehen, dass die Kexte tw. recht alt sind,nur der Apple und der Lilu sind aus 2020. Sind es bei den Anderen wirklich die aktuellen?


    Habe Dir gerade noch meinen aktuellen Sysreport hochgeladen, den ich dank grt für den T520 unter High Sierra laufen habe. Alle Seriennummern sind auf Null und müssen eingetragen werden, ansonsten läuft sie sehr gut unter HS, kannst ja mal damit versuchen.


    Btw. die von Dir verwendete Cloverversion solltest wenn möglich auch mal updaten.

    Files

    Gruß

    Günter

    Edited once, last by canyonwalker: Ergänzung EFI angehängt zu High Sierra für T520 ().

  • Alles klar, ich habe jetzt diese Kexte rausgenommen:


    AtherosWiFiInjector.kext

    BrcmFirmwareRepo.kext

    BrcmPatchRAM2.kext


    Der kext Ordner sieht jetzt so aus:

    Screen-Shot-2020-06-30-at-11-29-31-PM.png


    Ich konnte jetzt in den Install Stick Mojave Booten und habe die Externe HDD mit APFS erased und die Installation gestartet. Nach 7 Minuten geht der Laptop aus und wieder an. Wenn ich dann allerdings wieder in Clover und die Externe Mojave HDD starte kommt das Apple Logo in Ladebalken. Habe hier alles Bilder-Protokolliert und dann einmal in bootarg -v gestartet.

    IMG-2696.jpg

    IMG-2698.jpg

    IMG-2701.jpg

    IMG-2702.jpg

    IMG-2703.jpg

    Nachdem kein Ladebalken erschienen ist, habe ich nochmal in argboots -v gestartet:

    IMG-2704.jpg

    Bild in höherer Qualität Link: https://ibb.co/sJgLJ6X




    Ich nutze auf dem Install-Stick-Mojave Clover v2.5k r5070 (in meiner Signatur bezieht sich das auf mein ElCapitan System, sollte ich mal ändern, dass es keine Verwirrung gibt). Denkst du ich sollte Clover trotzdem nochmal upgraden? (Verstehe auch nicht warum Hext-Updater sagt ich habe 5108, habe noch den Installier hier vor kurzem drauf gemacht)


    Bezüglich der Kexte, habe ich immer in google eingegeben und auf z.B. https://bitbucket.org/RehabMan/os-x-intel-network/downloads/ den letzten IntelMausiEthernet.kext geladen. Anscheinend habe ich manuell die falschen Quellen benutzt. Habe das jetzt mit dem Kext-Updater geprüft und der sagt mir, es gibt bei IntelMausiEthernet und USBInjectAll neue Kexte. Diese habe ich jetzt noch geupgraded. Ist das eine zuverlässige Quelle oder sollte man das besser noch irgendwie manuell prüfen?


    Diese 3 Kexte hier habe ich konkret von Sascha_77 geschickt bekommen, weil der mir eine Wifi-Karte rebranded hat: AtherosWiFiInjector.kext; FakePCIID_AR9280_as_Custom.kext; FakePCIID.kext. Daher habe ich die nicht geupgraded. Aber da jetzt eh die der Atheros.kext draußen ist upgrade ich auch mal den FakePCIID.kext. Was ist mit FakePCIID_AR9280_as_Custom.kext?


    Kext-Updater Log:


    Ich probiere das gerade mit den aktualisierten Kexten und danach mit deinem Sysreport und eingefügter Seriennummern. Vielen Dank für deine Mühe 🙂


    Melde mich dann gleich wieder.

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Was den Kextupdate anbetrifft kannst Du ihm beruhigt vertrauen, der stammt von Sascha77;)

    Da mein Rechner ein T520 ist und eine andere Graka nämlich HD3000 hat, ist bei mir mit HS Ende. Unter Mojave läuft sie nicht vernünftig(hat man mir glaubwürdig versichert) die Mühe und Zeit es zu testen habe ich mir dann erspart. Habe keine Karte getauscht, BT, Audio und Ethernet laufen so;)

    Lediglich Cardreader und Fingerprint nicht;( was zu verkraften ist.


    Clover 5108 sollte es auch tun, denke ich.

    Hast Du mal geprüft ob 4 GB Ram ausreichend sind ?


    Was sind das den für 2 Volums die da rechts staffiert angezeigt werden.

    Sind das Install oder recovery Volumen? Falls er Movaje schon installiert haben sollte müsste einmal davon gestartet werden, so war das zumindest bei mir.

    Allerdings hatte es deutlich länger gedauert und es erfolgte autom.

    Gruß

    Günter

  • Oki, sehr gut mit dem Kext Updater 🙂 Also mit meinem updated kext Ordner bekomme ich leider das gleiche Resultat wie vorher (Mojave-Stick booten geht, nach 7min geht laptop aus und wieder an, wenn dann wieder in Clover starte kommt kein Apple Ladebalken, nur der Apfel)


    Das ist eine gute Frage ob Mojave auf meinem T530 läuft, ich habe ehrlich gesagt nur geschaut bei apple.com, was für Mojave notwendig ist und da Stand "MacBook Pro (Mitte 2012 oder neuer)" bei mir steht auch bei über den mac "MacBook Pro (13-inch, Mid 2012)". Also bin ich eigentlich davon ausgegangen, dass es geht.


    Aber falls High Sierra besser unter meinen Systemkomponenten läuft würde ich auch auf High Sierra upgraden. Für mich lohnt ein upgrade von ElCapitan eigentlich nur, falls ich folgendes nutzen kann: MS Office 2019; Pages & Numbers kompatibel mit iOS 13; iPhone XR sync mit iTunes (mit ElCapitan geht das aufgezählte nicht). Das sind meine Beweggründe für ein upgrade. Also im Prinzip ist mir nicht so wichtig auf welcher macOS Version ich bin, wenn diese Sachen funktionieren.


    Wo bekomme ich denn raus, ob Mojave bei mir läuft also mit 4 GB ram? Weil wenn ich bei MacBook Pro (13-Zoll, Mitte 2012) schaue gibt es eine i5/i7 Version und 4/8 GB RAM.


    Läuft bei dir denn High Sierra flüssig und kannst du da Pages/Numbers mit iOS 13 nutzen + iPhone syncen? Weiß nicht ob du ein iPhone oder iPad hast? Hast du vielleicht eine Empfehlung für mich, ob ich Mojave oder High Sierra nehmen sollte?


    Die 2 staffierten Volumen ist die Externe HDD, wo ich Mojave drauf installieren möchte. Einmal steht da "Boot macOS Inntal from Mojave" und das andere ist "Boot macOS Inntal Prebooter from Preboot". Ich glaube nicht, dass Mojave schon installiert wurde, denn das hat irgendwie abgebrochen habe ich das Gefühl, denn es hat auch nur 7 Minuten gedauert und dann ging der Laptop irgendwann aus. Ich habe dann versucht davon zu starten, aber da sieht man wie auf den Screenshots oben nur ein Apple Zeichen, ohne Ladebalken. Ich habe dann wie gesagt das im bootarg -v mode gestartet und der Screenshot https://ibb.co/sJgLJ6X (wie oben im post) zeigt die Ausgabe.


    IMG-2706.jpg

    IMG-2707.jpg

    Wenn ich dann was da klicken will kommt das hier, also kein Ladebalken:

    IMG-2703.jpg



    Ich wollte jetzt mal dein Sysreport testen, nur habe ich keine SmUUID und keine Board Serial Number. Also ich meiner config.plist, welche ich aktuell verwende ist das leer. Was soll ich da eintragen?


    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Du kannst die bisherigen Nummern verwenden oder mit dem Clover Configurator neue generieren.

    Das Thema synchronisieren müsstest Du mir von der Handhabung mal erklären, damit ich es mit einem Leihhandy mal testen kann.

    Hattest schon versucht Preboot zu starten?

    Gruß

    Günter

  • warum baust du nicht temporär die elCapitanplatte aus, und dafür die neue platte ein? wär eine fehlerquelle weniger.

    ich würde zusätzlich auch noch die beiden fakepciid-kexte rausnehmen, die wlankarte bräuchte ja noch anpassungen, um überhaupt wieder lauffähig zu werden - in mojave gibts die atheros40.kexte nicht mehr im system, die müsstest du aus highsierra klauen (lassen).

    als smbios würde ich macbookpro 9.2 empfehlen, canyonwalker hat mbp9.1 (richtig?)


    smbios gibts komplett, wenn man auf den button ganz rechts/untere hälfte klickt, nur die boardserial muss dann noch nach rt-variables -> mlb kopiert werden.


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin FÄLLT bis auf weiteres AUS!!

  • canyonwalker Mit synchronisieren, meine ich, wenn ich mein iPhone an mein ElCapitan stecke und “Trust” und den korrekten PIN eingebe, kommt der Fehler “iTunes could not connect to this iPhone. You do not have Permission”. (iPhone XR)

    Screen-Shot-2020-07-01-at-5-25-44-PM.png

    Ja, Preboot habe ich auch versucht zu starten, da kommt das gleiche wie bei Boot macOS Install from Mojave. (also Apple logo ohne Ladebalken)


    grt Die ElCapitan Platte ist die interne vom Lenovo Laptop. Ich versuche auf der externen USB Festplatte Mojave zu installieren. Macht das einen großen Unterschied? Die Externe USB Festplatte wird doch erkannt. Sollte ich lieber auf der internen Platte versuchen Mojave zu installieren? Ich dachte immer das macht keinen Unterschied.


    Bei canyonwalker steht MacBookPro8,1. Ich habe bei ElCapitan MacBookPro9,2. Ich lasse das mal wie du grt empfohlen hast auf MacBookPro9,2



    Ich habe jetzt 3 Versuche gemacht:


    (1)


    (2)


    (3)


    Zum Vergleich mein funktionierendes SMBIOS in ElCapitan (interessanter weise nutze ich in ElCapitan gar keine Board Serial Number MLB oder SmUUID:


    Ich weiß nicht, ob das relevant ist, bei SMBIOS steht wenn ich MBP9,2 generiere 04/12/2020 oder 04/10/2018 als BIOS Version (bei ElCapitan nutzte ich 21/03/12. Wenn ich bei mir im Bios nachschaue steht da auch 2012. Ist das wichtig oder liegt der Fehler was ich habe wo anders? Komischerweise sind im Boot-Menu beim StartUp des Laptops diese Einträge (das ist neu, war eigentlich nie dort zu sehen):


    IMG-2708.jpg

    IMG-2709.jpg

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop

  • Bevor ich jetzt zu testen anfange was das Thema Sync anbetrifft fällt mir eine Besonderheit ein, die Du ändern musst und zwar habe ich eine höhere Bildschirmauflösung und dafür im Bereich Graphics, auf der linken Seite, recht weit oben Duallink auf 1 gesetzt, den musst Du aber für Dich auf 0 setzen!

    Gruß

    Günter

  • Habe ich gerade versucht unter der SMBIOS Variante in Versuch (2) aus meinem letzten Post und deiner genannter Änderung. Leider erfolglos. ist der gleiche ERROR. BootStick Startet und installiert und 2 Minuten vor Ende geht der laptop aus und wieder an.


    Screen-Shot-2020-07-01-at-11-36-32-PM.png

    Lenovo ThinkPad T530 ~ MacBook Pro9.2 ~ OS X: El Capitan 10.11.6 ~ Mainboard: 24296MG ~ RAM: 4 GB
    UEFI BIOS Version G4ET62WW (2.04) - UEFI BIOS DATE 2012-09-13

    Clover 4392 (Für ElCapitan) - Clover v2.5k r5070 (Für Mojave-Installation)

    Intel i5-3210M @ 2.50GHz
    Intel HD Graphics 4000 (Display: 1366 x 768)
    WIFI-Card: Atheros 9280 (re-branded)
    Working: WiFi onboard, Bluetooth onboard, FaceTime, etc. Not Working: HandOff, AirDrop