OpenCore Catalina Installation bricht bei [EB|#LOG:EXITBS:START] ab

  • Er sagt im Video, dass alles einwandfrei funktioniert, wie WLAN, Bluetooth, Airdrop, Ruhemodus usw. usf.

    Ruhemodus ja scheinbar nicht, Bluetooth würde ich aber vermuten liegt eher an der Karte.


    Bzgl. Bluetooth/Ruhemodus: Die Catalina-Installation habe ich jetzt mit dem EFI von Technolli gemacht. Macht es Sinn es nochmal mit deewdews EFI zu installieren oder gibt es da keinen Unterschied und es kommt aufs Gleiche raus, wenn ich den EFI-Ordner am Ende einfach auf die SSD-EFI-Partition lege?


    marco-polo wenn du den Nerv hast, könntest du deine Adapter-Karte ja mal mit der von mir bei Amazon verlinkten vergleichen.

  • Ok, dann ist es vielleicht wie du vermutest ein Hardware defekt.

    Wenn das System einmal installiert ist, kannst du jederzeit den bootloader wechseln ohne das System zu berühren. Du kannst es auch mit Clover starten oder einer neuen OC version. Nur passen muss der bootloader. Zum sleep wake Thema schau dich mal hier im Forum um. Es gab dazu schon einige Beiträge. Bei mir hat es einfach funktioniert, weshalb ich mich nicht groß damit auseinandersetzen musste.

  • Sonny C. Der WLAN-Kartenadapter, den du in #77 verlinkt hast, sieht dem meinen zum Verwechseln ähnlich.

  • Da melde ich mich jetzt auch mal, weil ich Eure Hilfe brauche! Ich hänge hier nämlich schon eine Woche mit dem gleichen Problem wie in der Überschrift geschrieben rum. Ich habe es schon mit OC wie mit Clover probiert, komme aber bei OpenCore nicht über [EB|#LOG:EXITBS:START], und bei Clover nicht über End RandomSeed.


    Der Rechner:

    LG Gram 17, Prozessor: Intel Core i5-1035G7, Bezeichnung: Ice Lake-U, Graphic: Intel Iris Plus Graphics.


    Anbei mal beide EFI's.


    Files

    • CLOVER.zip

      (4.51 MB, downloaded 9 times, last: )
    • EFI-OC.zip

      (2.54 MB, downloaded 9 times, last: )

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 16 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, DW1560, macOS Mojave 10.14.6


    Hackmini 1: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.15.6


    Hackmini 2: Acer Revo Base, Intel Broadwell-U PCH-LP, Intel Core i3-5005U, Intel HD Graphics 5500, macOS Mojave 10.14.6


    In Arbeit: LG Gram 17, Prozessor: Intel Core i5-1035G7, Bezeichnung: Ice Lake-U, Graphic: Intel Iris Plus Graphics.

  • iPhoneTruth Vollzitat entfernt


    Also bei mir hat das geholfen.
    https://dortania.github.io/Ope…stuck-on-eblogexitbsstart

  • Verstehe ich das richtig, dass ich in der config.plist unter Kernel die USBPorts.kext einzutragen habe? Ich bin die OpenCore Anleitung jetzt mehrfach durch, finde zu dem Punkt aber leider keine genauen Instruktionen. Bevor ich mir jetzt die Installation wieder zunichte mache, ein Screenshot anbei. In der Anleitung steht, dass der Pfad auf die "executable" verweisen soll. Meine USBPorts.kext enthält aber nur die Info.plist - ist das korrekt? Lösche ich den Pfad dann einfach raus (siehe Screenshot)?


    Edit:

    Okay, habs einfach probiert, geht mit der Änderung noch alles :)

    Das Sleep-Problem hat es aber leider nicht gelöst :/

  • Sonny C. Vollkommen richtig so mit dem USBport.kext.

    Wegen dem sleep, tausche mal die SSDT-PLUG.aml gegen deine unter EFI/OC/ACPI aus.

  • mkslzk Besten Dank für den Link. Damit habe ich mich seit gestern schon mal durchgearbeitet.

    Die Änderung der Quirks hat nichts gebracht. Damit habe ich mich nun mit Einpflegen der Einträge in die MmioWhitelist beschäftigt.


    Allerdings finde ich im Bootlog für MMIO nur diese Einträge:

    ---

    266:205 00:066 OCABC: MMIO devirt start

    266:266 00:061 OCABC: MMIO devirt end, saved 0 KB

    ---

    Also keine Einträge dazwischen, die ich whitelisten könnte. :(


    Im Anhang mal die Logdatei

    Files

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 16 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, DW1560, macOS Mojave 10.14.6


    Hackmini 1: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.15.6


    Hackmini 2: Acer Revo Base, Intel Broadwell-U PCH-LP, Intel Core i3-5005U, Intel HD Graphics 5500, macOS Mojave 10.14.6


    In Arbeit: LG Gram 17, Prozessor: Intel Core i5-1035G7, Bezeichnung: Ice Lake-U, Graphic: Intel Iris Plus Graphics.

    Edited once, last by iPhoneTruth ().

  • Mit welcher Hardware hast du es denn zu tun?

    Hast du deine Config.plist mit dem OC Sanity Checker schon geprüft? https://opencore.slowgeek.com/

    Einfach CPU Architektur und OC Version auswählen und die plist per Drag and Drop reinziehen



    Hab im Gitbook mal die Section für Ice Lake gefunden. https://dortania.github.io/van…laptop.plist/icelake.html
    Eine MmioWhitelist wird da nicht benötigt. Es steht aber auch dabei das die Grafik nicht zwingend funktioniert da WhateverGreen noch geupdatet werden muss.

    Ob das stimmt kann ich nicht sagen ... möchte mich nicht auf Halbwissen festnageln

  • Die Hardware habe ich nun in die Signatur eingepflegt. Es geht um den LG Gram, Ice Lake.


    Bei Slowgreek wird Ice Lake noch nicht aufgeführt. Ich habe es mal mit Skylake probiert. Fehler gibt er ein paar wenige an, die aber genau als Einstellungen aufgeführt werden, die bei Ice Lake wichtig wären.


    Nach dieser Anleitung von dortania bin ich zunächst vorgegangen. :(

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 16 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, DW1560, macOS Mojave 10.14.6


    Hackmini 1: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.15.6


    Hackmini 2: Acer Revo Base, Intel Broadwell-U PCH-LP, Intel Core i3-5005U, Intel HD Graphics 5500, macOS Mojave 10.14.6


    In Arbeit: LG Gram 17, Prozessor: Intel Core i5-1035G7, Bezeichnung: Ice Lake-U, Graphic: Intel Iris Plus Graphics.

  • Hmmm, da bin ich leider auch überfragt ... bin recht neu in der Szene und hab in den letzten Tagen meinen Laptop gemacht... vielleicht meldet sich einer der Experten ...

  • iPhoneTruth Bei sanity check würd ich eher Coffee Lake auswählen, da die näher an Ice Lake dran sind. Kannst du deine EFI mal hochladen ?

  • Ok. Mache ich gleich mal.


    Im Anhang mal meine EFI.

    Files

    • EFI.zip

      (2.88 MB, downloaded 9 times, last: )

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 16 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, DW1560, macOS Mojave 10.14.6


    Hackmini 1: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.15.6


    Hackmini 2: Acer Revo Base, Intel Broadwell-U PCH-LP, Intel Core i3-5005U, Intel HD Graphics 5500, macOS Mojave 10.14.6


    In Arbeit: LG Gram 17, Prozessor: Intel Core i5-1035G7, Bezeichnung: Ice Lake-U, Graphic: Intel Iris Plus Graphics.

  • https://opencore.slowgeek.com/…59E3AD6Y&rs=coffeelake059

    Sind paar Fehler in deiner Config. In dem oben stehenden Link ist der Check deiner Plist anhand der Coffee Lake Architektur.


    SMC Kexte im Check kannst du ignorieren. Der Checker prüft ja anhand von der Desktop Configuration.

  • Und laut Anleitung sollten nur diese SSDTs drin sein.

    Da sind 2 weitere bei dir drin. Die könntest du in der config mal disablen.

  • Sonny C. Vollkommen richtig so mit dem USBport.kext.

    Wegen dem sleep, tausche mal die SSDT-PLUG.aml gegen deine unter EFI/OC/ACPI aus.

    Merci, leider keine Veränderung. Netzteil- und CPU-Lüfter drehen, Bildschirm bleibt schwarz, CPU-Lüfter hört dann auf, NT-Lüfter läuft durchgehend weiter, CPU Lüfter sporadisch mal eine Drehung.

    Ich habe jetzt mal eine pmset_log.txt gezogen, steige aber nicht wirklich durch. Fällt dir da was auf? Besser neues Thema, der Übersichtlichkeit halber, zu auf machen?


    Edit: Was mir auffällt: die Optionen unter Systemeinstellungen - Energie Sparen sind jetzt andere. Ich habe weniger Punkte auszuwählen und wieder zwei Slider für Ruhezustand Computer und Monitor. Liegt das an der SSDT-PLUG.aml?

    Files

    • pmset_log.txt

      (88.29 kB, downloaded 6 times, last: )
  • Sonny C. Hast Du schon meine EFI ausprobiert? Es scheint mir, dass meine EFI viel weiter ist als die Deine. Anschließend müssten wir lediglich noch das Problem mit den USB-Ports und der Audio-Ausgabe lösen, was mir nicht so wahnsinnig schwierig erscheint (insbesondere mit Hilfe des Forums), und fertig ist der HackMac?

    Edited once, last by marco-polo ().

  • Sonny C. Interessant, hab deine jetzt mal bei mir reingepackt und hab damit auch mehr Optionen. Sleep funktioniert weiterhin damit. Ja,du könntest einen eignen Thread dazu auf machen, dann wird das Problem sichtbarer für andere user die sich damit auskennen.

  • Sonny C. Hast Du schon meine EFI ausprobiert? Es scheint mir, dass meine EFI viel weiter ist als die Deine. Anschließend müssten wir lediglich noch das Problem mit den USB-Ports und der Audio-Ausgabe lösen, was mir nicht so wahnsinnig schwierig erscheint (insbesondere mit Hilfe des Forums), und fertig ist der HackMac?

    Scheue ich ehrlich gesagt wegen Clover <-> OC vor zurück. Dafür kenne ich mich einfach zu wenig aus.

    Bluetooth liegt denke ich an der Karte selbst (bekomme zum WE hoffentlich ein MacBook Air zum ausschlachten, dann kann ich das überprüfen). Ansonsten ist es "nur" der Ruhezustand der muckt.


    Edit:

    Vlt. hilft dir das hier aber weiter: https://www.reddit.com/r/hacki…mojave_on_gigabtye_b360n/

    Edited once, last by Sonny C. ().

  • marco-polo Deine EFI sieht etwas veraltet aus von der Ordnerstruktur, wenn du mal was neueres haben möchtest, dann schau mal hier nach. Install-Stick für diverse System-Varianten (High Sierra 10.13.6, Mojave 10.14.6 und Catalina 10.15)

    Die Clover ver. 5119 kannst du da einfach reinkopieren (bootx64.efi & cloverx64.efi) und du müsstest deine DeviceProperties mit übernehmen, damit du Bild bekommst.

    Damit sollte dein sound laufen. Für die USB ports siehe weiter oben was ich dazu geschrieben habe.