Clover Update - Was mache ich falsch?

  • Hallo meine Hacki Freunde, ich hab leider ein vermutlich sehr banales Problem, ich finde aber die Lösung irgendwie trotzdem nicht.


    Ich wollte gerade meine Clover Version updaten auf 5017, bin dazu in den configurator gegangen und habe die Version runtergeladen.

    Hab die OS-X EFI von der ich boote gemountet, kann es aber leider nur auf meiner Hackintosh SSD installieren. Das ist mir allerdings erst aufgfallen, als ich es schon installiert hab und die geladene Clover Version noch immer der alten (4988) entspricht.


    Wie bekomme ich jetzt die neue Clover Version dort hin wo ich sie brauche? Und kann ich die unabsichtlich erstellten Ordner EFI und EFI-Backups von meiner Hackintosh SSD einfach löschen, oder muss ich da etwas speziell deinstallieren?

    Danke für eure Hilfe :)
    Ganz liebe Grüße und bleibt gesund!

  • Moin,


    Clover kannst du im Prinzip ganz einfach selber updaten, indem du die Datei CLOVERX64.efi im Clover Ordner und die Datei BOOTX64.efi im Ordner BOOT mit der von der neuen Version ersetzt.

    Von dieser Seite bekommst du die neueste Version. https://github.com/CloverHacky…CloverBootloader/releases

    Wenn du CloverV2v5117 lädst findest du die aktuellen Dateien.


    PS: Tu das in dem EFI Ordner, der bisher dein System zum laufen gebracht hat. Die anderen Ordner brauchst du dann nicht mehr. Es darf nur ein Ordner auf deiner EFI Partition sein, der EFI heisst.

  • Und um ganz sicher zu gehen, einen Notfall Stick bereit legen.


    aber das o.g Vorgehen ist im Prinzip ohne Probleme anwendbar

  • Super, danke sehr! Hat ansich funktioniert, nur leider wacht der Computer jetzt nicht mehr aus dem Ruhezustand auf :/ Bisher war das immer ohne Probleme möglich. Kommt das vielleicht häufiger nach dem Update vor?

  • Hier läuft was schief. Die neue Clover-Version ist nicht mit der alten Ordnerstruktur der EFI kompatibel. Es ist also in diesem Fall nicht damit getan:

    indem du die Datei CLOVERX64.efi im Clover Ordner und die Datei BOOTX64.efi im Ordner BOOT mit der von der neuen Version ersetzt.

    Warum soll Clover überhaupt ungedated werden? Dein System ist doch auch nicht aktuell (10.9.5). Warum Clover-Update, wenn es läuft?

  • Edit by al6042 -> Bitte keine Vollzitate von Beiträgen, welche direkt über deiner Antwort stehen...


    Ui, das war mein altes System... Hab jetzt meine Computerdaten auf den neuesten Stand gebracht.

    Ein Update von Clover hab ich gemacht, weil ich gelesen habe es wäre gut immer wieder eins zu machen und weil der Computer zunehmend langsamer wird und besonders lange für den Start braucht, obwohl eine SSD drin ist. Der Start kommt mir jetzt zumindest deutlich schneller vor, nur geht eben leider der Ruhezustand nicht mehr. Also der Computer schläft zwar brav ein und geht auch wieder an wenn ich eine Taste drücke, Bild bekomme ich jedoch nicht mehr.

    Edited once, last by al6042 ().

  • Kannst du mal einen Screenshot vom Inhalt deines Clover Ordners schicken ?

  • Zip ist fertig. Danke für eure Hilfe!


    Falls euch etwas bezüglich USB 3.0 auffallen sollte: ich hab bereits einige sachen ausprobiert und verschiedene Anleitungen verfolgt, aber leider bekomme ich nur usb2.0 Geräte zum laufen, 3.0 wird aber fast nie erkannt und hat falls doch nur etwa 25MB/s Datenrate :/ Hab das inzwischen aufgegeben :oops:

    Files

    • EFI.zip

      (22.59 MB, downloaded 2 times, last: )
  • Ich habe aktualisiert und aufgeräumt, in der "config.plist" habe ich (erstmal) nur ein neues SMBIOS erzeugt.

  • Danke!

    Hab jetzt den Inhalt von meiner alten EFI komplett durch den von dir hochgeladenen ersetzt. Den APPLE Ordner benötige ich gar nicht in meiner alten EFI?

    Starten und alle Funktionen scheinen zu funktionieren, der Ruhezustand aber leider nicht. Der Monitor ist aus, der Computer läuft allerdings weiter und lässt sich da auch nicht mehr raus holen :/

  • Ja hab ihn grade hochgeladen :)

    Damit funktioniert alles, außer dass er langsam bootet und der USB 3.0 Support ist eingeschränkt (so wie jetzt auch).

    Files

    • EFI-4988.zip

      (22.58 MB, downloaded 3 times, last: )
  • In deinem Ordner finden sich aber auch schon Ordner, die erst zu späteren Clover-Versionen gehören. Das ist irgendwie Misch-Masch.

  • Vielleicht löst sich dein Aufwachproblem mit dieser EFI......

    Eventuell laufen die USB ports damit auch, aber um sie wirklich richtig zu deklarieren, müsstest du dir einen eigenen USBport.kext, mit Hilfe vom Hackintool, erstellen.