OpenCore Catalina HP Probook 450 G6 : alles läuft bis auf Camera

  • Messtechnik Fuchs

    Ich habe den Beitrag mal zum eigentlichen Thread dazu gepackt, denn es macht keinen Sinn die Arbeit über mehrere Vorgänge zu verteilen, wenn es letztendlich um das gleiche System geht.


    Mir fehlt in deiner Auflistung einer der folgenden Kexte:

    FakeSMC oder VirtualSMC...

    Von den Sensoren-Kexten sehe ich erstmal ab.


    Ohne diese würde die Kiste normalerweise nicht starten können.

    Zudem brauchst du keinen HDAEnabler, wenn du in der config.plist die "DeviceProperties" für deine interne Soundkarte eingesetzt hast.

    Zudem kenne ich keine DELL 1850 WLAN/BT Combo.... das sollte entweder die DELL DW1560 (2 Antennen) oder DW1830 (3 Antennen) sein.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hast Recht, FakeSMC hatte ich vergessen. Die Reihenfolge sieht tatsächlich so aus:


    Lilu

    WhateverGreen

    ACPIBattery

    ACPIPoller

    AirportBrcmFixup

    AppleALC

    BT4LEContinuityFixup

    BrcmFirmwareData

    BrcmPatchRAM3

    HDAEnabler

    RealtekRTL8111

    USBInjectAll

    VoodooPS2Controller

    VoodooPS2Keyboard

    VoodooPS2Mouse

    VoodooPS2Trackpad

    FakeSMC

    AppleBacklightFixup



    Die WLAN Karte ist die DELL 1850 mit 2 Antennen (die Bildschirmauflösung ist hier so hoch und alles ist so klein, dass ich mit meiner Gleitsichtbrille Probleme hab :-(

    HDAEnabler werde ich entfernen - vielleicht geht dann wenigstens Audio.

    Danke für die Tipps. Ich hab den neuen threat aufgemacht, da ich dachte, dass das ein anderes Thema ist, das vielleicht alle interessiert.

    Aber kann das auch damit zusammenhängen, dass meine Kamera nicht geht ? Oder fehlt mir da irgendwie eine kext?

  • Ins System kommst du ja...

    Poste doch bitte mal einen Screenshot vom PCIe-Tab des HackinTool-Programms.

    Damit sehen wir dann auch, welcher genaue WLAN-Chip darin verbaut ist.


    Was die Bezeichnung des Audio-Codecs betrifft, bin ich auch etwas irritiert... von einem ALC326 habe ich noch nix gehört.

    Hat sich da vielleicht ein kleiner Zahlendreher eingeschlichen und es ist der ALC236 gemeint?


    Bluetooth wird sich herausstellen, wenn du den erwähnten Screenshot gepostet hast.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Wegen Audio solltest du folgende Einträge in deiner config.plist aufnehmen oder, falls bereits vorhanden, ändern:

    Dann klappt das bestimmt auch ohne den ollen HDAEnabler.


    Ich habe die gleiche Broadcom-Karte in meinem GA H170N-Wifi.

    Dort nutze ich nur die folgenden Kexte:

    - AirportBrcmFixup (Version 2.0.6)

    - BrcmBluetoothInjector (Version 2.5.1)

    ggf. musst du noch die anderen beiden BT-Kexte hinzufügen, falls im Systembericht die Firmware Version mit 4096 endet.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Cool, bluetooth geht jetzt. Air Drop auch.

    Aber es kommt noch kein Ton. Auch nicht über einen bluetooth-Lautsprecher.

    Deine Einträge habe ich vorher aufgenommen.


    Hier noch zusätzlich der Sound- und der USB-Tab.

    Der ALC236 und die Kamera werden wohl schon irgendwie erkannt, aber tun nichts. Facetime meldet nach einer Weile, dass die Kamera kein Bild schickt.

    Hast Du vielleicht noch einen Tipp?

  • Wahrscheinlich wirst du für den ALC236 noch andere Layout-IDs testen müssen.

    Folgende sind möglich:

    Quelle: https://github.com/acidanthera…alc/wiki/supported-codecs


    Nach einander in die DeviceProperties unter "alc-layout-id" eintragen und zum jeweiligen Test neu starten.


    Wegen der Kamera kann ich nicht viel sagen...

    Wenn sie bei den USB-Geräten angezeigt und im PhotoBooth nutzbar ist, sollte sie auch in FaceTime funktionieren.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Leider geht es immer noch nicht.

    Muss man die alc-layout-id nicht als hex eingeben ? Ich dachte, irgendwo in der opencore-Beschreibung stünde das. Ich finde es leider nicht mehr.

    Egal, was ich da eintippe, es wird immer die "7" verwendet.

    Es wird auch (siehe Anhänge) ein PCI device erkannt - aber einen Audio-Eintrag gibt es dazu nicht.

    In meiner config.plist habe ich


    alc-layout-id Number 3

    AAPL,slot-name String Internal@0,31,3

    device_type String Audio device

    model String Cannon Point-LP High Definition Audio Controller


    Kann ich irgendwie die revision (z.B. 0x100001) eintragen?

  • Messtechnik Fuchs

    Changed the title of the thread from “OpenCore Catalina HP Probook 450 G6 : Audio geht nicht” to “OpenCore Catalina HP Probook 450 G6 : wie kann die audio revision eingetragen werden?”.
  • Hallo al6042,


    hm, geht leider nicht.

    Muss die ALC-layout-id nicht in hex angegeben werden?

    (ich verwende opencore)

    Die anderen Angaben habe ich durchprobiert.


    _____________________________________________________________________________________________

    Hab jetzt mal den VoodooHDA probiert und geht wunderbar. In den System Preferences/Sound unter Catalina muss man dann noch den entsprechenden Output angeben.

    Edited 2 times, last by Messtechnik Fuchs: Lösung gefunden ().

  • Jetzt funktioniert alles bis auf die Kamera.

    Diese wird zwar als USB device erkannt (Hackintool v3.4.0) mit folgenden Daten:


    Connector: USB3

    Dev Speed: 480Mbps

    Device: HP HD Camera


    Wenn ich mich recht erinnere hat doch USB3 eine höhere Datenrate als 480Mbps, oder ?

    Kann es sein, dass ich das noch anpassen muss ? (z.B. auf "Internal")

  • Messtechnik Fuchs

    Changed the title of the thread from “OpenCore Catalina HP Probook 450 G6 : wie kann die audio revision eingetragen werden?” to “OpenCore Catalina HP Probook 450 G6 : alles läuft bis auf Camera”.