RadeonBoost.kext - Benchmark Scores wie am echten Mac / unter Windows

  • Super danke dir, habs gefunden und aktiviert.

    Hat mir auf jeden Fall nochmal einen kleinen Boost verschafft.

  • Update von heute


    Habe jetzt X-Plane im Mojave und BigSur getestet. Gleiche Szene, selber Plane und Preset.

    Habe sogar ganz die selbe Framezahl, aber leider hab ich in BigSur leichtes shuttering ...


    Kann es mit der Optimierung von X-Plane und BigSur zusammenhängen, da ja die BigSur Treiber

    der Radeon VII super sind, oder hab ich noch was in der EFI was in BigSur nicht mehr funktioniert?


    Danke und schönen Abend

  • Per default ist algrey - mtrr_update_action - fix PAT aktiviert und Shaneee - mtrr_update_action - fix PAT ist deaktiviert da letzterer nicht mit Nvidia Karten funktioniert.

    Man muss selber den von Algrey deaktivieren und den von Shaneee aktivieren wenn man will.

    Wo genau in der Config.plist muss ich das eintragen? In den Bootargumenten?

    Aluveitie ich nutze eine sehr ähnliche Konfiguration wie du und auch Teile deiner EFI. Nur leider habe ich mit deinen ACPI's Probleme mit dem Ausschalten und Sleep.

  • YuriBiermanov Das sind die letzten beiden Kernel Patches.


    Die SSDT-TB3 für TB3 Hotplug scheint Probleme beim Shutdown zu verursachen, deaktivier die mal.

  • Perfekt! Shutdown funktioniert nun. Das Sleepproblem besteht weiter. Komischer Weise ging der Sleep schon einmal. Nun geht der Monitor aus, es dauert eine Weile und das CD-Rom wird kurz angesteuert.


    Trotzdem Danke für die schnelle Hilfe!


    Komischerweise war bei mir nur der Shaneee - mtrr_update_action - fix PAT Patch vorhanden und aktiviert - Okay meine Geekbenchmarkwerte sind auch völlig in Ordnung (80k Metal)

  • YuriBiermanov Kommt drauf an wann du die Patches runtergeladen hast. Der alte wurde etwas später wieder reaktiviert als herausgekommen ist, dass der neue mit Nvidia Karten Probleme macht.

  • Hallo zusammen,

    Ich bin recht NEU hier im Hackintosh Bereich und finde es absolut wahnsinn das Ganze auf einem PC zu betreiben.

    Ich habe die Config.plist von SchmokerLord und das Gigabyte z490 Vision D mit einer Saphire Vega 56.

    Ich habe das identische Problem. Geekbench unter Windows 79000 und mit Hacki bei 56000.

    Habe gesehen, dass man dies mit dem Radeonboost lösen kann. Ich habe dies im Kextfolder kopiert. Ich weiss aber nicht genau was ich im Config.plist eintragen muss. Habe eine EFI gefunden in diesem Verlauf wo jemand unter Kernel diverse Strings hinzugefügt hat. Bei PC Start erhalte ich ein Schemafehler, jedoch startet die Kiste. Benchmark jedoch unverändert.


    Kann mir bitte jemand sagen, was ich genau in der Config eintragen muss? Wäre meega toll

  • 19. April 2020: V1.2 - Removed support for Vega 56, Vega 64 and Vega Frontier - read about the reason here and here

    LG Chris


    Meine Hardware:

  • Hi Chris,


    Das heisst man kann dies mit der VEGA 56 nicht nutzen?

  • Alfista156GTA : Genau - Lese doch den 1 Eintrag in diesem Thread oder Begründung hier .

    Intel PC: Mainboard: Asus Z170 Pro Gaming - Prozessor: Intel Core i7-6700K + Grafikkarte: MSI Radeon Vega 56 8 GB - Bootloader: OpenCore 0.6.4 - Betriebssystem: macOS Big Sur 11.1,


    AMD PC: Mainboard: X470 Aorus Gaming Ultra - Prozessor: AMD Ryzen 5 2600 - Grafikkarte: Sapphire Radeon RX 580 8 GB - Bootloader: OC 0.6.4 - Betriebssystem: macOS Big Sur 11.1

  • Hi Jungs,


    Es gibt ja eine Möglichkeit für BIG Sur via SSDT-RadeonVII-Araguaia.aml.


    laut CMMChris kann dies nicht verwendet werden weil die Ausgänge nicht passen.


    Wer könnte denn die Ausgänge patchen?

  • DerTschnig Kommt drauf an welche Port du brauchst, bei mir mit einem DisplayPort keine Probleme mit dem Araguaia. Laut DSM kann man die fixen, wie genau das ginge weiss ich allerdings nicht.

  • Indem man die Framebuffer Binary patcht (Kext2Patch). Genau dasselbe was man mit den Intel GPU Treibern auch macht - nur das es hier keine GUI gibt und auch WEG keine Patching Automatik dafür bietet.


    Habe mich daran schon versucht habe es aber nicht alltagstauglich hinbekommen. Araguaia macht noch andere Probleme als nicht funktionierende / nicht passende Ausgänge. Sleep / Wake und Hotplug funktioniert auch nicht richtig vor allem im Multimonitor Betrieb. Und das scheint man durch einfache Connector Patches nicht beheben zu können. Wundert mich aber auch nicht sonderlich. Araguaia zielt ja letztenendes auf eine völlig andere Grafikkarte ab, welche ausschließlich Thunderbolt Ausgänge bietet.


    Und nur mal am Rande: Ne SSDT braucht man nicht um Araguaia zu nutzen. Diese Device Properties reichen völlig:

    @0,name | ATY,Araguaia | String

    @1,name | ATY,Araguaia | String

    @2,name | ATY,Araguaia | String

    @3,name | ATY,Araguaia | String


    Edit: Hier ein Frambeuffer Dump von Araguaia

    DP, DP, DP, DP, DP, DP
    000400000001000000010123200000001000050600000000
    000400000001000000010213100000002001060500000000
    000400000001000000010343400000001102040400000000
    000400000001000000010433300000002103030300000000
    000400000001000000010563600000001204020200000000
    000400000001000000010653500000002205010100000000

    LG Chris


    Meine Hardware:

  • Kann man grundsätzlich was kaputt machen, wenn man die Araguaia

    trotzdem verwendet?


    Hab zurzeit nur einen Monitor am Start ?


    gglg

  • Nein kaputt machen kannst du da nichts. Mir stellt sich aber die Frage nach dem Warum. Bringt dir doch am Ende nichts außer etwaiger Probleme.

    LG Chris


    Meine Hardware:

  • Spürt man den erhöhenden Wert in Geekbench dann real auch wo... das is meine Frage....


    Mir kommt in Mojave mit der radeonboost

    alles ein wenig weicher und flüssiger vor als in big sur!!


    Kann aber natürlich auch nur Einbildung sein

  • seltsam bei mir deaktiviert es die Ethernet Controller und Wifi kann dann nicht mehr online gehen woran das wohl liegt...

  • hi, gibt es die Möglichkeit denn Kext doch iwie für eine RX5600XT zu benutzten? Die is ja in dem ersten Beitrag durchgestrichen aufgelistet...

    System:

    AMD Ryzen 5 2600

    MSI B450 Gaming Plus

    Gigabyte RX 5600XT

    2x8GB Corsair Vengeance RGB Pro


    BS: Win 10 und Catalina 10.15.7

  • Was sind denn gute Werte für die Radeon VII im Geekbench unter MacOS? Bei Big Sur erreicht meine etwa 55k, unter Mojave gibt es knapp 74k.


    Ich glaube Windows erreicht so 88k, da finde ich 74k gar nicht mal verkehrt...

    GA-Z97X-UD7 TH / 4790K / Radeon VII / LG 34UM95-P
    GA-Z97N-WiFi / 4790K / RX580
    HP ProBook 650 G1 / Clover