10.15.4 + Clover 5109 auf MSI X99A 5820K I Trotz Umfassenden EFI ist Installation von OSX Nicht Möglich I Probleme mit boot.efi

  • weisst du... du machst es den helfern auch verdammt schwer.

    eigentlich wärs am einfachsten und sinnvollsten, wenn du einen efi-ordner bekommst, damit, genauso wie er ist, ohne darin herumzubasteln, per usb-stick deinen rechner bootest, und dann kurz und präzise dem helfer berichtest, was genau passiert ist.

    mit screenshots, fotos etc,

    aber keine endlosen "philosophien", was eventuell vielleicht oder auch nicht, oder doch, der grund gewesen sein könnte... oder was wer irgendwo irgendwie mal gesagt/geschrieben hat was man eigentlich...

    mit sowas kann dein helfer wirklich nichts anfangen..

    er/sie hat sich bei der zusammenstellung des efi-ordners was gedacht, und braucht rückmeldungen, was mit genau diesem efi-ordner passiert ist, damit er/sie weiterhelfen kann.

    wenn du nicht in dieser form mitarbeitest, bringts nix, und die helfer gehen dir stück für stück verloren. das hat nix mit "thread geht unter" zu tun, sondern mit desillusionierten helfern, die mit dem gefühl, dass ihre hilfe nicht angenommen wird, aus dem thread nach und nach rausgehen.


    so, jetzt hast du deinen beitrag editiert, ich schick meinen aber trotzdem so ab...

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin GEHT WIEDER LOS!! nächster termin 19. oder 26.8.2020 19.00 (ankündigung kommt noch ;))

  • Ähmm, ich kann leider nicht ganz Folgen, vielleicht liegt es an den ganzen Texten zwischendurch, weil ich hab doch alles genauso so gemacht, wie du gerade beschrieben hast (Screenshot #54 ), deswegen fasse ich nochmal alles zusammen, was bisher Geschehen ist.


    Verlinkungen funktionieren leider irgendwie nicht

    Zuvor: Eigenes EFI hochgeladen, DSM2 hats gesehen und dann eine Korrigierte Fassung #33 hochgeladen, welche ich genauso benutze, dass Einzige was ich ändere, ist nun die Quirks.plist welche griven vorgeschlagen hat.


    #53 Ratschläge + Frage von DSM2

    #54 Antwort auf Frage von DSM2


    1.) Das Originale EFI von #33 = boot.efi von #1

    2.) Das Originale EFI von #33 ohne "slide=0


    = 12 Bootversuche, oft das Gleiche, jedoch ingesamt unterschiedliche Meldungen, welche wohl alle dass Gleiche sagen wollen.


    Slide=0 habe ich als Minibefehl wahrgenommen wie keepsyms und -v, dass der so große Auswirkungen hat, konnte ich natürlich nicht wissen. Habe auch schon angeregt, dazu ein Wiki zu erstellen, da es vielen EInsteigern helfen könnte, wenn man ungefähr ne Ahnung hat, was die ganzen Dinge im CloverC bewirken.


    Dieser MemoryFehler, welche nach der Entfernung von Slide=0 noch auftritt, erscheint mir nun gerade nichtmehr, als unlösbar. Werde mal selbst probieren, beim BIOS vielleicht nur die Einträge machen, welche ich wohl vom ElCapitan übernehmen kann?


    #55 Reaktion + Hilfe von griven


    Seit #56 Versuche ich nun mit den Auführlichen Hilfe von griven Erfolge zu erzieln. DSM2 hat den Beitrag mit nen Daumen markiert


    Der Tipp von griven ist, dass ich die Quirks.plist bearbeiten soll.


    Um die scheinbare Verwirrung zu beseitigen, hier das DSM2 EFI von #33 wo nur folgendes verändert wurde.


    1. F4 wurde gedrückt, ohne weitere Schritte

    2. Einige Kexte wurden probiert, alle nicht DSM2 Kexte in Ordner

    3. Alternative Config.plist zum testen hinzugefügt

    4. Bei Treiber UEFI, wurde aufgrund von griven OCQuirks.plist reingepackt


    Diesen Quirks.plist bearbeite ich aktuell aus Basis von #55 , siehe meine Auflistung, welche der Übersicht dient, damit vielleicht andere Nutzer sehen, dass das nicht funktioniert hat.

    Files

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

  • Ich habe hier mal die EFI von DSM2 aus Post 33 als Grundlage genommen und OCQuirks so konfiguriert wie ich denke das es funktionieren müsste auf Deinem Board. Bitte verwende diese EFI genau so wie sie ist ohne irgend etwas daran zu verändern. Kopiere die EFI am besten auf einen FAT32 formatierten USB Stick und starte davon den Rechner. Wenn der Rechner damit nicht durch bootet Dokumentire bitte genau wo er stehen bleibt am besten mit Fotos und poste diese hier zusammen mit einer kurzen Beschreibung dessen was Du genau gemacht hast. Es ist wichtig das Du die EFI unverändert verwendest wenn man Dir helfen soll denn auf die Weise haben wir einen definierten Ausgangspunkt von dem aus wir alle weiteren Schritte planen können.

    Files

    • EFI.zip

      (4.16 MB, downloaded 24 times, last: )
  • Ok, ich nutze derzeit noch hauptsächlich den Installstick (MacJournaled) mit dem EFI, Clover auf SSD ist noch garnicht installiert, werde mir jetzt einen FAT32 Stick erstellen.


    Nur zum Booten ein Stick, werde dann gleich berichten, was ich jetzt schon gesehen habe, ist dass npci=0x2000 gelöscht worden.


    Berichte gleich, hmm reicht die FAT Funktion von Festplattendienstprogramm, oder soll ich GPArted nutzen.

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

  • fat mit fdp reicht vollkommen aus.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    nächster Termin: stammtisch in berlin GEHT WIEDER LOS!! nächster termin 19. oder 26.8.2020 19.00 (ankündigung kommt noch ;))

  • Bin jetzt Gparted und es geht ja um nen eigenen Stick, nur zum Booten, da Fat32 sich kaum für nen Installatstick eigenen dürfte. Da es wichtig scheint, deswegen die Frage, welche Partitionstabelle, ist denn dann am besten? gpt, msdos,mac,dvh,atari etc.

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

  • Fat32 ist MBR (msdos in Gparted)...

    Die Idee hinter dem Fat32 Stick ist das Du hier einfach dran arbeiten kannst ohne die Notwendigkeit zu haben die EFI Partition jedes mal mounten zu müssen (die EFI Partition ist nämlich auch nur eine kleine Fat32 Partition)...

  • Habe jetzt msdos mit fat32 formatiert und werden jetzt dann dass EFI dort einbauen, ohne den npci=0x2000 (der war sehr lange dabei, deswegen die Erwähnung)


    Bericht kommt Gleich:

  • Und wie ist der Stand der Dinge nun?

  • Fotos vom Bildschirm sind nun mal nicht das Einfachste, mit den Ganzen Spiegelungen, am Tag nahezu unmöglich:


    Ohhjee, die Forensoftware hat da scheinbar ihre Probleme und man kann es nur verschwommen sehen, daher extern eingebunden, da die Software an die Grenzen stösst und alles extrem verschwommen, praktisch unlesbar ist.


    ( Nach Art von griven wie #63 erwähnt ohne jegliche Änderung, mit msdos und fat 32 )

    panic1115776copyfjx5.jpg

    Weitere Fotos ::: Foto 1

    Foto 2

    Foto 3

    Extern Test ( externe Verlinkung ist glaub ich verboten? )

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

    Edited 12 times, last by Jumanji ().

  • Also bei mir geht der Boot von Grivens EFI, d.h. er bootet in den MacOS Installer (allerdings habe allerdings eine CPU spezifische Broadwell-E(P) Modifikation hinzugefügt)


    Update


    Auf der Broadwell-EP Maschine geht die EFI (mit CPU Type Mode)

    Auf der Haswell-EP (12core) geht die EFI nicht


    Die gleiche Fehlermeldung

  • Wenn es bootet, ist es halt ein Zufall, ist ja auch ganz andere Hardware, irgendwelche speziellen komischen Fujitsudinger, hat wohl kaum was mit meinen System gemeinsam, ist irgendwie so ein Barebone, wohl kaum ein normaler Desktop.


    Hinzufügen soll man nichts, weil es sonst in der Übersicht verloren geht.

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

  • Bist Du dir das so sicher?


    Glauben oder wissen?



    griven

    die Haswell-EP hat fast den gleichen Crash Dump. Ein paar Offsets weichen ab.


    Werde mal morgen daran basteln ...


    Grüsse Florian

  • :offtopic2::auslach:

    Ach, habs fast vergessen, Ist halt irgendso ein Ding vom Aldi, wenn es durch Zufall funktioniert, hat man Glück. Ist dann halt wieder was Anderes aus dem Forum, einfach wo runtergeladen, ohne dass es was mit dem eigenen System zu tun hat.


    Topic: (wie #63 erwähnt ) + Mehr Screens bei #70panic497kp1.jpgpanic215936r9jrm.jpg[dagegen]:gehtsnoch:[dafuer]:gibtsnicht::facepalm::ichsagnichts::btt::spank:

    Test: #63 @#60 #@63 hmmm Quirkst hier noch Jemand[wech]


    Wichtig: Folgende Quirks Kombinationen, hab ich in über 10 Std (pure Suche). selbst schon getestest, alles Standard, Kombinationen unten:


    Auschnitt von Beitrag:

    Liste ( https://github.com/ReddestDream/OcQuirks )

    1: DevirtualiseMmio Origi = Y I Test = N I No Boot

    2: DevirtualiseMmio = Y I AvoidRuntimeDefrag=N I Reboot nach Datum

    3: DevirtualiseMmio = Y + AvoidRuntimeDefrag=Y I MemoryPanic

    4: DevirtualiseMmio = Y + AvoidRuntimeDefrag=Y + ProvideCustomSlide= N I MemoryPanic

    5: DevirtualiseMmio = Y + AvoidRuntimeDefrag=Y + ProvideCustomSlide= N + SetupVirtualMap =N I Freeze bei Datum

    6: DevirtualiseMmio = Y + AvoidRuntimeDefrag=N + ProvideCustomSlide= N + SetupVirtualMap =N I Freeze bei Datum

    7: DevirtualiseMmio = Y I AvoidRuntimeDefrag=Y + ProvideCustomSlide= Y + SetupVirtualMap =N I Freeze bei Datum

    8: DevirtualiseMmio = Y + AvoidRuntimeDefrag=N + ProvideCustomSlide= N + SetupVirtualMap =N I Freeze bei Datum

    Hmm, Ok, ich glaub SetupVirtualMap =N Immer Freeze bei Datum
    9: DevirtualiseMmio = N + AvoidRuntimeDefrag=Y + ProvideCustomSlide= N + SetupVirtualMap =Y I no boot

    Neue Tests

    10: DevirtualiseMmio = Y + ProtectMemoryRegions = Y I KernelPanic

    Buuuh, diese ganzen Befehle und alles scheint schon so eingestellt, wie es am meisten Sinn hat.

    RebuildAppleMemoryMap = True I Generate Memory Map compatible with macOS.
    Welchen Sinn soll es haben, den auszuschalten, wenn es sich negativ anhört?

    Ob Quirks wirklich was kann frage ich mich gerade, nachdem ich wirklich 10 Stunden schon gequirkst habe, wenn alle kleinen Tipps zusammengewürfelt werden, dann kann mal es vielleicht schaffen, dass es bootet. Ist es Wirklich Quirks, oder kann es nicht auch noch was anderes sein, vielleicht Quirks ich noch 100 Stunden, obwohl es dann nur ein Kext, vielleicht gar nur Treiber, oder ein Mausklick in der config.plist ist. al6064 hat auch mal eine Guide zu DSDT erstellt, vielleicht ist es das doch, auch wenn er gepostet hat, dass DSDT kaum noch benutzt wird.


    So bin hier mal für paar Stunden raus, vielleicht hat ja jemand noch ne Idee zum Quirksen, welche Kombi noch funktionieren könnte.

    MSI X99A (E7885IMS.MB0) + Intel 5820K + GTX970 (RX590 N/A) + 4x8GB DDR4-2400 CL16 Clover 5112 UEFI + 10.15.4

    Edited 17 times, last by Jumanji: Was mit den # los? Quirkst hier noch Jemand? Aktuelle QuirksDauer = +10 Stunden Meine Iniatative beachten, seit über 1 Woche am EFI basteln ().

  • :offtopic2::auslach:

    Ach, habs fast vergessen, Ist halt irgendso ein Ding vom Aldi, wenn es durch Zufall funktioniert, hat man Glück. Ist dann halt wieder was Anderes aus dem Forum, einfach wo runtergeladen, ohne dass es was mit dem eigenen System zu tun hat.

    Wer im Glashaus sitzt, sollte nicht mit Steinen schmeißen... Du solltest deine Art mal überdenken zumal du selber irgendwas zusammengewürfelt hast ohne Sinn und verstand.

    Meinst dir dann aber gegenüber anderen überheblich werden zu können und plötzlich Ahnung zu haben ? Sei froh das man dir hilft und halt den Ball flach.

    Files

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Soweit haben wir jetzt einen Zustand erreicht der das anfängliche Problem erstmal sicher löst (Der Fehler mit dem AptioFix) daran können wir also getrost einen Haken machen denn meine Einstellungen für OCQuirks funktionieren offensichtlich. Die Phase zwischen dem Ende UEFI und Boot des System ist sicher überwunden und genau darum ging es mir erstmal. Das Fehlerbild das wir jetzt sehen hat nichts mehr mit dem AptioFix zu tun sondern von nun an liegen wir bei den Fehlern im Tanzbereich von macOS (der Kernel ist entpackt und gestartet es kommt aber im Bereich von macOS zu einer Panik) und das ist gut so denn damit können wir nun weiter arbeiten. Jumanji das Spiel und die Regeln bleiben die gleichen! Du testet bitte nun weiter und zwar mit der EFI die DSM2 in Post 75 angehangen hat. Auch hier wird die EFI wieder genau so verwendet wie sie ist ohne jegliche Änderungen und auch hier bitte wieder den Test dokumentieren und bei Misserfolg inkl. Bildern hochladen und kurz beschreiben was getan wurde.


    Eine Sache noch Jumanji hör bitte einfach endlich auf zu spekulieren und an Sachen zu schrauben von denen Du keine Ahnung hast und zu denen Dir vollständig das Verständnis fehlt. OCQuirks hat den Sinn und Zweck den Fehler zu adressieren den Du eingangs hattest also das Problem anzugreifen das der Rechner dabei scheitert die notwendigen Vorraussetzungen zu schaffen um macOS überhaupt starten zu können (failed to allocate Runtime Area) nicht mehr und auch nicht weniger. Es handelt sich dabei nicht um ein Allheilmittel um jegliche Kernelpanik, die im weiteren Verlauf auftreten kann, zu vermeiden. Deutlich gesagt also Finger weg von der OcQuirks.plist da ist nichts drin enthalten das Du verändern könntest/müsstest um die Kernelpanik die Du aktuell hast zu beeinflussen denn das ist ein ganz anderes Fehlerbild. OcQuirks wirkt im Tanzbereich der Firmware zwischen UEFI und Bootloader von macOS und hat mit dem was Du jetzt als Fehler hast nichts mehr zu tun.

  • Edit by DSM2: Bitte keine Vollzitate!


    Es ist völlig ausreichend einen User mit @Usernamehier zu markieren.


    Hab die EFI heute getestet, hab fast die selbe Hardwarebasis, 5820k, X99A Raider und ne R9 285 (Aktuell ne andere AMD drinnen zum test), leider rennt die EFI immer in nen Memory Panic

    Edited once, last by DSM2 ().

  • Ich bin was die Hackintosh Thematik angeht raus...

    Mache keinerlei Support und baue erst recht keine EFIs.

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Edit by DSM2: Bitte keine Vollzitate!

    Es ist völlig ausreichend einen User mit @Usernamehier zu markieren.



    Schade da du hier glaub ich als super kompetent giltst, aber alles gut, ich wurstel mich so durch, die Hardware macht mich nur irre.

    Edited once, last by DSM2 ().