Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • @TheWachowski

    Danke für die ausführliche Beschreibung.Ich werde es dann am Wochenende updaten.

    Melde mich danach.

    Viele Grüße

    Leo


    Gehäuse: be quite 700 - Mainboard: Gigabyte Designare Z390 - CPU: i9 9900K - RAM: 128 GByte DDR4 (2666Mhz) - Grafik: Sapphire Nitro+ RX 5700 XT 8GB - WLAN/BT: Fenvi T919- WLAN PCIe-Karte LAN: TN4010 10G Ethernet PCIe Karte - Speicher: 3 x NVMe M.2 SSD´s Summe 5TB und 3x SATA SSDs in SW RAID (6TB)


  • Guten Abend


    die Installation von SONOMA 14.5 bleibt bei 28 Minuten hängen.

    Kann dies mit den Sicherheitseinstellungen zusammen hängen.

    OC ist auf dem neusten Stand 1.0.0 und aktuelle Version Sonoma 14.4.1

    Besten Dank für Eure Hilfe.

  • @Teddy07


    ich habe mein SSD noch nicht mit CCC gesichert. Erst danach kann ich versuchen das Update zu installieren.

    Viele Grüße

    Leo


    Gehäuse: be quite 700 - Mainboard: Gigabyte Designare Z390 - CPU: i9 9900K - RAM: 128 GByte DDR4 (2666Mhz) - Grafik: Sapphire Nitro+ RX 5700 XT 8GB - WLAN/BT: Fenvi T919- WLAN PCIe-Karte LAN: TN4010 10G Ethernet PCIe Karte - Speicher: 3 x NVMe M.2 SSD´s Summe 5TB und 3x SATA SSDs in SW RAID (6TB)


  • Hi Teddy07


    Welches SM Bios verwendest du?

  • So, Leute. Nachdem ich dann dieses mal doch deutlich länger als sonst gewartet habe, da ich die Maschine verlässlich gebraucht habe und keine Experimente wagen konnte, habe ich nun endlich auf Sonoma aktualisiert.

    Vielen Dank an alle, die das möglich gemacht haben. Vorneweg den Entwicklern des OC Legacy Patcher, MacGrummel für seine tolle Anleitung (und allen, die ihm dabei geholfen haben) und NATÜRLICH dem Forum hier als solches. Ich kann gar nicht genug wertschätzen, wie viele Male mir das Gesäß gerettet wurde.

    Wer also bis dato Bammel hatte: einfach stur der verlinkten Anleitung folgen und es kann nichts schief gehen.

    Zwei Fragen habe ich noch an alle, die genausoweit sind:

    1. So wie ich das verstanden habe gibt es keinen wirklichen Grund SecureBootModel wieder anzuknippsen, korrekt? (wobei ich am Ende der Installation sogar erst einmal panisch war, weil ich mir die alte Einstellung nicht gemerkt hatte, nur um dann im backup festzustellen, dass die auch vorher schon auf disabled stand).
    2. Sollte man bzgl. der Updates zukünftig einfach immer Full-Installer ziehen und drüberklatschen, oder die "VM-Simulation" Einstellung wählen? Hat letzteres denn sonst noch irgendwelche Auswirkungen?

    Some men see things as they are and say 'why?', I dream things that never were and say 'why not?'

  • SecureBootModel kann abgeschaltet bleiben bzw. ist die Einstellung relativ egal solange man RestrictEvents.kext mit dem BootArg revpatch=sbvmm verwendet (wie empfohlen). Was die Updates angeht bekommt man generell immer den vollen Installer angeboten sobald man den Patcher verwendet hat (liegt am modifizierten RootFS) es gibt hier also keine Notwendigkeit das Installerpaket gesondert zu ziehen und das Update manuell anzustoßen.


    Ein wenig Vorsicht ist allerdings bei der Verwendung von macOS Beta Versionen im Zusammenspielt mit OCLP geboten denn es kann immer sein das Apple irgendwas an macOS so verändert das die bisherigen Patchsets nicht mehr funktionieren. Wer hier unbedacht updated kann sich mitunter Funktionseinbußen einhandeln (kein funktionierendes WLAN mehr zum Beispiel).

  • Danke. Den Zusammenhang zwischen Patch und der Notwendigkeit bei einem T2 "behafteten" SMBIOS das Updateverhalten anpassen zu müssen ist mir klar. Meine Frage bezog sich nur darauf zu verstehen, ob sbvmm noch andere Auswirkungen hat, weil z.B. macOS dann denkt es liefe in einer VM und man daher lieber selbst die Pakete zieht, oder ob sich das einzig und allein auf das Updateverhalten auswirkt.

    Some men see things as they are and say 'why?', I dream things that never were and say 'why not?'

  • Laut der Beschreibung auf Github wirkt er sich "nur" auf das Updateverhalten aus. Ich verwende ihn am Elitbook und habe bisher keinerlei negativen/anderen Auswirkungen feststellen können.

  • Perfekt!
    Kext und bootarg rein: 14.5 wird angeboten. Besser geht's nicht.

    Some men see things as they are and say 'why?', I dream things that never were and say 'why not?'

  • ich habe gerade von macOS 14.4.1 auf 14.5 aktualisiert. Es gab keine Probleme.


    OC 1.0.0

    Aktuelle Kexte.

    iMacPro1,1


    Gehäuse: be quite 700 - Mainboard: Gigabyte Designare Z390 - CPU: i9 9900K - RAM: 128 GByte DDR4 (2666Mhz) - Grafik: Sapphire Nitro+ RX 5700 XT 8GB - WLAN/BT: Fenvi T919- WLAN PCIe-Karte LAN: TN4010 10G Ethernet PCIe Karte - Speicher: 3 x NVMe M.2 SSD´s Summe 5TB und 3x SATA SSDs in SW RAID (6TB)


    Edited once, last by Leotust ().

  • Leotust
    Dito! Alles genauso.

    Some men see things as they are and say 'why?', I dream things that never were and say 'why not?'

  • Nach erfolgreichem Update von Mojave auf Monterey 12.7.5, OC 0.8.3 ist es lediglich der i211 Ethernet Port (en1), der nicht funktioniert. Ist ja ein bekanntes Problem hier, aber lässt es sich irgendwie lösen?


    Laut user f11 läuft der i211 Ethernet Port seit späteren Monterey Versionen nativ ohne SmallTree kext.


    Kann mich hier jemand leiten, wie ich config.plist anpassen muss, sobald die SmallTreeIntel82576_patched.kext rausfliegt?



    „ACHTUNG: Unter Monterey funktioniert der obere Ethernet-Port (Intel I211, en1) momentan noch nicht. Der untere (Intel I219V7, en0) geht einwandfrei.

    Der i211 Ethernet-port läuft übrigens nativ seit einigen späteren Monterey-Versionen und auch unter Ventura. Die SmallTreeIntel kext kann also rausfliegen.

  • 120bpm Ich bin wie gesagt nicht mehr im Thema drin, aber falls der i211 Ethernet Port nativ läuft, dann würdest du einfach den Eintrag für die Kext-Datei aus der config.plist löschen, und das wär’s dann auch schon, was das betrifft.

    bzw.


    Bzw. zum Ausprobieren erstmal nur den Haken bei "Enabled" entfernen.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • JimSalabim Schön, dass du wieder da bist!!

  • JimSalabim super, vielen Dank!

    Das habe ich direkt mal probiert. Kext einfach aus der plist gelöscht bzw. deaktiviert.


    Teilerfolg: Die en1 wird dann erkannt und bekommt auch ne IP zugewiesen. Das an den oberen Lanport en1 angeschlossene Audiointerface (Metric Halo) wird nicht erkannt.


    Nach einigen Minuten kommt es dann zum Freeze und oder Reboot.


    Sobald ich die SmallTreeIntel82576_patched.kext wieder aktiviere, gibt es keinen Freeze mehr – jedoch funktioniert dann auch der obere LAN Port en1 nicht mehr.


    Hat da jemand ne Idee, wie man den oberen LAN Port bzw. das System ohne die SmallTree stabil bekommt?


    Hier mein EFI (anonymisiert): EFI

    Edited 4 times, last by 120bpm ().

  • Hallo Zusammen, ich möchte die Grafik Karte AMD RX 6950 XT kaufen.

    Was muss ich bei der Installation zusätzlich zu dem Eintrag "agdpmod=pikera" berücksichtigen?

    Verwendet jemand diese Karte?

    Ist die Karte zu empfehlen?

    Viele Grüße

    Leo


    Gehäuse: be quite 700 - Mainboard: Gigabyte Designare Z390 - CPU: i9 9900K - RAM: 128 GByte DDR4 (2666Mhz) - Grafik: Sapphire Nitro+ RX 5700 XT 8GB - WLAN/BT: Fenvi T919- WLAN PCIe-Karte LAN: TN4010 10G Ethernet PCIe Karte - Speicher: 3 x NVMe M.2 SSD´s Summe 5TB und 3x SATA SSDs in SW RAID (6TB)


    Edited once, last by Leotust ().

  • Leotust : Ich würde die Karte wahrscheinlich nicht nehmen, weil sie nicht nativ von macOS unterstützt wird, sondern einen besonderen Kext braucht. Und wenn ich mich recht entsinne, war mit dem bei macOS Sonoma 14.3 Ende im Gelände, vielleicht kann Dir da aber hObelware weiter helfen, was die Funktionalität angeht..


    :hackintosh:

  • @MacGrummel


    Ich danke Dir für die schnelle Antwort. Dann werde ich mir die RX 6900XT kaufen.

    Viele Grüße

    Leo


    Gehäuse: be quite 700 - Mainboard: Gigabyte Designare Z390 - CPU: i9 9900K - RAM: 128 GByte DDR4 (2666Mhz) - Grafik: Sapphire Nitro+ RX 5700 XT 8GB - WLAN/BT: Fenvi T919- WLAN PCIe-Karte LAN: TN4010 10G Ethernet PCIe Karte - Speicher: 3 x NVMe M.2 SSD´s Summe 5TB und 3x SATA SSDs in SW RAID (6TB)