HP EliteBook 840 G1 & OpenCore Catalina/Big Sur

  • Franck if all work, perfect 👍

    Sure you can update open core... Why not🤷‍♂️

    Dell XPS 13 7390  Intel® Core™ i7-10510u - Intel Iris Plus - Killer WLAN / Bluetooth Modul - 500GB NVMe - 16 GB RAM - Big Sur - MacBookPro16,3 - OpenCore 0.7.5

    Dell Latitude 7280  Intel® Core™ i7-7600u Kaby Lake - HD 620 - BCM94360NG Modul - 500GB NVMe - 16 GB RAM - Monterey - MacBookPro15,2 - OpenCore 0.7.5

    ASUS H170 G11CB-DE006T  Intel® Core™ i7-6700 Skylake - HD 530 - BCM94360NG Modul - 256GB SSD - 16 GB RAM - Big Sur - iMAC17,1 - OpenCore 0.7.4

    MSI B150-i Gaming Pro  Intel® Core™ i5-6400 Skylake - HD 530 - BCM94360NG Modul - 500GB SSD - 12 GB RAM - Monterey - iMAC17,1 - OpenCore 0.7.2

    Intel NUC6I7KYK  Intel® Core™ i7-6770HQ Skylake - Iris Pro 580 - Intel WLAN / Bluetooth Modul - 256 GB NVMe - 16 GB RAM - Big Sur - iMac17,1 - Open Core 0.7.4

  • Hello all of you

    i have read all the post and all informations about kext, OC, param and others things but i still have some problems

    > My config is HP 840G1 with broadcom BCM94352HMB PCI card (for wifi/bluetooth)

    > I use OC 7.0 and Bigsur 11.6


    The PC boot (after a quite long time) and start to BigSur OS.

    My problems are :

    - After some try and modification, i have succeed to use the trackpad (thanks for explications) but buttons still not works.

    - Wifi and bluetooth doesnt woks : wifi card seems to be identified (in device panel) but no bluetooth device seems to be identified. I use AirportBCRMfixup kext (with explications to deactivate bcrm4360 injector) and try some params (for instance add PCI card in OC param)... without any success...


    If you have some ideas and/or some files that could be usefull it will be great


    Thanks for your works, your informations .

    I have attached my config.plist file if needed