HP EliteBook 840 G1 & OpenCore Catalina/Big Sur

  • Ich hab in der config die ACPIBattery Kext mal an Stelle 2 gepackt. Lilu muss ja als erstes laufen.


    Keine Veränderung :-/ Hast n Tipp?

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • Ich hab´s nicht probiert. Vllt. hat es jboeren schon geschafft :)

  • Ich weiß nicht aber kann das was mit den Patches zu tun haben? Brauche ich vllt ne DSDT wie bei Clover? Du scheinst versierter zu sein als ich theCurseOfHackintosh 😀

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • DSDT sollte drin sein, kann es grad nicht anschauen.

  • DSDT sollte drin sein, kann es grad nicht anschauen.

    Nö die fehlt 😀 ich Pack Mal meine rein

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • War mir eben nicht sicher :D

    Und in der Config musst du die auch eintragen :)

  • gut also im clover hab ich auch keine xD aber dann werdens wohl diverse patches sein die in der config drin sind vom clover config file.


    kann man die irgendwie migrieren?

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • Ich habe keine dsdt. Alles sind clover hotpatches. Leider habe ich moment nicht viel zeit.

  • Ich glaube wir benötigen einfach noch die Battery Patches als SSDT. Ich hab da mal was gefunden aus Rehabman Repo auf Github.


    Ich kann es gerade nicht testen (arbeit und so)



    Anbei als ASL SSDT-BATT.rar

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • damit funktioniert es auch nicht, habe ich schon alles probiert :-(

  • verdammt... ich habe eben die clover patches aus der config mal übernommen auch ohne erfolg...

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • FakeSMC, wie du auch im Clover kext Ordner hast ;)

  • Kann es sein das der RTC Fix nicht funktioniert? Ich habe bei jedem Start oder Neustart einen CMOS Fehler und nur ein Resetten und nochmaliger Neustart behebt das.

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • Kann ich mal schauen, aber nicht jetzt.

  • Immer mit der Ruhe :) ich habe auch erfahren, dass die FakePCIID Kext raus kann weil das ja eigentlich Whatevergreen übernimmt nur für die Netzwerkkarte benötige ich dann die passende Kext statt der FakePCIID_Broadcom Kext. Gibt es dazu Erkenntnisse ?😀

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • RTCMemoryFixUp.kext mal probiert?

  • Ich hab mal nen bisschen aufgeräumt und mit den Sanity Checker einige Anpassungen gemacht. VoodooHDA ersetzt durch AppleALC, FakePCIID rausgeworfen und mit AirportBRCMFixup.Kext+ BrcmPatchRAM3.kext ersetzt.


    VirtualSMC statt FakeSMC und ACPIBatteryManager raus da Batterie bei mir eh nicht geht... es sei denn jemand findet bzw hat Patches für mich?


    Insgesamt wirkt es sauberer find ich :) Allerdings bringt der RTCMemoryFixup.kext nichts bei mir :-/


    Die CMOS Fehler bleiben beim rebooten


    Da wäre Hilfe echt cool :)


    Anbei die aufgefrischte EFI-Struktur (inkl aktuallisierter Kexte)

    Files

    • OCEFI.zip

      (5.74 MB, downloaded 103 times, last: )

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1

  • Hat niemand eine Idee oder Tipp? 😬


    Also beim CMOS Fehler handelt es sich um einen Checksummen Fehler. Ich bin für jede Hilfe dankbar :)

    HP EliteBook 840 G1: Intel i5 4300U / Intel HD 4400 / 240GB Kingston SSD / 16GB DDR3 1600MHz / OpenCore 0.7.0 / Big Sur 11.3.1