Bericht HP-Probook 440 G6 - Intel UHD Graphics 620 bleibt bei 7MB

  • Hallo an Alle - wie versprochen, hier nachfolgend mein Bericht, mit der Bitte um Hilfe


    Es soll ein HP-Probook 440-G6 mit MacOS Catalina zum laufen gebracht werden, dies aber möglichst ohne im eigentlichen Betriebssystem herum zu ändern. Soweit bin ich dank Eurer vielen Beiträge und Hilfestellungen hier ganz gut durch gekommen. Noch gibt es aber Probleme mit der internen Grafik, die trotz aller Versuche nach wie vor zwar richtig erkannt, jedoch mit nur 7 MB Speicher angezeigt wird und so die Grafikbeschleunigung fehlt.


    Vielleicht hat jemand eine Idee? (unten dazu mehr)


    Unabhängig davon, wie bin ich vorgegangen:

    1. Vorbereitung
      Zunächst habe ich dem Gerät neue RAM-Riegel, eine größere SSD und eine SATA SDD verbaut, sowie die interne WLAN-Bluetooth-Karte gegen eine DM-1830 auf Empfehlung von DSM2 ausgetauscht. Danach ergibt sich folgende Konfiguration:

      Intel Core i5-8265U, Intel UHD Graphics 620, DDR4-2400 16 GB, M.2 NVMe Samsung 970 Evo mit 500 GB, SATA-SSD mit 480 GB, Realtek RTL811, WLAN + Bluetooth mit DM-1830. HD-Kamera, Mikrofon, Anschlüsse: (2 USB 3.1, 1 USB 3.1 Type C, 1 USB 2.0, 1 HDMI 1.4b, 1 Ethernet 1Gb, 1 Audio),

      Nach dem alles verbaut war, habe ich die üblichen Einstellungen im Bios angepasst:
      - Fastboot - disable,
      - Securityboot - disable
      - VTx und VTd - disable
      - Intel SGX - disable
      - TPM (Trusted Plattform Modul) - disable
      - DPTF - disable
      - Wake-on-LAN - disable
    2. Installation
      Für die Installation habe ich mir mit TINU - wie hier vielfach beschrieben - einen Install-Stick erstellt, dann die EFI-Partion erzeugt. Den Clover-Ordner habe ich mit nach zahlreichem Lesen hier im Forum selbst zusammengestellt. Das heißt, die nötigen (vermuteten) Kexts zusammengesucht und so die Ordner gefüllt. Irgendwann hatte ich einen EFI-Ordner und eine Config, mit der ich installieren konnten.
    3. Nach der Installation
      Nach der Installation habe ich durch viel probieren und wieder Lesen und wieder probieren den EFI-Ordner und die Config „feinjustiert“ und weiter ergänzt. Und siehe da, Stück für Stück kamen weitere Funktionen dazu. Dabei habe ich mir soweit wie möglich alle Änderungen am Cover-Ordner dokumentiert, so dass ich möglichst später noch nachverfolgen konnte, warum nun wieder etwas anderes nicht funktionierte. Die Kexts sollten jetzt alle aktuell sein und ich hoffe meine Config enthält nicht soviel Müll. Auf die gleiche Weise habe ich das Patchen der DSDT dokumentiert und nach einander den Erfolg oder Misserfolg getestet. Die DSDT habe ich mit MaciASL wie folgt gepatcht: Fehler auskommentiert, GFX0 to IPGU -Patch, Replace-Names-Patch und Laptop-Audio 3 - Patch. Der daraus entstandene Clover-Ordner entspricht dem angefügten Stand.
       
      Mit diesem Ordner habe ich vorsorglich die Installation von MacOS wiederholt. Einfach nur, um sicher zu sein, dass mein zahlreichen Versuche nicht doch irgendetwas am System verändert haben.
    4. Fazit und wo brauche ich Eure Hilfe
      Mit dem angefügten Clover-Ordner funktioniert schon recht viel:
      - Das Geräte boote fast fehlerfrei (so weit ich das selbst auf einen Video sehen kann) und braucht vom Clover-Start bis zum LogIn-Screen ca. 24 Sekunden

      Was funktioniert scheinbar fehlerfrei:
      WLAN, Bluetooth, (auch AirDrop geht), LAN, USB-2 und USB-3 - (USB-C habe noch nicht testen können), Kamera funktionieren (auch AirDrop geht), Sound funktioniert und kann auch über die Funktionstasten gesteuert werden. Mikrofon geht auch.

      Was fehlt noch:
      A. Problem Grafik
      Wie auf dem Bild zu sehen, wird die Grafikkarte zwar richtig erkannt, jedoch nur mit 7 MB.

      Um das Problem zu lösen, habe ich zunächst noch einmal die BIos-Einstellungen überprüft. Anschließend verschiedene Einstellungen in der Config probiert (Grafik-ID und Plattform-ID) verschiedne Werte getestet. Aber es blieb stets dabei. Weder die Bezeichnung der Grafik noch die 7 MB ließen sich durch irgendetwas beeindrucken. Hier bin ich für Hinweise dankbar:

      B. Problem Hintergrundbeleuchtung
      Hier bin ich noch nicht dazu gekommen, nach Lösungen zu suchen. Zu erst wollte ich das Grafikproblem lösen.

      C. Problem Touchpad
      Hier muss ich noch ran, derzeit funktioniert es nur wie eine Mouse (Mousezeiger und Klick). Ob hier allerdings eine Gestensteuerung möglich ist, muss ich noch recherchieren.

      D. Sleep-Modus
      An dieses Thema gehe ich am Schluss, wenn alles andere läuft. Das Display wird jedoch beim Zuklappen abgeschaltet, dennoch denke ich, dass ich hier noch mal ran muss.

      E. Batterieanzeige funktioniert noch nicht.


    Für Vorschläge und die letzten Punkte noch in den Griff zu bekommen, danke ich schon jetzt.

    Images

    Files

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert OS Catalina und Windows10 Dualboot

    bis auf WLAN scheint alles zu laufen. Vielen Dank für all Eure Beiträge und Downloads! :)


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover


    Mein derzeitiges Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-62016, 16 GB DDR-4, WLAN-Karte DW-1830, Clover (in Arbeit)

    Edited once, last by RenStad ().