Maus und Tastatur friert ein + kein Ton

  • Hallo


    Ich habe meinen Hackintosh nun seit einigen Wochen im Betrieb und bin eigentlich ziemlich zufrieden.

    Bis auf ein Problem, welches immer wieder auftritt:


    Wenn ich einige Sekunden lang keine Aktion ausführe, beispielsweise ein Video bei youtube schaue, friert nach einiger Zeit die Maus und die Tastatur ein.

    Zusätzlich verabschiedet sich die Tonausgabe meines Hackintosh.


    Ich konnte das ganze bisher noch nicht nachstellen, bzw. provozieren, es tritt einfach immer wieder auf in Phasen in denen ich keine Aktion ausführe.

    Da ich einen externen DAC per USB für die Tonausgabe verwende, gehe ich fast davon aus, das die USB-Ports in eine Art Sleep fallen, sobald ich die Maus einige Zeit nicht mehr bewege.


    Ich habe mir dann schon sämtliche Logs in der Konsole angeschaut, konnte aber kein Event finden, welches während diesem Zeitpunkt aufgetreten ist.


    Das Interessanteste dabei ist, das Mac OS ganz normal weiterläuft, das youtube Video wird beispielsweise einfach weiter wiedergegeben, nur ohne Ton. In der Statusbar sehe ich zudem auch die Uhrzeit die sich weiterhin aktualisiert. Es scheint also nicht den ganzen Hackintosh einzufrieren, nur irgendwie alle USB-Ports.


    Habt ihr einen Tipp für mich, wie ich dieses Problem lösen kann?


    Viele Grüsse


    Edit:

    Was mir noch auffällt, wenn ich den Hackintosh dann hard-reboote tritt das Problem nicht mehr auf. Es tritt aktuell nur auf, wenn ich den Hack in den Ruhezustand versetze und ihn dann nach einigen Minunten oder Stunden wieder wecke. Dann arbeite ich ganz normal weiter und sobald ich längere Zeit keine Eingabe mache, frieren die USB-Ports ein.

  • Wenn möglich, versuche doch mal mit der internen Audio zu arbeiten, wie sieht es dann aus?

    Bitte hänge mal deine EFI hier noch an.

  • Ich gehe hierbei davon aus das die USBPorts nicht richtig konfiguriert sind. Das Entscheidende Detail ist die Aussage das das Problem nur auftritt wenn der Rechner vorher im Ruhezustand war. Beim eintreten in den Ruhezustand werden unter anderem auch die Powerlevel für USB verändert (nicht als intern deklarierte Ports werden abgeschaltet usw.) verlässt man den Ruhezustand wieder wachen quasi auch die USB Ports wieder auf aber eben so wie es im ACPI definiert ist oder eben auch nicht (EC Device). Es empfielt sich an der Stelle dringen die USBPorts korrekt zu definieren und hierzu mal das Hackintool zu bemühen ;)