Lenovo ThinkPad L13 Yoga Catalina Installation

  • Hallo,

    ich wollte mal fragen, wie es mit dem der Hackintosh Kompatibilität aussieht beim Lenovo Yoga L13. Konnte noch nichts dazu finden, das Notebook ist ja recht neu.

    Verbaut ist in dem Notebook ein i5 bzw. i7 der 10. Generation, wlan ist mir klar, das wird nicht funktionieren, da eine Intel Karte verbaut ist, diese kann man ja aber tauschen.


    Hoffe mir kann jemand helfen :)

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Hat inzwischen jemand mit dem Modell Erfahrung?

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Okay, das hört sich interessant an, ich habe das Gerät derzeit noch nicht, war eben am Überlegen...

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Von den Spezifikationen her sollte sich das recht gut zu einem Hackbook machen lassen zumindest ist da auf den ersten Blick erstmal nichts drin was das Vorhaben verhindern würde ;)

    Als Booter würde ich in dem Fall direkt auf OpenCore setzen und gar nicht erst mit Clover anfangen man wird vermutlich ein wenig Arbeit und Hirnschmalz reinstecken müssen aber gehen sollte es...

  • Das Gerät hat wohl eine Bios Wlan Whitelist... Da müsste man sich wohl noch was einfallen lassen. Verbaut ist nämlich eine Intel 9560ngw Karte.

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Jemand eine Idee wegen der BIOS Whitelist, Bzw. gibt es einer Karte die eventuell unterstützt wird? Finde leider nichts dazu.

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

    Edited once, last by Timk ().

  • Habe nun mal versucht Catalina zu installieren, leider will Clover nicht so recht, es erscheint immer: AMF: ONLY 94/256 SLIDE VALUES ARE USABLE, bin gerade noch am Probieren von anderen Memory Fixes... Denke aber OpenCore wäre sowieso besser, kann mir da jemand einen Tipp geben, wie ich am Besten vorgehen soll bei OpenCore? Habe damit noch nichts gemacht, finde auch recht wenig zu meiner Hardware.

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Habe nun den Stick erstellt, und versucht zu booten. Komme auch in OpenCore bis zur Bootauswahl, leider zeigt er mir danach nur noch einen schwarzen Bildschirm und es passiert nichts...

    Zuletzt steht im OC Log auf dem Stick nur: failed to match a default boot option

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Lade mal die EFI hoch damit man sich das man angucken kann :)

  • griven Ist im Anhang.

    Files

    • EFI.zip

      (2.01 MB, downloaded 35 times, last: )

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

    Edited once, last by Timk ().

  • Sieht soweit für mich okay aus. Ich habe ein paar Kleinigkeiten ergänzt teste mal so: EFI.zip

  • griven Gerade probiert, leider gleiches Problem - schwarzer Bildschirm nach der Bootauswahl.

    Im Bios ist alles deaktiviert was geht, sprich Secure-Boot, TPM... lediglich den Grafikspeicher konnte ich nur auf 256mb setzen, geringer geht nicht.


    Nativ wird ja die 10. Generation von Intel (Comet Lake) noch nicht bei macOS unterstützt soweit ich weiß. Ich habe nun bei OpenCore die Config für Coffee Lake nehmen müssen, eventuell ist die nicht kompatibel und deswegen mag er nicht hochfahren...


    Hat jemand noch eine Idee, was ich probieren könnte?


    Edit: Hatte nicht die neuste Catalina Version, ist mir aufgefallen, nach dem Erstellen des Sticks mit der Neusten erhalte ich folgenden Fehler

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

    Edited 4 times, last by Timk ().

  • Timk

    Changed the title of the thread from “Lenovo ThinkPad L13 Yoga Kompatibilität” to “Lenovo ThinkPad L13 Yoga Catalina Installation”.
  • Puh was immer da passiert passiert ja eigentlich schon bevor der Kernel (boot.efi) überhaupt richtig gestartet wurde sprich der Fehler und/oder das Problem muss irgendwo in oder um OpenCore liegen. Wenn Du im Bios den Möglichkeit dazu hast dann schalte mal den CSM Mode aus sofern eingeschaltet oder ein sofern ausgeschaltet ich hatte damit einige Probleme auf dem Yoga S1 im Zusammenspiel mit der neuesten OpenCore Version (btw. welche Version von OpenCore nutzt Du und wo hast Du die binares her genommen)?

  • btw. welche Version von OpenCore nutzt Du und wo hast Du die binares her genommen

    https://github.com/acidanthera/OpenCorePkg

    mit dem macbuild.tool habe ich dann das Ganze erstellt.

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI

  • Okay dann kann es wirklich ein CSM Thema sein in dem Fall bitte peinlich genau darauf achten das der CSM Mode im Bios deaktiviert ist oder unbedingt die NOOPT Variante verwenden (in dem Fall darf CSM aktiv bleiben).

  • CSM ist deaktiviert (Gleiches Fehlerbild wenn es aktiviert ist), wie gehe ich denn vor bei der NOOPT Variante? Sagt mir gerade gar nichts.

    Ich habe gerade gelesen, dass Comet Lake unter Catalina 10.15.4 (ist auf dem Stick) wohl doch schon Support erhalten hat, also kann das ja eigentlich auch nicht das Problem sein.

    System #1: MSI x58 Pro-E, Xeon E5649 @4 Ghz, 16GB DDR3 RAM, Radeon R9 290 Gaming, 250GB SSD, 1TB HDD, Windows 10 Pro

    System #2: Lenovo ThinkPad L13 Yoga, Intel i7-10510U, 16GB DDR4, 512GB NVME SSD, Windows 10 Pro

    System #3: Mini-PC, i5-4350U, 8GB DDR3 RAM, 64GB SSD SanDisk, macOS Mojave @ Clover UEFI