GC-Titan Ridge nach Firmware-Update ohne Hotplug funktionslos

  • Hallo zusammen,


    ich wollte es nochmal hier probieren, bevor ich es ganz aufgebe…
    Ich habe bisher mein Promise Pegasus R4 RAID, dank GC-Titan-Ridge an meinen Windows PC mit Asrock X399 Taichi(Bios 3.80) und AMD Threadripper 2950X schließen können. Da kein Hotplug funktioniert, war stets ein Neustart nötig, damit es nicht nur in der Thunderbolt-Software, sondern auch im Windows Geräte-Manager zu sehen war, aber das ist ja nicht weiter schlimm. Auch eine EGPU(Sonnet eGFX Breakaway Box 550 mit RTX 2070) konnte ich auf diese Weise verbinden.
    Nun hatte ich letztens mal das Thunderbolt FW Update Tool von der Gigabyte Seite ( https://www.gigabyte.com/Mothe…upport#support-dl-utility ) ausgeführt, um anschließend festzustellen, dass der Warmboot-Trick jetzt leider nicht mehr funktioniert. L Es hatte die NVM-Firmware von 23 auf 43 geupdatet. Wie zu erwarten kommt bei Gigabyte-Support anfrage nur folgende Antwort: “Verifiziertes Team hat geantwortet, es gibt keine alte Version des FW-Tools, das dem Benutzer zur Verfügung gestellt werden kann.”

    Das RAID hat eine Status LED, die nach dem Anschließen nach gewisser Zeit Blau leuchtet. Früher ist diese LED bei einem Neustart konstant Blau geblieben. Inzwischen wird sie aber immer kurz vor dem Ausschalten rot, also wird es wohl heruntergefahren.

    Ich habe schon folgendes probiert:

    - PCIe-Slots geändert
    - USB Header- und Netzteil- Kabel an/abgesteckt ( THB-C gibt’s bei mir nicht)
    - Thunderbolt Header-Trick ( https://www.warp2search.at/forum/attachments/phbt-png.7771/ )
    - mehrmals geflasht, falls Flashvorgang fehlerhaft
    - verschiedene Geräte angeschlossen: EGPU, Thunderbolt-Dock, RAID, Apollo Twin duo
    - auch mit Daisy chain
    - BIOS Reset


    Thunderbolt-Bridge Netzwerk funktioniert übrigens noch (auch über Daisy chain vom RAID) und USB-Geräte wurden noch nie erkannt.
    Es gibt nicht zufällig jemand, der seine Gigabyte GC-Titan-Ridge noch nicht geupdatet hat und weiß wie man den Flash ausliest, um so ein altes Firmware-Image zu erstellen, oder?
    Oder ganz absurd: Ich schicke jemandem, dessen Titan-Ridge noch eine alte Firmware hat, meine zu. Die Person checkt, ob sie bei sich geht und schickt mir seine zu. Ich würde dann anschließend auch mal schauen, ob ich die Firmware irgendwie auslesen kann. Porto und Arbeitsaufwand zahle natürlich ich.

    Wie man an den letzten Kommentaren in diesem Link sieht, geht es übrigens nicht nur mir so:
    https://forum.level1techs.com/…h-thunderbolt-3/143615/39

  • Mit einer alten Firmware kann ich nicht helfen, obwohl ich auch diese Karte nutze. Aber speziell zu den Promise Raids vielleicht eine Info, möglicherweise betrifft es aber nur Intel-Systeme:


    Mein System, siehe Signatur, nutzt auch diese Karte. Via SSDT (eingebettet in die ACPI durch Bootloader Clover oder OpenCore) funktioniert auch Hot-Plug. In wie weit das auch eine Relevanz für ein AMD-System ohne TB-Header und BIOS-Einstellungen zur Karte haben kann, weiß ich nicht. Auch betreibe ich ausschliesslich macOS.

    Ich nutze ebenfalls Promise RAIDs (Pegasus2 R6 und Pegasus2 R8 über original Apple TB3->TB2 Adapter). Durch HotPlug lässt es sich beliebig während der Laufzeit anschliessen und mounten. Das Problem: Ich konnte mein System nicht mit angeschlossenem und eingeschalteten RAID starten. Das hatte auch nichts mit macOS oder Windows oder Bootloader Clover oder OpenCore zu tun, schon in der BIOS-Bootphase blieb der Rechner ohne weitere Infos einfach stecken. Sobald das ASUS-Logo erschien (was normalerweise etwa drei Sekunden zu sehen ist) hing der Rechner. Nichts zu machen. Hätte ich kein Hotplug, hätte ich die RAIDs nie anschließen können, das wäre bitter gewesen.

    Seit einiger Zeit fahre ich eine hundertprozentige Lösung für dieses Problem, ein anderer Forenteilnehmer machte mich darauf aufmerksam. Normalerweise wird hier von einer reinen UEFI-Lösung ausgegangen, CSM (Compatibility Support Module, BIOS-Emulation innerhalb des UEFI-Standards) ist verpönt. Dieser lässt sich aber vielfältig einstellen und die hauptsächlichen Sachen weiterhin via UEFI erledigen. Meine Einstellungen dazu sehen so aus, damit funktioniert der Start auch reibungslos:


    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Mal nachgeforscht, was in diesem Archive vorhanden ist?


    https://www.gigabyte.com/Mothe…upport#support-dl-utility

  • floris

    leider Alpine Ridge, nicht Titan Ridge …


    Es gibt keine weiteres von Gigabyte veröffentlichte Firmware zu diesem Controller. Es gab einen Auslieferungszustand, und nun ein Update.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Zudem werden die Karten schon lange mit Version 43 ausgeliefert.


    Da musst du schon sehr viel Glück haben, dass die jemand noch auf der alten Firmware hat.

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.3 (19D76)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.3 (19D76)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Vielleicht hier, vom Intel Mirror im Release Note

    Code
    1. [...] JHL7540/7340 Series - "Titan Ridge" [...]


    Die Files innerhalb des Zips Juni 2018


    https://downloadmirror.intel.c…ase_Notes_17.4.77.400.txt


    https://downloadmirror.intel.c…_WIN10_64_17.4.77.400.zip

  • Was hat die Software Version jetzt mit der Firmware zu tun?

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.3 (19D76)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.3 (19D76)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Ein Strohalm, aber eventuell ist das die Firmware enthalten ....

  • Na eben nicht, deshalb ja auch meine Frage, was er damit soll?!

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.3 (19D76)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.3 (19D76)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Da hilft wohl nur ein Firmware-Dump von einer anderen Karte welche noch die alte Version hat. Per Soft oder Hardware.


    PS: Welchen Chip haben die eigentlich drauf die TB_Karten?

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Ich hätte da noch den Alten stand...
    Aber weiss nicht wie ich den auslesen könnte :-)


    Gruss Coban



    EDIT: Spielte mit dem Gedanken das eventuell der Firmware Update Tool vom GigaByte mit einem Argument oder so abspeichern könnte aber will jetzt im moment nicht riskieren und doch noch Updaten, vielleicht kann ja einer von euch mit dem tool experimentieren und den dazu bewegen?
    Board Bios Updater bieten ja fast alle sowas an...

    MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Clover aktuell | macOS Mojave 10.14 / Windows 10 Pro / Ubuntu 18.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

    Edited once, last by cobanramo ().

  • Würde ich Dir nicht auf blauen Dunst empfehlen... ich werde heute abends mal schauen können was da möglich wäre.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Könnte drauf wetten das der FlashTBT.exe mit einem passenden Slash/Argument das kann aber eben raten ist nicht wissen... :-)


    MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Clover aktuell | macOS Mojave 10.14 / Windows 10 Pro / Ubuntu 18.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • eventuell mal mit /help oder /? oder /hilfe ausführen und sehen ob der irgendwelche Argumente ausgibt


    Ist da eventuell die Möglichkeit den Firmwarechip mit nem Clip auszulesen?

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Naja, hab mal zur Sicherheit den Firmware .bin entfernt und mit allem möglichen Kombinationen die mir einfällt probiert... nix nada...


    Vielleicht unterstützt das Tool wirklich keine Parameter oder muss über dem config.ini die beiliegt erfolgen.

    Ne anfrage an Gigabyte Support wäre sicher auch nicht verkehrt.


    Bekomme außer diesen bin Auswahl Fenster nichts anderes...


    Scheint müsste ich wirklich so ne USB Flasher besorgen und damit das auslesen so wie DSM2 das hingewiesen hat.


    Gruss Coban

    MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Clover aktuell | macOS Mojave 10.14 / Windows 10 Pro / Ubuntu 18.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Viel Spaß mit dem Gigabyte Support... Ich kann dir sagen das da nichts kommen wird.


    Flasher besorgen und auslesen, mehr bleibt da nicht.

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.3 (19D76)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.3 (19D76)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Wow, cool wie ihr euch ins Zeug legt.

    Genau, dieses FlashTBT zeigt dann bei Status einfach nur die aktuelle und die zuinstallierende NVM Version an. Und den Support hatte ich ja schon kontaktiert. Die wollen die alte Firmware nicht rausgeben.

    Was den Chip angeht, steht ja bei den Spezifikationen Intel® DSL7540 Thunderbolt™ 3 controller. Dazu finde ich aber auch nix.

    Ich muss mich generell erstmal noch etwas informieren, kenne mich auf dem Gebiet überhaupt nicht aus.

  • Das die den alten Firmware nicht rausgeben wollen kann ich verstehen.

    Man könnte vielleicht versuchen zu erfahren ob man mit diesem FlashTBT Tool einen "Backup" von vorhandener Firmware erstellen kann.

    Denke wenn man so auf die art die kommt ist es eher möglich von denen was zu erfahren.


    Gruss Coban

    MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Clover aktuell | macOS Mojave 10.14 / Windows 10 Pro / Ubuntu 18.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Ich kann dir aus Erfahrung sagen, dass der Support alles andere als Ahnung hat und die welche Ahnung haben stellen sich quer.


    Ich bin seit Monaten in Kontakt mit Gigabyte und gebracht hat es mir noch gar nichts, ausser graue Haare, Kopfschmerzen sowie Wutanfälle. Meine Situation mit Asus beim Dominus war dagegen Kindergarten.


    cobanramo

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.3 (19D76)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.3 (19D76)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!