Vega 64 DisplayPort Probleme

  • Gut, damit greifen die Boot Args also nach wie vor nicht, auch auf einem Hackintosh nicht. Hoffen wir mal dass die WEG Entwickler das noch in den Griff bekommen.

    LG Chris


    Meine Hardware:

  • Oder hätte ich die beiden .kexts mal in S/L/E reintun sollen anstatt in die EFI?

  • Nein nicht nötig. Muss in der EFI funktionieren. Bei echten Macs läuft es auch nicht in L/E oder S/L/E.

    LG Chris


    Meine Hardware:

  • Ok, dann erstmal danke dir und wir müssen jetzt mal abwarten oder? Warum haben denn irgendwie nur so wenige das Problem?

    Mit High Sierra hatte ich dieses Problem nicht.

  • Von welchem Problem redest du denn nun genau?

    LG Chris


    Meine Hardware:

  • Von der fehlenden Hardwarebeschleunigung und dem DRM, da war das mit skiki.kext getan

  • Komme nicht mit, welche fehlende Hardware Beschleunigung? Funktioniert doch alles. Und DRM mit IGPU hat noch nie funktioniert.

    LG Chris


    Meine Hardware:

  • CMMChris

    Nur damit ich es richtig verstehe "

    "So ich habe eine Rückmeldung bekommen. Anscheinend soll der iMacPro1,1 Board-ID Spoof in einem anderen SMBIOS nun mit shikigva=160 und shiki-id=Mac-7BA5B2D9E42DDD94 funktionieren. Wenn du magst kannst du das mal ausprobieren und testen ob dann sowohl DRM über die AMD Karte als auch Sidecar über die IGPU läuft."

    So bald dieser fix wirklich funktioniert wird man im IMAcPro 1.1 die IGPU einschalten müssen und mit der von dir beschriebenen Lösung auch theoretisch Sidecar nutzen können?

    PowerMac G5 ATX Umbau

    Klick

  • Quote from CMMChris

    iMacPro1,1 Board-ID Spoof in einem anderen SMBIOS

    Quote from Achilles31

    … wird man im IMAcPro 1.1 …

    Nein, anderes SMBIOS. Also ungleich iMacPro. Denn im iMacPro gibt es keine IGPU. Aber mit beispielsweise iMac18.3 SMBIOS wird zusätzlich die iMacPro-ID (7BA5B2D9E42DDD94) verwendet inkl. shikivga …

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Nein du würfelst hier diverse Dinge durcheinander. Ich fasse nochmal alles möglichst verständlich für dich zusammen. Du hattest folgende Anfragen:

    A) Nicht alle Grafikausgänge funktionieren

    B) Du willst gerne Sidecar nutzen


    A) Haben wir ja durch den Black Screen Patch gelöst. Hierzu ein paar Hintergründe und Grundlagen.
    Verantwortlich für das Deaktivieren von Grafikausgängen ist der Treiber "AppleGraphicsDevicePolicy" (AGDP). In diesem sind für gewisse Macs per entsprechender Board-ID Konfigurationen hinterlegt, welche zu diesem Verhalten führen. Um das zu unterbinden gibt es zwei verschiedene Ansätze per Kext Patch. Einmal das Umbenennen von "board-id" zu "board-ix", wodurch die Prüfung von AGDP ins Leere läuft und der Treiber zum Schluss kommt, dass keine "Policy" nötig ist. Entsprechend laufen dann alle Ausgänge. Ein anderer Patch Ansatz verhindert das Laden von AGDP komplett.


    Wenn man Whatevergreen nutzt, sorgt diese Kext in der Regel automatisch für das Ausführen dieser Patches. By default nutzt Whatevergreen die zuletzt genannte Methode, blockiert AGDP also komplett. Steuern kann man die Art des von Whatevergreen ausgeführten Patches über das "agdpmod" Boot Arg. agdpmod=pikera ist der Black Screen Patch bzw. board-id Patch den du in deine Config gesetzt hast. agdpmod=vit9696 dagegen ist der Patch der das Laden von AGDP unterbindet.


    Es empfiehlt sich übrigens auch bei Nutzung von Whatevergreen den Black Screen Patch im Kexts2Patch Bereich seiner Config zu behalten. Speziell bei macOS Updates kann es Situationen geben in denen Whatevergreen nicht vollumfänglich greift. Ohne den zusätzlichen Kext2Patch hat man dann unter Umständen einen schwarzen Bildschirm in der zweiten Phase während System Updates.


    B) Sidecar ist eine verzwickte Geschichte. Grundsätzlich geht Sidecar auf einem Hackintosh nur über die IGPU und damit auch nur mit einem SMBIOS das die IGPU für das hardware-beschleunigte Encoding und Decoding von H.264 und H.265 alias HEVC nutzt. Auf Macs ohne IGPU welche den T2 Chip nutzen, setzt Apple diesen fürs Encoding des Sidecar Video Streams ein. Entsprechend ist Sidecar auf einem Hackintosh der als iMacPro1,1 oder MacPro7,1 läuft nicht funktionsfähig, da hier natürlich der T2 Chip fehlt. Ein automatischer Fallback auf andere Encoder findet leider nicht statt.


    Genau das ist aber ein Problem, da sämtliche Nutzer von AMD Polaris, Vega10, Vega20 oder Navi10 bevorzugt das iMacPro1,1 oder MacPro7,1 SMBIOS nutzen. Der Grund dafür ist wiederum, dass hier für das Encoding und Decoding (abseits von Sidecar) von H.264 sowie H.265 Material die dedizierte Grafikkarte genutzt wird. Diese bieten in der Regel eine bessere Encoding Performance als die IGPU, was zum Beispiel beim Videoschnitt im Export von Vorteil ist. Ein weiterer Grund ist das Thema DRM. Die Wiedergabe von DRM Geschützten Inhalten per Streaming von iTunes bzw. den Nachfolge-Apps oder in Safari auf Netflix oder Amazon Prime (FairPlay DRM) läuft nur wenn die AMD GPU dekodiert. Sobald die IGPU am Start ist, funktioniert die Wiedergabe nicht, wie du ja bereits am eigenen Leib erfahren hast.


    Das ganze bringt einen nun in eine Zwickmühle: Entweder man nutzt ein SMBIOS wie iMac18,3 in welchem nur die IGPU zur Videobeschleunigung angesteuert wird. Hier kommt man in den Genuss von Sidecar, muss allerdings auf eventuelle Performance Vorteile der AMD Videobeschleunigung und natürlich auch FairPlay DRM verzichten. Oder man nutzt das iMacPro1,1 / MacPro7,1 SMBIOS, hat dann funktionierendes FairPlay DRM und eventuelle Performance Vorteile bei der Videoverarbeitung, muss dafür jedoch auf Sidecar verzichten.


    Eine Möglichkeit beide Welten miteinander zu verschmelzen sind die Boot-Args um die es hier zuletzt ging. Diese bringen Whatevergreen dazu, der AppleGVA (dieses Framework ist für die Steuerung von Encoding / Decoding beim Rendern und Abspielen von Videoinhalten zuständig und steuert welche Hardware genutzt wird) ein anderes SMBIOS unterzujubeln als tatsächlich aktiv ist - in diesem Fall würde AppleGVA denken sie läuft auf einem iMacPro1,1, während du tatsächlich das iMac18,3 SMBIOS nutzt. Sidecar selbst bleibt davon unberührt. Entsprechend könntest du Sidecar nutzen und gleichzeitig würde die AMD Karte fürs Dekodieren und Enkodieren vom Videos genutzt werden, was dir eventuell Performance Vorteile und auch funktionierendes FairPlay DRM bringen würde.


    Das Problem an der Sache ist nun, dass dieser Spoof aktuell nicht funktionieren will. Früher lief das ganze aber definitiv mal, wurde hier auch von einigen Nutzern eingesetzt. Nun sind also die Entwickler von Whatevergreen am Zug das ganze zu fixen.

    LG Chris


    Meine Hardware:

  • CMMChris <3 Dankeschön

    PowerMac G5 ATX Umbau

    Klick

  • Oh, ich dachte eben ich antworte sir_daniel. Nicht gesehen dass sich hier ein anderer User eingeschlichen hat. Naja, hat dir wohl auch weitergeholfen. :)

    LG Chris


    Meine Hardware:

  • Oh Chris wow, vielen vielen Dank! :)
    Auch wenn das vielleicht gar nicht für mich war, so habe ich das Ganze definitiv verstanden. Danke für diese ausführlichen Infos! Wenn du aus München wärst, würd ich dich mal aufn Kaffee einladen... So muss dir mein Danke reichen! :D


    Cheers, dann warten wir mal ab was das WEG-Team so zaubert.

  • Doch war im Grunde an dich gerichtet. Ich habe nicht bemerkt dass Post Nummer 28 nicht von dir kam ;)

    LG Chris


    Meine Hardware:

  • sir_daniel Kannst du bitte mal im iMac18,3 SMBIOS das Bootflag shikigva=16 setzen ohne das shiki-id Bootflag. Laut vit9696 soll das funktionieren.

    Danach Reboot und Netflix in Safari testen.

    LG Chris


    Meine Hardware:

  • Hallo,

    nein leider keine Verbesserung/Veränderung! :(

  • Ah hättest du gar nicht testen müssen. Kann gar nicht funktionieren weil das shikigva=16 in Bezug auf das Problem gar keinen Sinn ergibt. Hatte verpennt dir deshalb bescheid zu geben.


    Noch was für alle die ebenfalls unter dem nicht funktionierenden Board-ID Spoofing in Catalina leiden: Ich werde mich bezüglich dieser Problematik nicht weiter engagieren. Ich habe mein bestes getan viele Leute testen zu lassen und versucht die WEG Entwickler darauf hinzuweisen. Offenbar will man aber nicht einsehen dass es hier ein Problem gibt und für mich fühlt es sich an als würde ich gegen eine Wand reden.


    Ganz ehrlich, ich habe besseres zu tun als da meine Zeit zu verschwenden. Wer meinen Ärger nachvollziehen will kann sich den WEG Support Topic ab hier bis zu meinem Post am 30. November gönnen.


    Sollte jemand die Muse haben in der Sache weiter zu vermitteln, nur zu. Gibt ja sehr viele Leute die überglücklich wären wenn das Board-ID Spoofing für AppleGVA wieder laufen würde.

    LG Chris


    Meine Hardware: