Catalina auf Ryzen 5 3600, B450M, RX580 - Probleme mit OsxAptioFix

  • Hallo,


    ich versuche mich an meinem allerersten Hackintosh Installation (Catalina), also seid bitte gnädig ;)


    Ich habe mich an den Installationsguide hier im AMD-Installation-Unterforum gehalten (HOWTO: RYZEN – EL CAPITAN - CATALINA von ralf.). Leider komme ich direkt am Anfang nicht mehr weiter.


    Zunächst Bios-Einstellungen: UEFI aktiv, SVM enabled, Serial und Parallelport disabled, XHCI Hand-off und Legacy USB Support enabled


    Dann den Stick unter GUID formatiert (Ein mit MBR formatierter Stick bootet beim Zielrechner überhaupt nicht) und dann mit Clover Configurator die EFI-Partition gemountet und mit Clover v2.5k r5098 Clover installiert, dann die Plist mit der aus dem oben genannten Thread überschrieben und mit Clover Configurator eine neue Seriennummer erzeugt und gespeichert.


    Dann habe ich wie im Thread beschrieben die genannten kext Dateien in den /EFI/CLOVER/kexts kopiert und in EFI/CLOVER/drivers/UEFI habe ich dann die im Thread genannte OsxAptioFix2Drv-free2000.efi kopiert. Damit konnte ich bis in die Installation booten und diese blieb dann bei dem Stand hängen den ihr in Bild 1 seht. Dann habe ich diese Datei einfach mal gelöscht und bekam nur eine Kreuzreihe ohne irgend einen Text. Dann habe ich als nächstes OsxAptioFix3Drv.efi ausprobiert und bekam Bild 2 als Antwort an der gleichen Stelle.


    Irgendjemand eine Idee was das weitere korrekte Vorgehen wäre? Bzw. was ich für meine Hardwarekonfiguration evtl besser machen könnte?


    Die EFI Datei habe ich gezippt in den Anhang geladen.


    Danke schon mal an die Wissenden!

  • :welcome:


    teste es mal hiermit

    Files

    • config.plist

      (26.96 kB, downloaded 20 times, last: )
  • Hi, danke!


    Leider ändert das nichts, außer, dass in Bild 2 alles unterhalb inkl. der der ERROR Zeile verschwindet

    AMD Ryzen 5 3600 - MSI B450M Mortar Max - MSI RX580 8GB - SSD - 32GB G.Skill RipJaws V DDR4-3200 - 960GB Corsair Force Series MP510 M.2 2280 PCIe 3.0 x4 NVMe

  • Hast du bereits die 10.15.1 geladen? Steht in dern Info.plist im Installer-Paket.

    Da gibt es für Clover noch keine Kernel-Patches. Jedenfalls sind keine veröffentlicht worden. Sonst würde ich erst Mojave oder High Sierra installieren.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Ich glaube nicht, die info.plist sieht bei mir so aus:


    AMD Ryzen 5 3600 - MSI B450M Mortar Max - MSI RX580 8GB - SSD - 32GB G.Skill RipJaws V DDR4-3200 - 960GB Corsair Force Series MP510 M.2 2280 PCIe 3.0 x4 NVMe

  • Doch das ist die 10.15.1.


    Du könntest den probieren

    Files

    • EFI.zip

      (1.69 MB, downloaded 56 times, last: )

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Wow vielen Dank,


    das ging schon mal deutlich weiter!


    Leider scheint VirtualSMC Probleme zu machen, ich bekomme diese Fehlermeldung. Liegt das an den genannten fehlenden Kernelpatches?

    Images

    AMD Ryzen 5 3600 - MSI B450M Mortar Max - MSI RX580 8GB - SSD - 32GB G.Skill RipJaws V DDR4-3200 - 960GB Corsair Force Series MP510 M.2 2280 PCIe 3.0 x4 NVMe

  • Nein, dann wäre es nicht so weit gebootet.

    das ist OpenCore. Das ist ein anderer, ein RTC Fehler. Da gabs mal ein fixup. müsste ich mal schauen. Falls das hier gerade ein OpenCore-Experte liest...

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Kurze Zwischenfrage ralf. , sind das diese neuen Patches, die das BitMask-Feature nutzen? Versuche schon den ganzen Abend die zum Laufen zu bewegen, allerdings unter Clover...

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Nein, OpenCore. Es scheint so dass AMDHacking mit OpenCore weiter geht, und Clover irgendwie vernachlässigt wird.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Ja hab ich gelesen, Clover hat das Feature aber seit r5095 auch, und es gibt auch eine passende patches.plist (aber nur auf amd-osx.com). Funzt aber nicht.

    Hab mir die EFI angesehen, das sind wieder andere Patches, gibts da ne Quelle für?

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Ich hab jetzt mal einfach aus dem Forum einen EFI runtergeladen, und ein bisschen von unötigen Dateien bereinigt. Das ist für mich auch alles recht neu.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Okay, alles klar. Dann muss ich mich da auch mal einlesen.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • @DocSavage

    Probier mal einen anderen USB-Port


    EDIT

    Auf dem Zen1 läuft es. Den anderen teste ich später mal


    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

    Edited 3 times, last by ralf. ().

  • DocSavage Catalina 10.15.1 beta 3 19B86 wird wohl nicht klappen mit dem AMD Patch.

    Entweder du sucht hier nach 19A583 oder 19A602 oder wartest bis die 19B88 unterstützt wird.


    Hier hast du dann aber schon mal einen passenden Ordner der schon für die System funktioniert mit den Patch Versionen 19A583 und 19A602.

    Files

    • EFI.zip

      (4.08 MB, downloaded 17 times, last: )
  • @DocSavage

    Probier mal einen anderen USB-Port


    Moin Ralf,


    je nachdem, in welchen USB-Port ich den Stick einstecke verändert sich die Fehlermeldung.


    Habe zwei rückseitige USB3 und einen rückseitigen USB2 Port zusätzlich ausprobiert und die Fehlermeldung unten angehängt. Der USB-Stick blinkt allerdings dann noch, ich weiß nicht ob es da evtl. noch weiter gehen würde?

    _____________________________________

    edit:

    DocSavage Catalina 10.15.1 beta 3 19B86 wird wohl nicht klappen mit dem AMD Patch.

    Entweder du sucht hier nach 19A583 oder 19A602 oder wartest bis die 19B88 unterstützt wird.


    Hier hast du dann aber schon mal einen passenden Ordner der schon für die System funktioniert mit den Patch Versionen 19A583 und 19A602.

    Deinen Post hatte ich noch gar nicht gesehen, danke! Das werde ich gleich mal, wenn die Zeit dafür ist, probieren. Habe noch eine alte Catalina Installationsdatei gefunden mit der und deinem EFI Ordner sollte es dann ja gehen!

    Ich werde berichten..

  • rubenszy Doch, zumindest die 19B88 müsste klappen. Es sind neue Patches aufgetaucht, die mit Bit Masks arbeiten und somit nicht mehr nur für einen spezifischen Kernel-Build funktionieren, sondern prinzipiell mehrere Builds Patschen können. In anderen Foren gibt es bereits mehrere Systeme die auf 19B88 laufen.

    Versuche das selbst seit gestern, bisher mit mäßigem Erfolg, was aber sich daran liegt, dass diese Methode OpenCore erfordert, mit dem ich noch keine Erfahrung habe.


    Man sieht ja auch dass die Patches gegriffen haben, sonst würde er gar nicht so weit kommen.


    Dennoch ist es natürlich sinnvoll keine Beta zu nehmen DocSavage , mit der 10.15.0 bist du auf der sicheren Seite, das neuere ist auch für uns neu.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Die Updates sind erst seit 4 Tagen draußen, wieso wird nicht mit dem gearbeitet was schon funktioniert, gebt doch den Leuten die daran sitzen auch mal die Zeit, der Rechner funktioniert doch mit der 10.15 Version, wo ist das Problem wenn es mal eine Woche oder zwei dauert bis die Patche vorhanden sind.


    Du meinst doch nicht etwa den Quatsch hier.


    oder meinst du die config.plist


    So bald es nur patche sind, muss OC nicht zwingend erforderlich sein, dafür gibt es Find und Replace, so mit kann man sich sein Clover config selbst patchen.

    Edited 2 times, last by rubenszy ().

  • Ja ich meine die config.plist. Das tolle daran ist doch, dass es eben nicht mehr erforderlich ist, sich seine Clover-Config selbst zu patchen, das macht die Maschine jetzt selbst.

    Schätze mal, dass aktualisierte Patches damit nur noch zwei mal im Jahr nötig sind, zur neuen Major-Version und zu 10.XX.4, da dort meist mehr geändert wird.


    Den Ausschnitt da oben, ja Clover soll das jetzt auch können, aber wenn ich den damit füttere bleibt er komplett hängen (ja, habe r5095 und neuer probiert). Mit Clover taugt das noch nichts. Technisch ist es aber 1 zu 1 das selbe.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • @DocSavage

    Hab hier mal einen geänderten OC-Ordner

    Files

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum