HEVC Exportproblem mit FCPX 10.4.7 Compressor 4.4.5

  • Moin,

    wie der Überschrift zu entnehmen codiert meine Vega 56 momentan leider kein HEVC Format mit Compressor.

    Es dauert unfassbar lange und laut iState nur sehr wenig bis gar keine Last an der Graka.

    Laut VideoProc wird übrigens alles unterstützt.


    Habe ich etwas falsch konfiguriert?


    Im Bios ist die iGPU abgeschaltet.

    Meinen EFI Ordner habe ich mal beigelegt.

    Würde mich sehr über Hilfe freuen.


    Grüße

    Files

    • EFI.zip

      (3.55 MB, downloaded 10 times, last: )

    Edited once, last by Lukaspa ().

  • Wenn VideoProc grün ist funktioniert HEVC Encoding / Decoding, sonst wäre es nicht grün. Dass du keine Last an der Grafikkarte siehst ist normal. Die Lastanzeige von macOS zeigt nur GPU Last an. Die Videobeschleunigung wird dort nicht berücksichtigt.

    LG Chris


    Meine Hardware:

  • kann nur 8it und kein 10bit Hevc.. und im Compressor steht dien Einstellung auf 10 Bit und die 8 Bit sind vermutlich rot ausgegraut [wech]


    Hevc ist allgemein unter OSX und WIN10 in den Applikationen relativ zäh bei finden eines passenden Workflows und selbst Nvidia verspricht in den Specs den jeweiligen Support und hält ihn nicht ein..

  • Moin danke für die Antworten.


    CMMChris

    ich habe mal einen Test mit aktiver iGPU gemacht und dann war mein Videoprojekte nach 18 Minuten gerendert.

    bei deaktivierter iGPU habe ich das rendern nach 30 Minuten abgebrochen, da bis dahin höchstens 5% gerendert wurden.


    ist denn meine Config.plis in Ordnung?

    Ich habe unter ACPI quasi nix mehr an.

    Dafür weg drin.


    motiongroup

    danke für den Hinweis bezüglich 8 und 10 Bit.

    ich render immer in 8 Bit.

  • Welche Version von Compressor benutzt du? 4.4.5 setzt wie FCPX 10.4.7 voll auf Quicksync/T2 (letzteren haben Hackintoshs halt nicht). Mit Davinci Resolve wirst du dagegen einen Ausschlag auf der Vega sehen können.

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1

  • Ah. Ok.
    ja ich benutze Compressor 4.4.5

    Wobei ich noch nicht ganz verstehe was das nun bedeutet.
    stark vereinfacht Ausgedrückt dachte ich, wenn ich den Hacki als MacPro 1.1 konfiguriere, dass dann die Programme auch entsprechend wissen, dass hier quicksync nicht geht, da der orginal Mac dich keine iGPU hat:/ oder habe ich da Denkfehler?

  • Schau mal ob es mit VideoProc schneller geht. Eventuell hat Apple in Compressor auf den T2 umgestellt.

    LG Chris


    Meine Hardware:

  • Lukaspa Der iMac Pro hat auch nen T2, der beim neuen Final Cut / Compressor benutzt wird. Hackintosh-Nutzer haben da Pech. Würde fast vorschlagen auf 10.4.6 und 4.4.4 zu bleiben, wenn man HEVC benutzt.

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1

  • Also zumindest bei H.264 nutzt Final Cut bei mir nach wie vor die AMD Karte.

    LG Chris


    Meine Hardware:

  • Danke für die Denkanstöße. Werde mal alles durchprobieren. Sprich verschiedene Compressorversionen und HEVC mit VideoProc
    melde mich dann nochmal.


    SO...

    CMMChris Also ich habe mal einen Test mit VideoProc gemacht .h264 in HEVC und da macht die GPU auch nicht wirklich Freudensprünge... siehe Bild


    macinsane Des Weiteren habe ich Finale und Compressor auf Version 10.4.6 und 4.4.4 downgegraded und immer noch das Gleiche!

    GPU wird bei HEVC export nicht genutzt.


    Kann sich vielleicht doch noch mal jemand meine EFI bitte ansehen. Bin da auch echt unsicher, ob da alles so stimmt.

    Edited 2 times, last by Lukaspa ().

  • Mit der Umstellung auf Metal und Einbeziehung des T2 hat sich zum Teil Fundamentales geändert. Bei einem Projekt erreicht mit HEVC 25fps mein Original Mac Mini mit der Intel Grafik dieselbe Exportzeit wie mein Hack mit der Vega 64, es ist krass.

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1

  • Lukaspa Lies doch mal was ich weiter oben geschrieben habe. Es ist alles in Ordnung bei dir.

    LG Chris


    Meine Hardware:

  • CMMChris Hi, ok danke dir.

    Ich war nur enttäuscht, dass ich mit Compressor kein HEVC exportieren kann...


    Ich habe deshalb nun ein wenig herumgespielt.

    Meine EFI habe ich so gelassen, also keine ACPI Patches und nur WEG drin.

    Die iGPU wieder eingeschaltet. Und siehe da mit den aktuellen Version von Finale und Compressor habe ich volle Unterstützung beim HEVC Export.



    Bei VideoProc ist auch alles auf grün.

    Bildvorschau und Netflix in Safari geht auch.

  • Aktive IGPU und iMacPro1,1 ist eine schlechte Kombination. Führt zu gelegentlichen Kernel Panics weil die Parameter nicht passen.


    Edit: Habe gerade mal einen neuen Vergleich gemacht mit Catalina. IGPU an oder aus macht keinen Unterschied, weder in der benötigten Zeit noch an der Auslastung der Grafikkarte. Wie gesagt, man sieht die Encoder / Decoder Last nicht in der Lastanzeige. Man sieht aber wenn die IGPU etwas tut und zwar im Intel Power Gadget. Wenn auf der IGPU encodiert oder decodiert wird, wird dort ein Takt angezeigt. In meinen Tests bleibt dieser durchgehend auf 0,00GHz. Wird also nicht angesprochen. So soll es auch sein.


    Würde die Radeon nicht fürs Encoding oder Decoding genutzt werden, so wäre der Test auch gar nicht möglich gewesen.

    LG Chris


    Meine Hardware:

    Edited once, last by CMMChris ().

  • Wenn auf der IGPU encodiert oder decodiert wird, wird dort ein Takt angezeigt. In meinen Tests bleibt dieser durchgehend auf 0,00GHz. Wird also nicht angesprochen. So soll es auch sein.

    So soll es eigentlich nicht sein, auf nem richtigen Mac codiert die IGPU bzw. der T2 bei 10.4.7/4.4.5 mit. Deshalb ist auch das Apple Forum voll mit Leuten, die sich beschweren, dass ihre externe GPU mit der neuesten Version augenscheinlich nichts mehr tut. Kann das bei mir, wie gesagt, auch nachvollziehen. Meine externe Vega macht bei 10.4.7 deutlich weniger als bei 10.4.6, dafür geht die IGPU-Auslastung nach oben. Exportzeiten sind aber deutlich besser geworden.

    Wie gesagt, mein Ryzen iMac Pro mit Vega 64 ist nun nicht mehr schneller als der Mini.

    Betroffen ist bislang nur FCPX. DaVinci dagegen röchelt mit IGPU und benötigt unbedingt die Vega. Vermutlich benutzt Apple allein derzeit diese Variante.

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1

  • So soll es eigentlich nicht sein

    Natürlich soll es so sein. Es ist alles wie immer im iMacPro1,1 SMBIOS. Auch FCPX funktioniert top wie immer.

    Was eGPUs machen interessiert mich herzlich wenig. Hier geht es um eine eingebaute Grafikkarte.

    LG Chris


    Meine Hardware:

  • Ja, auf nem Hack geht es nicht besser. Wir profitieren vom T2 leider nicht.

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1

  • Was würdet ihr denn nun empfehlen, wenn ich Compressor HEVC ausgeben muss.
    welche Konfiguration würde denn am besten passen? Nur die Radeon geht bei mir ja nicht. Auch nicht mit einer älteren Compressorvariante.

  • Nur die Radeon geht bei mir ja nicht. Auch nicht mit einer älteren Compressorvariante.

    Was hast du denn immer mit "die Radeon geht nicht". Natürlich geht sie, sonst könntest du gar nicht erst exportieren. Das HEVC Encoding ist unter macOS sogar noch schneller als unter Windoof im direkten Vergleich mit VideoProc und denselben Files.

    LG Chris


    Meine Hardware:

  • Ganz ruhig. Jemand hat ein Problem und da nützt es wenig, ihm zu sagen, dass er keines hat. Lukaspa Lad noch mal deine EFI hoch, die du jetzt gerade verwendest und ich schau drauf. Mit „geht nicht“ meinst du „langsam“ oder gar nicht? Bei FCPX oder Videoproc?

    Ryzen MSI B450-A PRO MAX, Ryzen 3600, 16 GB RAM, ASUS ROG Strix OC Vega 64, macOS 10.14.6 / macOS 10.15

    Intel ASUS B250M-C, Core i5 6400, 32 GB RAM, Sapphire Nitro+ RX 580, macOS 10.15

    Original Mac Mini 2018 (i7 8700, 16 GB RAM, Asrock Phantom Gaming X Vega 56 via Razer Core X), MacBookAir6,1