Feintuning notwendig?

  • Hallo zusammen!


    Das hier ist mein erster Beitrag im Forum und ich komme direkt mit einem Anliegen daher.

    Ich habe jetzt am WE endlich mal den Plan Hackintosh in Angriff genommen.

    Mein Ablauf war, noch unter Windows mit der Virtual Box und High Sierra einen Bootstick für High Sierra zu erstellen.

    Genutzt habe ich dabei UniBeast für den Stick und danach Multibeast für die Treiber usw.


    Generell war das alles eine sehr holprige Geschichte. "Irgendwie" hat es dann am Ende geklappt. Aber das ist auch mein Problem. "Irgendwie"

    Dazu direkt mein Anliegen. Wie kann ich nachprüfen, was noch fehlerhaft ist?

    Eigentlich habe ich meine größten Probleme ausgeräumt. Grafikkarte wird richtig unterstützt, USB, LAN, Audio klappt.

    Ich bin mir aber absolut nicht sicher, ob das so standhaft ist, weil ich diese Probleme immer irgendwie gelöst habe, ohne wirklich zu wissen, was ich da tue. Ich habe herumprobiert und am Ende lief es.


    Zu meinem System:


    Motherboard: Gigabyte Z87X-D3H

    CPU: Intel I5-4670K

    Graka: MSI GTX 970 4GB

    OS: High Sierra 10.13.6 mit den aktuellen Updates


    Kann ich irgendwie nachprüfen, ob das System stabil läuft, ob mit den Treibern/kext's alles richtig ist?



    Ziemlich viel auf einmal. Aber danke schon eimal für eure Hilfe.


    LG

  • Hallo Orakel.

    Test ob dein System an sich stabil läuft kannst du nur mit benchmarks, was aber nur deine CPU, GPU und RAM testet. Ob, wie gut und wie lange deine Anschlüsse etc funktionieren steht in den Sternen, generell gilt aber never change a running System. Solange es also auf deiner jetzigen Clover/macOS Version läuft und du nichts in der Config verstellst, sollte sich auch nicht viel ändern, aber es kann trotzdem immer mal zu Problemen kommen, testen kann man dies aber vorher nicht.


    Eine Notiz noch zu deiner Installationsmethode:

    UniBeast und MultiBeast sind hier im Forum nicht so gerne gesehen, da diese Tools zum Teil ins System eingreifen und nicht ersichtlich ist wie viel sie verändern oder was genau verändert wurde. Es kann also sein, dass du auf manche Probleme keine funktionierende Lösung finden wirst, da Multi- und Unibeast schon zu viel an deinen Daten rumgespielt haben.


    MfG

  • Du wirst hier für deine Installation mit Unibiest und Multibiest keine Unterstützung bekommen. Diese Tools verändern die Installation derart, daß wir Dir nicht helfen können. Hier wird grundsätzlich eine Vanilla-Installation angestrebt, also ein originales macOS - Veränderungen finden ausschließlich in der EFI statt.


    Da Du nun aber schonmal ein einigermaßen laufendes macOS hast, kannst Du dieses dafür nutzen, Dir einen Vanilla-Bootstick zu bauen.

  • Hallo Orakel und willkommen im Forum!

    Das Tonytool ist der Grund für deine Unsicherheit, weshalb hier jeder deine Unsicherheit teilt und Support daher so nicht möglich ist. Lösche es und mach es richtig. Schau in unsere Wikis und verstehe, was eine Vanillainstallation ist und ihre Vorteile.

    iMac Pro 1,1: Catalina, High Sierra, Windows10, BL: Clover 5098, Mainboard: Ga-z97mx Gaming5, CPU: i7-4790K, Ram: 16Gb Crucial Ballistix
    Grafik: Sapphire RX5700 XT Nitro+ 8Gb, SSD: Samsung 970 NVME 500GB, Samsung 850 Evo 500Gb, 2x Samsung 840 Evo 250Gb, HDD: Seagate ST3000DM001 3TB Wifi:
    BCM94360CD Combo (oob), Bluetooth: Gmyle Bt v4.0 (oob), PSU: be quiet! Dark Power Pro11, Case: Jonsbo UMX4

  • Danke für eure Antworten.

    Ja, ich habe gemerkt dass das nicht die perfekte Herangehensweise war. Das fing schon mit widersprüchlichen BIOS Einstellungen an.

    Schade, dass man nicht über irgendwelche Scripts oder Terminal Befehle schauen kann, wo der Hund begraben liegt. Naja, dann wird's am Ende wohl eine neue Installation werden. Ein richtig Originales OSX war ja von Anfang an mein Wunsch.



    LG

  • Hallo und herzlich Willkommen im Forum... :)

    wenn die Kiste schon mal installiert ist, sollte man einfach mal schauen, dass die Tony-Einflüsse entfernt werden.

    Da durch die Beaster Installation einige der Kexte direkt im System, anstatt in der EFI, platziert werden, empfiehlt es sich hier nach einer gewissen Reihenfolge zu gehen.

    Das funktioniert am besten im Systembericht, im Bereich Software, indem du den Punkt "Erweiterungen" anklickst und wartest bis die Liste gefüllt wird.

    Dann klickst du auf die Tabellen-Überschrift "Erhalten von" zweimal, sodass die Sortier-Reihenfolge mit "Verifizierte Entwickler" beginnt.

    Zwischen "Verifizierte Entwickler" und "Apple" wird es eine Reihe von Kexten geben, die mit "Unbekannt" oder "Nicht Signiert" gekennzeichnet sind...


    Bitte erstelle davon ebenfalls einen Screenshot und poste ihn hier, damit wir prüfen können, ob diese überhaupt benötigt, bzw. auch in der EFI abgelegt werden können.


    Auch weiss ich, dass die config.plist der Tony-Tools sehr wenig Details in der SMBIOS-Sektion enthält... das muss dringend behoben werden.


    In Anbetracht deiner Hardware, die du besser auch entweder in deiner Signatur oder deinem Profil, im Bereich "Über mich" einträgst, empfehle ich einen Blick in das EFI-Paket aus Install-Stick für diverse System-Varianten (High Sierra 10.13.6, Mojave 10.14.6 und Catalina 10.15)

    Darin findest du den Ordner "CLOVER-HSW", der ziemlich genau deine Kiste abdecken sollte.

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Oh weh...

    da sträuben sich mir nicht nur die Nackenhaare...

    Da wurde mal wieder mit dem Vorschlaghammer einfach alles rein geprügelt... 🤦🏼‍♂


    Ich würde vorschlagen, dass du die hier aufgeführten Kexte erstmal aus den entsprechenden Ordnern in ein neues Verzeichnis auf deinem Desktop verschiebst und im Nachgang den Kext-Cache per "Werkzeuge" aus dem Kext Updater - Neue Version 3.x reparierst.

    Dann benennst du den EFI-Ordner auf deiner versteckten EFI-Partition zu "EFI-Alt" um und erstellst einen neues "EFI"-Verzeichnis.

    Dahin kopierst du die Unterordner "BOOT" und "CLOVER-HSW" aus dem oben verlinkten EFI-Paket.

    Daraufhin musst du aber dringend den Ordner "CLOVER-HSW" zu "CLOVER" umbenennen, damit dieser auch tatsächlich genutzt werden kann.


    Damit solltest du bereits in der Lage sein, die Kiste neu zu starten und die Tony-Tools erfolgreich in die ewigen Jagdgründe geschickt haben.


    EDIT:
    Eben noch vergessen zu erwähnen...

    Da die überarbeitete AppleHDA ebenfalls verloren geht, muss diese natürlich im Original-Zustand wieder in den Ordner /System/Library/Extensions kopiert werden, bevor per "Werkzeuge" des Kext-Updaters der Kext-Cache neu erstellt wird.

    Der aktuellste Kext liegt hier bei.

    Files

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Okay, da fängts schon an.

    Ich denke mal, dass du die von "unbekannt" und "nicht signiert" meinst. Wie komme ich in die Verzeichnisse, um die dann auf den Desktop zu bringen?

  • Mit dem Finder...?

    Die Kexte findest du in den Verzeichnissen /Library/Extensions und /System/Library/Extensions

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Jo, habe ich gefunden.

    Soll ich die nur in den neuen Ordner kopieren oder auch aus den Verzeichnissen in den Papierkorb verschieben?

  • Zum sicherstellen würde ich die erstmal in einen eigenen Ordner auf dem Desktop verschieben.


    Achte auch bitte auf meinen EDIT in Beitrag #8

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • OK, nochmal in der Reihenfolge.


    Ich habe alle kexte in einen "neuen Ordner" auf den Desktop kopiert. Die Originale sind aber in den Verzeichnissen geblieben. Dann habe ich das Werkzeug ausgeführt. Und jetzt soll ich den AppleHDA Kext wieder zurück kopieren? Oder deinen Verwenden?

  • Jetzt wird es wohl langsam Zeit für den Hinweis auf unser Wiki.

    Darin findest du nämlich so vortreffliche Infos wie 1 EFI mounten

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Orakel Ich will mich hier nicht einmischen, Al6042 wird dir den richtigen Weg weisen. Wenn dann anschließend alles funktioniert, dann lösche noch /Library/LaunchServices/com.tony*****.InstallHelper.

    Gruß, karacho


    Hier werden Sie geholfen. Aber bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...


    Beratungsresistenten Usern empfehle ich, auf den Spoiler zu klicken!

  • karacho

    Den kannte ich noch garnicht... danke für den Hinweis.

    Da sieht man mal, wie sehr sich das Zeug ins System einbuddelt.

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Tut mir leid, ich komme nicht wirklich mit.


    Also: Kexte aus den Verzeichnissen auf den Desktop Ordner kopiert, Die kexte aber nicht in den Papierkorb verschoben. Was nun? Werkzeug ausführen oder deine Apple HDA mit meiner ersetzen?

  • Liegt vielleicht am EDIT selbst...


    Die Kexte mit dem Hinweis "Unbekannt" oder "nicht signiert" sollst du in einen neuen Ordner auf deinem Desktop verschieben.

    Dann den Original AppleHDA.kext aus dem Anhang aus Post #8 in dessen ursprüngliche Position (/System/Library/Extensions) kopieren.

    Danach muss aus dem Tool "Kext-Updater", in dessen Unterbereich "Werkzeuge", die Funktion "Baut Kextcache neu auf und repariert die Dateirechte in /SL/LE & /L/E" ausführen.

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ich würde nicht versuchen, dieses System clean zu bekommen.

    Erstelle Dir einen neuen Install-Stick, nimm die empfohlene EFI aus Post #6, und installiere neu. Alles andere ist Rumgegurke.