Dualboot: Wie Windows installieren wenn man kein Windows hat?

  • Hubert, nimm mal diese Iso.

  • Ich weiß nicht, wie ich während der Installation einen Screenshot machen kann, daher tippe ich die Fehlermeldung ab:


    Ich habe danach einen weiteren Versuch gemacht indem ich den Stick an eine andere USB-Buchse angesteckt hatte. Nach dem Hinweis von ResEdit habe ich sogar ein USB-2.0-Verlängerungskabel zwischen Computer und Stick gehängt (weil der Stick 3.0 ist und der Computer nur 3.0 oder 3.1 Anschlüsse hat). Das Resultat war in jedem Fall dasselbe.


    Es fällt mir auch schwer zu glauben, dass Windows keinen Treiber für genau das Medium finden kann, von dem es bereits erfolgreich gebootet und Programme und Daten geladen hat.


    Die ISO-Datei habe ich übrigens von dieser Adresse heruntergeladen: http://www.software-cdn.de/dow…Win10_1903_German_x64.iso


    (Den Aktivierungscode habe ich mittlerweile auch erhalten, den gebe ich aber nicht weiter. Den musste ich auch noch gar nicht eingeben.)


    jhahn Danke für deine ISO-Datei. Ich werde es morgen damit versuchen, ich habe heute noch was anderes vor.


    Ich danke allen aber schon mal für ihre großartige Hilfe! Danke!

  • Wenn du noch eine freie Festplatte hast, kannst du auch dort die Installationsdaten aufspielen und die Festplatte dann über SATA einbinden und dann Windows auf die Zielplatte installieren. Ist zwar Platzverschwendung, aber ist ja auch nur für den Moment der Installation notwendig.

    Exakt diese Fehlermeldung hatte ich übrigens auch mit meinem USB 3 Stick.


    Wie sieht es denn mit dem BIOS aus? Hast du vor der Windows Installation erneut die "optimized Settings" geladen? Oder sind spezielle Sachen angepasst worden, die zwar für die Installation von macOS notwendig waren, jetzt aber der Installation von Windows im Wege stehen könnten? Möglicherweise im Bereich der USB-Schnittstellenkonfiguration?

    Edited 2 times, last by ResEdit ().

  • hast du die Platte auf die Windows soll irgendwie formatiert oder war da schonmal ein OS drauf?

    Rufe mal von deinem Install-Stick die Windows-Eingabeaufforderung auf und starte diskpart. Damit die Platte mit dem clean-Befehl löschen, danach ist sie quasi fabrikneu.

    Windows dann in den nicht zugeordneten Speicherplatz installieren, dabei erzeugt der Installer eigenständig die benötigten Partitionen.


    Ich könnte mir auch vorstellen dass dein Installation Stick fehlerhaft ist, du hast geschrieben, Etcher hätte eine Fehlermeldung ausgegeben

    Meine Systeme


  • ... Windows-Eingabeaufforderung ... diskpart ... clean ...

    Hast du den Titel dieses Threads gelesen? (»... wenn man kein Windows hat«)

    Wenn ich keinen Rechner habe auf dem Windows läuft, wie soll ich dann deinen Vorschlag umsetzen?


    Die »Fehlermeldung« von Etcher war übrigens keine Fehlermeldung, sondern nur ein Warnhinweis und sah so aus:



    Aber der Rechner hat ja trotzdem von dem Bootstick gebootet, darauf befindliche Programme gelesen und ausgeführt. Immerhin hat der Setup-Prozess ja erst nach dem 3. oder 4. Schritt gemeckert. Bis dahin war es ja kein Problem etwas von dem Stick zu lesen.


    Ich muss jetzt zur Arbeit, ich werde am Abend neue Versuche unternehmen.

  • Hallo Hubert, ich kenne genau diesen Fehler auch nur in Verbindung mit USB3 ODER unter Win 7 mit deaktiviertem CSM und nicht 100% UEFI Hardware (GTX970). Klar, unter XP gabs das auch schon, da war meist der SATA Controller schuld, da ohne Patchen kein AHCI moeglich war.

    Wie ist CSM bei dir gesetzt?


    Wenn nichts hilft, schieb die Installation - wie hier schon vorgeschlagen wurde - auf eine SATA Platte/SSD und installiere das System von dort aus.

    MacBookPro9,2: ThinkPad T430 (i5-3320m, 8GB RAM, HD4000) @ 10.14.6

    iMac17,1: i5-3550, H77-D3H, 12GB RAM, HD7750 2GB @ 10.15.1

    iMac12,1: i7-3930k, X79 Extreme9, 16GB RAM, RX480 8G @ 10.14.6

    PowerBook & MacBook's <2010 @ 10.4.11 - 10.13.6

  • Die Variante mit einer VM erscheint mir auch nicht verkehrt und ist ohne weitere Fallstricke zu realisieren.

  • Da du schon Linux installiert hast würde ich trotzdem mal den bootbaren USB-Stick mit deinem win10-Iso-file mittels "-->WoeUSB" erstellen. Hatte bei mir einwandfrei funktioniert.


    Mit "sudo woeusbgui" dann starten



    Edited once, last by user232 ().

  • Hast du den Titel dieses Threads gelesen? (»... wenn man kein Windows hat«)

    Wenn ich keinen Rechner habe auf dem Windows läuft, wie soll ich dann deinen Vorschlag umsetzen?

    Dazu brauchst du kein installiertes Windows. Wenn du die Installation vom Stick startest hast du die Möglichkeit die Eingabeaufforderung aufzurufen


    https://www.windows-faq.de/201…-vom-windows-10-aufrufen/

    Meine Systeme


  • Mir hätte die Idee gut gefallen, ein internes Laufwerk anstelle des USB-Sticks als Installationslaufwerk zu verwenden, aber Etcher meldet



    Kann ich nicht einfach den Inhalt der ISO-Datei in ein internes Laufwerk kopieren das mit FAT32 formatiert ist und dann von diesem Laufwerk booten? Was für Zaubertricks vollführt denn Etcher eigentlich?


    UPDATE:

    Den Inhalt der ISO-Datei in ein internes Laufwerk zu kopieren das mit FAT32 formatiert ist und von dort aus die Installation durchzuführen klappt prima. (Die Installation läuft gerade)

    Edited once, last by Hubert1965 ().

  • Ich habe ebenfalls ähnliche Versuche (rein interessehalber) gemacht.

    Das Erstellen des Sticks mit Etcher funktioniert nur scheinbar, das Setup bricht dann aber mit wechselnden Fehlermeldungen ab.

    Das Mounten der ISO mit DiskMounter funktioniert gut, das Kopieren auf ein FAT32-Medium ist letztendlich dann auch die Lösung.


    Aber: Das Formatieren eines USB-Sticks unter macOS ist mit Tücken behaftet. Ich habe nun mehrfach festgestellt, daß eine versteckte EFI-Partition auf dem Stick trotz kompletter Formatierung nicht gelöscht wird - und das ist unter macOS nicht direkt erkennbar. Wenn man später z.B. ein Windows-Setup von diesem Stick startet, verliert das Setup die Partition mit den Daten und sucht in der falschen (alten EFI-) Partition - die Installation scheitert.


    Wenn es jetzt bei Hubert klappt, hat er intuitiv alles richtig gemacht. :top:

  • Aktueller Stand:


    Alle drei Betriebssysteme sind installiert (macOS Catalina, Ubuntu mit KDE (also Kubuntu), und Windows 10 Pro). Bei Windows gab es das Problem, dass kein Treiber für die WLAN-Karte vorhanden war, aber es gab hier im Forum einen Thread der genau dieses Problem behandelt hat, dort gab es auch den Treiber zum Runterladen, und den habe ich dann via USB-Stick in Windows ausgeführt, und jetzt klappt auch das.


    Ich kann, wenn ich vorher im Bios die Bootreihenfolge ändere, auch jedes der drei Betriebssysteme starten. Wenn ich die Platte mit MacOS an die erste Position stelle, fragt mich Clover, von welchem System ich booten will, da fehlt aber Ubuntu. Es sind nur vorhanden (in dieser Reihenfolge von links nach rechts):


    Windows - Recovery - macOS


    Ich hätte aber gerne:


    macOS - Ubuntu - Windows


    (ob ich das Recovery-Laufwerk brauche weiß ich nicht, wenn es klug ist, das zu haben, dann soll es - wenn möglich - die vierte Option, also ganz recht sein)


    Ich nehme an, dass dazu eine Änderung irgendwo im EFI-Ordner notwendig ist. An welcher Stelle? Und was muss man da ändern?


    Andere Frage:


    Meine vierte SSD (mit 1 TB) soll die von allen drei Betriebssystemen gemeinsam genutzte Daten-Partition sein. In welchem Datensystem sollte ich die am besten formatieren? Ich würde ExFAT nehmen (dafür gibt's angeblich auch unter Ubuntu Treiber und macOS und Windows beherrschen das Format nativ). Ist das eine gute Wahl? Was spricht dagegen?

    • Helpful

    Setze mal bitte mit dem Clover-Configurator in der aktuellen config.plist unter dem Menüpunkt „GUI“ -> „SCAN“ den Haken bei „Linux“. Das hatte ich noch vergessen. Dann sollte es klappen.

  • Ich hab's ohne Configurator gemacht. plist-dateien sind ja nichts weiter als XML-Dateien. Ich habe daher die config.plist mit einem stinknormalen Texteditor bearbeitet. Mit deinen Angaben war die entsprechend Stelle schnell gefunden, ich musste nur den Wert von »false« auf »true« ändern. Jetzt ist auch Linux in der Auswahl sichtbar. Alles Perfekt!


    Vielen Dank!

  • Hubert1965

    Du kannst auch die Recovery im Boot Menü ausknipsen.
    Ich mache das über den Clover Configurator in GUI-> Hide Volume



    Ob man das machen sollte kann ich dir aber nicht sagen. Ich finde es sauberer wenn ich nur Win und Apple als Boot Option habe.


    Gruß