AMD NAVI / RDNA (RX5700/XT etc.) in macOS | Benchmarks, Undervolting, Overclocking, PowerPlay Table

  • Genau wie ich oben geschrieben hab. SMBios bedingt. mitchde  ;)

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.2 (19C57)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.2 (19C57)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Es hängt eben schon auch von der AMD GPU ab. WEG nutzt standardmäßig den agdpmod=vit9696 AGDP Patch der AGDP komplett am Laden hindert und nicht nur den Board-ID Check killt. Genau das führt allerdings derzeit bei Navi10 Karten zu einem Blackscreen. Entsprechend brauchen diese Karten zwingend das agdpmod=pikera bootflag. Außnahme natürlich man nutzt ein SMBIOS das nicht in AGDP hinterlegt ist.

    LG Chris


    Meine Hardware:

  • Zum Thema Benchmark:

    Demnächst wirds den BASEMARK GPU Bench auch für OS X geben (als Version 1.2 mit METAL).

    https://www.basemark.com/benchmarks/basemark-gpu/

    Soll Dez kommen, die schon verfügbare BETA 1.2 ist nur für Kunden von Basemark zugänglich , wir müssen also noch bissle warten :) basemark-gpu-1-2-beta-is-ready/ für Kunden ;)

    Auch nicht den IndigoBench (GPU raytraing) vergessen: https://www.indigorenderer.com/indigobench#download

    Der rendert zwei Szenen - nur halt nicht vergessen vor dem Bench den Haken vor der CPU zu entfernen (sonst rendert der wie bei Luxmark auch möglich CPU+GPU statt nur GPU).

  • Moin. Wieder mal Wahnsinn, dass wir wieder ner PPT haben für die 5700er. Danke Chris.

    Habe jetzt ne 5700 bestellt die kommt die Tage.


    Ich muss mich aber outen.... ich habe echt Probleme mit dem Verständnis der Tabelle.

    Die Werte die da eingetragen sind, sind das Stock Werte von einer Karte XY? Wenn ich jetzt die Nitro+ von Sapphire habe, muss ich dann alle Werte abändern?


    Mein Ziel ist es, dass mein Stromverbrauch noch einmal reduziert wird. Und parallel dazu so silent wie möglich.

    Müsste ich dann nur MaxVoltageGfx anpassen? Könnte den ich den Rest so lassen wie er ist? Wenn nicht... wo bekomme ich die Werte der 5700xt Nitro+ her?

  • Die eingetragenen Werte sind die Standardwerte der Referenzkarten. Das steht doch auch in der Tabelle. Außerdem gibt es zu jedem Wert eine Erklärung.


    Im Grunde ist der einzige Wert den du von deiner Nitro+ brauchst das MinimumPWMLimit. Um diesen zu ermitteln schaust du in deine IORegistry, dort findest du den Eintrag "ATY,bin_dump" welcher einen Hex Dump deines VBIOS enthält. Kopiere dir den Kram in einen beliebigen Text Editor und suche hier nach dem Anfang der PowerPlay Table. Mit der Excel Tabelle als Vorlage sollte dir das keine Probleme bereiten.


    Wenn du die PowerPlay Table gefunden hast kannst du nun mit meinem Generator als Maske das PWM Limit lokalisieren. Dann einfach per Taschenrechner App im Programmierer Modus den Hex Wert umrechnen und im Generator eintragen. Wenn da z.B. 1E 00 steht tippst du in den Taschenrechner 1E ein und wechselst dann in den Dezimal Modus. Das Ergebnis wäre dann 30. Diesen Wert setzt du in der PowerPlay Table.


    Für den Rest kannst du selber die für dich optimalen Werte ermitteln.

    LG Chris


    Meine Hardware:

  • Funktioniert bei euch eigentlich die Hardwarebeschleunigung mit Videoproc?

    Bei mir wird alles rot angezeigt...


    Ansosten macht die Karte keine Probleme und wird sauber erkannt.

  • Ja funktioniert. iMacPro1,1 und Karte muss unter GFX0 oder GFXA hängen.

    LG Chris


    Meine Hardware:

  • Interessant -aber wie zu erwarten wg eGPU Einsatz (TB3 limitiert sehr schnelle GPUs) - 5700XT bei barefeats getestet (Pro Apps + Games) am iMacPro Radeon Pro Vega 64 (16GB HBM2 memory).

    Bei einigen Tests geht die interne iMacPro Vega sogar am schnellsten ans Werk.


    amd-5700-xt-1nr.png


    https://barefeats.com/amd-5700-xt-egpu-imac-pro.html




    Ganz anders wie beim Einsatz eGPU an einem iMacPro mit Radeon Pro Vega 64 (16GB HBM2 memory), siehts an einem MacBookPro 2016 mit Integrated Intel Graphics 550 aus.

    Da beschleunigen auch GPUs als EGPU - hier eine Vega 64 - sehr deutlich alle Pro App Workflows und alle Games Workflows.

    rmbp-13in-egpu-pro-1nr.png

    https://barefeats.com/blackmag…egpu-pro-macbook-pro.html

    Hinweis: Diese Info soll kein RX 5700XT Bench an sich sein, aber gute Tipp Kaufentscheidung für eGPU Nutzer, weil eben die Highend GPUs über TB3 gar nicht ausgereitzt werden und ne "Nummert kleiner GPU" oft auch reicht.

  • Der limitierende Faktor dürfte da in vielen Fällen eher die Abwärme sein. Mich würden die Tests mal mit PPT interessieren.

    LG Chris


    Meine Hardware:

  • Eher nicht die Abwärme. Das zweite Game zeigt, dass die schnelle eGPU bei sehr hoher Auflösung klar vorne liegt. Würde die GPU wegen Überhitzung runtertakten, wären die FPS Werte auch bei höchster Auflösung schlechter wie die der internen IMacpro Verga. Sind aber besser. Da hat die GPU selbst (ohne TB3 Transferzeiten) auch deutlich mehr Arbeit. Bei den 2 niedrigeren Auflösungen hingegen spielen die TB3 Transferzeiten (der Gpu Befehle und Datenübertragung von Texturen etc. über TB 3 an GPU) eine größere Rolle / Limitiert FPS-

    Apple Doc:

    2d11b405-c090-42e4-87f9-27e5d5a8c269.png

    https://developer.apple.com/do…derstanding_gpu_bandwidth


    Bin mir recht sicher, dass der Unterschied eGPU vs PCIe GPU bei einer RX 560 deutlich geringer ist wie bei Karten ab Vega 56 aufwärts. Je schneller die GPU desto eher bremst die begrenzende Bandbreite des TB3 Anschlusses.


    PS: Ich denke Rob wird diese Tests auch noch in einem MAcPro machen. Dessen PCIe sollte schneller wie TB3 sein (wenn auch nicht so schnell wie bei recht neuen Hackintoshs)

  • Ja funktioniert. iMacPro1,1 und Karte muss unter GFX0 oder GFXA hängen.

    Bei mir nicht... iMac19,1 - iGPU deaktiviert

    Die Karte wird im Hackintool unter GFX0 gelistet.


    Muss ich noch irgendwo ein Rename vornehmen? Falls ja welches?

  • Du brauchst glaube das iMac Pro SMBIOS

  • Aroghan Falsches SMBIOS. Kann ja nicht funktionieren wenn du in einem SMBIOS bist das auf IGPU ausgelegt ist.

    LG Chris


    Meine Hardware:

  • Okay, ich dachte, dass das SMBIOS vorangig von der CPU abhängt. Deswegen hatte ich das iMac19,1 ausgewählt. Werde das iMacPro1,1 testen :) Danke

  • So bei mir läuft nun auch eine Sapphire RX5700XT nitro+. Mit WEG und agdpmod=pikera keine Probleme hier. Powermanagement geht auch ohne Probleme Rechner geht nach definierten Zeitraum aus und kann

    dann wie mit der VEGA56 per Leertaste an der Tastatur wieder gestartet werden.

    Hat hier jemand Werte für die PowerTable für ein Sapphire ermittelt.

    Würde das gerne machen hab aber hier keinerlei Erfahrung bis jetzt sammeln können.


    Videoproc schaut soweit auch gut aus und Grafikbeschleunigung ist anscheinend auch im grünen Bereich.

  • Friert bei dir nicht nach dem Sleep sukzessive ein? Bei mir und einigen anderen - auch bei echten Mac Pros - läuft nach dem Wake erstmal alles, doch dann beginnt die UI zu stocken und friert irgendwann ganz ein. Nach mehreren Minuten scheißt der Rechner dann mit Kernel Panic ab.


    Die Werte für die Sapphire kannst du dir aus dem VBIOS der Karte ziehen. Einfach den Hex Dump aus der IORegistry in nen Text Editor kopieren und dann nach der PowerPlay Table suchen. Mit meinem Generator als Maske solltest du dir die einzelnen Werte dann ganz einfach raussuchen und umrechnen können. Alternativ kannst du auch in Windows dein VBIOS ins MorePowerTool von Hellm (Igorslab) laden und da die Werte abschreiben.

    LG Chris


    Meine Hardware:

  • Also Rechner läuft hier seit 4 Stunden ohne Probleme. Mehrmals bereits aus dem Standby geholt. Bis jetzt alles ok hier.


    Update: zu früh gefreut. nach mehr als 4 1/2 Stunde hatte ich genau das Problem Rechner friert ein. Schade aber so fliegt die 5700er wieder raus. Aktuell nicht zu gebrauchen. Warte erst einmal ab bis die Treiber den "BETA" Stus verlassen haben.

  • Mein Rechner friert unter smbios iMac Pro 1,1 immer noch sukzessive ein, nachdem ich auch virtualsmc getestet habe. Da dieses Problem wohl auch bei anderen Usern auftritt, werde ich auf 10.15.2 hoffen, und meinen Hack mit smbios iMac 14,2 weiter betreiben, ohne dieses allmähliche Einfrieren.

    iMac Pro 1,1: Catalina, Windows10, BL: Clover 5099, Mainboard: Gigabyte Designare, CPU: i7-9700K, Ram: 32Gb Corsair Vengeance LPX; Grafik: Sapphire RX5700 XT Nitro+ 8Gb, SSD: Samsung 970 NVME 500GB, Samsung 850 Evo 500Gb, HDD: Seagate ST3000DM001 3TB Wifi/Bluetooth: BCM94360CD Combo (oob), PSU: be quiet! Dark Power Pro11, Case: Jonsbo UMX4

  • Nutzt jemand Photoshop und Illustrator? Ich hab teilweise richtig krasse UI Fehler, Die Programme starten nicht oder brauchen ewig.

    Zum Arbeiten leider nicht Ideal 🙃