Sidecar mit dem Hackintosh (Unmöglich?!)

  • Das klingt sehr danach, dass bei dir Software-Encoding verwendet wird. "Geht nicht" heißt hier schwarzer Bildschirm.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 10.15.5, Manjaro Linux, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 10.15.5, Manjaro Linux, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.5), iPhone X 64GB (iOS 13.5.1)

  • Wenn "geht nicht ohne iGPU" schwarzer Bildschirm bedeutet, müsste das ja hiermit widerlegt sein. Oder täusche ich mich?

    Ich hab einen i7 5820k (keine iGPU) und eine RX580 auf dem GA X99P SLI und bekomme ein Bild auf dem iPad und kann auch mit dem Pencil navigieren.


    Gestern habe ich aus Jux und Dollerei einfach mal Sidecar für unsupportet Macs aktiviert (MacPro 6,1). Da wurde mein iPad erkannt, aber sobald ich es ausgewählt hatte kam ein Error (ich denke wegen fehlender BT Card).

    Nachdem ich dann heute die Fenvi T919 eingebaut habe, hat es quasi OoB funktioniert (nur per Kabel, per BT funktioniert nicht). Das Bild und die Latenz sind zwar wirklich nicht gut, aber immerhin mehr als ein Blackscreen. Vielleicht ist das ja ein kleiner Lichtblick für die Kenner. (Wenn das hier schon hinreichend bekannt ist, bremst mich bitte!)


    Wenn du sagst, dass vermutlich Software-Encoding verwendet wird, gibt es dort bekannte Möglichkeiten eine Verbesserung zu erzielen?

  • Nein, das war soweit bekannt. Nur, wie du sicherlich gemerkt hast, ist das Software-Encoding unbrauchbar. Mit dem „Hack“ bekomme ich es auch auf meinem MacBook Pro aus 2013 zum laufen, das technisch gar nicht in der Lage ist, HEVC in Hardware zu encodieren.

    Als MacPro 6.1 hast du gar keinen Zugriff auf den Encoder deiner RX580. Wenn du als iMacPro 1,1 unterwegs bist und deine RX580 als Encoder läuft, wirst du sehen, dass dein iPad schwarz bleibt.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 10.15.5, Manjaro Linux, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 10.15.5, Manjaro Linux, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.5), iPhone X 64GB (iOS 13.5.1)