Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Für Hackintosh-Konfigurationen mit Gigabyte Z390 DESIGNARE mit Intel Core i9, i7, i5 oder i3 und Radeon-RX-GPU (RX 580, Vega 56, Vega 64, Radeon VII etc.) oder auch für den Betrieb ohne externe GPU (nur iGPU) habe ich vollständig funktionierende EFI-Ordner erstellt, die ich hier bereitstelle.

    Hinweis: Die RX 5700 (XT) kann hier im Gegensatz zu den genannten GPUs momentan noch Probleme verursachen.


    Geeignet sind die Ordner für diese macOS-Versionen:

    Mojave 10.14.5 und 10.14.6 (nicht für ältere Versionen)

    Catalina 10.15.1 Mit Sidecar bzw. DRM gibt es jedoch Einschränkungen. Man muss sich entscheiden, was einem davon wichtiger ist (siehe Schritt 2 der Anleitung).


    Außerdem beigefügt hab ich die aktuelle BIOS-Version F8 und je ein BIOS-Profil mit den nötigen Einstellungen.


    Eine Liste an Hardware findet ihr in meiner Signatur. Für WLAN/Bluetooth empfehle ich die Fenvi T919 PCIe Karte. Die läuft out of the box und auch Handoff, Airdrop etc. läuft einwandfrei.


    Kurzer Hinweis zum RAM:

    Es sollte jeder RAM gehen, der auf der Kompatibilitätsliste des Mainboards aufgeführt ist (und auch so einige andere), aber:

    Bei schnellerem RAM als 2600 MHz kann es beim Verwenden von USB-Platten/-Sticks vorkommen, dass nach dem Ruhezustand gemeldet wird, dass sie nicht korrekt ausgeworfen wurden. Wen das stört, muss langsameren RAM nehmen oder die Taktgeschwindigkeit im Bios auf 2600 MHz drosseln.

    ANLEITUNG:

    Vorbereitung am echten Mac:


    1. Schritt: macOS-Installationsstick erstellen:

    USB-Stick (oder ext. Platte) mit mind. 8 GB Speicher (Catalina: mehr als 8 GB) mit dem Festplattendienstprogramm formatieren. Diesen Schritt nicht überspringen, da hierbei die anschließend benötigte EFI-Partition automatisch im Hintergrund erzeugt wird.

    Name: INSTALLER
    Format: macOS Extended (Journaled)
    Schema: GUID-Partitionstabelle


    Mojave laden (https://itunes.apple.com/de/ap…398502828?ls=1&mt=12&l=de).

    oder:

    Catalina laden (https://apps.apple.com/de/app/…talina/id1466841314?mt=12)-

    Wenn das Installationsprogramm nach dem Download startet, dieses einfach beenden.

    Terminal öffnen und folgendes eingeben:

    für Mojave:
    sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/INSTALLER

    für Catalina:

    sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/INSTALLER

    Computerpasswort eingeben und mit Enter bestätigen, danach auf Aufforderung mit Y und Enter das Löschen des Volumes bestätigen und warten bis der Stick erstellt ist.


    2. Schritt: Korrekte EFI-Konfiguration auf den Stick kopieren:

    Welcher EFI-Ordner für welche Konfiguration?

    • Wenn man ohne externe GPU, sondern nur mit iGPU arbeitet:
      Z390-Designare-nur-iGPU-iMac19,1
    • Wenn man ne Radeon-GPU hat:
      • macOS Mojave: Z390-Designare-Radeon-GPU-iMacPro1,1
      • macOS Catalina: Kommt drauf an, was einem wichtiger ist: DRM-Inhalte problemlos abspielen zu können oder Sidecar.
        DRM: Z390-Designare-Radeon-GPU-iMacPro1,1 (würde ich empfehlen, wenn man Sidecar nicht braucht.)
        Sidecar: Z390-Designare-Radeon-GPU-iMac19,1

    CLOVER CONFIGURATOR runterladen:

    https://mackie100projects.altervista.org/download/ccg/

    Im Clover Configurator unter „Tools“ Mount EFI wählen und unten die EFI-Partition des USB-Sticks mounten ("EFI on Install macOS …").

    Meinen Ordner "EFI" auf die soeben gemountete EFI-Partition des Sticks kopieren (nicht auf die "Install macOS …"-Partition). Sollte da schon ein EFI-Ordner drauf sein, diesen einfach ersetzen.

    Datei config.plist im Ordner EFI/CLOVER auf der EFI-Partition des Sticks mit Clover Configurator öffnen.
    Zunächst wählt man "SMBIOS": Hier drückt man aufs Kästchen rechts mit den Pfeilen und wählt die iMacPro1,1- oder iMac19,1-Konfiguration.

    Dadurch werden eine neue Seriennummer, neue SmUUID und neue Board-Seriennummer generiert.

    Ich empfehle nun noch folgendes:
    Board Serial Number ersetzen: die soeben generierte Seriennummer plus 5 weitere beliebige Buchstaben am Ende eintragen.
    Unter "Rt Variables" die MLB mit der eben erstellten Board Serial Number ersetzen.



    Speichern.

    Am Hackintosh:


    3. Schritt: BIOS einstellen

    VERSION F8:

    Den Ordner "BIOS" kann man einfach auf einer FAT-formatierten Partition ablegen (zum Beispiel auf der EFI-Partition des USB-Sticks direkt neben dem EFI-Ordner).

    Dann macht man über die Q-Flash-Utility im Bios das BIOS-Update auf Version F8. Dort also einfach den entsprechenden Drive, den Ordner "BIOS" und darin den Ordner "mb_bios_z390-designare_f8" auswählen, und los gehts.


    Anschließend die Settings einstellen:


    BIOS-SETTINGS:

    "Load Optimized Defaults", dann folgende Änderungen vornehmen

    (oder stattdessen einfach unter "Save & Exit" meine Datei aus dem Ordner "BIOS-Einstellungen" als Profil reinladen, dann ist fast alles Folgende bereits erledigt. Trotzdem bitte nochmal durchchecken.)


    F2 drücken ("Advanced Mode")


    Tweaker:

    CPU Upgrade: Gaming Profile oder (je nach Kühlung) Advanced Profile (dann taktet er bis 5 Ghz hoch)

    Extreme Memory Profile(X.M.P.): Profile 1

    Advanced CPU Settings:

    VT-d: Disabled


    Settings:

    IO Ports:

    Initial Display Output: PCie 1 Slot

    (es sei denn, die Grafikkarte steckt in einem anderen Slot).

    Wenn man keine Grafikkarte hat und nur die iGPU verwendet, stattdessen bitte IGFX auswählen.

    Internal Graphics: Enabled

    (auch mit iMacPro1,1 SMBIOS, da sonst die GPU in Final Cut Pro und Compressor nicht alle Aufgaben übernimmt, die sie soll (obwohl die iGPU unter iMacPro1,1 nicht arbeitet). Die Gründe sind unklar, aber es ist so. Möglicherweise hängt das auch von der verwendeten Grafikkarte ab.

    Falls Probleme auftreten oder man Final Cut oder Compressor nicht benutzt, auf Disabled stellen (gilt nur für den Ordner mit iMacPro1,1 SMBIOS)

    Thunderbolt Configuration:

    Discrete Thunderbolt(™) Configuration:

    Thunderbolt Usb Support: Enabled

    GPIO3 Force Pwr: Enabled

    USB Configuration:

    XHCI Hand-off: Enabled

    Smart Fan 5:

    Die Lüftersteuerung (Smart Fan) bitte nach euren Bedürfnissen einrichten. Ich habe bei mir den CPU-Lüfter auf "Silent", den Rest auf "Manual" und meine eigenen Lüfterkurven eingestellt, die alle nochmal leiser sind als die Silent-Einstellung. Außer beim CPU-Lüfter habe ich bei allen Lüftern "VRM MOS" als Sensor ausgewählt.

    Boot:

    CSM Support: Disabled. Nur auf Enabled stellen, wenn das Clover-Menü nicht in der richtigen Auflösung bzw. verzerrt angezeigt wird.


    4. Schritt: macOS installieren:

    Hackintosh von der EFI-Partition des USB-Sticks booten (beim Starten mehrfach F12 drücken, dann Partition auswählen). Anschließend im CLOVER-Menü von der Installations-Partition starten („Install macOS Mojave“/„Install macOS Catalina“). Achtung: Das kann länger als 5 Minuten dauern, bis es, nachdem der Apfel erscheint, weitergeht. Danach geht man im Installationsprogramm zunächst über die Dienstprogramme ins Festplattendienstprogramm und formatiert die zukünftige System-SSD im Format APFS. Anschließend installiert man macOS auf eben dieser SSD.


    5. Schritt EFI-Ordner auf SSD kopieren:

    EFI-Partition der System-SSD mit Clover Configurator mounten (Mount EFI). Nun den EFI-Ordner auf der System-SSD löschen und mit dem aktuellen von der EFI-Partition des USB-Sticks ersetzen.


    Nun die config.plist des neuen EFI-Ordners auf der EFI-Partition der System-SSD öffnen:

    "Boot": Unter "Default Boot Volume" den Namen der Hackintosh-Systempartition eintragen, dann wird nach dem Timeout von selbst gebootet.


    Wer will, dass das Clover-Menü nicht auftaucht und stattdessen direkt von der Hackintosh-SSD gebootet wird, kann den Timeout auf 0 stellen. Will man trotzdem ins Clover-Menü, drückt man nach dem Start während des Gigabyte-Logos mehrfach eine beliebige Taste (nur keine, die schon belegt ist, also nicht F12 oder Entf. – ich nehme einfach immer "J"), bis das Menü erscheint.

    Den Namen der System-SSD kann man im Finder einfach bedenkenlos umbenennen so wie man möchte.


    Nur falls unter "Über diesen Mac" der Prozessor nicht korrekt angezeigt wird, ändert man in der config.plist folgendes:

    "Cpu:" Bei "Type" je nach Prozessor einen dieser Werte eintragen:

    Für Core i3: 0x0309

    Für Core i5: 0x0605

    Für Core i7: 0x0705

    Für Core i9: leer lassen (wird ohnehin korrekt angezeigt)


    Unter "SMBIOS" und "Rt Variables" braucht man nun nichts mehr zu ändern. Seriennummer etc. haben wir ja schon in Schritt 2 generiert.


    Datei speichern, Rechner runterfahren/neu starten.


    6. Schritt: Boot-Reihenfolge ("Boot" -> "Boot Option Priorities") im BIOS:
    Die Hackintosh-System-SSD (z. B. "UEFI OS (Samsung SSD 960 EVO 1TB") sollte an erster Stelle stehen.


    7. Schritt: USB-Stick entfernen, booten, FERTIG.


    Was tun bei System-/EFI-/Clover-Updates?

    Möglichkeit 1:

    Entweder warten, bis ich hier den komplett aktualisierten EFI-Ordner hochgeladen habe, und diesen verwenden (Seriennummer, Board Serial Number, SmUUID und MLB wieder aus der vorherigen config.plist eintragen), oder:

    Möglichkeit 2:

    Tool "Kext Updater" herunterladen:

    Kext Updater

    Das überprüft die Kexts und Clover auf Updates und lädt diese auf den Schreibtisch herunter. Die entsprechenden Kexts (im Ordner EFI/CLOVER/kexts) müssen einfach durch die neuen ersetzt werden (ggf. auch VirtualSmc.efi im Ordner "EFI/CLOVER/drivers/UEFI", falls es hier ein Update gibt).

    Das Clover-Update installiert man einfach mit dem Installationsprogramm. Folgende Einstellungen nimmt man unter "Anpassen" noch vor:


    Vor einem macOS-System-Update sollte man immer Kext- und Clover-Updates machen.


    Hinweis:

    Nach jedem Update des EFI-Ordners im Clover-Menü F11 drücken, um den NVRAM zurückzusetzen!


    UPDATE 10.11.2019:

    Endlich hab ich dank der Hilfe von karacho eine Lösung gefunden, um auf den Treiber OsxAptioFix2Drv-free2000.efi, vor dem der Entwickler warnt, verzichten zu können. Die EFI-Ordner hab ich entsprechend aktualisiert. Statt dieser Datei befinden sich nun FwRuntimeServices.efi und ne entsprechend konfigurierte OcQuirks.efi in EFI/CLOVER/drivers/UEFI. Wenn jemand OcQuirks stattdessen selbst erstellen will, muss er die Option DevirtualiseMmio dabei auf True setzen, sonst geht’s nicht.

    Files

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

    Edited 54 times, last by JimSalabim ().

  • Hi. Erstmal ein dickes Danke für den bereitgestellte EFI und für die ausführliche Erklärung.

    Ich werkele noch an meine erste Hackintosh herum und habe bis jetzt geschafft die Installation zu Ende zu bringen (mit fremde Hilfe).


    Das System bootet zwar, aber kurz nachdem das Apfel erscheint wird der Bildschirm schwarz und es sieht es so aus als würde er ständig ein und ausgehen.

    Es geht so weiter bis der Computer in Ruhezustand geht (ich hoffe die Bezeichnung ist technisch korrekt).

    Wenn ich dann auf die Tastatur irgendeine Taste drücke oder mit der Maus klicke, es ist deutlich zu hören wie der Computer wieder an geht und es erscheint direkt der Login-Maske, ich kann mich einloggen und es scheint alles gut zu funktionieren.


    Ich habe auch eine Z390 Designare, nur mit i7-8700K CPU und MSI RX570 Grafikkarte. Würde dein EFI trotzdem passen? Vielleicht verschwindet dann diese Fehlfunktion.

    Mainboard: Gigabyte Z390 Designare - CPU: i7-8700K - GPU: MSI Radeon RX570 Armor - RAM: 64 GB DDR4 HyperX

    System-Laufwerk: WD Blue SSD SN500 NVMe M.2 500GB - macOS: Mojave 10.14.6 - Clover: 5.4.5.0

  • Hi Teoligant

    Mein EFI-Ordner passt auch zu deinem System – allerdings solltest du die config.plist in deinem Falle durch die hier im Anhang ersetzen. Geändert habe ich dort wegen deiner Konfiguration folgendes: SMBIOS auf iMac19,2 statt iMacPro1,1. Außerdem habe ich die headless platform ID 0x3E980003 eingerichtet, weil du die RX570 hast und sich das dort ggf. noch empfiehlt, dass die iGPU ein paar Aufgaben übernimmt.

    Außerdem müsstest du dann in dem Fall im BIOS noch "Internal Graphics" auf "enabled" schalten.

    Files

    • config.plist

      (5.64 kB, downloaded 109 times, last: )

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

    Edited once, last by JimSalabim ().

  • Hi,


    erst mal vielen Dank für den Ordner, denn so weit wie mit diesem bin ich bisher nicht gekommen. Ich versuche seit einer guten Woche einen Hackintosh mit 10.14.6 zu installiern und das ohne Erfolg.

    Eigentlich klingen meine Komponenten ähnlich zu Deinen - drum hatte ich gehofft der EFI Ordner könnte helfen.

    Ich habe:

    Z390 Designare - I9-9900K - 64GB 3600-18 Corsair - 2 x Samsung 970 EVO Plus M.2 1TB und 256GB sowie SATA 12TB HDD - RADEON VII im ersten Port. Keine weiteren Karten verbaut. MAUS und Tastatur hängen an USB3.0 auf der Rückseite.


    Im Grunde habe ich das alles unter Windows getestet. Die Firmware der SSD habe ich noch nicht aktualisiert. Soll man wohl tun, weiß nicht, denn ich habe kein Windows mehr auf der Maschine und das einrichten würde mich nun einige Stunden kosten. Braucht es das in einer nagelneuen SSD? Bin ich mir unsicher.


    Vielleicht hast Du eine Idee was das Problem sein könnte:


    Ich habe Dein F7 Update eingespielt und die BIOS Settings geprüft- Scheint zu passen.

    Habe dann auf meinem Stick nach Mojave auch CLOVER Installiert und den EFI Ordner komplett durch Deinen ersetzt. Hatte bei den ersten Versuchen noch neue GUIDS generiert, das habe ich dieses mal sein lassen. Einzig den Modus -v habe ich eingestellt, um etwas zu sehen.


    Ich kann nun mit dem USB Stick starten. Diesen habe ich auf der Rückseite direkt in einen der USB 3.0 Ports gesteckt. Booten klappt. Er bleibt zwar einen Moment hängen bei den +++++++++++++++++++++++++++++, aber gut. Nachdem ich in den letzten Tagen mit anderen Versuchen schon alle möglichen Fehler und Timeouts gesehen habe, bin ich ja mal glücklich so weit zu kommen. Der Bildschirm wird dann kurz schwarz, dann Mac Grau mit der Maus und schlussendlich schwarz mit Apfel und Ladebalken. Ich wähle dann auf der nächsten Seite die Sprache aus und er zeigt das Menü mit den MacUtilities an. Im Grunde das gleiche was ich zur Installation eben auch auf einem MAC sehe. Bis er dorthin kommt vergehen aber schon etwa knapp 10 Minuten. Ist das denn normal?

    Ich formatiere also die Platten und kann dann MacOS auf der 1TB SSD installieren. Diese ist übrigens im oberen der beiden Slots verbaut.


    Ok, nachdem ich die notwendigen Eingaben gemacht habe, rennt er also los mit der Installation. Ich bewege hierbei die Maus etwa alls 60sek, um zu vermeiden das er in SLEEP fällt, denn dann geht die Tastatur und Maus nicht mehr und er hängt komplett. Wenn er dann sagt es dauert noch so 3min - also bei etwa 70% würde ich sagen - wird plötzlich der Bildschirm schwarz, links oben blinkt der Cursor. Manchmal tut er das für etwa 3 Minuten und er bootet neu, dann wieder bleibt er einfach in diesem Zustand hängen.


    Wenn ich dann im Menü statt des USB die SSD wähle, denn die zeigt er nun an, kommt er bis zu einem schwarzen Bildschirm mit Menüleiste. Links in der Menüleiste ein Apfel, daneben der Text "Language Chooser". Aber egal welchen USB Port ich verwende, Tastatur und Maus erkennt er nicht und weiter geht es auch nicht.


    Auch wenn ich einfach den Installer noch mal ausführe ändert sich nichts......gleiches Verhalten, was aber auch logisch ist.


    Nun meine Fragen:


    - Habe ich bei Deiner Anleitung irgend etwas überlesen? Gibt es denn sowas wie ein minimales Setup auf KEXT und EFI Dateien, mit denen er einfach mal starten sollte?


    - wie ist es denn mit einem LOG? -V habe ich ja eingestellt und das sehe ich auch am Anfang. Aber hier sind wir ja hinter dem Mac Gui Installer - da sehe ich dann ja keine Log ausgaben mehr.


    - Hast Du noch eine andere Idee was ich versuchen könnte?


    Vielen Dank schon mal vorab und ich hoffe ich bin hier richtig und hätte das nicht irgendwo anders posten sollen. Eine passende Antwort zu diesem Setup habe ich jedenfalls im Forum auch nicht gefunden und ich habe in den letzten Tagen gelernt, das es wirklich schin dfrauf ankommt, in welches Loch man die Schraube dreht und ob das ganze bei Vollmond oder Mittags um 12 gemacht wurde........


    Herzliche Grüße,

    Oliver

  • Hi okaluscha  
    die Firmware von der EVO Plus musst du aktualisieren. Nur mit der aktualisierten Firmware ist die SSD Hackintosh-kompatibel. Ich würde nicht unbedingt davon ausgehen, dass von Werk schon die aktuellste drauf ist. Vielleicht kannst du das unter Windows mal checken und dann eben ggf. das Update aufspielen.
    Wenn es dann immer noch nicht geht, sag nochnmal Bescheid. Eigentlich sollte die Installation mit meinem Ordner ohne irgendwelche Änderungen problemlos durchlaufen. Wenn man sehen will, was los ist, dann ist auch nur "-v" als Bootargument nötig, weiter nichts.

    EDIT: Wegen Log für die macOS-Installation kannst du mal schauen, ob dir das hier weiterhilft:

    https://www.youtube.com/watch?v=_TK_Y-PtEFI

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Ich habe alles nach deiner Anleitung gemacht (bis auf die Einstellung in BIOS wegen iGPU, aber es scheint auch so gut zu funktionieren) und alles läuft wie geschmiert. Die Fehlfunktion von meine vorherige Post ist auch verschwunden. Bis jetzt hatte ich keinerlei Probleme mit was ich probiert habe, ok Bluetooth ging nicht aber ich verwende sowieso eine externe Dongle und mit dem geht es.
    Nicht alle USB Ports funktionieren, aber das hat bestimmt mit den 15-Port-Limit zu tun, oder?

    Sehr nett das mit den angepasste config.plist. Du hast mir das ganze um Einiges erleichtert. Vielen Dank!


    P.S.: Ich merke gerade dass meine Signatur alt ist, die wollte ich noch bearbeiten oder löschen, aber finde nicht wo ich das machen soll. Inzwischen habe die MSI Board usw. nicht mehr.

    Mainboard: Gigabyte Z390 Designare - CPU: i7-8700K - GPU: MSI Radeon RX570 Armor - RAM: 64 GB DDR4 HyperX

    System-Laufwerk: WD Blue SSD SN500 NVMe M.2 500GB - macOS: Mojave 10.14.6 - Clover: 5.4.5.0

  • Die interne Bluetooth-/WLAN-Karte auf dem Mainboard geht unter macOS sowieso nicht.

    Welche USB-Ports gehen denn nicht? Hast du in der config.plist noch irgendwas geändert? Oder im EFI-Ordner?

    Eigentlich ist das alles so konfiguriert, dass alle Ports gehen. Folgende Einschränkungen gibt es wegen des Port-Limits: An den USB-C-/Thunderbolt-Anschlüssen funktionieren keine USB-2.0-Geräte. Am internen USB-3.1-(Type-C)-Header funktioniert ebenfalls kein USB 2.0. Aber da schließt man normalerweise ja eh keine USB-2.0-Geräte an.
    Ansonsten sollten alle (also alle "normalen" USB-Anschlüsse) gehen.


    Folgende Dateien sind für die Belegung der USB-Anschlüsse relevant und müssen unbedingt vorhanden sein:

    CLOVER/kexts/Other/USBInjectAll.kext

    CLOVER/ACPI/patched/SSDT-UIAC-DESIGNARE-Z390-V7.aml

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Sorry, mein Fehler. 😬🤦‍♂️

    Es handelt sich um 2 USB-Ports die vorne an meinem Gehäuse sind (Fractal Design Define R6 USB-C), haben mit den Anschlüssen hinten am Mainboard nichts zu tun.

    In der config.plist und im EFI-Ordner habe ich nichts geändert außer was du mir mit der SMBIOS empfohlen hast.

    Was mir aber aufgefallen ist: ich habe an der USB3.0 (Blau) einen Hub angeschloßen. Dort scheint aber immer nur ein Gerät zu funktionieren. Wenn ich noch was anschließe, wird es nicht erkannt. Aber bevor ich deine Zeit vergeude, will ich das noch weiter testen. Ich hatte gestern und heute keine Zeit dafür.

    Mainboard: Gigabyte Z390 Designare - CPU: i7-8700K - GPU: MSI Radeon RX570 Armor - RAM: 64 GB DDR4 HyperX

    System-Laufwerk: WD Blue SSD SN500 NVMe M.2 500GB - macOS: Mojave 10.14.6 - Clover: 5.4.5.0

  • Teoligant Das Fractal Design Define R6 Gehäuse braucht eine andere USB-Konfiguration – glücklicherweise habe ich die da. :-) Du musst einfach nur die Datei SSDT-UIAC-DESIGNARE-Z390-V7.aml aus dem Ordner CLOVER/ACPI/patched löschen und stattdessen die Datei SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-V3.aml (hier im Anhang) reinkopieren.

    Files

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Teoligant Das Fractal Design Define R6 Gehäuse braucht eine andere USB-Konfiguration – glücklicherweise habe ich die da. :-) Du musst einfach nur die Datei SSDT-UIAC-DESIGNARE-Z390-V7.aml aus dem Ordner CLOVER/ACPI/patched löschen und stattdessen die Datei SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-V3.aml (hier im Anhang) reinkopieren.

    Ich bin neu hier, unschwer zu erkennen... ;) Ich wollte mir eigentlich ein MacMini holen um mein 15" Macbook Pro Late 15" in Rente zu schicken bzw. zu verkaufen. Aber irgendwie ist mir das zu unflexibel und ich will mehr bums haben. Nun habe ich mich derzeit auch für die Konfiguration Gigabyte Z390 DESIGNARE Mainboard und i9 9900K sowie Radeon-RX entschieden.


    Aber gut das hier Leute fragen stellen und JimSalabim auch noch die passenden Antworten parat hat :D Ok, jetzt habe ich verstanden dass für verschiede Gehäuse auch unterschiedliche USB Konfigurationen benötigt werden.... welches Gehäuse nutzt Du denn? JimSalabim . Ich hatte eigentlich ein BeQuiet ausgesucht, aber da grad eine config für das Fractal R6 ist... vielleicht auch eine Option :)


    Achtung Newbie Frage: Mit den Dateien habe ich ein "Sorglos-Paket" für diese Konfiguration? Oder muss ich auch noch die 30 Schritte ausführen welche im englischsprachigen board (dessen Name hier zensiert ist) stehen ausführen? So ganz theoretisch ohne HW zum spielen ist das als Neuling schwer nachzuvollziehen.


    Beste Grüße,

    Ralf

  • sondeu Die Konfiguration mit dem Designare-Board, i9 und Radeon RX ist schon mal eine sehr gute Wahl :-)


    Verschiedene Gehäuse brauchen eigentlich nur in Ausnahmefällen eine eigene USB-Konfiguration. Das Fractal R6 ist einer dieser Ausnahmefälle. Welches BeQuiet hättest du denn im Auge?

    Ich habe das NZXT 500i.


    Welche Radeon RX hast du genau geplant? Bei einer RX570 würde ich ggf. die config.plist aus Post #3 verwenden (und in dem Fall auch den Rest von Post 3 befolgen). Spätestens ab der RX580 oder schneller einfach alles so machen wie in Post #1.


    Im Grunde ist das hier tatsächlich ein Rundum-Sorglos-Paket für die Konfiguration. Einfach einen Mojave-Installer-USB-Stick erstellen, eine EFI-Partition drauf erstellen (zum Beispiel einfach Clover mit völlig beliebigen Einstellungen auf den Stick installieren – oder auf anderem Weg eine EFI-Partition auf dem Stick erstellen, es gibt genügend – und dann den kompletten EFI-Ordner durch meinen hier ersetzen). Dann BIOS-Update machen, die BIOS-Einstellungen wie beschrieben vornehmen, vom Stick booten und ganz regulär Mojave auf deiner SSD installieren. Anschließend auch auf der Mojave-SSD eine EFI-Partition erstellen und dort ebenfalls meinen EFI-Ordner draufpacken. Fertig.

    Also im Endeffekt einfach eine komplett saubere Vanilla-Installation machen und keinesfalls sowas wie Multibeast oder Unibeast verwenden.

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

    Edited once, last by JimSalabim ().

  • Ich habe das be quiet! Silent Base 601 und dazu mal das 750W NT in den Warenkorb gepackt. Ist aber eigentlich alles noch offen - habe keinen Zeitdruck. Werde ggf. noch ein Thread im HW Bereich aufmachen, bzgl. RAM und SSD bin ich mir nämlich auch noch nicht 100% sicher.


    DIe RX570, die config.plist habe ich schon entdeckt. Kann aber auch ne RX580 werden, da habe ich mich nicht fest gelegt. So viel Grafik Power benötige ich da nicht. Benötige die Power für Adobe Lightroom und PS, die ziehen ja mehr CPU, auch wenn sie nun endlich eine erweitertet GPU Unterstützung drin haben mit der letzten Version. Ich habe hier auch noch ein Laptop mit I7 und ner 1070... eigentlich ausreichend... nur dummerweise läuft da Windows drauf ;) Das ist zum zocken gut, aber zum arbeiten möchte ich MacOS.


    Das liest sich sehr gut, lieben Dank für Dein Engagement und Deine Erklärungen, das nimmt mir dann doch die Zweifel welche ich erst hatte als ich das im engl. board alles gelesen hatte.

  • Mit dem Silent Base 601 läuft alles einwandfrei und es muss nichts extra konfiguriert werden. Beim RAM kannst du im Zweifel auf der Gigabyte-Homepage schauen, welcher mit dem Board problemlos kompatibel ist. Meinen kann ich jedenfalls empfehlen (siehe Signatur). Als SSD ist die 970 EVO wohl so ziemlich die beliebteste. Die EVO Plus braucht ein Firmware-Update, bevor man macOS drauf installieren kann.

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • :) Glücklicherweise für mich :)

    Danke, ich werde sie gleich herunterladen und reinkopieren.

    Mainboard: Gigabyte Z390 Designare - CPU: i7-8700K - GPU: MSI Radeon RX570 Armor - RAM: 64 GB DDR4 HyperX

    System-Laufwerk: WD Blue SSD SN500 NVMe M.2 500GB - macOS: Mojave 10.14.6 - Clover: 5.4.5.0

  • Hallo,


    vielen Dank - ja es hat geholfen die Firmware der SSD zu aktualisieren - finde ich irgendwie schräg... Nun hätte ich aber noch eine Frage: Mit diesem Board habe ich weder Bluetooth noch WLan- Hast Du einen Vorschlag für eine (oder zwei) entsprechende Karte, das ich dies auch bekomme und evtl. auch eine Anleitung wie ich das einrichte?


    Ach - wer lesen kann..... das steht es ja....


    Fenvi FV-T919 (BCM94360CD)


    Läuft die mit Deinem Ordner direkt oder muss ich da zusätzlich zu Deinem EFI Ordner noch etwas anpassen?


    Vielen Dank schon mal vorab!

  • Ja, die Intel-Bluetooth-/WLAN-Karte auf dem Board wird von macOS nicht unterstützt. Ich empfehle die Fenvi T919:

    https://de.aliexpress.com/item/32746786692.html

    Der Versand ging bei mir viel schneller als angeben, war nach einer Woche da.

    Die Karte funktioniert out of the box, keine weiteren Anpassungen nötig. Auch Airdrop, Handoff, Continuity usw. geht alles genau wie am echten Mac.

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Hi,


    ich habe Deine Hardware-Komponenten einmal in eine Liste aufgenommen - habe ich das so richtig gemacht? Ich würde nämlich gerne Deine Konfiguration nachbauen - brauche einen PC für Videoschnitt ... Kann ich bis zum Eintreffen der WLan-Karte den Ethernet-Port verwenden oder geht der auch nicht?


    https://geizhals.de/?cat=WL-1286726

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD: 1TB Samsung 970 Evo M.2 2280 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD)

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: HP Z27 UHD 4K (27 Zoll) · Tastatur:Cherry USB-Keyboard · Mouse/Trackpad: Logitech

  • Hi TobiasH

    ja, das sind genau die Komponenten.

    Den Ethernet Port kannst du verwenden – nur Bluetooth (und natürlich WLAN) geht dann eben noch nicht. Da kann man sich mit einem billigen Bluetooth-USB-Dongle natürlich solange aushelfen (aber damit funktionieren dann Airdrop usw. halt nicht – das geht nur mit den "richtigen" WLAN-/Bluetooth-Karten wie eben der Fenvi T919).


    Ich verwende bei mir für Internet übrigens auch nur den Ethernet-Port. WLAN hab ich lediglich aktiviert, damit eben Airdrop etc. funktioniert, aber ich verbinde mich überhaupt nicht mit dem WLAN-Netz.

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download

  • Hi TobiasH

    ja, das sind genau die Komponenten.

    Den Ethernet Port kannst du verwenden – nur Bluetooth (und natürlich WLAN) geht dann eben noch nicht. Da kann man sich mit einem billigen Bluetooth-USB-Dongle natürlich solange aushelfen (aber damit funktionieren dann Airdrop usw. halt nicht – das geht nur mit den "richtigen" WLAN-/Bluetooth-Karten wie eben der Fenvi T919).


    Ich verwende bei mir für Internet übrigens auch nur den Ethernet-Port. WLAN hab ich lediglich aktiviert, damit eben Airdrop etc. funktioniert, aber ich verbinde mich überhaupt nicht mit dem WLAN-Netz.

    Hi,


    danke, dass Du Dir die Konfiguration angesehen hast. Um ersteinmal in die Materie einzusteigen : könnte ich mir die Grafikkarte sparen und die Onboard Grafik nutzen? Hoffentlich schaffe ich es dann, Deine Dateien so anzupassen, dass das auch läuft ...


    Viele Grüße,

    Tobias

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD: 1TB Samsung 970 Evo M.2 2280 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD)

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: HP Z27 UHD 4K (27 Zoll) · Tastatur:Cherry USB-Keyboard · Mouse/Trackpad: Logitech

  • TobiasH Ja, das kannst du machen. Ich hab für den Zweck mal eine config.plist erstellt, die für die Konfiguration nur mit Onboard-Grafik ausgelegt ist. Du müsstest einfach die vorhandene config.plist mit dieser ersetzen (und natürlich Internal Graphics im Bios auf "enabled" stellen).

    Sollte eigentlich funktionieren. Benenne die Datei vorher aber bitte noch einfach in "config.plist" um! Wäre super, wenn du Bescheid geben könntest, ob das so klappt.

    Files

    HACKINTOSH für Musik- und Videoproduktion:

    Mainboard: Gigabyte Z390 Designare · CPU: Intel i9 9900K · CPU-Kühlung: be quiet! Dark Rock 4 Pro

    GPU: Asus Radeon RX Vega 64 ROG Strix OC · RAM: 32GB HyperX Predator DDR4-3600 CL17 (2x 16 GB) · Netzteil: 750 Watt Corsair RM750x

    System-SSD (Mojave): 1TB Samsung 970 Evo M.2 2280 NVMe · System-SSD (Catalina) und Datenspeicher: 960GB Corsair Force Series MP510 NVMe · WiFi-/Bluetooth-Karte (PCIe): Fenvi FV-T919 (BCM94360CD) · Firewire-Karte (PCIe): Syba SD-PEX30009

    Gehäuse: NZXT 500i · Gehäuselüfter Front: 2x be quiet! Silent Wings 3 Highspeed PWM 140mm · Gehäuselüfter Back/Top: 2x be quiet! Silent Wings 3 Highspeed PWM 120mm

    Monitor: LG 27UD69P-W (27 Zoll) · Tastatur: Apple USB-Keyboard · Mouse/Trackpad: Apple Magic Mouse 2, Apple Magic Trackpad 2, Logitech MX Master 2S

    Audio-Interface: MOTU 8A (Thunderbolt)


    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: fertiger EFI-Ordner zum Download