Ruhezustand wird über Nacht unerwartet unterbrochen

  • Hallo zusammen,


    auf meinem Hackintosh läuft eigentlich alles ohne Probleme außer die Sleep Probleme die ich momentan noch habe.

    Wenn ich meinen Hackintosh in den Sleep Modus schicke wird dieser meistens immer wieder mal aus dem Sleep geholt.


    Im System Log bekomme ich folgende Meldung als Wake Reason:


    Code
    1. 00:18:17.449906+0200 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW
    2. 2019-08-10 00:18:17.449909+0200 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI CNVW


    Die Ausgabe pmset -g log ergibt folgendes:


    Code
    1. 2019-08-10 00:03:20 +0200 Notification Next immediate inactivity window start:'2019-08-10 00:30:00 +0200' end:'2019-08-10 09:00:00 +0200' 2019-08-10 00:03:20 +0200 Kernel Client Acks Delays to Sleep notifications: [AppleHDADriver driver is slow(msg: SetState to 0)(1019 ms)] [AMDFramebufferVIB driver is slow(msg: SetState to 1)(1335 ms)] [AppleDeviceManagementHIDEventService driver is slow(msg: WillChangeState to 2)(495 ms)] [AppleAHCIDiskQueueManager driver is slow(msg: SetState to 0)(603 ms)] 2019-08-10 00:03:20 +0200 Assertions PID 200(mDNSResponder) Created MaintenanceWake "mDNSResponder:maintenance" 00:00:00 id:0x0xd00008372 [System: PrevIdle DeclUser BGTask SRPrevSleep kCPU kDisp] 2019-08-10 00:03:20 +0200 Assertions PID 200(mDNSResponder) Released MaintenanceWake "mDNSResponder:maintenance" 00:00:00 id:0x0xd00008372 [System: PrevIdle DeclUser BGTask kDisp] 2019-08-10 00:03:20 +0200 Assertions Kernel Idle sleep preventers: IODisplayWrangler 2019-08-10 00:03:20 +0200 Notification Display is turned on 2019-08-10 00:03:26 +0200 Wake Wake from Normal Sleep [CDNVA] due to XDCI CNVW/: Using AC (Charge:0%) 886 secs 2019-08-10 00:03:26 +0200 HibernateStats hibmode=0 standbydelay=0 203 2019-08-10 00:03:26 +0200 WakeTime WakeTime: 6.651 sec 2019-08-10 00:03:26 +0200 Kernel Client Acks Delays to Wake notifications: [AMDFramebufferVIB driver is slow(msg: SetState to 2)(369 ms)] [AppleHSBluetoothDevice driver is slow(msg: SetState to 1)(1242 ms)] [PRT1 driver is slow(msg: SetState to 2)(1119 ms)] [AppleHDADriver driver is slow(msg: SetState to 1)(1550 ms)] [PRT2 driver is slow(msg: SetState to 2)(4974 ms)] 2019-08-10 00:03:26 +0200 Assertions PID 55(powerd) Created InternalPreventSleep "com.apple.powermanagement.acwakelinger" 00:00:00 id:0x0xd0000837f [System: DeclUser BGTask SRPrevSleep kCPU kDisp] 2019-08-10 00:04:11 +0200 Assertions PID 55(powerd) TimedOut InternalPreventSleep "com.apple.powermanagement.acwakelinger" 00:00:45 id:0x0xd0000837f [System: PrevIdle DeclUser BGTask SRPrevSleep kCPU kDisp] 2019-08-10 00:04:32 +0200 Assertions PID 797(AddressBookSourceSync) Released PreventUserIdleSystemSleep "Address Book Source Sync" 00:01:00 id:0x0x1000083c2 [System: DeclUser BGTask kDisp] 2019-08-10 00:04:32 +0200 Assertions PID 319(UserEven



    Hier noch ein paar Infos zu meinem System:

    Ich habe eine Wlan Karte von Osx-wifi. Diese funktioniert OOB. Eine USB SSDT habe ich mir bereits eingerichtet. Die Bluetooth Kommunikation der Karte läuft über einen internen USB Port auf dem Mainboard. Diesen Port habe ich in der USB SSDT als intern eingerichtet (Port-Type: 255).


    Als SMBIOS verwende ich aktuell ImacPro1,1 wegen meiner RX 580.

    In Clover habe ich PluginType=true eingestellt. Das Power Management der CPU funktioniert auch.


    In den Systemeinstellungen ist Wake on LAN deaktiviert. Das gleiche im Bios:

    Hat jemand eine Idee warum der Hackintosh immer mal wieder von alleine aufwacht. Es passiert nicht oft, aber es ist nervig extrem nervig.

  • Mdnsresponder proxy. Der Mac führt wartungsaufgaben selbstständig auch im Ruhezustand aus.

    Ist ganz normal.

    Kannst du aber deaktivieren für deep sleep muss ich aber nochmal schauen wie. Hab es mal aktiviert gehabt, ich glaub das geht auch mit clover.

  • Der SleepProxyClient sollte schon deaktiviert sein. Ich habe das mittels Clover RC Script gemacht. Da gibt es eine Funktion Disable Sleep Proxy Client. Zusätzlich habe ich in die mDNSResponder.plist -NoMulticastAdvertisements als Programmparameter eingetragen. Heute Nacht ist er trotzdem wieder 1x aufgewacht.


  • Moin, mit dieser Anleitung konnte ich ein für mich zufriedenstellendes Ergebnis erreichen. Eventuell beantwortet das auch einig Fragen für dich.

    iMacPro1,1 im PowerMac G5 Gehäuse mit Wakü ● AsRock Z270 Taichi ● i7 6700k @4,7Ghz ● Predator HyperX 3200 DDR4

    Sapphire Radeon RX Vega 56 ● WIFI+BT Apple BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850

    Style/Umbau - zum Showroom hier lang

  • Ich hatte das Problem schon _immer_, auch mit meinen echten Macs. Damals waren definitiv (unter anderem) USB-Hubs schuld. Dann gibt's natürlich die Standard-Einstellung in den Prefs (Energie sparen -> Power Nap).

    ASUS Z97-A · intel i7 4970K · 24GB RAM · Grafikkarte: Sapphire RX580 Nitro+ 8GB
    Systemprofil: iMac 1,1 · Clover 5018 · macOS 10.13.6

  • Moin, mit dieser Anleitung konnte ich ein für mich zufriedenstellendes Ergebnis erreichen. Eventuell beantwortet das auch einig Fragen für dich.

    Danke für den Link. Werde die Tage noch weiter testen. Ich habe heute mal die Einstellungen FixShutdown in Clover entfernt. Seit um 8:30 ist er mal im Sleep gewesen, ohne von alleine aufzuwachen. Ich werde das weiter beobachten.

  • In einem früheren Thread hatte ich ein ähnliches Problem beschrieben. Die Lösung inkludierte insbesondere das Ausschalten von Find my Mac (Meinen Mac suchen) in den iCloud-Systemeinstellungen. Mit dieser Option wachen auch meine echten Macs regelmäßig auf, nur dass man es diesen aufgrund des besseren Power Naps (kein Lüfter/Aufleuchten einer Power LED) nicht anmerkt.

  • Code
    1. 2019-08-13 00:52:30 +0200 Assertions PID 905(backupd) ClientDied PreventUserIdleSystemSleep "Time Machine backup" 00:02:31 id:0x0x1000083c3 [System: DeclUser kDisp]

    scheint immer noch alles aktiv bei dir zu sein, laut deinem log um 02:31 Uhr TimeMachineBackup.

    Ich würds an deiner stelle lassen. Bestimmte funktionien gibt es nicht ohne Grund.


    Ich z.b. mache Backups grundsätzlich Nachts, hat den vorteil das ich dann nicht arbeite und nicht z.b. gerade in arbeit befindliche daten u.U. nicht mitgesichert werden aus verschiedenen Gründen.


    Wenn man z.b. gerade ein Programm kompiliert wird nur das zum zeitpunkt abgarbeitete gesichert aber nicht der komplette Prozess.


    Wenn die Kiste ganz aus sein soll dann wäre poweroff die bessere wahl.

  • Kurzer Zwischenbericht: Ich habe gestern meine DSDT folgendermaßen angepasst.

    Bei XHC und CNVW habe ich die _PWR Funktion


    Hier die PWR Funktion von XHC. Vorher stand hier 06D, 0x04.


    Code
    1. Method (_PRW, 0, NotSerialized) // _PRW: Power Resources for Wake
    2. {
    3. Return (GPRW (0x6D, Zero))
    4. }

    Das gleiche bei CNVW:


    Code
    1. Method (_PRW, 0, NotSerialized) // _PRW: Power Resources for Wake
    2. {
    3. Return (GPRW (0x6D, Zero))
    4. }

    Heute Nacht gab es mal keine Probleme mit dem Sleep.