Die Angst vor dem Cloverupdate von Vers. 4972

  • Hallo,


    nachdem hier von etlichen Problemen mit dem neuen Cloverupdate berichtet wurde habe ich Muffe das Update zu wagen.


    Ich, und vermutlich viele andere Newbees auch, wären euch sehr dankbar, wenn man hier eine schrittweise Anleitung beschreiben könnte, wie man wo welche Dateien in welche Ordner wechseln und oder kopieren muss.


    Am besten noch mit einer idiotensicheren Anleitung wie man einen funktionierenden Wiederherstellungsstick erstellt.


    Ich habe die entsprechenden Threads gelesen und werde leider nicht schlau draus, deshalb die Bitte.


    Das wär super.


    Danke.

  • Mach dir als Allererstes mal einen neuen Bootstick vom aktuellen Clover(EFI) deiner Installation!


    Danach am besten noch ne Kopie vom aktuellen Clover Ordner auf den Schreibtisch.


    Dann installiere den neuen Clover vergleiche beide Versionen Schreibtisch VS. EFI

    und zur größten Not haste noch den aktuellen Bootstick ...

    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

    • Helpful

    Ich würde erstmal garnicht updaten, sondern das neue Clover auf einen Stick installieren (aufpassen bei der Ziel Auswahl, damit du auch den Stick erwischst) und solange anpassen bis es läuft. Deine aktuelle EFI bleibt dabei sauber, also kann dir nichts passieren

    Meine Systeme


  • Jupp!

    Zudem besteht eigentlich kein Update Zwang wenn das läuft was laufen kann.

  • Danke für die Vorschläge, werde ich ausprobieren und berichten.

  • Ich lebe eher nach dem Motto !

    ,,Never touch a running System ,,


    und darauf schwöre ich ! ausser du magst Kopfweh und stundenlanges /Tage / kann auch wochenlanges Fehlersuchen.

  • Zuerst alte Efi sichern/kopieren, dann diese Ordenrstruktur (siehe Bild) und deine Kexte von drivers64UEFI in Clover/Drivers/UEFI hinein kopieren und als nächstes auf Clover_v2.5k_r5018 updaten und neu booten.


    Alles läuft, habe einfach den Wizzard ohne zusätzliche Haken setzen oä durchgeklickt. Das einzige was mir auffiel, dass ich jetzt im UEFI-Ordner so vbox-efis, fat.efi drin habe und mir die HFSPlus.efi gelöscht wurde, welche ich aber wieder von meinem EFI-Backup zurückspieln und diese vbox-efis löschen werde.


    EDIT:

    Ich spiele beim Scheitern eines Updates die alte EFI mittels einer Linux-Distribution wieder zurück.

  • Neues Release Clover 5018 akzeptiert kein HFSPlus.efi, nur noch hauseigenes langsames VBox. Die riegeln das aber mächtig ab. Wird Zeit, das OpenCore in die Puschen kommt und sich der finalen Version nähert inklusive Installer und Configurator.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G • i9-10980XE • DDR4 64GB • SSD 970 EVO Plus 1TB • Thunderbolt3 Titan Ridge • DeckLink 4K Extreme 12G • 2x AMD Radeon VII

  • Ja die musst du gezwungener Maßen drin behalten, da die anderen Treiber für Dateisysteme nichtmehr funktionieren.

    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

  • Download-Fritz

    Clover gibt vor dem Clovermenü schon eine sehr deutliche Warnung aus, die hfsplus.efi wird nicht geladen und entsprechend sieht man Bootlaufwerke mit diesem Dateisystem zu diesem Zeitpunkt nicht. APFS kein Ding, nach hochfahren macOS sieht man natürlich selbstverständlich auch hfsplus Laufwerke. Also benötigst man zum starten solcher Laufwerke den Clover eigenen Treiber.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G • i9-10980XE • DDR4 64GB • SSD 970 EVO Plus 1TB • Thunderbolt3 Titan Ridge • DeckLink 4K Extreme 12G • 2x AMD Radeon VII

  • Moin,

    sicherheitshalber einen Bootstick vorher erstellen.



    MemoryAdaptioFix wird gnadenlos ersetzt gegen OsxAdaptioFixDrv.

    Einen der drei auswählen, bei mir ist es *Fix3Drv

    Bitte ausprobieren..


    Ja, ich bin mir auch nicht so sicher ob ich die Neuerungen gut finde.

    iMacPro1,1 im PowerMac G5 Gehäuse Wakü ● AsRock Z270 Taichi ● i7 6700k @4700

    32GB Predator HyperX 3200 DDR4 ● Sapphire RX Vega 64 ● WIFI+BT Apple BCM94360CD PCI-E Card ● Samsung EVO NVMe

    Style/Umbau - zum Showroom hier lang

  • Download-Fritz Du den hatte Clover gelöscht und gegen OsxAdaptioFixDrv ausgetauscht.

    Damit bootet die Bude aber nicht und führt bei einigen sicherlich zu Panik.


    Scheint ja im Grunde die selbe Funktion zu haben, daher wenn aktualisieren dann nach Clover´s Willen. ;-)

    iMacPro1,1 im PowerMac G5 Gehäuse Wakü ● AsRock Z270 Taichi ● i7 6700k @4700

    32GB Predator HyperX 3200 DDR4 ● Sapphire RX Vega 64 ● WIFI+BT Apple BCM94360CD PCI-E Card ● Samsung EVO NVMe

    Style/Umbau - zum Showroom hier lang

  • Was kann ich (oder können auch andere) tun, um die Entwicklung von OpenCore zu unterstützen? Mir stinkt die Entwicklung mit Clover gewaltig. Ich werde mich damit jetzt mal näher auseinander setzen. Notfalls schreibe ich mir mit dem FileMaker einen plist Generator. Das ist kein Hexenwerk.


    Wie und wo steige ich da am besten bei OC ein?

  • Download-Fritz

    Nachdem ich den neuesten Clover installiert hatte und neu gestartet, gab es ein Meldung „HFSplus.efi“ wäre nicht kompatibel (genauen Wortlaut weiß ich nicht mehr). Danach Enter gedrückt und erst dann kam das Bootmenü. Ohne HFS+ Platte, nur APFS Platte. Konnte normal Mojave hochfahren, im Log sah ich auch, das hfsplus nicht eingebunden wurde. Ausgetauscht mit Clovers Treiber und alles war gut. Da muss es also eine ganz konkrete Abfrage geben. Kann sein, das ich aber eine 5019 oder später genommen habe, sitze nicht am Rechner um es nich mal durchzuspielen.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G • i9-10980XE • DDR4 64GB • SSD 970 EVO Plus 1TB • Thunderbolt3 Titan Ridge • DeckLink 4K Extreme 12G • 2x AMD Radeon VII

  • ResEdit Ein erster Schritt in meinen Augen wäre OpenCore auf dem eignen System zum laufen bringen. damit gemachte Erfahrungen, sowohl positiv als auch negativ, dann hier OpenCore mit den anderen im entsprechenden Bereich teilen.

    Bugs kann man hier melden https://github.com/acidanthera/bugtracker

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.15.6 | *
    MacMini8,1 HYSTOU P05B|I7-8550U IntelUHD620|16GB |500GB SSD |macOS 10.15.6 & macOS 11.0 b4 | *
    MacBookPro14,1 XiaoMi-Pro-15,6" |i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.15.6 | *
    MacBookPro16,1 RedMi 14" |i7-10510U | 8GB | 512GB SSD |macOS 10.15.5 & macOS 11.0 b4 | *
    NVISEN Y-MU01 |i7-10510U | 16GB | 256GB SSD | | *


    | * BootLoader OpenCore REL-061-2020-08-08

  • apfelnico Benutzt du die neueste HFSPlus.efi extrahiert aus einem Apple ROM?


    Aus welchen Gründen sollte man HFSPlus blocken und VBox HFS erzwingen?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Danke euch allen, jetzt habe ich es auch geschafft auf 5018 upzudaten. Besonderen Dank an Nightfly, der Tip erst den Stick upzudaten und so lange auszuprobieren bis es läuft war Gold wert. Ich denke ich werde mir in Zukunft angewöhnen erst den Bootstick ubzudaten und dann erst den PC.