Hackbook: Einige nervige Probleme :/

  • Ich bin es nochmal :),

    ich (bzw. andere, weil ich es ohne Hilfe nicht geschafft hätte) habe es erfolgreich geschafft, macOS Mojave auf dem IdeaPad zu installieren. Ich habe eine EFI aus dem Forum genommen (hier), die an sich super funktioniert.

    Es funktioniert alles so weit gut, inklusive Akkuanzeige und allem drum und dran. Sogar der SD-Kartenleser funktioniert :). Dies sind natürlich alles tolle Sachen, aber laut des EFI-Erstellers ist die EFI etwas rudimentär und auch ich bemerke einige Fehlerchen.


    1. Sleep funktioniert nur manuell, nach dem Aufwachen lässt sich Bluetooth nicht mehr aktivieren

    2. Siri funktioniert nicht, es kommt immer nur: Bitte das Gesagte wiederholen!

    3. Sobald man ein HDMI-Kabel einsteckt, schmiert das gesamte System ab

    4. Bei den Touchpad-Einstellungen ist es immer genau anders herum, beispielsweise muss man für natürliches Scrollen die Checkbox deaktivieren

    5. Vor allem bei langsamen Mausbewegungen fühlt sich der Cursor etwas hakelig an und (gefühlt) stoppt der Mauszeiger manchmal ganz kurz ab

    6. Bei der Intel UHD 620 werden "nur" 1536MB angezeigt, mit meiner alten EFI (auch im Anhang) waren es noch 2048MB (so sollte es, soweit ich weiß, auch sein)

    7. Bluetooth lässt sich nicht deaktivieren


    Dies alles sind Punkte, die ich gerne behoben haben würde, allerdings fehlen mir dazu die Kenntnisse (vor allem über DSDT etc.). Ich würde mich wirklich sehr freuen, wenn sich jemand der Sache annehmen würde, ihr würdet mir dadurch wirklich einen riesigen Gefallen tun.


    Ideal wäre es natürlich, wenn die Probleme alle beseitigt werden könnten, aber auch kleine Schritte sind super.


    Ich bedanke mich schon einmal im Voraus für die Hilfe, die ich hier schon immer toll erhalten habe.


    Grüße von meinem Hackbook :)

  • DeHack

    Changed the title of the thread from “ABSOLUTES Feintuning: Lenovo IdeaPad 330s” to “Hackbook: Einige nervige Probleme :/”.
  • DeHack

    Added the Label In Arbeit
  • Huhu,


    um dir besser helfen zu könne, müssen wir mehr Hardware Daten haben.


    Welches Lenovo IdeaPad ist es denn?

    Welche Wifi/Bluetooth karte ist verbaut?



    Viele Grüße

    DerGiftzwerg

    Aktuelle Baustelle: Lenovo L540, i5-4300M, 8GB DDR3, ALC3202, DW1560 (BCM94352z), OSX 10.15. Beta, Clover r4972

    Gigabyte Z77-DS3H, Bios: F11a Ozmosis [Rev 1.1], i7-2600K, GT710, 8GB DDR3, 240GB SSD, OSX 10.12.6 & 10.13.5, Wlan: TP-WDN4800
    Asus P8Z77-M, i7-3770, 10GB DDR3-1333, 240GB SSD, OSX 10.12.6, iMac 14.2, Ozmosis
    Dell 7570, i7-8550U, UHD620, 16GB DDR4, ALC295, DW1830, 240GB SSD, 10.12.6 & Mojave PB2, Clover r4586

    Lenovo Ideapad 500s-14isk, i5-6200U, 16GB DDR3,ALC236, DW1560 (BCM94352z), OSX 10.15 Beta, Clover r4972

    Verkauft:

    Dell Latitude E6420, i5-2520M, 10.12.5, Wlan: Dell DW1520

    Asus P8Z77-M, i5-2400, 4GB DDR3-1333, Nvidia GT710, 240GB SSD, OSX 10.12.6, iMac 14.2, Ozmosis

  • DerGiftzwerg

    Hm, eigentlich hatte ich das im Forum eingetragen.

    Lenovo IdeaPad 330S-14IKB

    i3 8130u

    8GB DDR4 RAM

    128GB SSD

    Intel UHD 620

  • Lösch mal diese Kexte aus dem Other Ordner (aus EFI-aktuel)!



    UHD 620 Ram-Zuweisung. Wo ist denn deine alte Efi? Da wird es sicherlich einen Kext to Patch Eintrag für geben!

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot Sierra 10.12 und Mojave 10.14.3 Clover 4934
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot Sierra 10.12 und Mojave 10.14.6 Clover 5070
    • Lenovo Thinkpad X240 I7-4600U HD4400 8GB Dualboot Sierra 10.12 und Mojave 10.14.6 Clover 5070
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.6 Clover 5070
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • EaseYourPain   DerGiftzwerg

    Danke, dass ich euch dem annehmt.

    Es gibt ein kleines Update, meine EFI funktioniert an sich sehr gut, allerdings besteht noch das Problem mit Touchpad, dass bei konstanter Bewegung immer kurz stoppt. Außerdem funktioniert zwar der Ton über die Kopfhörer, allerdings ist 0,0 gar kein Bass vorhanden. Wenn Leute sprechen, versteht man quasi so gut wie gar nichts.

    Ton und Bild über HDMI funktioniert (allerdings nur FullHD), Lautsprecher auch, Siri Problem besteht weiterhin (Mikrofon funktioniert).

    Sleep habe ich durch meine eigene EFI jetzt überhaupt nicht mehr funktionstüchtig.


    Also zusammengefasst:

    1. Kein Sleep

    2. Touchpad "ruckelt", Einstellungen immer noch verkehrt herum

    3. Akkuanzeige ist etwas komisch, manchmal nach Neustart mehr % als vor Neustart etc.

    4. Siri funktioniert nicht

    5. HDMI "nur" in FullHD (ist aber nicht allzu schlimm)

    6. Über Kopfhörer kein Bass


    Ich habe die DSDT aus der EFI hier aus dem Forum einfach übernommen und sonst ein bisschen mein eigenes Süppchen gekocht :).

    Anbei ist die EFI.

  • Welche WLAN/Bluetooth Karte ist denn verbaut? Habe den Bluetooth Treiber in Verdacht wenn das trackpad stottert. Warum auch immer wird das Trackpad nicht als intern sondern als externes Bluetooth Trackpad erkannt. Wenn Bluetooth auch nach dem sleep nicht funzt, liegt dort eventuell der Hund begraben.

    An einer Lösung zu HDMI bin ich selbstverständlich auch interessiert.

  • daschmc

    Im Moment noch die originale, eine neue (genau deine) ist bestellt. Irgendwie funktioniert die standartmäßige Bluetoothkarte wohl. Das mit den Kexten werde ich versuchen. Mit meiner EFI geht HDMI einfach, keine Ahnung wieso :).


    Edit: Ich habe ja gar keinen Bluetooth-Kext, trotzdem geht Bluetooth. Übrigens geht Bluetooth immer, allerdings lässt es sich nicht deaktivieren.

    Edited once, last by DeHack ().

  • Mach doch mal Testhalber im Bios/Uefi das interne Bluetooth aus !?

    Und teste dann nochmal weiter.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • locojens

    Ich kann nur WLAN deaktivieren, Bluetooth nicht. Scheint wohl ein extra Modul zu sein?! WLAN deaktiviert -> keine Besserung.

  • Bluetooth ist meist ein extra Modul bei den "Älteren" Lenovos, die finden auch jedesmal wieder ne tolle Stelle das Teil zu verstecken, beim meinem alten X200s war es im Bildschirmgehäuse, beim aktuellen x230 ist es unter der Handballenablage...


    Es gibt aber normalerweise auch Tastenkombinationen bei den lenovos um Bluetooth an bzw. aus -zuschalten Fn Taste und eine der F-Tasten...

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware: