Filevault mit Hackintosh problemlos möglich?

  • Hi, nachdem mir mein Macbook gestohlen wurde und ich darauf kein Filevault aktiviert habe, möchte ich nun alle meine Festplatten, Backups, Clones aber auch das Hackintoshsystem mit Filevault veschlüsseln.


    Ich meine irgendwo mal gelesen zu haben, dass dies bei Hackintoshs eher problematisch sein soll, kann aber gerade nichts dazu finden.

    Hat jemand Filevault im eigenen Hackintoshsystem aktiviert? Ist dies problemlos möglich?

  • Du must dazu :) die richtigen Treiber in Clover laden. Voraussichtlich bei dir die im Bild.


    Grüße und Good Hack Michael


    :hackintosh:

  • Hallo Download-Fritz ,

    läuft wunderbar damit. Muss ich dann auch mal mit OC Testen. Allerdings werden für Filevault die ander Kexte aus Post 3 zusätzlich benötigt.

    Grüße und Good Hack Michael


    :hackintosh:

  • Habe ich eben getestet und die Partition mit Filevault blieb bei mir vor dem Anmeldebildschirm stecken. Aber ich werde es nochmal testen und berichten.

    Grüße und Good Hack Michael


    :hackintosh:

  • Ohne den AptioInputFix-64.efi komme ich zum Anmeldebildschirm, kann aber nichts eingeben über die USB-Tastatur. Mit diesem funktioniert das ganze super und die Tastatur steht sogar auf Deutsch. :thumbup:


    Was bedeutet du hast da mal wieder recht. :klatschen:


    Und wenn wir gerade dabei sind danke für deine echt hervorragende Leistung. :klatschen::klatschen:


    Grüße und Good Hack Michael


    :hackintosh:

  • Sehe ich also richtig das für FileVault nur diese beiden UEFI-Treiber benötigt werden?


    AppleUiSupport.efi

    AptioInputFix

    iMac19,2: Mojave 10.14.6 | Clover 5018 | i7-8700 | ASUS Prime Z370-A | Sapphire Nitro+ Radeon RX 580 8G | BCM943602CS

  • Statt der Clover-Treiber am besten die Acidanthera-Treiber verwenden: https://github.com/acidanthera/AppleSupportPkg/releases

    Sorry, ich bin noch eher auf der Anfängerseite :)

    Also ich habe das applesupport...release.zip herruntergeladen. Darin finde ich vier efi files die ich sicher in meinem efi Ordner kopiern sollte. Der einzige Ordner der dort efi Dateien enthält ist clover > drivers64UEFI oder der tools ordner (aber dort wohl eher nicht).

  • Hallo Paprika ,

    ja diese zusätzlich und Filevault sollte laufen.


    Hallo flaneurin ,


    der Ordner "clover > drivers64UEFI" ist genau der richtige.


    Vorher testen ob der Boot in den Recovery Mode funktioniert. Sollte es zu einem Fehler kommen kann man über diesen die Verschlüsselung rückgängig machen.

    Auf meinem Zenbook nutze ich Filevault seit dem Start von Mojave und hatte noch nie ein Problem damit.

    Grüße und Good Hack Michael


    :hackintosh:

  • vielen dank.


    also wenn ich es richtig verstanden habe, benötige nur AptioinputFix (über Clover) und AppleUiSupport.efi direkt über den Download in post#4?


    Das mit dem Revorymode habe ich irgendwo gelesen. Um ganz sicher zu gehen könnte ich also zuerst das ganze auf meiner Clone SSD ausprobieren?

  • Wenn du von dem Clone booten kannst dann ja.

    Grüße und Good Hack Michael


    :hackintosh:

  • AptioInputFix am besten auch aus der ZIP, wer weiß, wie neu der Clobber-Treiber ist. UsbKbDxe wird nicht benötigt, würde ich AptioInputFix aber vorziehen, wenn er denn funktioniert. Auf Aptio 4 klappt's wegen Firmwarebugs nicht.

  • Hi,


    ich hätte eine Frage bzgl. Filevault.

    Ich habe eben auf meinem System ebenfalls Filevault aktiviert und die dazugehörigen Treiber installiert.

    Allerdings befinden sich bei mir im "driver64UEFI"-Ordner zum Teil Doppeleinträge.

    Könntet Ihr mir bitte sagen, welche Treiber nicht mehr notwendig sind, sodass ich diese entfernen kann?


    Habe zwei BScreenshots angehängt:

    1. Vorher - also Filevault nicht aktiv.

    2. Filevault aktiv.


    Eine rein kosmetische Frage:

    Während der Passworteingabe im Clover-Bootmenu sieht das Bild ziemlich verpixelt aus.

    Kann man die Auflösung erhöhen?