WiFi top - Bluetooth (BCM943602CS) flop

  • Moin Moin


    wie ihr sehen könnt, ist das mein erster Post hier im Forum. Vielen Dank auch schon mal für den ein oder anderen Tipp, den ich mir hier, während meiner Bauphase bei euch abgucken konnte!

    Zu meinem Hackintosh-Glück fehlt nicht mehr viel, lediglich die Bluetooth Eigenschaften kann ich noch nicht nutzen. Zur Info: Verbaut habe ich einen > LeHang BCM943224PCIEBT2/bcm94360CS2/BCM943602CS WiFi + Bluetooth 4.0 Karte PCI-E Adapter < mit dem > A1502 A1398 Airport Bluetooth Board BCM943602CS < Chip.


    WiFi funktionierte OOB und auch der Bluetooth-USB-Host-Controller wird im Gerätebaum angezeigt (siehe Bilder). Das Bluetooth Symbol ist ebenfalls in der Systemleiste zu sehen, jedoch "Bluetooth: Aktiviert" ist ausgegraut.

    In anderen Threads wurde schon von DSDT´s und SSDT´s gesprochen, einigen wurde auch angeraten keine Fixes zu nutzen, etc. Soweit ich das jetzt richtig deute, habe ich sowas alles nicht - wirklich nen Plan habe ich davon aber nicht.


    Ich denke, dass ich wohl nicht die richtigen .kexte im EFI/Clover Ordner habe, da ich die Konfigurationen eines anderen, zum größten Teil übernommen habe und vielleicht hat er ja andere Komponenten verbaut.

    Vielleicht weiß ja jemand Rat und kann mir weiterhelfen. Vielen Dank schon mal!



    Bild > Pic5_efi_clover_plist_1 < zeigt das ACPI Chapter meiner config.plist, auf Seite 2 der Fixes ist auch nicht ausgewählt

  • Hey, warum verwendest Du die ganzen *BRCM* Kernel-Erweiterungen?

    Meine BCM94360CS2 Karte wird OOB erkannt, ohne extra Treiber oder Patches.

  • AirportBrcmFixup.kext erlaubt z.B. die Einstellung einer Länderkennung (mittels Bootarg brcmfx-country=DE). Ist kein Geschwindigkeitsvorteil, aber ich nutze als gehorsamer Bürger nur WLAN-Channels, die in DE zulässig sind ;-)

    Meine beiden Originalsmacs (Air & Mini) halten sich übrigens nicht an die Länderkennung, dort steht: "Länderkennung: US". Die kleinen Strolche!

    Working horse: iMacPro1,1, Gigabyte GA-Z170MX Gaming 5 (BIOS F22f), i5 6600K@4GHz, Gigabyte RX460 4GB, 32 GB Ballistix Sport LT 2400 MHz, Samsung 850 Pro, Fenvi T919 (BCM94360CD), Jonsbo UMX3, macOS 10.14.5, Clover


    Front room brain: Mac mini 2014, 4GB RAM, 256GB SSD, macOS 10.14.5


    Outdoor buddy: MacBook Air 2012 11", 4GB RAM, 128GB SSD, macOS 10.14.5

  • Hey, warum verwendest Du die ganzen *BRCM* Kernel-Erweiterungen?

    Meine BCM94360CS2 Karte wird OOB erkannt, ohne extra Treiber oder Patches.

    Weil ich mich an den Clover-Einstellungen und der Bauanleitung eines anderen Users gehalten hatte und ich auch nicht wirklich selbst nen Plan habe, was wofür zu verwenden ist wenn es in die Feinheiten geht. :/ Wie gesagt, ich bin hier Neuling und auch eher Nutzer eines Macs als Bauer eines Hackintoshs...

    Ich werd´s jedenfalls mal ohne die ganzen BRCM´s versuchen.


    edit:


    Leider hat das löschen der drei "BRCM" Kexte aus dem EFI/Clover/kexts Ordner nichts gebracht...

    In nem engl. Forum haben sie davon gesprochen, dass die Wifi/BT Adapter Karte evtl. mit dem onboard WiFi/BT kollidiert?! Kann so etwas sein und wenn ja wie umgeht man dies? Onboard WiFi/BT ausbauen oder gibt´s da n Patch für?


    Edited once, last by maxbahr ().

  • Zu allererst solltest Du sicherstellen das der BT Teil der Karte auch als USB Gerät erkannt wird denn das sit die Basis für funktionierendes Bluetooth. Schau mal im Systembericht unter USB ob das Gerät dort auftaucht und falls das nicht der Fall sein sollte heißt es erstmal die USB Ports entsprechend zu patchen (macOS USB Portlimit sei hier als Stichwort genannt).

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Ich hatte auch die kleine CS2 aus der Serie.. Hatte auch keinen BT Empfang, selbst dann nicht wenn ich zB die Maus direkt ins Gehäuse gehalten habe. Laut Systembericht und so war BT korrekt im System am laufen. Bin dann auf die BCM94630CD umgestiegen mit 4 Antennen (3x WLAN 1x BT). Jetzt keine Probleme mehr.

    Discord-Server.png

    rizzi.png

  • Also ich habe die Karte eingesetzt und es war sofort alles Startklar.

    Keine kexte oder ähnliches.


    Die LeHang ist nur die PCI Karte. (Habe ich übrigens auch)

    Das Bluetooth Modul musst du ja extra kaufen (Woher?) und auf die PCI Karte stecken.


    So, bis dahin war noch alle easy aber dann...dann die Kabel mit den Ministecker auf das Bluetooth Modul stecken, hat mich fast wahnsinnig gemacht.


    Sind nämlich die Stecker richtig drauf? Der mittlere Stecker (mittlere Antenne) ist für das Bluetooth verantwortlich. Die anderen,Wlan 2,5GHz und 5,0GHz.


    Wenn du Probleme mit dem Bluetooth hast, so wie ich auch dann kannst du dir ein Verlängerungskabel Bei Amazon kaufen. 2m = 6 Euro oder so.


    Auf jedem Fall muss es gehen.