2 GraKa und X520-T2 am Gigabyte Z370

  • Hallo Leute,


    eine Frage an euch, ich habe in meinem Rechner eine GIGABYTE GeForce GTX 1050 TI OC Grafikkarte, an der aktuell 2 Monitore hängen. Ich möchte mein Setup nun um zwei weitere Monitore erweitern, also so dass ich 4 Monitore habe. Dafür möchte ich mir eine zweite GIGABYTE GeForce GTX 1050 TI OC kaufen. Am Mainboard habe ich ein 16x PCIe Slot und "2 x PCI Express x16 slots, running at x4"


    Kann in daran die zweite GraKa betreiben?

    Und nur mal so als Frage nebenbei, die X520-T2 hat ja einen 4x PCI Port. Ich kann die doch problemlos in ein 16x Slot stecken, dann geht der Slot halt einfach weiter. Oder irre ich mich da?

  • Normalerweise funzen beide x16 slots mit 2 Grakas. Ich kenne aber das Board nicht.

    Bei den meisten Hacks kann man ja auch an der Graka 3 Monitore anschließen und noch einen an der IGP.

    Vielleicht mal die Hardware ins Profil eintragen.

    AMD 7 3700X - Nofan CR-95C - ASUS Prime B350-Plus - RX 460 + Passivkühler - silentmaxx Fanless II 500 Platinum

    AMD X4 605e - Scythe Ninja Plus Passiv - ASRock N68-S3 UCC - 8400GS - Thermaltake Silent PurePower 350W Fanless

    Intel i3 4330 - Scythe Orochi B Passiv - Asus H81M-C - 16GB RAM - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6600T - CoollinkCoratorPassiv - GA-Z170-HD3P - 1050TiPassiv - SuperFlower GoldenSilent Fanless 500 Platinum

  • Okay, ich brauche jetzt tatsächlich etwas Hilfe.

    Ich habe die zweite GraKa gekauft und eingebaut. Ebenso die Netzwerkkarte. Bis ich die Treiber der Netzwerkkarte installiert habe, hat alles wunderbar funktioniert. Nachdem ich aber den Treiber installiert habe, hatte ich abwechselnd entweder auf einer Grafikkarte oder auf der anderen Grafikkarte Grafikfehler. Die 10GbE Karte funktioniert aber mit Vollspeed.


    Am Liebsten würde ich ehrlich gesagt beide GraKas verwenden, aber wahrscheinlich wird es nicht möglich sein. Aber das nächste Problem ist, dass irgendwie die IGP auch nicht will. Im UEFI ist die IGP eingeschaltet. Aber ich bekomme da weder ein Bild über HDMI noch über DVI raus und OS X findet die Grafikkarte auch nicht.

  • was von Hardware hast du denn alles verbaut Mainboard cpu etc,. ?

  • Die Grafikkarten laufen beide mit x8. Das ist schon in Ordnung, normalerweise einzeln voll x16. Du hast aber nur 16 Lanes für die PCIe an der CPU. Wenn jetzt die Netzwerkkarte noch dazu kommt, dann läuft eine Grafikkarte ebenfalls nur x4. Das ist nicht gut. Gibt es einen x4 per PCH angebunden (Chipsatz)?

    Die interne Grafik würde ich ausschalten.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • was von Hardware hast du denn alles verbaut Mainboard cpu etc,. ?

    Gigabyte Z370 HD3

    Intel Core i3 8100 4x 3.60GHz

    32GB (4x 8192MB) Crucial CT2K8G4DFS8213

    Gigabyte NVIDIA GeForce GTX 1050 Ti


    Und dazu gekommen ist jetzt:

    Gigabyte NVIDIA GeForce GTX 1050 Ti

    X520-T2 mit den SmallTree Treibern

    Die Grafikkarten laufen beide mit x8. Das ist schon in Ordnung, normalerweise einzeln voll x16. Du hast aber nur 16 Lanes für die PCIe an der CPU. Wenn jetzt die Netzwerkkarte noch dazu kommt, dann läuft eine Grafikkarte ebenfalls nur x4. Das ist nicht gut. Gibt es einen x4 per PCH angebunden (Chipsatz)?

    Die interne Grafik würde ich ausschalten.

    Ich habe die auch testweise im UEFI deaktiviert, ebenso wie die On Board Netzwerkkarte, geändert hat sich da aber nichts.


    Nach den technischen Daten von Intel hat der Z370 Chipsatz 24 PCIe Lanes. Die CPU aber nur 16. Heißt es, ich würde eine andere CPU benötigen? Aber jetzt auf die schnelle konnte ich in der 9. Generation nicht einmal eine i7 CPU finden mit mehr als 16 Lanes.


    Eine weitere Alternative wäre IMHO die beiden Karten zu verkaufen und stattdessen eine GTX 960 oder 1060 mit 5 Anschlüssen zu holen.

  • LL0rd

    Andere CPU bringt nix, es sei denn, du willst einen kompletten Plattformwechsel. Das sollte wohl überlegt sein und kostet richtig Knete (X299). Dein Mainboard ist leider nicht optimale Wahl (Gigabyte Z370 HD3). Es hat drei große PCIe Slots, davon nur der erste x16, die anderen beiden x4. Alle sind mit der CPU verbunden, die hier 16Lanes zur Verfügung stellt. Wird neben den ersten Slot (Grafikkarte, x16) ein weiterer Slot verwendet, so wird der erste auf x8 gedrosselt, es ergeben sich insgesamt wieder 16 Lanes. Leider sind die zwei anderen nur x4. Die restlichen x1 Slots sind an der PCH (Chipsatz) angebunden, hier stehen insgesamt 24 Lanes zur Verfügung (wobei sich CPU und Chipsatz über eine x4 "Brücke" unterhalten, das ist der Flaschenhals).


    Anders zum Beispiel bei dem "Gigabyte Z370 UD3H": Auch hier findest du drei PCIe Slots in voller Länge (und weitere drei PCIe x1 via Chipsatz). Aber diese sind meiner Meinung nach besser aufgeteilt. Denn der erste ist wie immer x16, sollte im zweiten etwas stecken, so werden beide zu x8. Das ist optimal für zwei Grafikkarten. Der dritte ist x4 und teilt sich die Bandbreite mit einem der beiden M2 (PCIe NVMe SSD, x4) – ist also über den Chipsatz angebunden! Steckt also in den betreffenden M2 Slot nichts (es ist eh noch ein zweiter da), so ist dieser PCIe aktiv.


    Die Kehrseite ist, wie ich schon anmerkte, der Flaschenhals zwischen CPU und Chipsatz. Die Netzwerkkarte würde auch hier nicht mit 100% Leistung laufen, denn Audio, Sata, M2 und USB3.1 Gen2 wollen je nach Nutzung auch versorgt sein.



    Wenn es primär um Hackintosh geht, du unbedingt die 10Gbit Netzwerkkarte benötigst und nicht unbedingt abhängig von Nvidia bist, dann würde ich in deinem Fall die beiden Grafikkarten rauswerfen und EINE schnelle AMD einbauen und auf Mojave wechseln. Das könnte Vega56/64 sein, oder aber auch ganz neu Radeon VII (Unterstützung folgt in finaler 10.14.5).

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Dein Mainboard ist leider nicht optimale Wahl (Gigabyte Z370 HD3). Es hat drei große PCIe Slots, davon nur der erste x16, die anderen beiden x4. Alle sind mit der CPU verbunden, die hier 16Lanes zur Verfügung stellt.

    Es ist mein erster Hackintosh. Und ich habe mir das Board gekauft, weil es damals auf einer Hardware Guide Seite als Budget ATX Board empfohlen wurde. "Damals" habe ich einfach nur einen Rechner gebraucht, der als Ergänzung zu meinem Notebook dient, da mein 13" MBP mit 8 GB RAM mir für meine normale Arbeit nicht ausgereicht hat. Und mein 2012er MBPr leider kaputtging. Für den Rechner habe ich ca. 500€ bezahlt. Hab den Rechner am 01.05.2018 gebaut. Das letzte Jahr war ich mit der Kiste zufrieden. Jetzt haben sich aber die Anforderungen etwas geändert => 10 GBit und 4 (wenn nicht 6 Monitore)

    Wenn es primär um Hackintosh geht, du unbedingt die 10Gbit Netzwerkkarte benötigst und nicht unbedingt abhängig von Nvidia bist, dann würde ich in deinem Fall die beiden Grafikkarten rauswerfen und EINE schnelle AMD einbauen und auf Mojave wechseln. Das könnte Vega56/64 sein, oder aber auch ganz neu Radeon VII (Unterstützung folgt in finaler 10.14.5).

    Leider bin ich abhängig von Nvidia (CUDA). Deshalb kann ich nicht auf die Radeon wechseln. Und ein Update auf Mojave kommt bei mir momentan nicht in Frage, da ich keine Zeit habe, das OS neu aufzuspielen. Oder gar ein Backup der Platte zu ziehen für einen Update-Versuch. Hänge momentan auf 10.13.4.


    Ich habe gerade über Kleinanzeigen in meiner Stadt eine 1060 Karte für 85€ gekauft. Die 1050 Ti habe ich für das gleiche Geld gekauft. Ich habe die beiden 1050 Karten nun rausgeworfen und die 1060 eingebaut. 4 Monitore laufen damit problemlos. Wahrscheinlich werde ich noch nen 5. Monitor dazu nehmen, mir fehlt da aber noch das DP-Kabel für.


    Aber ich danke euch für den Support! Jetzt weiß ich, worauf ich achten muss, wenn ich den nächsten Rechner zusammenstelle.