OpenCore Sammelthread (Hilfe und Diskussion)

  • Neu in 067:


    - Improved CPU frequency calculation on Haswell and earlier


    Klingt gut – wie auch immer sich das ausdrückt. ;)

  • OSX-Einsteiger,

    das hat nichts gebracht. Ich habe die Änderung rückgängig gemacht. Nach wie vor bleibt der Kasten hängen.

  • denn USBInjectAll.kext brauchst du auf jeden fall und XhciPortLimit

  • Schönen Abend,


    Habe seit ein paar Tagen voll die Probleme mit der icloud......

    Muss bei jedem Starten die Cloud anmelden. War bis jetzt kein Problem.....

    (Mit Clover das selbe Problem) Konnte bis jetzt eigentlich immer hin und her wechseln...


    Hat wer von Euch die selben Probleme?


    oder hätte wer einen Tipp


    gglg

  • Ist bestimmt schonmal gepostet worden:

    wie kann ich mit OC0.6.x die Default SSDTs ziehen?

    Bin mit meinem ASRock x299 OC Formular auf ein ASRock x299 CREATE umgestiegen und benötige nun erstmal die Stock-SSDTs.

    Habe leider auch keinen bootbaren CLOVER-USB-Stick mehr, um sie ggf. damit zu ziehen.


    Ich weiss, daß es mit OC auch geht, bin mir bloß nicht sicher, ob ich dazu eine DEVELOPER Version kompilieren muss, oder ob das mittels config.plist auch in der RELEASE-Compilation möglich ist.

    ASUS WS X299 SAGE/10G • Intel Core i9-7920X 12-Core 2.9GHz • 96GB RAM • ASRock Radeon VII Phantom Gaming • 2x Samsung 970EVO NVMe M.2 SSD 500GB
    Custom Wasserkühlung • Thermaltake TheTower 900 • 1x LG 38UC99-W @ 3840 x 1600 (75Hz) via DP • SAMSUNG TV UE46ES7090 @ 1920 x 1080 (60Hz) via HDMI
    WINDOWS 7 ENTERPRISE • WINDOWS 10 ENTERPRISE INSIDER (PRO950 NVMe) • macOS 10.15.x latest Build (on Samsung 960 EVO NVMe) • OpeCore always latest

  • Nee, ich brauche nicht "vorgefertigte", sondern die, die im BIOS hinterlegt sind, damit ich diese dann anpassen kann.

    ASUS WS X299 SAGE/10G • Intel Core i9-7920X 12-Core 2.9GHz • 96GB RAM • ASRock Radeon VII Phantom Gaming • 2x Samsung 970EVO NVMe M.2 SSD 500GB
    Custom Wasserkühlung • Thermaltake TheTower 900 • 1x LG 38UC99-W @ 3840 x 1600 (75Hz) via DP • SAMSUNG TV UE46ES7090 @ 1920 x 1080 (60Hz) via HDMI
    WINDOWS 7 ENTERPRISE • WINDOWS 10 ENTERPRISE INSIDER (PRO950 NVMe) • macOS 10.15.x latest Build (on Samsung 960 EVO NVMe) • OpeCore always latest

  • Danke, ich meinte mich zu erinnern, daß es eben nur mit der DEBUG-Version geht.

    ASUS WS X299 SAGE/10G • Intel Core i9-7920X 12-Core 2.9GHz • 96GB RAM • ASRock Radeon VII Phantom Gaming • 2x Samsung 970EVO NVMe M.2 SSD 500GB
    Custom Wasserkühlung • Thermaltake TheTower 900 • 1x LG 38UC99-W @ 3840 x 1600 (75Hz) via DP • SAMSUNG TV UE46ES7090 @ 1920 x 1080 (60Hz) via HDMI
    WINDOWS 7 ENTERPRISE • WINDOWS 10 ENTERPRISE INSIDER (PRO950 NVMe) • macOS 10.15.x latest Build (on Samsung 960 EVO NVMe) • OpeCore always latest

  • ich vermute hier die Linux-Efi. Diese lässt sich aber nicht booten.



    Gibt es dazu inzwischen einen Workarround?


    Werden besondere Treiber für ext2 benötigt?


    Ich habe mit Google keine Hinweise dazu gefunden.


    in der Configuration lediglich dieses hier:

    Description: OEM manufacturer of the particular board. Shall not be specified unless strictly required. Should

    not contain Apple Inc., as this confuses numerous services present in the operating system, such as firmware

    updates, eficheck, as well as kernel extensions developed in Acidanthera, such as Lilu and its plugins. In addition

    it will also make some operating systems such as Linux unbootable

    Grüße

    Arkturus


    iMacPro1,1 (KBL) Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119, BS 11.1 (20C5048k) OC 0.6.8

    MacBookPro14,1 (KBL) Thinkpad T470 Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz, Intel HD Graphics 620 VRAM 2048 MB, 16.00 GB RAM, M.2 NGFF SATA TS512GMTS430S, M.2 PCIe SSD NTEL SSDPEKNW512G8, BigSur 11.3 Beta 6, OC 0.6.8

    iMacPro1,1 (HSW) Asus B85E, Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz Haswell, RAM M12.00 GB, AMD Radeon RX 560 4GB VRAM, OpenCore 0.6.7, BigSur 11.3 Beta 6

    MacBookPro11,2 (Ivy) ThinkPad T430, Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz, 8.00 GB VRAM, Intel HD Graphics 4000, OpenCore 0.6.8, BigSur 11.3 Beta 6

  • Hi Jungs,


    Finde leider die Variablen für den ProcessorType in 0.6.6 nirgends?


    Hätte bitte wer einen Tipp..


    Danke

  • Werden besondere Treiber für ext2 benötigt?

    Für den Start von Linux m. W nicht.

    Das hier habe ich unter Clover durch die Installation als Ubuntu-Ordner erhalten:


    Damit bootet Ubuntu bestens.

    Diesen Ordner habe ich dann später für den Einsatz unter OC an die gleiche Stelle kopiert und dann hier ...


    eine Verknüpfung zur grubx64.efi hergestellt. Das war Alles. Ist auch hier irgendwo im OC-Thread weiter zurück beschrieben.

    Ich hoffe doch, darum ging es Dir.


    Gut. dass ich mit dem OC-Aufräumen noch nicht durch bin - das war noch da. ;)

  • danke für den Hinweis. Ich dachte es wäre mit einem Uefi-Treiber abgetan und meinte im Augenwinkel mal etwas zu ext2 Treibern gesehen zu haben. Aber auch Google hat dazu nichts ausgespuckt.

    Grüße

    Arkturus


    iMacPro1,1 (KBL) Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119, BS 11.1 (20C5048k) OC 0.6.8

    MacBookPro14,1 (KBL) Thinkpad T470 Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz, Intel HD Graphics 620 VRAM 2048 MB, 16.00 GB RAM, M.2 NGFF SATA TS512GMTS430S, M.2 PCIe SSD NTEL SSDPEKNW512G8, BigSur 11.3 Beta 6, OC 0.6.8

    iMacPro1,1 (HSW) Asus B85E, Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz Haswell, RAM M12.00 GB, AMD Radeon RX 560 4GB VRAM, OpenCore 0.6.7, BigSur 11.3 Beta 6

    MacBookPro11,2 (Ivy) ThinkPad T430, Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz, 8.00 GB VRAM, Intel HD Graphics 4000, OpenCore 0.6.8, BigSur 11.3 Beta 6

  • Entweder mit der Debug Version von OC dumpen oder mit SSDTTime unter Windows. Du kannst ansonsten aber auch einfach Clover als zip runter laden, entpacken und ohne es zu konfigurieren auf einen USB Stick ballern (nur HfsPlus.efi muss halt dazu), um die DSDT zu dumpen. Muss ja nicht booten können, sondern nur auslesen!

  • Hat sich schon erledigt das Thema:

    ich habe einfach einen alten Stick genommen, Clover drauf und gebootet. Zack "F4" gedrückt et voila: ich habe meine Stock SSDTs.

    Danke an alle, die geantwortet haben.


    Have a nice day... und Danke für den Fisch!

    ASUS WS X299 SAGE/10G • Intel Core i9-7920X 12-Core 2.9GHz • 96GB RAM • ASRock Radeon VII Phantom Gaming • 2x Samsung 970EVO NVMe M.2 SSD 500GB
    Custom Wasserkühlung • Thermaltake TheTower 900 • 1x LG 38UC99-W @ 3840 x 1600 (75Hz) via DP • SAMSUNG TV UE46ES7090 @ 1920 x 1080 (60Hz) via HDMI
    WINDOWS 7 ENTERPRISE • WINDOWS 10 ENTERPRISE INSIDER (PRO950 NVMe) • macOS 10.15.x latest Build (on Samsung 960 EVO NVMe) • OpeCore always latest

  • DerTschnig schau mal ob Deine SN vergeben ist. Das Problem kenn ich eigentlich nur wenn ich mit meiner EFI auf einem anderen System rumgespielt habe und die Kiste im Netz war.


    Gruß,
    Chris

    Hast recht gehabt.

  • Hallo, wer hat Kontakte zu Entwicklerteam?

    Habe ein Fehler gefunden.

    Wenn man MacOS über die Wiederherstellung neu aufsetzten will geht das nicht, wenn OpenHfsPlus.efi als driver benutzt wird.

    Da erkennt er die com.apple.recovery.boot im USB nicht. (Egal welche MacOS Version)

    Benutzt man HfsPlus.efi funktioniert die Wiederherstellung wieder.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Die Devs sind eh hier im Forum, vit9696 und Download-Fritz. Aber ohne Logs werden die dir eher nicht helfen können... Gordon-1979


    Edit: Zu langsam, DF war schneller (und genauer)...